]> git.pld-linux.org Git - packages/dbus-glib.git/blob - dbus-glib.spec
- updated to 0.84
[packages/dbus-glib.git] / dbus-glib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 #
6 %define         dbus_version    1.1
7 %define         expat_version   1:1.95.5
8 %define         glib_version    1:2.10.1
9 #
10 Summary:        GLib-based library for using D-BUS
11 Summary(pl.UTF-8):      Biblioteka do używania D-BUS oparta o GLib
12 Name:           dbus-glib
13 Version:        0.84
14 Release:        1
15 License:        AFL v2.1 or GPL v2
16 Group:          Libraries
17 Source0:        http://dbus.freedesktop.org/releases/dbus-glib/%{name}-%{version}.tar.gz
18 # Source0-md5:  69fbe31fb3ee778715dff44cdd5178bf
19 Patch0:         %{name}-configure.patch
20 Patch1:         %{name}-as-needed.patch
21 URL:            http://www.freedesktop.org/Software/DBusBindings
22 BuildRequires:  autoconf >= 2.52
23 BuildRequires:  automake >= 1:1.9
24 BuildRequires:  dbus-devel >= %{dbus_version}
25 BuildRequires:  expat-devel >= %{expat_version}
26 BuildRequires:  gettext-devel
27 BuildRequires:  glib2-devel >= %{glib_version}
28 %{?with_apidocs:BuildRequires:  gtk-doc-automake >= 1.8}
29 BuildRequires:  libtool
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpmbuild(macros) >= 1.527
32 Requires:       dbus-libs >= %{dbus_version}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 D-BUS add-on library to integrate the standard D-BUS library with the
37 GLib thread abstraction and main loop.
38
39 %description -l pl.UTF-8
40 Dodatkowa biblioteka D-BUS do integracji standardowej biblioteki D-BUS
41 z abstrakcją wątków i główną pętlą GLib.
42
43 %package devel
44 Summary:        Header files for GLib-based library for using D-BUS
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       dbus-devel >= %{dbus_version}
49 Requires:       glib2-devel >= %{glib2_version}
50
51 %description devel
52 Header files for GLib-based library for using D-BUS.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib.
56
57 %package static
58 Summary:        Static GLib-based library for using D-BUS
59 Summary(pl.UTF-8):      Statyczna biblioteka do używania D-BUS oparta o GLib
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static GLib-based library for using D-BUS.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka do używania D-BUS oparta o GLib.
68
69 %package apidocs
70 Summary:        D-BUS-GLib API documentation
71 Summary(pl.UTF-8):      Dokumentacja API D-BUS-GLib
72 Group:          Documentation
73 Requires:       gtk-doc-common
74
75 %description apidocs
76 D-BUS-GLib API documentation.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API D-BUS-GLib.
80
81 %package -n bash-completion-dbus
82 Summary:        bash-completion for dbus-send
83 Summary(pl.UTF-8):      Bashowe uzupełnianie poleceń dla dbus-send
84 Group:          Applications/Shells
85 Requires:       bash-completion
86
87 %description -n bash-completion-dbus
88 This package provides bash-completion for dbus-send.
89
90 %description -n bash-completion-dbus -l pl.UTF-8
91 Ten pakiet dostarcza bashowe uzupełnianie poleceń dla dbus-send.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96 %patch1 -p1
97
98 %if %{without apidocs}
99 echo 'EXTRA_DIST=' > gtk-doc.make
100 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
101 %endif
102
103 %build
104 %{?with_apidocs:%{__gtkdocize}}
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         %{__enable_disable apidocs gtk-doc} \
112         --with-html-dir=%{_gtkdocdir} \
113         %{__disable static_libs static}
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT \
122         profiledir=/etc/bash_completion.d
123
124 mv -f $RPM_BUILD_ROOT/etc/bash_completion.d/{dbus-bash-completion.sh,dbus}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 # AFL not in common-licenses, so COPYING included
135 %doc AUTHORS COPYING ChangeLog NEWS README
136 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libdbus-glib-1.so.2
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/dbus-binding-tool
142 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so
143 %{_libdir}/libdbus-glib-1.la
144 %{_mandir}/man1/dbus-binding-tool.1*
145 %{_includedir}/dbus*/dbus/dbus-glib*.h
146 %{_includedir}/dbus*/dbus/dbus-gtype-specialized.h
147 %{_pkgconfigdir}/dbus-glib-1.pc
148
149 %if %{with static_libs}
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libdbus-glib-1.a
153 %endif
154
155 %if %{with apidocs}
156 %files apidocs
157 %defattr(644,root,root,755)
158 %{_gtkdocdir}/dbus-glib
159 %endif
160
161 %files -n bash-completion-dbus
162 %defattr(644,root,root,755)
163 /etc/bash_completion.d/dbus
164 %attr(755,root,root) %{_libdir}/dbus-bash-completion-helper
This page took 0.08978 seconds and 3 git commands to generate.