]> git.pld-linux.org Git - packages/dbus-glib.git/blob - dbus-glib.spec
- updated to 0.88
[packages/dbus-glib.git] / dbus-glib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 #
6 %define         dbus_version    1.1
7 %define         expat_version   1:1.95.5
8 %define         glib_version    1:2.24
9 #
10 Summary:        GLib-based library for using D-BUS
11 Summary(pl.UTF-8):      Biblioteka do używania D-BUS oparta o GLib
12 Name:           dbus-glib
13 Version:        0.88
14 Release:        1
15 License:        AFL v2.1 or GPL v2
16 Group:          Libraries
17 Source0:        http://dbus.freedesktop.org/releases/dbus-glib/%{name}-%{version}.tar.gz
18 # Source0-md5:  7c04ba01df6130c2c4e62f73bea0d0d5
19 Patch0:         %{name}-configure.patch
20 Patch1:         %{name}-as-needed.patch
21 URL:            http://www.freedesktop.org/Software/DBusBindings
22 BuildRequires:  autoconf >= 2.52
23 BuildRequires:  automake >= 1:1.9
24 BuildRequires:  dbus-devel >= %{dbus_version}
25 %{?with_apidocs:BuildRequires:  docbook-dtd412-xml}
26 BuildRequires:  expat-devel >= %{expat_version}
27 BuildRequires:  gettext-devel
28 BuildRequires:  glib2-devel >= %{glib_version}
29 %{?with_apidocs:BuildRequires:  gtk-doc-automake >= 1.8}
30 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
31 BuildRequires:  libtool
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpmbuild(macros) >= 1.527
34 Requires:       dbus-libs >= %{dbus_version}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 D-BUS add-on library to integrate the standard D-BUS library with the
39 GLib thread abstraction and main loop.
40
41 %description -l pl.UTF-8
42 Dodatkowa biblioteka D-BUS do integracji standardowej biblioteki D-BUS
43 z abstrakcją wątków i główną pętlą GLib.
44
45 %package devel
46 Summary:        Header files for GLib-based library for using D-BUS
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       dbus-devel >= %{dbus_version}
51 Requires:       glib2-devel >= %{glib2_version}
52
53 %description devel
54 Header files for GLib-based library for using D-BUS.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib.
58
59 %package static
60 Summary:        Static GLib-based library for using D-BUS
61 Summary(pl.UTF-8):      Statyczna biblioteka do używania D-BUS oparta o GLib
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static GLib-based library for using D-BUS.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka do używania D-BUS oparta o GLib.
70
71 %package apidocs
72 Summary:        D-BUS-GLib API documentation
73 Summary(pl.UTF-8):      Dokumentacja API D-BUS-GLib
74 Group:          Documentation
75 Requires:       gtk-doc-common
76
77 %description apidocs
78 D-BUS-GLib API documentation.
79
80 %description apidocs -l pl.UTF-8
81 Dokumentacja API D-BUS-GLib.
82
83 %package -n bash-completion-dbus
84 Summary:        bash-completion for dbus-send
85 Summary(pl.UTF-8):      Bashowe uzupełnianie poleceń dla dbus-send
86 Group:          Applications/Shells
87 Requires:       bash-completion
88
89 %description -n bash-completion-dbus
90 This package provides bash-completion for dbus-send.
91
92 %description -n bash-completion-dbus -l pl.UTF-8
93 Ten pakiet dostarcza bashowe uzupełnianie poleceń dla dbus-send.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98 %patch1 -p1
99
100 %if %{without apidocs}
101 echo 'EXTRA_DIST=' > gtk-doc.make
102 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
103 %endif
104
105 %build
106 %{?with_apidocs:%{__gtkdocize}}
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         %{__enable_disable apidocs gtk-doc} \
114         %{__disable static_libs static} \
115         --disable-silent-rules \
116         --with-html-dir=%{_gtkdocdir}
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT \
125         profiledir=/etc/bash_completion.d
126
127 mv -f $RPM_BUILD_ROOT/etc/bash_completion.d/{dbus-bash-completion.sh,dbus}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 # AFL not in common-licenses, so COPYING included
138 %doc AUTHORS COPYING ChangeLog NEWS README
139 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libdbus-glib-1.so.2
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/dbus-binding-tool
145 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so
146 %{_libdir}/libdbus-glib-1.la
147 %{_mandir}/man1/dbus-binding-tool.1*
148 %{_includedir}/dbus*/dbus/dbus-glib*.h
149 %{_includedir}/dbus*/dbus/dbus-gtype-specialized.h
150 %{_pkgconfigdir}/dbus-glib-1.pc
151
152 %if %{with static_libs}
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/libdbus-glib-1.a
156 %endif
157
158 %if %{with apidocs}
159 %files apidocs
160 %defattr(644,root,root,755)
161 %{_gtkdocdir}/dbus-glib
162 %endif
163
164 %files -n bash-completion-dbus
165 %defattr(644,root,root,755)
166 /etc/bash_completion.d/dbus
167 %attr(755,root,root) %{_libdir}/dbus-bash-completion-helper
This page took 0.040132 seconds and 3 git commands to generate.