]> git.pld-linux.org Git - packages/cyrus-sasl.git/commitdiff
- fix completely broken logic in get_fqhostname auto/th/cyrus-sasl-2_1_25-4_9
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 21 Oct 2011 12:13:08 +0000 (12:13 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cyrus-sasl-get_fqhostname.patch -> 1.1
    cyrus-sasl.spec -> 1.214

cyrus-sasl-get_fqhostname.patch [new file with mode: 0644]
cyrus-sasl.spec

diff --git a/cyrus-sasl-get_fqhostname.patch b/cyrus-sasl-get_fqhostname.patch
new file mode 100644 (file)
index 0000000..b3dc444
--- /dev/null
@@ -0,0 +1,59 @@
+--- cyrus-sasl-2.1.25/lib/saslutil.c.orig      2011-10-21 13:59:59.354462366 +0200
++++ cyrus-sasl-2.1.25/lib/saslutil.c   2011-10-21 14:10:55.849675881 +0200
+@@ -555,32 +555,44 @@
+                 NULL,         /* don't care abour service/port */
+                 &hints,
+                 &result) != 0) {
+-      /* errno on Unix, WSASetLastError on Windows are already done by the function */
+-      return (-1);
++        if (abort_if_no_fqdn) {
++          /* errno on Unix, WSASetLastError on Windows are already done by the function */
++          return (-1);
++      } else {
++          goto LOWERCASE;
++      }
+     }
+-    if (abort_if_no_fqdn && (result == NULL || result->ai_canonname == NULL)) {
++    if (result == NULL || result->ai_canonname == NULL) {
+       freeaddrinfo (result);
++        if (abort_if_no_fqdn) {
+ #ifdef WIN32
+-      WSASetLastError (WSANO_DATA);
++          WSASetLastError (WSANO_DATA);
+ #elif defined(ENODATA)
+-      errno = ENODATA;
++          errno = ENODATA;
+ #elif defined(EADDRNOTAVAIL)
+-      errno = EADDRNOTAVAIL;
++          errno = EADDRNOTAVAIL;
+ #endif
+-      return (-1);
++          return (-1);
++      } else {
++          goto LOWERCASE;
++      }
+     }
+-    if (abort_if_no_fqdn && strchr (result->ai_canonname, '.') == NULL) {
++    if (strchr (result->ai_canonname, '.') == NULL) {
+       freeaddrinfo (result);
++        if (abort_if_no_fqdn) {
+ #ifdef WIN32
+-      WSASetLastError (WSANO_DATA);
++          WSASetLastError (WSANO_DATA);
+ #elif defined(ENODATA)
+-      errno = ENODATA;
++          errno = ENODATA;
+ #elif defined(EADDRNOTAVAIL)
+-      errno = EADDRNOTAVAIL;
++          errno = EADDRNOTAVAIL;
+ #endif
+-      return (-1);
++          return (-1);
++      } else {
++          goto LOWERCASE;
++      }
+     }
index 5379f9e636483e53344aa5d69cb95e64e4294431..dce68b2dd2032692489cbf9cb0795644880d9cc3 100644 (file)
@@ -25,7 +25,7 @@ Summary(ru.UTF-8):    Библиотека Cyrus SASL
 Summary(uk.UTF-8):     Бібліотека Cyrus SASL
 Name:          cyrus-sasl
 Version:       2.1.25
 Summary(uk.UTF-8):     Бібліотека Cyrus SASL
 Name:          cyrus-sasl
 Version:       2.1.25
-Release:       4.5
+Release:       4.9
 License:       distributable
 Group:         Libraries
 Source0:       ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
 License:       distributable
 Group:         Libraries
 Source0:       ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
@@ -56,6 +56,7 @@ Patch17:      0032-revert_1.103_revision_to_unbreak_GSSAPI.patch
 Patch18:       0033-fix_segfault_in_GSSAPI.patch
 Patch19:       0034-fix_dovecot_authentication.patch
 Patch20:       %{name}-auxprop.patch
 Patch18:       0033-fix_segfault_in_GSSAPI.patch
 Patch19:       0034-fix_dovecot_authentication.patch
 Patch20:       %{name}-auxprop.patch
+Patch21:       %{name}-get_fqhostname.patch
 URL:           http://asg.web.cmu.edu/sasl/
 BuildRequires: autoconf >= 2.54
 BuildRequires: automake >= 1:1.7
 URL:           http://asg.web.cmu.edu/sasl/
 BuildRequires: autoconf >= 2.54
 BuildRequires: automake >= 1:1.7
@@ -490,6 +491,7 @@ Wtyczka Nagiosa do sprawdzania działania saslauthd.
 %patch18 -p1
 %patch19 -p1
 %patch20 -p1
 %patch18 -p1
 %patch19 -p1
 %patch20 -p1
+%patch21 -p1
 
 cd doc
 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
 
 cd doc
 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
This page took 0.053174 seconds and 4 git commands to generate.