]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
5379f9e636483e53344aa5d69cb95e64e4294431
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite 2 plugin
11 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
12 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
13 %bcond_with     opie            # OTP plugin using opie library instead of internal code
14 %bcond_with     srp             # build srp plugin
15 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.25
28 Release:        4.5
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
32 # Source0-md5:  341cffe829a4d71f2a6503d669d5a946
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-db.patch
46 Patch8:         %{name}-keytab.patch
47 Patch9:         %{name}-sizes.patch
48 Patch10:        %{name}-nagios-plugin.patch
49 Patch11:        %{name}-parallel-make.patch
50 Patch12:        %{name}-gssapi-detect.patch
51 Patch13:        %{name}-saslauthd-httpform-urlescape.patch
52 Patch14:        %{name}-ac-libs.patch
53 Patch15:        %{name}-pam.patch
54 Patch16:        %{name}-gssapi_ext.patch
55 Patch17:        0032-revert_1.103_revision_to_unbreak_GSSAPI.patch
56 Patch18:        0033-fix_segfault_in_GSSAPI.patch
57 Patch19:        0034-fix_dovecot_authentication.patch
58 Patch20:        %{name}-auxprop.patch
59 URL:            http://asg.web.cmu.edu/sasl/
60 BuildRequires:  autoconf >= 2.54
61 BuildRequires:  automake >= 1:1.7
62 %{?with_authlib:BuildRequires:  courier-authlib-devel}
63 BuildRequires:  db-devel
64 BuildRequires:  ed
65 BuildRequires:  groff
66 %{?with_gssapi:BuildRequires:   heimdal-devel}
67 BuildRequires:  libtool >= 1.4
68 %{?with_mysql:BuildRequires:    mysql-devel}
69 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
70 BuildRequires:  openssl-devel >= 0.9.7d
71 %{?with_opie:BuildRequires:     opie-devel}
72 BuildRequires:  pam-devel
73 %{?with_pgsql:BuildRequires:    postgresql-devel}
74 BuildRequires:  rpmbuild(macros) >= 1.268
75 %{?with_sqlite:BuildRequires:   sqlite-devel}
76 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
77 Requires:       pam >= 0.79.0
78 Requires:       %{name}-libs = %{version}-%{release}
79 Obsoletes:      cyrus-sasl-x509 < %{version}
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %define         _sysconfdir     /etc/sasl
83
84 %define         specflags       -fno-strict-aliasing
85
86 %description
87 This is an implementation of the SASL API, useful for adding
88 authentication, authorization, and security to network protocols. The
89 SASL protocol itself is documented in rfc2222; the API standard is a
90 work in progress.
91
92 Note: remember to install appropriate plugins, or you won't have any
93 authentication mechanisms available.
94
95 %description -l pl.UTF-8
96 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
97 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
98 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
99 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
100 RFC 2222; standaryzacja API jest w toku.
101
102 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
103 doinstalować odpowiednie wtyczki.
104
105 %description -l pt_BR.UTF-8
106 Esta é uma implementação da API SASL, útil para acrescentar
107 autenticação, autorização e seguança (criptografia) para protocolos de
108 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
109 ainda está em desenvolvimento.
110
111 %description -l ru.UTF-8
112 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
113 Authentication and Security Layer, метод для добавления поддержки
114 аутентикации к протоколам, основанным на соединениях.
115
116 %description -l uk.UTF-8
117 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
118 Authentication and Security Layer, метод для додання підтримки
119 аутентикації до протоколів, базованих на з'єднаннях.
120
121 %package libs
122 Summary:        cyrus-sasl library itself
123 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
124 Group:          Libraries
125 Requires(post,postun):  /sbin/ldconfig
126 Conflicts:      cyrus-sasl < 2.1.23-8
127
128 %description libs
129 cyrus-sasl library itself.
130
131 %description libs -l pl.UTF-8
132 Sama biblioteka cyrus-sasl.
133
134 %package devel
135 Summary:        Header files and documentation for cyrus-sasl
136 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
137 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
138 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
139 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
140 Group:          Development/Libraries
141 Requires:       %{name} = %{version}-%{release}
142
143 %description devel
144 This includes the header files and documentation needed to develop
145 applications which use SASL.
146
147 %description devel -l pl.UTF-8
148 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
149
150 %description devel -l pt_BR.UTF-8
151 Este pacote inclui os arquivos de cabeçalho e documentação necessários
152 para desenvolver aplicativos que usem SASL.
153
154 %description devel -l ru.UTF-8
155 Хедеры и библиотеки, необходимые для разработки приложений,
156 использующих Cyrus SASL.
157
158 %description devel -l uk.UTF-8
159 Хедери та бібліотеки, необхідні для розробки програм, що
160 використовують Cyrus SASL.
161
162 %package static
163 Summary:        Static cyrus-sasl libraries
164 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
165 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
166 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
167 Group:          Development/Libraries
168 Requires:       %{name}-devel = %{version}-%{release}
169
170 %description static
171 Static cyrus-sasl libraries.
172
173 %description static -l pl.UTF-8
174 Statyczne biblioteki cyrus-sasl.
175
176 %description static -l ru.UTF-8
177 Статические библиотеки, необходимые для разработки приложений,
178 использующих Cyrus SASL.
179
180 %description static -l uk.UTF-8
181 Статичні бібліотеки, необхідні для розробки програм, що використовують
182 Cyrus SASL.
183
184 %package anonymous
185 Summary:        Anonymous Cyrus SASL plugin
186 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
187 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
188 Group:          Libraries
189 Requires:       %{name} = %{version}-%{release}
190
191 %description anonymous
192 This plugin implements the SASL ANONYMOUS mechanism, used for
193 anonymous authentication.
194
195 %description anonymous -l pl.UTF-8
196 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
197 anonimowego uwierzytelniania.
198
199 %description anonymous -l pt_BR.UTF-8
200 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
201 autenticação anônima.
202
203 %package cram-md5
204 Summary:        Cram-MD5 Cyrus SASL plugin
205 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
206 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
207 Group:          Libraries
208 Requires:       %{name} = %{version}-%{release}
209
210 %description cram-md5
211 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
212 mandatory-to-implement authentication mechanism for a number of
213 protocols; it uses MD5 with a challenge/response system to
214 authenticate the user.
215
216 %description cram-md5 -l pl.UTF-8
217 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
218 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
219 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
220 systemem challenge/response.
221
222 %description cram-md5 -l pt_BR.UTF-8
223 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
224 mecanismo de autenticação obrigatório de ser implementado para vários
225 protocolos: ele usa MD5 com um sistema de desafio/resposta para
226 autenticar o usuário.
227
228 %package digest-md5
229 Summary:        Digest-MD5 Cyrus SASL plugin
230 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
231 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
232 Group:          Libraries
233 Requires:       %{name} = %{version}-%{release}
234
235 %description digest-md5
236 This plugin implements the latest draft of the SASL DIGEST-MD5
237 mechanism. Although not yet finalized, this is likely to become the
238 new mandatory-to-implement authentication system in all new protocols.
239 It's based on the digest md5 authentication system designed for HTTP.
240
241 %description digest-md5 -l pl.UTF-8
242 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
243 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
244 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
245 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
246 Digest-MD5 zaprojektowanym dla HTTP.
247
248 %description digest-md5 -l pt_BR.UTF-8
249 Este plugin implementa a última versão da especificação do mecanismo
250 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
251 provavelmente será o novo sistema de autenticação obrigatório para
252 protocolos novos. Ele é baseado na autenticação md5 digest
253 desenvolvida para HTTP.
254
255 %package gssapi
256 Summary:        GSSAPI Cyrus SASL plugin
257 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
258 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
259 Group:          Libraries
260 Requires:       %{name} = %{version}-%{release}
261
262 %description gssapi
263 This plugin implements the SASL GSSAPI mechanism, used for
264 GSSAPI/Kerberos5 authentication.
265
266 %description gssapi -l pl.UTF-8
267 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
268 uwierzytelniania z użyciem GSSAPI/Kerberos5.
269
270 %description gssapi -l pt_BR.UTF-8
271 Este plugin implementa o mecanismo SASL GSSAPI, usado para
272 autenticação Kerberos/GSSAPI.
273
274 %package login
275 Summary:        Unsupported Login Cyrus SASL plugin
276 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
277 Group:          Libraries
278 Requires:       %{name} = %{version}-%{release}
279
280 %description login
281 Unsupported LOGIN Cyrus SASL plugin.
282
283 %description login -l pl.UTF-8
284 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
285 SASL.
286
287 %package mysql
288 Summary:        Cyrus SASL MySQL plugin
289 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
290 Group:          Libraries
291 Requires:       %{name} = %{version}-%{release}
292
293 %description mysql
294 Cyrus SASL MySQL plugin.
295
296 %description mysql -l pl.UTF-8
297 Wtyczka MySQL do Cyrus SASL.
298
299 %package otp
300 Summary:        OTP Cyrus SASL plugin
301 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
302 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
303 Group:          Libraries
304 Requires:       %{name} = %{version}-%{release}
305 Obsoletes:      cyrus-sasl-opie < %{version}
306
307 %description otp
308 This plugin implements the SASL OTP (One Time Password) mechanism.
309
310 %description otp -l pl.UTF-8
311 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
312 SASL.
313
314 %package pgsql
315 Summary:        Cyrus SASL PostgreSQL plugin
316 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
317 Group:          Libraries
318 Requires:       %{name} = %{version}-%{release}
319
320 %description pgsql
321 Cyrus SASL PostgreSQL plugin.
322
323 %description pgsql -l pl.UTF-8
324 Wtyczka PostgreSQL do Cyrus SASL.
325
326 %package plain
327 Summary:        Plain Cyrus SASL plugin
328 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
329 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
330 Group:          Libraries
331 Requires:       %{name} = %{version}-%{release}
332
333 %description plain
334 This plugin implements the SASL PLAIN mechanism. Although insecure,
335 PLAIN is useful for transitioning to new security mechanisms, as this
336 is the only mechanism which gives the server a copy of the user's
337 password.
338
339 %description plain -l pl.UTF-8
340 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
341 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
342 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
343 który udostępnia serwerowi kopię hasła użytkownika.
344
345 %description plain -l pt_BR.UTF-8
346 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
347 mecanismo é útil durante transições para novos mecanismos de
348 segurança, pois é o único esquema que fornece uma cópia da senha do
349 usuário para o servidor.
350
351 %package sasldb
352 Summary:        Cyrus SASL sasldb plugin
353 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
354 Group:          Libraries
355 Requires:       %{name} = %{version}-%{release}
356
357 %description sasldb
358 Cyrus SASL sasldb plugin.
359
360 %description sasldb -l pl.UTF-8
361 Wtyczka sasldb do Cyrus SASL.
362
363 %package scram
364 Summary:        SCRAM Cyrus SASL plugin
365 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
366 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
367 Group:          Libraries
368 Requires:       %{name} = %{version}-%{release}
369
370 %description scram
371 This plugin implements the SASL SCRAM-MD5 mechanism.
372
373 %description scram -l pl.UTF-8
374 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
375
376 %description scram -l pt_BR.UTF-8
377 Este plugin implementa o mecanismo SASL SCRAM.
378
379 %package sqlite
380 Summary:        Cyrus SQLite 2 PostgreSQL plugin
381 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
382 Group:          Libraries
383 Requires:       %{name} = %{version}-%{release}
384
385 %description sqlite
386 Cyrus SASL SQLite 2 plugin.
387
388 %description sqlite -l pl.UTF-8
389 Wtyczka SQLite 2 do Cyrus SASL.
390
391 %package sqlite3
392 Summary:        Cyrus SQLite 3 PostgreSQL plugin
393 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
394 Group:          Libraries
395 Requires:       %{name} = %{version}-%{release}
396
397 %description sqlite3
398 Cyrus SASL SQLite 3 plugin.
399
400 %description sqlite3 -l pl.UTF-8
401 Wtyczka SQLite 3 do Cyrus SASL.
402
403 %package srp
404 Summary:        SRP Cyrus SASL plugin
405 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
406 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
407 Group:          Libraries
408 Requires:       %{name} = %{version}-%{release}
409
410 %description srp
411 This plugin implements the SASL SRP mechanism, based on the Secure
412 Remote Password protocol. This mechanism performs mutual
413 authentication and can provide a security layer with replay detection,
414 integrity protection and/or condifentiality protection.
415
416 %description srp -l pl.UTF-8
417 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
418 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
419 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
420 powtarzania, zabezpieczeniem integralności i/lub poufności.
421
422 %description srp -l pt_BR.UTF-8
423 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
424 (Secure Remote Password). Este mecanismo oferece autenticação mútua
425 (do cliente e do servidor) e pode prover uma camada de segurança com
426 detecção de ataques de replay, garantia de integridade e/ou
427 confidencialidade.
428
429 %package pwcheck
430 Summary:        Cyrus SASL pwcheck helper
431 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
432 Group:          Libraries
433 Requires:       %{name} = %{version}-%{release}
434
435 %description pwcheck
436 Cyrus SASL pwcheck helper.
437
438 %description pwcheck -l pl.UTF-8
439 Program pomocniczy pwcheck do Cyrus SASL.
440
441 %package saslauthd
442 Summary:        Cyrus SASL authd
443 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
444 Group:          Daemons
445 Requires(post,preun):   /sbin/chkconfig
446 Requires:       %{name} = %{version}-%{release}
447 Requires:       /sbin/chkconfig
448 Requires:       rc-scripts
449
450 %description saslauthd
451 Cyrus SASL authd.
452
453 %description saslauthd -l pl.UTF-8
454 Demon authd do Cyrus SASL.
455
456 %package -n nagios-plugin-check_saslauthd
457 Summary:        Nagios plugin to check health of saslauthd
458 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
459 Group:          Networking
460 Requires:       nagios-core
461
462 %description -n nagios-plugin-check_saslauthd
463 Nagios plugin to check health of saslauthd.
464
465 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
466 Wtyczka Nagiosa do sprawdzania działania saslauthd.
467
468 %prep
469 %setup -q
470 %patch0 -p1
471 %patch1 -p1
472 %patch2 -p1
473 %patch3 -p1
474 %patch4 -p1
475 %if %{with cryptedpw}
476 %patch5 -p1
477 %patch6 -p1
478 %endif
479 %patch7 -p1
480 %patch8 -p1
481 %patch9 -p1
482 %patch10 -p1
483 %patch11 -p1
484 %patch12 -p1
485 %patch13 -p0
486 %patch14 -p1
487 %patch15 -p1
488 %patch16 -p1
489 %patch17 -p1
490 %patch18 -p1
491 %patch19 -p1
492 %patch20 -p1
493
494 cd doc
495 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
496 ls rfc*.txt >> rfc-compliance
497 rm -f rfc*.txt
498 cd ..
499
500 # old version
501 %{__rm} config/libtool.m4
502
503 # update to our paths
504 sed -i -e '
505         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
506         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
507         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
508         s,/var/state/saslauthd,/var/lib/sasl2,g
509 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
510
511 %build
512 %{__libtoolize}
513 %{__aclocal} -I cmulocal -I config
514 %{__autoheader}
515 %{__autoconf}
516 %{__automake}
517 cd saslauthd
518 %{__aclocal} -I ../cmulocal -I ../config
519 %{__autoheader}
520 %{__autoconf}
521 %{__automake}
522 cd ..
523 %configure \
524         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
525         --disable-krb4 \
526         %{!?with_gssapi: --disable-gssapi} \
527         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
528         --enable-login \
529         --enable-sample \
530         --enable-httpform \
531         --enable-sql \
532         %{?with_srp: --enable-srp} \
533         --enable-static \
534         --with-plugindir=%{_libdir}/sasl2 \
535         --with-configdir=%{_sysconfdir} \
536         --with-dblib=berkeley \
537         --with-dbpath=/var/lib/sasl2/sasl.db \
538         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
539         %{?with_ldap: --with-ldap=%{_prefix}} \
540         %{?with_ldap: --enable-ldapdb} \
541         %{?with_mysql: --with-mysql=%{_prefix}} \
542         %{?with_pgsql: --with-pgsql=%{_prefix}} \
543         %{?with_sqlite: --with-sqlite=%{_prefix}} \
544         %{?with_sqlite3: --with-sqlite3=%{_prefix}} \
545         %{?with_opie: --with-opie=%{_prefix}} \
546         --with-pam \
547         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
548         --with-saslauthd=/var/lib/sasl2
549
550 %{__make}
551
552 %{__make} -C saslauthd testsaslauthd
553 %{__make} -C saslauthd saslcache
554 %{__make} -C sample sample-client sample-server
555
556 cd doc
557 RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
558 for i in $RFCLIST; do
559         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
560         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
561 done
562
563 %install
564 rm -rf $RPM_BUILD_ROOT
565 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
566                 $RPM_BUILD_ROOT%{_mandir}/man8
567
568 %{__make} install \
569         sasldir=%{_libdir}/sasl2 \
570         DESTDIR=$RPM_BUILD_ROOT
571
572 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
573
574 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
575 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
576
577 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
578
579 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
580
581 # create empty config
582 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
583 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
584 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
585 cp -a %{SOURCE3} cyrus.pam
586
587 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
588
589 # sample programs for testing sasl
590 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
591 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
592
593 # package for ghost
594 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
595
596 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
597 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
598
599 %clean
600 rm -rf $RPM_BUILD_ROOT
601
602 %post   libs -p /sbin/ldconfig
603 %postun libs -p /sbin/ldconfig
604
605 %post saslauthd
606 /sbin/chkconfig --add saslauthd
607 %service saslauthd restart
608
609 %preun saslauthd
610 if [ "$1" = "0" ]; then
611         %service saslauthd stop
612         /sbin/chkconfig --del saslauthd
613 fi
614
615 %triggerin saslauthd -- pam
616 # restart saslauthd if pam is upgraded
617 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
618 if [ "$2" != 1 ]; then
619         %service -q saslauthd restart
620 fi
621
622 %files
623 %defattr(644,root,root,755)
624 %doc AUTHORS COPYING ChangeLog NEWS README
625 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
626 %dir %{_sysconfdir}
627 %dir %{_libdir}/sasl2
628 # sample programs to subpackage instead?
629 %attr(755,root,root) %{_bindir}/sasl-sample-client
630 %attr(755,root,root) %{_bindir}/sasl-sample-server
631 %attr(755,root,root) %{_sbindir}/pluginviewer
632 %attr(755,root,root) %{_sbindir}/sasldblistusers2
633 %attr(755,root,root) %{_sbindir}/saslpasswd2
634 %dir /var/lib/sasl2
635 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
636 %{_mandir}/man8/pluginviewer.8*
637 %{_mandir}/man8/sasldblistusers2.8*
638 %{_mandir}/man8/saslpasswd2.8*
639
640 %files libs
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
643 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
644
645 %files devel
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_libdir}/libsasl2.so
648 %attr(755,root,root) %{_libdir}/libsasl.so
649 %{_libdir}/libsasl2.la
650 %{_includedir}/sasl
651 %{_mandir}/man3/sasl*.3*
652
653 %files static
654 %defattr(644,root,root,755)
655 %{_libdir}/libsasl2.a
656
657 %files anonymous
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
660
661 %if %{with gssapi}
662 %files gssapi
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
665 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
666 %endif
667
668 %files cram-md5
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
671
672 %files digest-md5
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
675
676 %files login
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
679
680 %if %{with mysql}
681 %files mysql
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
684 %endif
685
686 %files otp
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
689
690 %if %{with pgsql}
691 %files pgsql
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
694 %endif
695
696 %files plain
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
699
700 %files sasldb
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
703
704 %files scram
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
707
708 %if %{with sqlite}
709 %files sqlite
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
712 %endif
713
714 %if %{with sqlite3}
715 %files sqlite3
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
718 %endif
719
720 %if %{with srp}
721 %files srp
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
724 %endif
725
726 %if %{with pwcheck}
727 %files pwcheck
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_sbindir}/pwcheck
730 %endif
731
732 %files saslauthd
733 %defattr(644,root,root,755)
734 %doc cyrus.pam
735 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
736 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
737 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
738 %attr(755,root,root) %{_sbindir}/saslauthd
739 %attr(755,root,root) %{_sbindir}/testsaslauthd
740 %attr(755,root,root) %{_sbindir}/saslcache
741 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
742 %ghost /var/lib/sasl2/cache.flock
743 %ghost /var/lib/sasl2/cache.mmap
744 %ghost /var/lib/sasl2/mux
745 %ghost /var/lib/sasl2/mux.accept
746 %ghost /var/lib/sasl2/saslauthd.pid
747 %{_mandir}/man8/saslauthd.8*
748
749 %files -n nagios-plugin-check_saslauthd
750 %defattr(644,root,root,755)
751 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
752 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.083029 seconds and 2 git commands to generate.