]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- fix completely broken logic in get_fqhostname
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite 2 plugin
11 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
12 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
13 %bcond_with     opie            # OTP plugin using opie library instead of internal code
14 %bcond_with     srp             # build srp plugin
15 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.25
28 Release:        4.9
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
32 # Source0-md5:  341cffe829a4d71f2a6503d669d5a946
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-db.patch
46 Patch8:         %{name}-keytab.patch
47 Patch9:         %{name}-sizes.patch
48 Patch10:        %{name}-nagios-plugin.patch
49 Patch11:        %{name}-parallel-make.patch
50 Patch12:        %{name}-gssapi-detect.patch
51 Patch13:        %{name}-saslauthd-httpform-urlescape.patch
52 Patch14:        %{name}-ac-libs.patch
53 Patch15:        %{name}-pam.patch
54 Patch16:        %{name}-gssapi_ext.patch
55 Patch17:        0032-revert_1.103_revision_to_unbreak_GSSAPI.patch
56 Patch18:        0033-fix_segfault_in_GSSAPI.patch
57 Patch19:        0034-fix_dovecot_authentication.patch
58 Patch20:        %{name}-auxprop.patch
59 Patch21:        %{name}-get_fqhostname.patch
60 URL:            http://asg.web.cmu.edu/sasl/
61 BuildRequires:  autoconf >= 2.54
62 BuildRequires:  automake >= 1:1.7
63 %{?with_authlib:BuildRequires:  courier-authlib-devel}
64 BuildRequires:  db-devel
65 BuildRequires:  ed
66 BuildRequires:  groff
67 %{?with_gssapi:BuildRequires:   heimdal-devel}
68 BuildRequires:  libtool >= 1.4
69 %{?with_mysql:BuildRequires:    mysql-devel}
70 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
71 BuildRequires:  openssl-devel >= 0.9.7d
72 %{?with_opie:BuildRequires:     opie-devel}
73 BuildRequires:  pam-devel
74 %{?with_pgsql:BuildRequires:    postgresql-devel}
75 BuildRequires:  rpmbuild(macros) >= 1.268
76 %{?with_sqlite:BuildRequires:   sqlite-devel}
77 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
78 Requires:       pam >= 0.79.0
79 Requires:       %{name}-libs = %{version}-%{release}
80 Obsoletes:      cyrus-sasl-x509 < %{version}
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %define         _sysconfdir     /etc/sasl
84
85 %define         specflags       -fno-strict-aliasing
86
87 %description
88 This is an implementation of the SASL API, useful for adding
89 authentication, authorization, and security to network protocols. The
90 SASL protocol itself is documented in rfc2222; the API standard is a
91 work in progress.
92
93 Note: remember to install appropriate plugins, or you won't have any
94 authentication mechanisms available.
95
96 %description -l pl.UTF-8
97 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
98 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
99 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
100 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
101 RFC 2222; standaryzacja API jest w toku.
102
103 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
104 doinstalować odpowiednie wtyczki.
105
106 %description -l pt_BR.UTF-8
107 Esta é uma implementação da API SASL, útil para acrescentar
108 autenticação, autorização e seguança (criptografia) para protocolos de
109 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
110 ainda está em desenvolvimento.
111
112 %description -l ru.UTF-8
113 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
114 Authentication and Security Layer, метод для добавления поддержки
115 аутентикации к протоколам, основанным на соединениях.
116
117 %description -l uk.UTF-8
118 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
119 Authentication and Security Layer, метод для додання підтримки
120 аутентикації до протоколів, базованих на з'єднаннях.
121
122 %package libs
123 Summary:        cyrus-sasl library itself
124 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
125 Group:          Libraries
126 Requires(post,postun):  /sbin/ldconfig
127 Conflicts:      cyrus-sasl < 2.1.23-8
128
129 %description libs
130 cyrus-sasl library itself.
131
132 %description libs -l pl.UTF-8
133 Sama biblioteka cyrus-sasl.
134
135 %package devel
136 Summary:        Header files and documentation for cyrus-sasl
137 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
138 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
139 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
140 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
141 Group:          Development/Libraries
142 Requires:       %{name} = %{version}-%{release}
143
144 %description devel
145 This includes the header files and documentation needed to develop
146 applications which use SASL.
147
148 %description devel -l pl.UTF-8
149 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
150
151 %description devel -l pt_BR.UTF-8
152 Este pacote inclui os arquivos de cabeçalho e documentação necessários
153 para desenvolver aplicativos que usem SASL.
154
155 %description devel -l ru.UTF-8
156 Хедеры и библиотеки, необходимые для разработки приложений,
157 использующих Cyrus SASL.
158
159 %description devel -l uk.UTF-8
160 Хедери та бібліотеки, необхідні для розробки програм, що
161 використовують Cyrus SASL.
162
163 %package static
164 Summary:        Static cyrus-sasl libraries
165 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
166 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
167 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
168 Group:          Development/Libraries
169 Requires:       %{name}-devel = %{version}-%{release}
170
171 %description static
172 Static cyrus-sasl libraries.
173
174 %description static -l pl.UTF-8
175 Statyczne biblioteki cyrus-sasl.
176
177 %description static -l ru.UTF-8
178 Статические библиотеки, необходимые для разработки приложений,
179 использующих Cyrus SASL.
180
181 %description static -l uk.UTF-8
182 Статичні бібліотеки, необхідні для розробки програм, що використовують
183 Cyrus SASL.
184
185 %package anonymous
186 Summary:        Anonymous Cyrus SASL plugin
187 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
188 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
189 Group:          Libraries
190 Requires:       %{name} = %{version}-%{release}
191
192 %description anonymous
193 This plugin implements the SASL ANONYMOUS mechanism, used for
194 anonymous authentication.
195
196 %description anonymous -l pl.UTF-8
197 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
198 anonimowego uwierzytelniania.
199
200 %description anonymous -l pt_BR.UTF-8
201 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
202 autenticação anônima.
203
204 %package cram-md5
205 Summary:        Cram-MD5 Cyrus SASL plugin
206 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
207 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
208 Group:          Libraries
209 Requires:       %{name} = %{version}-%{release}
210
211 %description cram-md5
212 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
213 mandatory-to-implement authentication mechanism for a number of
214 protocols; it uses MD5 with a challenge/response system to
215 authenticate the user.
216
217 %description cram-md5 -l pl.UTF-8
218 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
219 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
220 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
221 systemem challenge/response.
222
223 %description cram-md5 -l pt_BR.UTF-8
224 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
225 mecanismo de autenticação obrigatório de ser implementado para vários
226 protocolos: ele usa MD5 com um sistema de desafio/resposta para
227 autenticar o usuário.
228
229 %package digest-md5
230 Summary:        Digest-MD5 Cyrus SASL plugin
231 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
232 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
233 Group:          Libraries
234 Requires:       %{name} = %{version}-%{release}
235
236 %description digest-md5
237 This plugin implements the latest draft of the SASL DIGEST-MD5
238 mechanism. Although not yet finalized, this is likely to become the
239 new mandatory-to-implement authentication system in all new protocols.
240 It's based on the digest md5 authentication system designed for HTTP.
241
242 %description digest-md5 -l pl.UTF-8
243 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
244 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
245 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
246 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
247 Digest-MD5 zaprojektowanym dla HTTP.
248
249 %description digest-md5 -l pt_BR.UTF-8
250 Este plugin implementa a última versão da especificação do mecanismo
251 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
252 provavelmente será o novo sistema de autenticação obrigatório para
253 protocolos novos. Ele é baseado na autenticação md5 digest
254 desenvolvida para HTTP.
255
256 %package gssapi
257 Summary:        GSSAPI Cyrus SASL plugin
258 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
259 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
260 Group:          Libraries
261 Requires:       %{name} = %{version}-%{release}
262
263 %description gssapi
264 This plugin implements the SASL GSSAPI mechanism, used for
265 GSSAPI/Kerberos5 authentication.
266
267 %description gssapi -l pl.UTF-8
268 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
269 uwierzytelniania z użyciem GSSAPI/Kerberos5.
270
271 %description gssapi -l pt_BR.UTF-8
272 Este plugin implementa o mecanismo SASL GSSAPI, usado para
273 autenticação Kerberos/GSSAPI.
274
275 %package login
276 Summary:        Unsupported Login Cyrus SASL plugin
277 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
278 Group:          Libraries
279 Requires:       %{name} = %{version}-%{release}
280
281 %description login
282 Unsupported LOGIN Cyrus SASL plugin.
283
284 %description login -l pl.UTF-8
285 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
286 SASL.
287
288 %package mysql
289 Summary:        Cyrus SASL MySQL plugin
290 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
291 Group:          Libraries
292 Requires:       %{name} = %{version}-%{release}
293
294 %description mysql
295 Cyrus SASL MySQL plugin.
296
297 %description mysql -l pl.UTF-8
298 Wtyczka MySQL do Cyrus SASL.
299
300 %package otp
301 Summary:        OTP Cyrus SASL plugin
302 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
303 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
304 Group:          Libraries
305 Requires:       %{name} = %{version}-%{release}
306 Obsoletes:      cyrus-sasl-opie < %{version}
307
308 %description otp
309 This plugin implements the SASL OTP (One Time Password) mechanism.
310
311 %description otp -l pl.UTF-8
312 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
313 SASL.
314
315 %package pgsql
316 Summary:        Cyrus SASL PostgreSQL plugin
317 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
318 Group:          Libraries
319 Requires:       %{name} = %{version}-%{release}
320
321 %description pgsql
322 Cyrus SASL PostgreSQL plugin.
323
324 %description pgsql -l pl.UTF-8
325 Wtyczka PostgreSQL do Cyrus SASL.
326
327 %package plain
328 Summary:        Plain Cyrus SASL plugin
329 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
330 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
331 Group:          Libraries
332 Requires:       %{name} = %{version}-%{release}
333
334 %description plain
335 This plugin implements the SASL PLAIN mechanism. Although insecure,
336 PLAIN is useful for transitioning to new security mechanisms, as this
337 is the only mechanism which gives the server a copy of the user's
338 password.
339
340 %description plain -l pl.UTF-8
341 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
342 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
343 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
344 który udostępnia serwerowi kopię hasła użytkownika.
345
346 %description plain -l pt_BR.UTF-8
347 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
348 mecanismo é útil durante transições para novos mecanismos de
349 segurança, pois é o único esquema que fornece uma cópia da senha do
350 usuário para o servidor.
351
352 %package sasldb
353 Summary:        Cyrus SASL sasldb plugin
354 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
355 Group:          Libraries
356 Requires:       %{name} = %{version}-%{release}
357
358 %description sasldb
359 Cyrus SASL sasldb plugin.
360
361 %description sasldb -l pl.UTF-8
362 Wtyczka sasldb do Cyrus SASL.
363
364 %package scram
365 Summary:        SCRAM Cyrus SASL plugin
366 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
367 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
368 Group:          Libraries
369 Requires:       %{name} = %{version}-%{release}
370
371 %description scram
372 This plugin implements the SASL SCRAM-MD5 mechanism.
373
374 %description scram -l pl.UTF-8
375 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
376
377 %description scram -l pt_BR.UTF-8
378 Este plugin implementa o mecanismo SASL SCRAM.
379
380 %package sqlite
381 Summary:        Cyrus SQLite 2 PostgreSQL plugin
382 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
383 Group:          Libraries
384 Requires:       %{name} = %{version}-%{release}
385
386 %description sqlite
387 Cyrus SASL SQLite 2 plugin.
388
389 %description sqlite -l pl.UTF-8
390 Wtyczka SQLite 2 do Cyrus SASL.
391
392 %package sqlite3
393 Summary:        Cyrus SQLite 3 PostgreSQL plugin
394 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
395 Group:          Libraries
396 Requires:       %{name} = %{version}-%{release}
397
398 %description sqlite3
399 Cyrus SASL SQLite 3 plugin.
400
401 %description sqlite3 -l pl.UTF-8
402 Wtyczka SQLite 3 do Cyrus SASL.
403
404 %package srp
405 Summary:        SRP Cyrus SASL plugin
406 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
407 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
408 Group:          Libraries
409 Requires:       %{name} = %{version}-%{release}
410
411 %description srp
412 This plugin implements the SASL SRP mechanism, based on the Secure
413 Remote Password protocol. This mechanism performs mutual
414 authentication and can provide a security layer with replay detection,
415 integrity protection and/or condifentiality protection.
416
417 %description srp -l pl.UTF-8
418 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
419 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
420 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
421 powtarzania, zabezpieczeniem integralności i/lub poufności.
422
423 %description srp -l pt_BR.UTF-8
424 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
425 (Secure Remote Password). Este mecanismo oferece autenticação mútua
426 (do cliente e do servidor) e pode prover uma camada de segurança com
427 detecção de ataques de replay, garantia de integridade e/ou
428 confidencialidade.
429
430 %package pwcheck
431 Summary:        Cyrus SASL pwcheck helper
432 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
433 Group:          Libraries
434 Requires:       %{name} = %{version}-%{release}
435
436 %description pwcheck
437 Cyrus SASL pwcheck helper.
438
439 %description pwcheck -l pl.UTF-8
440 Program pomocniczy pwcheck do Cyrus SASL.
441
442 %package saslauthd
443 Summary:        Cyrus SASL authd
444 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
445 Group:          Daemons
446 Requires(post,preun):   /sbin/chkconfig
447 Requires:       %{name} = %{version}-%{release}
448 Requires:       /sbin/chkconfig
449 Requires:       rc-scripts
450
451 %description saslauthd
452 Cyrus SASL authd.
453
454 %description saslauthd -l pl.UTF-8
455 Demon authd do Cyrus SASL.
456
457 %package -n nagios-plugin-check_saslauthd
458 Summary:        Nagios plugin to check health of saslauthd
459 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
460 Group:          Networking
461 Requires:       nagios-core
462
463 %description -n nagios-plugin-check_saslauthd
464 Nagios plugin to check health of saslauthd.
465
466 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
467 Wtyczka Nagiosa do sprawdzania działania saslauthd.
468
469 %prep
470 %setup -q
471 %patch0 -p1
472 %patch1 -p1
473 %patch2 -p1
474 %patch3 -p1
475 %patch4 -p1
476 %if %{with cryptedpw}
477 %patch5 -p1
478 %patch6 -p1
479 %endif
480 %patch7 -p1
481 %patch8 -p1
482 %patch9 -p1
483 %patch10 -p1
484 %patch11 -p1
485 %patch12 -p1
486 %patch13 -p0
487 %patch14 -p1
488 %patch15 -p1
489 %patch16 -p1
490 %patch17 -p1
491 %patch18 -p1
492 %patch19 -p1
493 %patch20 -p1
494 %patch21 -p1
495
496 cd doc
497 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
498 ls rfc*.txt >> rfc-compliance
499 rm -f rfc*.txt
500 cd ..
501
502 # old version
503 %{__rm} config/libtool.m4
504
505 # update to our paths
506 sed -i -e '
507         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
508         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
509         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
510         s,/var/state/saslauthd,/var/lib/sasl2,g
511 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
512
513 %build
514 %{__libtoolize}
515 %{__aclocal} -I cmulocal -I config
516 %{__autoheader}
517 %{__autoconf}
518 %{__automake}
519 cd saslauthd
520 %{__aclocal} -I ../cmulocal -I ../config
521 %{__autoheader}
522 %{__autoconf}
523 %{__automake}
524 cd ..
525 %configure \
526         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
527         --disable-krb4 \
528         %{!?with_gssapi: --disable-gssapi} \
529         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
530         --enable-login \
531         --enable-sample \
532         --enable-httpform \
533         --enable-sql \
534         %{?with_srp: --enable-srp} \
535         --enable-static \
536         --with-plugindir=%{_libdir}/sasl2 \
537         --with-configdir=%{_sysconfdir} \
538         --with-dblib=berkeley \
539         --with-dbpath=/var/lib/sasl2/sasl.db \
540         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
541         %{?with_ldap: --with-ldap=%{_prefix}} \
542         %{?with_ldap: --enable-ldapdb} \
543         %{?with_mysql: --with-mysql=%{_prefix}} \
544         %{?with_pgsql: --with-pgsql=%{_prefix}} \
545         %{?with_sqlite: --with-sqlite=%{_prefix}} \
546         %{?with_sqlite3: --with-sqlite3=%{_prefix}} \
547         %{?with_opie: --with-opie=%{_prefix}} \
548         --with-pam \
549         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
550         --with-saslauthd=/var/lib/sasl2
551
552 %{__make}
553
554 %{__make} -C saslauthd testsaslauthd
555 %{__make} -C saslauthd saslcache
556 %{__make} -C sample sample-client sample-server
557
558 cd doc
559 RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
560 for i in $RFCLIST; do
561         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
562         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
563 done
564
565 %install
566 rm -rf $RPM_BUILD_ROOT
567 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
568                 $RPM_BUILD_ROOT%{_mandir}/man8
569
570 %{__make} install \
571         sasldir=%{_libdir}/sasl2 \
572         DESTDIR=$RPM_BUILD_ROOT
573
574 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
575
576 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
577 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
578
579 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
580
581 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
582
583 # create empty config
584 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
585 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
586 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
587 cp -a %{SOURCE3} cyrus.pam
588
589 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
590
591 # sample programs for testing sasl
592 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
593 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
594
595 # package for ghost
596 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
597
598 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
599 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
600
601 %clean
602 rm -rf $RPM_BUILD_ROOT
603
604 %post   libs -p /sbin/ldconfig
605 %postun libs -p /sbin/ldconfig
606
607 %post saslauthd
608 /sbin/chkconfig --add saslauthd
609 %service saslauthd restart
610
611 %preun saslauthd
612 if [ "$1" = "0" ]; then
613         %service saslauthd stop
614         /sbin/chkconfig --del saslauthd
615 fi
616
617 %triggerin saslauthd -- pam
618 # restart saslauthd if pam is upgraded
619 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
620 if [ "$2" != 1 ]; then
621         %service -q saslauthd restart
622 fi
623
624 %files
625 %defattr(644,root,root,755)
626 %doc AUTHORS COPYING ChangeLog NEWS README
627 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
628 %dir %{_sysconfdir}
629 %dir %{_libdir}/sasl2
630 # sample programs to subpackage instead?
631 %attr(755,root,root) %{_bindir}/sasl-sample-client
632 %attr(755,root,root) %{_bindir}/sasl-sample-server
633 %attr(755,root,root) %{_sbindir}/pluginviewer
634 %attr(755,root,root) %{_sbindir}/sasldblistusers2
635 %attr(755,root,root) %{_sbindir}/saslpasswd2
636 %dir /var/lib/sasl2
637 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
638 %{_mandir}/man8/pluginviewer.8*
639 %{_mandir}/man8/sasldblistusers2.8*
640 %{_mandir}/man8/saslpasswd2.8*
641
642 %files libs
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
645 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
646
647 %files devel
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/libsasl2.so
650 %attr(755,root,root) %{_libdir}/libsasl.so
651 %{_libdir}/libsasl2.la
652 %{_includedir}/sasl
653 %{_mandir}/man3/sasl*.3*
654
655 %files static
656 %defattr(644,root,root,755)
657 %{_libdir}/libsasl2.a
658
659 %files anonymous
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
662
663 %if %{with gssapi}
664 %files gssapi
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
667 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
668 %endif
669
670 %files cram-md5
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
673
674 %files digest-md5
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
677
678 %files login
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
681
682 %if %{with mysql}
683 %files mysql
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
686 %endif
687
688 %files otp
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
691
692 %if %{with pgsql}
693 %files pgsql
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
696 %endif
697
698 %files plain
699 %defattr(644,root,root,755)
700 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
701
702 %files sasldb
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
705
706 %files scram
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
709
710 %if %{with sqlite}
711 %files sqlite
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
714 %endif
715
716 %if %{with sqlite3}
717 %files sqlite3
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
720 %endif
721
722 %if %{with srp}
723 %files srp
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
726 %endif
727
728 %if %{with pwcheck}
729 %files pwcheck
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_sbindir}/pwcheck
732 %endif
733
734 %files saslauthd
735 %defattr(644,root,root,755)
736 %doc cyrus.pam
737 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
738 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
739 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
740 %attr(755,root,root) %{_sbindir}/saslauthd
741 %attr(755,root,root) %{_sbindir}/testsaslauthd
742 %attr(755,root,root) %{_sbindir}/saslcache
743 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
744 %ghost /var/lib/sasl2/cache.flock
745 %ghost /var/lib/sasl2/cache.mmap
746 %ghost /var/lib/sasl2/mux
747 %ghost /var/lib/sasl2/mux.accept
748 %ghost /var/lib/sasl2/saslauthd.pid
749 %{_mandir}/man8/saslauthd.8*
750
751 %files -n nagios-plugin-check_saslauthd
752 %defattr(644,root,root,755)
753 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
754 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.105395 seconds and 3 git commands to generate.