]> git.pld-linux.org Git - packages/crossmingw32-libffi.git/blob - crossmingw32-libffi.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-libffi.git] / crossmingw32-libffi.spec
1 Summary:        Foreign Function Interface library (cross MinGW32 version)
2 Summary(pl.UTF-8):      Biblioteka Foreign Function Interface (wersja skrośna MinGW32)
3 Name:           crossmingw32-libffi
4 Version:        3.0.13
5 Release:        2
6 License:        MIT-like
7 Group:          Libraries
8 Source0:        ftp://sourceware.org/pub/libffi/libffi-%{version}.tar.gz
9 # Source0-md5:  45f3b6dbc9ee7c7dfbbbc5feba571529
10 URL:            http://sources.redhat.com/libffi/
11 BuildRequires:  texinfo
12 Requires:       crossmingw32-runtime
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         no_install_post_strip   1
16
17 %define         target                  i386-mingw32
18 %define         target_platform         i386-pc-mingw32
19
20 %define         _sysprefix              /usr
21 %define         _prefix                 %{_sysprefix}/%{target}
22 %define         _libdir                 %{_prefix}/lib
23 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
24 %define         _dlldir                 /usr/share/wine/windows/system
25 %define         __cc                    %{target}-gcc
26 %define         __pkgconfig_provides    %{nil}
27
28 %ifnarch %{ix86}
29 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
30 %define         optflags        -O2
31 %endif
32 # -z options are invalid for mingw linker, most of -f options are Linux-specific
33 %define         filterout_ld    -Wl,-z,.*
34 %define         filterout_c     -f[-a-z0-9=]*
35
36 %description
37 The libffi library provides a portable, high level programming
38 interface to various calling conventions. This allows a programmer to
39 call any function specified by a call interface description at
40 run-time.
41
42 Ffi stands for Foreign Function Interface. A foreign function
43 interface is the popular name for the interface that allows code
44 written in one language to call code written in another language. The
45 libffi library really only provides the lowest, machine dependent
46 layer of a fully featured foreign function interface. A layer must
47 exist above libffi that handles type conversions for values passed
48 between the two languages.
49
50 This package contains the cross version for MinGW32.
51
52 %description -l pl.UTF-8
53 Biblioteka libffi dostarcza przenośny, wysokopoziomowy interfejs do
54 różnych konwencji wywołań funkcji. Pozwala to programiście wywołać
55 dowolną funkcję podaną przez opis interfejsu wywołania w czasie
56 działania programu.
57
58 FFI to skrót od Foreign Function Interface, czyli interfejsu do obcych
59 funkcji. Jest to potoczna nazwa interfejsu pozwalającego programowi
60 napisanemu w jednym języku wywoływać kod napisany w innym języku.
61 Biblioteka libffi daje tylko najniższą, zależną od maszyny warstwę
62 pełnego interfejsu. Potrzebne są wyższe warstwy do obsługi konwersji
63 typów dla wartości przekazywanych pomiędzy różnymi językami.
64
65 Ten pakiet zawiera wersję skrośną dla MinGW32.
66
67 %package static
68 Summary:        Static libffi library (cross MinGW32 version)
69 Summary(pl.UTF-8):      Statyczna biblioteka libffi (wersja skrośna MinGW32)
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description static
74 Static libffi library (cross MinGW32 version).
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka libffi (wersja skrośna MinGW32).
78
79 %package dll
80 Summary:        Foreign Function Interface DLL library for Windows
81 Summary(pl.UTF-8):      Biblioteka DLL Foreign Function Interface dla Windows
82 Group:          Applications/Emulators
83 Requires:       wine
84
85 %description dll
86 Foreign Function Interface DLL library for Windows.
87
88 %description dll -l pl.UTF-8
89 Biblioteka DLL Foreign Function Interface dla Windows.
90
91 %prep
92 %setup -q -n libffi-%{version}
93
94 %build
95 %configure \
96         --target=%{target} \
97         --host=%{target}
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 install -d $RPM_BUILD_ROOT%{_dlldir}
108 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
109
110 %if 0%{!?debug:1}
111 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
112 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
113 %endif
114
115 %{__rm} -r $RPM_BUILD_ROOT{%{_mandir},%{_infodir}}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc ChangeLog* LICENSE README
123 %{_libdir}/libffi.dll.a
124 %{_libdir}/libffi.la
125 %{_libdir}/libffi-%{version}
126 %{_pkgconfigdir}/libffi.pc
127
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/libffi.a
131
132 %files dll
133 %defattr(644,root,root,755)
134 %{_dlldir}/libffi-6.dll
This page took 0.071928 seconds and 4 git commands to generate.