]> git.pld-linux.org Git - packages/crossmingw32-libffi.git/blame - crossmingw32-libffi.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-libffi.git] / crossmingw32-libffi.spec
CommitLineData
5a3544d1
JB
1Summary: Foreign Function Interface library (cross MinGW32 version)
2Summary(pl.UTF-8): Biblioteka Foreign Function Interface (wersja skrośna MinGW32)
3Name: crossmingw32-libffi
c3671c6c 4Version: 3.0.13
79252b16 5Release: 2
5a3544d1
JB
6License: MIT-like
7Group: Libraries
8Source0: ftp://sourceware.org/pub/libffi/libffi-%{version}.tar.gz
c3671c6c 9# Source0-md5: 45f3b6dbc9ee7c7dfbbbc5feba571529
5a3544d1 10URL: http://sources.redhat.com/libffi/
5a3544d1
JB
11BuildRequires: texinfo
12Requires: crossmingw32-runtime
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15%define no_install_post_strip 1
16
17%define target i386-mingw32
18%define target_platform i386-pc-mingw32
19
20%define _sysprefix /usr
21%define _prefix %{_sysprefix}/%{target}
22%define _libdir %{_prefix}/lib
23%define _pkgconfigdir %{_prefix}/lib/pkgconfig
24%define _dlldir /usr/share/wine/windows/system
25%define __cc %{target}-gcc
79252b16 26%define __pkgconfig_provides %{nil}
5a3544d1
JB
27
28%ifnarch %{ix86}
29# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
30%define optflags -O2
31%endif
a39e0238
JB
32# -z options are invalid for mingw linker, most of -f options are Linux-specific
33%define filterout_ld -Wl,-z,.*
34%define filterout_c -f[-a-z0-9=]*
5a3544d1
JB
35
36%description
37The libffi library provides a portable, high level programming
38interface to various calling conventions. This allows a programmer to
39call any function specified by a call interface description at
40run-time.
41
42Ffi stands for Foreign Function Interface. A foreign function
43interface is the popular name for the interface that allows code
44written in one language to call code written in another language. The
45libffi library really only provides the lowest, machine dependent
46layer of a fully featured foreign function interface. A layer must
47exist above libffi that handles type conversions for values passed
48between the two languages.
49
50This package contains the cross version for MinGW32.
51
52%description -l pl.UTF-8
53Biblioteka libffi dostarcza przenośny, wysokopoziomowy interfejs do
54różnych konwencji wywołań funkcji. Pozwala to programiście wywołać
55dowolną funkcję podaną przez opis interfejsu wywołania w czasie
56działania programu.
57
58FFI to skrót od Foreign Function Interface, czyli interfejsu do obcych
59funkcji. Jest to potoczna nazwa interfejsu pozwalającego programowi
60napisanemu w jednym języku wywoływać kod napisany w innym języku.
61Biblioteka libffi daje tylko najniższą, zależną od maszyny warstwę
62pełnego interfejsu. Potrzebne są wyższe warstwy do obsługi konwersji
63typów dla wartości przekazywanych pomiędzy różnymi językami.
64
65Ten pakiet zawiera wersję skrośną dla MinGW32.
66
67%package static
68Summary: Static libffi library (cross MinGW32 version)
69Summary(pl.UTF-8): Statyczna biblioteka libffi (wersja skrośna MinGW32)
70Group: Development/Libraries
71Requires: %{name} = %{version}-%{release}
72
73%description static
74Static libffi library (cross MinGW32 version).
75
76%description static -l pl.UTF-8
77Statyczna biblioteka libffi (wersja skrośna MinGW32).
78
79%package dll
80Summary: Foreign Function Interface DLL library for Windows
81Summary(pl.UTF-8): Biblioteka DLL Foreign Function Interface dla Windows
82Group: Applications/Emulators
83Requires: wine
84
85%description dll
86Foreign Function Interface DLL library for Windows.
87
88%description dll -l pl.UTF-8
89Biblioteka DLL Foreign Function Interface dla Windows.
90
91%prep
92%setup -q -n libffi-%{version}
93
94%build
5a3544d1
JB
95%configure \
96 --target=%{target} \
97 --host=%{target}
98
99%{__make}
100
101%install
102rm -rf $RPM_BUILD_ROOT
103
104%{__make} install \
105 DESTDIR=$RPM_BUILD_ROOT
106
107install -d $RPM_BUILD_ROOT%{_dlldir}
108mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
109
110%if 0%{!?debug:1}
111%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
112%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
113%endif
114
115%{__rm} -r $RPM_BUILD_ROOT{%{_mandir},%{_infodir}}
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%files
121%defattr(644,root,root,755)
122%doc ChangeLog* LICENSE README
123%{_libdir}/libffi.dll.a
124%{_libdir}/libffi.la
125%{_libdir}/libffi-%{version}
126%{_pkgconfigdir}/libffi.pc
127
128%files static
129%defattr(644,root,root,755)
130%{_libdir}/libffi.a
131
132%files dll
133%defattr(644,root,root,755)
5185441b 134%{_dlldir}/libffi-6.dll
This page took 0.108906 seconds and 4 git commands to generate.