]> git.pld-linux.org Git - packages/crossmingw32-boost.git/blob - crossmingw32-boost.spec
- rel 1 (builds, seems to work)
[packages/crossmingw32-boost.git] / crossmingw32-boost.spec
1 %define         realname        boost
2 Summary:        The Boost C++ Libraries - Mingw32 cross version
3 Summary(pl.UTF-8):      Biblioteki C++ "Boost" - wersja skrośna dla Mingw32
4 Name:           crossmingw32-%{realname}
5 Version:        1.36.0
6 %define fver    %(echo %{version} | tr . _)
7 Release:        1
8 License:        Boost Software License and others
9 Group:          Development/Libraries
10 Source0:        http://dl.sourceforge.net/boost/%{realname}_%{fver}.tar.bz2
11 # Source0-md5:  328bfec66c312150e4c2a78dcecb504b
12 Patch0:         %{name}-win.patch
13 URL:            http://www.boost.org/
14 BuildRequires:  boost-jam >= 3.1.12
15 BuildRequires:  crossmingw32-bzip2
16 BuildRequires:  crossmingw32-gcc-c++
17 BuildRequires:  crossmingw32-runtime
18 BuildRequires:  crossmingw32-w32api
19 BuildRequires:  crossmingw32-zlib
20 BuildRequires:  libtool >= 2:1.4d
21 Requires:       crossmingw32-bzip2
22 Requires:       crossmingw32-runtime
23 Requires:       crossmingw32-zlib
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         no_install_post_strip   1
27
28 %define         target          i386-mingw32
29 %define         target_platform i386-pc-mingw32
30
31 %define         _sysprefix      /usr
32 %define         _prefix         %{_sysprefix}/%{target}
33 %define         _libdir         %{_prefix}/lib
34 %define         _dlldir         /usr/share/wine/windows/system
35
36 %define         __cc            %{target}-gcc
37 %define         __cxx           %{target}-g++
38
39 %ifnarch %{ix86}
40 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
41 %define         optflags        -O2
42 %endif
43
44 %description
45 The Boost web site provides free peer-reviewed portable C++ source
46 libraries. The emphasis is on libraries which work well with the C++
47 Standard Library. One goal is to establish "existing practice" and
48 provide reference implementations so that the Boost libraries are
49 suitable for eventual standardization. Some of the libraries have
50 already been proposed for inclusion in the C++ Standards Committee's
51 upcoming C++ Standard Library Technical Report.
52
53 %description -l pl.UTF-8
54 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
55 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
56 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
57 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
58 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
59 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
60 Raporcie Technicznym Biblioteki Standardowej C++
61
62 %package dll
63 Summary:        Boost - DLL libraries for Windows
64 Summary(pl.UTF-8):      Boost - biblioteki DLL dla Windows
65 Group:          Applications/Emulators
66 Requires:       crossmingw32-bzip2-dll
67 Requires:       crossmingw32-zlib-dll
68 Requires:       wine
69
70 %description dll
71 Boost - DLL libraries for Windows.
72
73 %description dll -l pl.UTF-8
74 Boost - biblioteki DLL dla Windows.
75
76 %prep
77 %setup -q -n %{realname}_%{fver}
78 %patch0 -p1
79
80 echo 'using gcc : : i386-mingw32-g++ : <cxxflags>"%{rpmcxxflags}" ;' \
81         >tools/build/v2/user-config.jam
82
83 %build
84 CC=%{__cc} ; export CC
85 CXX=%{__cxx} ; export CXX
86 LD=%{target}-ld ; export LD
87 AR=%{target}-ar ; export AR
88 AS=%{target}-as ; export AS
89 CROSS_COMPILE=1 ; export CROSS_COMPILE
90 RANLIB=%{target}-ranlib ; export RANLIB
91 LDSHARED="%{__cc} -shared" ; export LDSHARED
92 TARGET="%{target}" ; export TARGET
93
94 bjam \
95         -q -d2 \
96         -sBZIP2_BINARY=bzip2 \
97         --toolset=gcc \
98         --without-python \
99         --without-serialization \
100         --without-test \
101         variant=release \
102         debug-symbols=on \
103         inlining=on \
104         link=static,shared \
105         target-os=windows \
106         threading=multi \
107         threadapi=win32
108
109 mkdir wlib
110 find bin.v2/libs -name '*.a' -exec cp '{}' wlib \;
111 find bin.v2/libs -name '*.dll' -exec cp '{}' wlib \;
112
113 %if 0%{!?debug:1}
114 %{target}-strip wlib/*.dll
115 %{target}-strip -g -R.comment -R.note wlib/*.a
116 %endif
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_dlldir}}
121
122 cp -r boost $RPM_BUILD_ROOT%{_includedir}
123 install wlib/*.a $RPM_BUILD_ROOT%{_libdir}
124 install wlib/*.dll $RPM_BUILD_ROOT%{_dlldir}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 %defattr(644,root,root,755)
131 %{_includedir}/boost
132 %{_libdir}/*.a
133
134 %files dll
135 %defattr(644,root,root,755)
136 %{_dlldir}/*.dll
This page took 0.066499 seconds and 3 git commands to generate.