]> git.pld-linux.org Git - packages/crossmingw32-boost.git/blame - crossmingw32-boost.spec
- rel 1 (builds, seems to work)
[packages/crossmingw32-boost.git] / crossmingw32-boost.spec
CommitLineData
28441938 1%define realname boost
2Summary: The Boost C++ Libraries - Mingw32 cross version
f825d7b1 3Summary(pl.UTF-8): Biblioteki C++ "Boost" - wersja skrośna dla Mingw32
28441938 4Name: crossmingw32-%{realname}
8d134d9a 5Version: 1.36.0
670a15d7 6%define fver %(echo %{version} | tr . _)
ff36f437 7Release: 1
28441938 8License: Boost Software License and others
33145f37 9Group: Development/Libraries
670a15d7 10Source0: http://dl.sourceforge.net/boost/%{realname}_%{fver}.tar.bz2
8d134d9a 11# Source0-md5: 328bfec66c312150e4c2a78dcecb504b
28441938 12Patch0: %{name}-win.patch
13URL: http://www.boost.org/
8d134d9a 14BuildRequires: boost-jam >= 3.1.12
a72e6f01 15BuildRequires: crossmingw32-bzip2
28441938 16BuildRequires: crossmingw32-gcc-c++
17BuildRequires: crossmingw32-runtime
18BuildRequires: crossmingw32-w32api
a72e6f01 19BuildRequires: crossmingw32-zlib
28441938 20BuildRequires: libtool >= 2:1.4d
a72e6f01
ŁK
21Requires: crossmingw32-bzip2
22Requires: crossmingw32-runtime
23Requires: crossmingw32-zlib
28441938 24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%define no_install_post_strip 1
27
28%define target i386-mingw32
29%define target_platform i386-pc-mingw32
c66a9041
JB
30
31%define _sysprefix /usr
32%define _prefix %{_sysprefix}/%{target}
33%define _libdir %{_prefix}/lib
34%define _dlldir /usr/share/wine/windows/system
28441938 35
36%define __cc %{target}-gcc
37%define __cxx %{target}-g++
38
c66a9041
JB
39%ifnarch %{ix86}
40# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
28441938 41%define optflags -O2
42%endif
43
44%description
45The Boost web site provides free peer-reviewed portable C++ source
46libraries. The emphasis is on libraries which work well with the C++
47Standard Library. One goal is to establish "existing practice" and
48provide reference implementations so that the Boost libraries are
49suitable for eventual standardization. Some of the libraries have
50already been proposed for inclusion in the C++ Standards Committee's
51upcoming C++ Standard Library Technical Report.
52
241a7e06 53%description -l pl.UTF-8
28441938 54Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
241a7e06
JR
55kodem źródłowym. Nacisk położono na biblioteki, które dobrze
56współpracują ze standardową biblioteką C++. Celem jest ustanowienie
57"istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
58"Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
59już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
28441938 60Raporcie Technicznym Biblioteki Standardowej C++
61
62%package dll
c66a9041
JB
63Summary: Boost - DLL libraries for Windows
64Summary(pl.UTF-8): Boost - biblioteki DLL dla Windows
28441938 65Group: Applications/Emulators
670a15d7
JB
66Requires: crossmingw32-bzip2-dll
67Requires: crossmingw32-zlib-dll
68Requires: wine
28441938 69
70%description dll
c66a9041 71Boost - DLL libraries for Windows.
28441938 72
241a7e06 73%description dll -l pl.UTF-8
c66a9041 74Boost - biblioteki DLL dla Windows.
28441938 75
76%prep
670a15d7 77%setup -q -n %{realname}_%{fver}
28441938 78%patch0 -p1
79
ff36f437
ŁK
80echo 'using gcc : : i386-mingw32-g++ : <cxxflags>"%{rpmcxxflags}" ;' \
81 >tools/build/v2/user-config.jam
28441938 82
83%build
c66a9041
JB
84CC=%{__cc} ; export CC
85CXX=%{__cxx} ; export CXX
28441938 86LD=%{target}-ld ; export LD
87AR=%{target}-ar ; export AR
88AS=%{target}-as ; export AS
89CROSS_COMPILE=1 ; export CROSS_COMPILE
28441938 90RANLIB=%{target}-ranlib ; export RANLIB
c66a9041 91LDSHARED="%{__cc} -shared" ; export LDSHARED
28441938 92TARGET="%{target}" ; export TARGET
93
28441938 94bjam \
0826927f
JB
95 -q -d2 \
96 -sBZIP2_BINARY=bzip2 \
97 --toolset=gcc \
98 --without-python \
99 --without-serialization \
100 --without-test \
101 variant=release \
102 debug-symbols=on \
103 inlining=on \
104 link=static,shared \
ff36f437 105 target-os=windows \
0826927f
JB
106 threading=multi \
107 threadapi=win32
28441938 108
109mkdir wlib
ff36f437
ŁK
110find bin.v2/libs -name '*.a' -exec cp '{}' wlib \;
111find bin.v2/libs -name '*.dll' -exec cp '{}' wlib \;
28441938 112
113%if 0%{!?debug:1}
114%{target}-strip wlib/*.dll
115%{target}-strip -g -R.comment -R.note wlib/*.a
116%endif
117
118%install
119rm -rf $RPM_BUILD_ROOT
c66a9041 120install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_dlldir}}
28441938 121
c66a9041
JB
122cp -r boost $RPM_BUILD_ROOT%{_includedir}
123install wlib/*.a $RPM_BUILD_ROOT%{_libdir}
124install wlib/*.dll $RPM_BUILD_ROOT%{_dlldir}
28441938 125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%files
130%defattr(644,root,root,755)
c66a9041
JB
131%{_includedir}/boost
132%{_libdir}/*.a
28441938 133
134%files dll
135%defattr(644,root,root,755)
c66a9041 136%{_dlldir}/*.dll
This page took 0.11103 seconds and 4 git commands to generate.