]> git.pld-linux.org Git - packages/cronie.git/blame - cronie.spec
- update to 1.4.2
[packages/cronie.git] / cronie.spec
CommitLineData
955f0d7d
ER
1# TODO
2# - update paths in manuals (create .in files and send upstream)
3# - make /etc/pam.d independant of sysconfdir (configure-able option and send upstream)
9088c091
AM
4#
5# Conditional build:
946518b7 6%bcond_without inotify # without inotify support
0d2f2c46
ER
7%if "%{pld_release}" == "ac"
8%bcond_with selinux # without SELinux support
9%bcond_with audit # without audit support
10%else
11%bcond_without selinux # without SELinux support
828712ad 12%bcond_without audit # without audit support
0d2f2c46
ER
13%endif
14
9088c091
AM
15Summary: Cron daemon for executing programs at set times
16Name: cronie
fd39f74d
ER
17Version: 1.4.2
18Release: 1
19License: MIT and BSD and GPL v2
9088c091 20Group: Daemons
fd39f74d
ER
21Source0: https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
22# Source0-md5: 9c7cef09ff9c92a90a314a1e947fae5c
9088c091
AM
23Source1: %{name}.init
24Source2: cron.logrotate
25Source3: cron.sysconfig
26Source4: %{name}.crontab
27Source5: %{name}.pam
f440f0d0 28Patch0: inotify-nosys.patch
9c2aa177 29Patch1: %{name}-nosyscrontab.patch
9088c091 30URL: https://fedorahosted.org/cronie/
828712ad
ER
31%{?with_audit:BuildRequires: audit-libs-devel}
32BuildRequires: autoconf
33BuildRequires: automake
9088c091
AM
34%{?with_selinux:BuildRequires: libselinux-devel}
35BuildRequires: pam-devel
0d2f2c46 36BuildRequires: rpm >= 4.4.9-56
9088c091
AM
37BuildRequires: rpmbuild(macros) >= 1.268
38Requires(post): fileutils
39Requires(post,preun): /sbin/chkconfig
40Requires(post,preun): rc-scripts
41Requires(postun): /usr/sbin/groupdel
42Requires(pre): /usr/bin/getgid
43Requires(pre): /usr/sbin/groupadd
44Requires: /bin/run-parts
45Requires: /sbin/chkconfig
46Requires: psmisc >= 20.1
47Requires: rc-scripts
f440f0d0 48%{?with_inotify:Requires: uname(release) >= 2.6.13}
9088c091
AM
49Provides: crondaemon
50Provides: crontabs = 1.7
51Provides: group(crontab)
0d2f2c46 52%if "%{pld_release}" == "th"
84a870a4 53Provides: vixie-cron = 4:4.4
daf76cdc 54%endif
9088c091
AM
55Obsoletes: crondaemon
56Obsoletes: crontabs
0d2f2c46 57%if "%{pld_release}" == "th"
84a870a4 58Obsoletes: vixie-cron <= 4:4.3
daf76cdc 59%endif
9088c091
AM
60BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62%description
84a870a4
AM
63Cronie contains the standard UNIX daemon crond that runs specified
64programs at scheduled times and related tools. It is based on the
65original cron and has security and configuration enhancements like the
66ability to use pam and SELinux.
9088c091
AM
67
68%package anacron
84a870a4
AM
69Summary: Utility for running regular jobs
70Group: Base
71Provides: anacron = 2.4
72Obsoletes: anacron <= 2.3
9088c091
AM
73
74%description anacron
84a870a4
AM
75Anacron becames part of cronie. Anacron is used only for running
76regular jobs. The default settings execute regular jobs by anacron,
77however this could be overloaded in settings.
9088c091
AM
78
79%prep
80%setup -q
f440f0d0 81%patch0 -p1
9c2aa177 82%patch1 -p1
9088c091
AM
83
84%build
828712ad
ER
85%{__aclocal}
86%{__autoconf}
87%{__autoheader}
88%{__automake}
9088c091 89%configure \
d39ca4fd 90 SYSCRONTAB=/etc/crontab \
695ed2ed 91 SYS_CROND_DIR=/etc/cron.d \
72768a3d 92 --sysconfdir=/etc/cron \
9088c091 93 --with-pam \
45b0067d 94 --with%{!?with_selinux:out}-selinux \
828712ad 95 --with%{!?with_audit:out}-audit \
946518b7 96 --with%{!?with_inotify:out}-inotify \
9088c091
AM
97 --enable-anacron
98
99%{__make}
100
101%install
102rm -rf $RPM_BUILD_ROOT
d07a95b8 103install -d $RPM_BUILD_ROOT{/var/{log,spool/{ana,}cron},%{_mandir}} \
9088c091
AM
104 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
105 $RPM_BUILD_ROOT%{_sysconfdir}/{cron,cron.{d,hourly,daily,weekly,monthly},pam.d}
106
107%{__make} install \
0d2f2c46 108 pamdir=/etc/pam.d \
9088c091
AM
109 DESTDIR=$RPM_BUILD_ROOT
110
fd39f74d
ER
111install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
112cp -a contrib/0anacron $RPM_BUILD_ROOT/etc/cron.hourly/0anacron
113cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/cron
114cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
115cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
116cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
9088c091
AM
117
118touch $RPM_BUILD_ROOT/var/log/cron
119
120cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.allow << 'EOF'
121# cron.allow This file describes the names of the users which are
122# allowed to use the local cron daemon
123root
124EOF
125
126cat > $RPM_BUILD_ROOT%{_sysconfdir}/cron/cron.deny << 'EOF'
127# cron.deny This file describes the names of the users which are
128# NOT allowed to use the local cron daemon
129EOF
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%pre
135%groupadd -g 117 -r -f crontab
136
137%post
fd39f74d
ER
138if [ ! -f /var/log/cron ]; then
139 umask 027
140 touch /var/log/cron
141 chgrp crontab /var/log/cron
142 chmod 660 /var/log/cron
143fi
9088c091 144/sbin/chkconfig --add crond
9088c091
AM
145%service crond restart "Cron Daemon"
146
147%preun
148if [ "$1" = "0" ]; then
149 %service crond stop
150 /sbin/chkconfig --del crond
151fi
152
153%postun
154if [ "$1" = "0" ]; then
155 %groupremove crontab
156fi
157
158%triggerpostun -- hc-cron
159# reinstall crond init.d links, which could be different
160/sbin/chkconfig --del crond
161/sbin/chkconfig --add crond
162
77af6cfd
AM
163%triggerun -- vixie-cron
164# Prevent preun from crond from working
165chmod a-x /etc/rc.d/init.d/crond
166
167%triggerpostun -- vixie-cron
168# Restore what triggerun removed
169chmod 754 /etc/rc.d/init.d/crond
170/sbin/chkconfig --add crond
171
9088c091
AM
172%files
173%defattr(644,root,root,755)
174%doc AUTHORS ChangeLog README
175%attr(750,root,crontab) %dir %{_sysconfdir}/cron*
176%attr(640,root,crontab) %config(noreplace,missingok) /etc/cron.d/crontab
177%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.allow
178%attr(640,root,crontab) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/cron/cron.deny
179%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cron
180%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/crond
181%attr(754,root,root) /etc/rc.d/init.d/crond
182%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
183%attr(755,root,root) %{_sbindir}/crond
184%attr(2755,root,crontab) %{_bindir}/crontab
185
186%{_mandir}/man8/crond.8*
187%{_mandir}/man8/cron.8*
188%{_mandir}/man5/crontab.5*
189%{_mandir}/man1/crontab.1*
190
191%attr(1730,root,crontab) /var/spool/cron
192%attr(660,root,crontab) %ghost /var/log/cron
193
194%files anacron
195%defattr(644,root,root,755)
196%attr(755,root,root) %{_sbindir}/anacron
84a870a4 197%attr(755,root,root) %{_sysconfdir}/cron.hourly/0anacron
9088c091
AM
198%{_mandir}/man5/anacrontab.5*
199%{_mandir}/man8/anacron.8*
d07a95b8
AM
200
201%attr(1730,root,crontab) /var/spool/anacron
This page took 0.055965 seconds and 4 git commands to generate.