]> git.pld-linux.org Git - packages/coreutils.git/commitdiff
-up to 8.6; really run tests; po pl patch merged upstream auto/th/coreutils-8_6-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 17 Oct 2010 19:53:52 +0000 (19:53 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    coreutils-advcopy.patch -> 1.7
    coreutils-fmt-wchars.patch -> 1.7
    coreutils-getgid.patch -> 1.16
    coreutils-info.patch -> 1.9
    coreutils.spec -> 1.166

coreutils-advcopy.patch
coreutils-fmt-wchars.patch
coreutils-getgid.patch
coreutils-info.patch
coreutils.spec

index 2eca7d5d53eebdc6b48781fffd6c2cc4459ea44a..0eee167fd072d01ccdb6a1fcae4017a346f29170 100644 (file)
@@ -126,7 +126,7 @@ diff -ru coreutils-8.4.orig/src/copy.c coreutils-8.4/src/copy.c
 +      int last_size = g_iTotalWritten;
 +      /* END progress mod */
 +
 +      int last_size = g_iTotalWritten;
 +      /* END progress mod */
 +
-       for (;;)
+       while (true)
          {
 +          if (progress) {
 +          /* BEGIN progress mod */
          {
 +          if (progress) {
 +          /* BEGIN progress mod */
index 3b636b07fe20f16fe95b7196d6d343cd0bef11ba..48d02278aa729fdcdd96081a01903401e2111526 100644 (file)
@@ -491,7 +491,7 @@ diff -ur coreutils-7.6.org/src/fmt.c coreutils-7.6/src/fmt.c
 +static wint_t
 +get_space (FILE *f, wint_t c)
  {
 +static wint_t
 +get_space (FILE *f, wint_t c)
  {
-   for (;;)
+   while (true)
      {
 -      if (c == ' ')
 +      if (c == L' ')
      {
 -      if (c == ' ')
 +      if (c == L' ')
index 4f326e902ee06db6de4a0d4e074dcf97dbff6e2c..eef4d6099e7a1459a5e5491996fdb0320ac4ac47 100644 (file)
@@ -216,3 +216,14 @@ diff -Nur coreutils-4.5.3.orig/src/getgid.c coreutils-4.5.3/src/getgid.c
  #: src/getlimits.c:29 src/timeout.c:74 src/truncate.c:42
  msgid "Padraig Brady"
 
  #: src/getlimits.c:29 src/timeout.c:74 src/truncate.c:42
  msgid "Padraig Brady"
 
+--- coreutils-8.6/README~      2010-10-17 21:37:11.589739007 +0200
++++ coreutils-8.6/README       2010-10-17 21:42:27.222782339 +0200
+@@ -9,7 +9,7 @@
+   [ arch base64 basename cat chcon chgrp chmod chown chroot cksum comm cp
+   csplit cut date dd df dir dircolors dirname du echo env expand expr
+-  factor false fmt fold groups head hostid hostname id install join kill
++  factor false fmt fold getgid groups head hostid hostname id install join kill
+   link ln logname ls md5sum mkdir mkfifo mknod mktemp mv nice nl nohup
+   nproc od paste pathchk pinky pr printenv printf ptx pwd readlink rm rmdir
+   runcon runuser seq sha1sum sha224sum sha256sum sha384sum sha512sum shred shuf
index be9a6f7e80355c174cf45cdb9e0bc9843c19b550..488d80d127ab636c33b8088089f91c401751b7bb 100644 (file)
  @section @command{md5sum}: Print or check MD5 digests
  
  @pindex md5sum
  @section @command{md5sum}: Print or check MD5 digests
  
  @pindex md5sum
-@@ -3419,7 +3401,7 @@
- considered infeasible at the moment, it is known how to produce
- different files with identical MD5 (a ``collision''), something which
- can be a security issue in certain contexts.  For more secure hashes,
--consider using SHA-1 or SHA-2.  @xref{sha1sum invocation}, and
-+consider using SHA-1 or SHA-2.  @xref{sha1sum}, and
- @ref{sha2 utilities}.
- If a @var{file} is specified as @samp{-} or if no files are given
 @@ -3527,7 +3509,7 @@
  @exitstatus
  
 @@ -3527,7 +3509,7 @@
  @exitstatus
  
  except that keys with the same value sort together.
  
  If multiple random sort fields are specified, the same random hash
  except that keys with the same value sort together.
  
  If multiple random sort fields are specified, the same random hash
+@@ -4060,7 +4060,7 @@
+ Limit the number of sorts run in parallel to @var{n}. By default,
+ @var{n} is set to the number of available processors, and values
+ greater than that are reduced to that limit. Also see
+-@ref{nproc invocation}.
++@ref{nproc}.
+ @item -u
+ @itemx --unique
 @@ -4077,7 +4059,7 @@
  this equivalence does not extend to arbitrary @command{sort} options.
  For example, @code{sort -n -u} inspects only the value of the initial
 @@ -4077,7 +4059,7 @@
  this equivalence does not extend to arbitrary @command{sort} options.
  For example, @code{sort -n -u} inspects only the value of the initial
index 3c02ac91b332cd35d541416a8716ead3c901395f..c61c48978be5ed31315857aa5dad75dfa14298c2 100644 (file)
@@ -5,12 +5,12 @@
 Summary:       GNU Core-utils - basic command line utilities
 Summary(pl.UTF-8):     GNU Core-utils - podstawowe narzędzia działające z linii poleceń
 Name:          coreutils
 Summary:       GNU Core-utils - basic command line utilities
 Summary(pl.UTF-8):     GNU Core-utils - podstawowe narzędzia działające z linii poleceń
 Name:          coreutils
-Version:       8.5
-Release:       3
+Version:       8.6
+Release:       1
 License:       GPL v3+
 Group:         Applications/System
 Source0:       http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
 License:       GPL v3+
 Group:         Applications/System
 Source0:       http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
-# Source0-md5: 55170ed640e300f5b81640c6f4641513
+# Source0-md5: 17d693d282ac57c62b241a045e7b511c
 Source1:       %{name}-non-english-man-pages.tar.bz2
 # Source1-md5: f7c986ebc74ccb8d08ed70141063f14c
 Source2:       DIR_COLORS
 Source1:       %{name}-non-english-man-pages.tar.bz2
 # Source1-md5: f7c986ebc74ccb8d08ed70141063f14c
 Source2:       DIR_COLORS
@@ -110,7 +110,7 @@ Programy zawarte w tym pakiecie to:
 
 %prep
 %setup -q -a1
 
 %prep
 %setup -q -a1
-%patch13 -p1
+#%patch13 -p1
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -149,7 +149,7 @@ rm -f po/stamp-po
 
 %{__make}
 
 
 %{__make}
 
-%{?with_tests:%{__make} tests}
+%{?with_tests:%{__make} tests check}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.166994 seconds and 4 git commands to generate.