]> git.pld-linux.org Git - packages/cone.git/blame - cone.spec
- disable tests (require working valgrind)
[packages/cone.git] / cone.spec
CommitLineData
147daf49 1#
b848eaf8 2# Conditional build:
524452f3 3%bcond_with tests # "make check" (requires operational valgrind, i.e. with glibc-debuginfo)
b848eaf8
JB
4%bcond_with gnutls # GnuTLS instead of OpenSSL
5%bcond_with socks # (Courier) Socks support
6
6657dc05 7Summary: CONE - Console Newsreader and Emailer
28d6cad6 8Summary(pl.UTF-8): CONE - tekstowy klient poczty i czytnik newsów
f976440c 9Name: cone
dbfec406
JB
10Version: 1.8
11Release: 1
b848eaf8 12License: GPL v3 with OpenSSL exception
f976440c 13Group: Applications/Mail
79f20932 14Source0: https://downloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
dbfec406 15# Source0-md5: 3b5c398c693d6aa60ea90f4d19f0ac39
ad21e748 16Patch0: %{name}-maildir.patch
b848eaf8 17Patch1: %{name}-curses.patch
509212ad 18URL: http://www.courier-mta.org/cone/
f976440c 19BuildRequires: aspell-devel
b848eaf8 20BuildRequires: autoconf >= 2.59
6657dc05 21BuildRequires: automake
b848eaf8 22%{?with_socks:BuildRequires: courier-sox-devel}
56116331 23BuildRequires: courier-unicode-devel >= 2.1
79f20932 24BuildRequires: gettext-tools
b848eaf8
JB
25# or gnupg2 --with-gpg2, will use the same at runtime
26BuildRequires: gnupg
27%{?with_gnutls:BuildRequires: gnutls-devel >= 3.0}
28%{?with_gnutls:BuildRequires: libgcrypt-devel}
29%{?with_gnutls:BuildRequires: libgpg-error-devel}
dbfec406 30BuildRequires: libidn2-devel >= 0.0.0
f976440c 31BuildRequires: libstdc++-devel
b848eaf8
JB
32BuildRequires: libtool >= 2:1.5
33BuildRequires: libxml2-devel >= 2.0
34BuildRequires: ncurses-devel >= 5
35BuildRequires: openldap-devel
36%{!?with_gnutls:BuildRequires: openssl-devel >= 0.9.7d}
79f20932 37BuildRequires: pcre2-8-devel
509212ad 38BuildRequires: perl-base
b848eaf8
JB
39BuildRequires: pkgconfig
40BuildRequires: procps
48814c1c 41BuildRequires: sysconftool
524452f3 42%{?with_tests:BuildRequires: valgrind}
f976440c 43BuildRequires: zlib-devel
31f2e7d7 44Requires: ca-certificates
b848eaf8 45Suggests: gnupg
ae636a87
JB
46Conflicts: courier-imap < 5
47Conflicts: courier-imapd < 1
48Conflicts: maildrop < 3
f976440c
AA
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
509212ad
JB
52CONE is a simple, text-based E-mail reader and writer, and a simple
53newsreader.
f976440c 54
8628d5b4
JR
55%description -l pl.UTF-8
56CONE jest prostym, tekstowym klientem pocztowym, a także prostym
57czytnikiem newsów.
f976440c 58
509212ad 59%package devel
b848eaf8
JB
60Summary: Header files and static LibMAIL library
61Summary(pl.UTF-8): Pliki nagłówkowe i biblioteka statyczna LibMAIL
62Group: Development/Libraries
63Requires: courier-unicode-devel >= 2.0
64%{?with_gnutls:Requires: gnutls-devel >= 3.0}
dbfec406 65Requires: libidn2-devel >= 0.0.0
b848eaf8
JB
66Requires: libstdc++-devel
67%{!?with_gnutls:Requires: openssl-devel >= 0.9.7d}
68Obsoletes: cone-static < 0.96
f976440c
AA
69
70%description devel
b848eaf8
JB
71This package includes the header files and static library for
72developing applications using LibMAIL - a high level, C++ OO library
73for mail clients.
f976440c 74
8628d5b4 75%description devel -l pl.UTF-8
b848eaf8
JB
76Ten pakiet zawiera pliki nagłówkowe i bibliotekę statyczną do
77tworzenia aplikacji z użyciem LibMAIL - wysokopoziomowej,
78zorientowanej obiektowo biblioteki C++ dla klientów pocztowych.
f976440c 79
6657dc05
AA
80%package -n leaf
81Summary: Console text file editor
28d6cad6 82Summary(pl.UTF-8): Konsolowy edytor plików tekstowych
6657dc05
AA
83Group: Applications/Editors
84
85%description -n leaf
b78eacde
ER
86Leaf is a simple console text file editor, with paragraph
87word-wrapping and spell checking. Leaf is based on the text editor in
88the Cone mail reader and composer.
6657dc05 89
8628d5b4 90%description -n leaf -l pl.UTF-8
b848eaf8
JB
91Leaf jest prostym konsolowym edytorem plików tekstowych, z zawijaniem
92wierszy w akapitach i sprawdzaniem pisowni. Jest oparty na edytorze
93używanym w czytniku poczty Cone.
6657dc05 94
f976440c
AA
95%prep
96%setup -q
ad21e748 97%patch0 -p1
f976440c
AA
98
99%build
b848eaf8
JB
100%{__libtoolize}
101for d in $(sed -ne 's/.*AC_CONFIG_SUBDIRS(\([^)]*\))/\1/p' configure.ac) . ; do
102 if [ -d "$d" ]; then
103 cd $d
104 %{__aclocal}
105 %{__autoconf}
106 if grep -q AC_CONFIG_HEADER configure.ac ; then
107 %{__autoheader}
108 fi
109 %{__automake}
110 cd -
111 fi
112done
113
f976440c 114%configure \
b848eaf8 115 SENDMAIL=/usr/lib/sendmail \
a3ca27dd 116 --with-certdb=%{_sysconfdir}/certs/ca-certificates.crt \
b848eaf8 117 --with-devel \
ae636a87
JB
118 %{?with_gnutls:--with-gnutls} \
119 --with-notice=unicode
f976440c
AA
120
121%{__make}
122
b848eaf8
JB
123%if %{with tests}
124%{__make} check
125%endif
f976440c
AA
126
127%install
128rm -rf $RPM_BUILD_ROOT
129
130%{__make} install \
131 DESTDIR=$RPM_BUILD_ROOT
132
b848eaf8 133%{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/cone.dist $RPM_BUILD_ROOT%{_sysconfdir}/cone
6657dc05 134
b848eaf8
JB
135# move docs to more specific location
136install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
137%{__mv} $RPM_BUILD_ROOT%{_datadir}/cone/{*.html,manpage.css} $RPM_BUILD_ROOT%{_docdir}/%{name}
f976440c 138
f976440c
AA
139%clean
140rm -rf $RPM_BUILD_ROOT
141
ae636a87
JB
142%triggerpostun -- %{name} < 1
143%banner -e cone-unicode <<EOF
144WARNING: you have to convert any existing maildirs to Unicode naming scheme.
145See INSTALL file for details.
146EOF
147
f976440c
AA
148%files
149%defattr(644,root,root,755)
b848eaf8
JB
150%doc AUTHORS COPYING ChangeLog NEWS README
151%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cone
509212ad 152%attr(755,root,root) %{_bindir}/cone
509212ad 153%attr(755,root,root) %{_bindir}/mailtool
b848eaf8 154%attr(755,root,root) %{_libexecdir}/cone
f976440c 155%{_datadir}/cone
b848eaf8
JB
156%{_mandir}/man1/cone.1*
157%{_mandir}/man1/mailtool.1*
158%dir %{_docdir}/%{name}
159%{_docdir}/%{name}/FAQ.html
160%{_docdir}/%{name}/INSTALL.html
161%{_docdir}/%{name}/README.html
162%{_docdir}/%{name}/add.html
163%{_docdir}/%{name}/attributes.html
164%{_docdir}/%{name}/bk01-toc.html
165%{_docdir}/%{name}/cone*.html
166%{_docdir}/%{name}/conn.html
167%{_docdir}/%{name}/index.html
168%{_docdir}/%{name}/maillist.html
169%{_docdir}/%{name}/mailtool.html
170%{_docdir}/%{name}/manpage.css
171%{_docdir}/%{name}/moredocs.html
172%{_docdir}/%{name}/search.html
173%{_docdir}/%{name}/smap*.html
174%{_docdir}/%{name}/store.html
f976440c
AA
175
176%files devel
177%defattr(644,root,root,755)
b848eaf8 178%{_libdir}/libmail.a
b41719b0 179%{_libdir}/libmail.la
f976440c 180%{_includedir}/libmail
b848eaf8
JB
181%{_mandir}/man3/mail::*.3x*
182%dir %{_docdir}/%{name}
183%{_docdir}/%{name}/account-*.html
184%{_docdir}/%{name}/address.html
185%{_docdir}/%{name}/cppnamespace.html
186%{_docdir}/%{name}/emailaddress.html
187%{_docdir}/%{name}/envelope.html
188%{_docdir}/%{name}/folder-*.html
189%{_docdir}/%{name}/header-*.html
190%{_docdir}/%{name}/libmail*.html
191%{_docdir}/%{name}/mail-*.html
192%{_docdir}/%{name}/mimestruct.html
193%{_docdir}/%{name}/misc.html
194%{_docdir}/%{name}/native.html
195%{_docdir}/%{name}/synchronous.html
6657dc05
AA
196
197%files -n leaf
198%defattr(644,root,root,755)
6657dc05 199%attr(755,root,root) %{_bindir}/leaf
b848eaf8
JB
200%{_mandir}/man1/leaf.1*
201%dir %{_docdir}/%{name}
202%{_docdir}/%{name}/leaf.html
This page took 0.15752 seconds and 4 git commands to generate.