]> git.pld-linux.org Git - packages/cone.git/blame - cone.spec
Release 2 (by relup.sh)
[packages/cone.git] / cone.spec
CommitLineData
147daf49 1#
b848eaf8
JB
2# Conditional build:
3%bcond_without tests # "make check"
4%bcond_with gnutls # GnuTLS instead of OpenSSL
5%bcond_with socks # (Courier) Socks support
6
6657dc05 7Summary: CONE - Console Newsreader and Emailer
28d6cad6 8Summary(pl.UTF-8): CONE - tekstowy klient poczty i czytnik newsów
f976440c 9Name: cone
79f20932 10Version: 1.5
5eaf0e7d 11Release: 2
b848eaf8 12License: GPL v3 with OpenSSL exception
f976440c 13Group: Applications/Mail
79f20932
JB
14Source0: https://downloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
15# Source0-md5: a67ea05b272b17f4333ec648a9f7c809
ad21e748 16Patch0: %{name}-maildir.patch
b848eaf8 17Patch1: %{name}-curses.patch
509212ad 18URL: http://www.courier-mta.org/cone/
f976440c 19BuildRequires: aspell-devel
b848eaf8 20BuildRequires: autoconf >= 2.59
6657dc05 21BuildRequires: automake
b848eaf8 22%{?with_socks:BuildRequires: courier-sox-devel}
56116331 23BuildRequires: courier-unicode-devel >= 2.1
79f20932 24BuildRequires: gettext-tools
b848eaf8
JB
25# or gnupg2 --with-gpg2, will use the same at runtime
26BuildRequires: gnupg
27%{?with_gnutls:BuildRequires: gnutls-devel >= 3.0}
28%{?with_gnutls:BuildRequires: libgcrypt-devel}
29%{?with_gnutls:BuildRequires: libgpg-error-devel}
30BuildRequires: libidn-devel >= 0.0.0
f976440c 31BuildRequires: libstdc++-devel
b848eaf8
JB
32BuildRequires: libtool >= 2:1.5
33BuildRequires: libxml2-devel >= 2.0
34BuildRequires: ncurses-devel >= 5
35BuildRequires: openldap-devel
36%{!?with_gnutls:BuildRequires: openssl-devel >= 0.9.7d}
79f20932 37BuildRequires: pcre2-8-devel
509212ad 38BuildRequires: perl-base
b848eaf8
JB
39BuildRequires: pkgconfig
40BuildRequires: procps
48814c1c 41BuildRequires: sysconftool
f976440c 42BuildRequires: zlib-devel
31f2e7d7 43Requires: ca-certificates
b848eaf8 44Suggests: gnupg
ae636a87
JB
45Conflicts: courier-imap < 5
46Conflicts: courier-imapd < 1
47Conflicts: maildrop < 3
f976440c
AA
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
509212ad
JB
51CONE is a simple, text-based E-mail reader and writer, and a simple
52newsreader.
f976440c 53
8628d5b4
JR
54%description -l pl.UTF-8
55CONE jest prostym, tekstowym klientem pocztowym, a także prostym
56czytnikiem newsów.
f976440c 57
509212ad 58%package devel
b848eaf8
JB
59Summary: Header files and static LibMAIL library
60Summary(pl.UTF-8): Pliki nagłówkowe i biblioteka statyczna LibMAIL
61Group: Development/Libraries
62Requires: courier-unicode-devel >= 2.0
63%{?with_gnutls:Requires: gnutls-devel >= 3.0}
64Requires: libidn-devel >= 0.0.0
65Requires: libstdc++-devel
66%{!?with_gnutls:Requires: openssl-devel >= 0.9.7d}
67Obsoletes: cone-static < 0.96
f976440c
AA
68
69%description devel
b848eaf8
JB
70This package includes the header files and static library for
71developing applications using LibMAIL - a high level, C++ OO library
72for mail clients.
f976440c 73
8628d5b4 74%description devel -l pl.UTF-8
b848eaf8
JB
75Ten pakiet zawiera pliki nagłówkowe i bibliotekę statyczną do
76tworzenia aplikacji z użyciem LibMAIL - wysokopoziomowej,
77zorientowanej obiektowo biblioteki C++ dla klientów pocztowych.
f976440c 78
6657dc05
AA
79%package -n leaf
80Summary: Console text file editor
28d6cad6 81Summary(pl.UTF-8): Konsolowy edytor plików tekstowych
6657dc05
AA
82Group: Applications/Editors
83
84%description -n leaf
b78eacde
ER
85Leaf is a simple console text file editor, with paragraph
86word-wrapping and spell checking. Leaf is based on the text editor in
87the Cone mail reader and composer.
6657dc05 88
8628d5b4 89%description -n leaf -l pl.UTF-8
b848eaf8
JB
90Leaf jest prostym konsolowym edytorem plików tekstowych, z zawijaniem
91wierszy w akapitach i sprawdzaniem pisowni. Jest oparty na edytorze
92używanym w czytniku poczty Cone.
6657dc05 93
f976440c
AA
94%prep
95%setup -q
ad21e748 96%patch0 -p1
f976440c
AA
97
98%build
b848eaf8
JB
99%{__libtoolize}
100for d in $(sed -ne 's/.*AC_CONFIG_SUBDIRS(\([^)]*\))/\1/p' configure.ac) . ; do
101 if [ -d "$d" ]; then
102 cd $d
103 %{__aclocal}
104 %{__autoconf}
105 if grep -q AC_CONFIG_HEADER configure.ac ; then
106 %{__autoheader}
107 fi
108 %{__automake}
109 cd -
110 fi
111done
112
f976440c 113%configure \
b848eaf8 114 SENDMAIL=/usr/lib/sendmail \
a3ca27dd 115 --with-certdb=%{_sysconfdir}/certs/ca-certificates.crt \
b848eaf8 116 --with-devel \
ae636a87
JB
117 %{?with_gnutls:--with-gnutls} \
118 --with-notice=unicode
f976440c
AA
119
120%{__make}
121
b848eaf8
JB
122%if %{with tests}
123%{__make} check
124%endif
f976440c
AA
125
126%install
127rm -rf $RPM_BUILD_ROOT
128
129%{__make} install \
130 DESTDIR=$RPM_BUILD_ROOT
131
b848eaf8 132%{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/cone.dist $RPM_BUILD_ROOT%{_sysconfdir}/cone
6657dc05 133
b848eaf8
JB
134# move docs to more specific location
135install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
136%{__mv} $RPM_BUILD_ROOT%{_datadir}/cone/{*.html,manpage.css} $RPM_BUILD_ROOT%{_docdir}/%{name}
f976440c 137
f976440c
AA
138%clean
139rm -rf $RPM_BUILD_ROOT
140
ae636a87
JB
141%triggerpostun -- %{name} < 1
142%banner -e cone-unicode <<EOF
143WARNING: you have to convert any existing maildirs to Unicode naming scheme.
144See INSTALL file for details.
145EOF
146
f976440c
AA
147%files
148%defattr(644,root,root,755)
b848eaf8
JB
149%doc AUTHORS COPYING ChangeLog NEWS README
150%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cone
509212ad 151%attr(755,root,root) %{_bindir}/cone
509212ad 152%attr(755,root,root) %{_bindir}/mailtool
b848eaf8 153%attr(755,root,root) %{_libexecdir}/cone
f976440c 154%{_datadir}/cone
b848eaf8
JB
155%{_mandir}/man1/cone.1*
156%{_mandir}/man1/mailtool.1*
157%dir %{_docdir}/%{name}
158%{_docdir}/%{name}/FAQ.html
159%{_docdir}/%{name}/INSTALL.html
160%{_docdir}/%{name}/README.html
161%{_docdir}/%{name}/add.html
162%{_docdir}/%{name}/attributes.html
163%{_docdir}/%{name}/bk01-toc.html
164%{_docdir}/%{name}/cone*.html
165%{_docdir}/%{name}/conn.html
166%{_docdir}/%{name}/index.html
167%{_docdir}/%{name}/maillist.html
168%{_docdir}/%{name}/mailtool.html
169%{_docdir}/%{name}/manpage.css
170%{_docdir}/%{name}/moredocs.html
171%{_docdir}/%{name}/search.html
172%{_docdir}/%{name}/smap*.html
173%{_docdir}/%{name}/store.html
f976440c
AA
174
175%files devel
176%defattr(644,root,root,755)
b848eaf8 177%{_libdir}/libmail.a
b41719b0 178%{_libdir}/libmail.la
f976440c 179%{_includedir}/libmail
b848eaf8
JB
180%{_mandir}/man3/mail::*.3x*
181%dir %{_docdir}/%{name}
182%{_docdir}/%{name}/account-*.html
183%{_docdir}/%{name}/address.html
184%{_docdir}/%{name}/cppnamespace.html
185%{_docdir}/%{name}/emailaddress.html
186%{_docdir}/%{name}/envelope.html
187%{_docdir}/%{name}/folder-*.html
188%{_docdir}/%{name}/header-*.html
189%{_docdir}/%{name}/libmail*.html
190%{_docdir}/%{name}/mail-*.html
191%{_docdir}/%{name}/mimestruct.html
192%{_docdir}/%{name}/misc.html
193%{_docdir}/%{name}/native.html
194%{_docdir}/%{name}/synchronous.html
6657dc05
AA
195
196%files -n leaf
197%defattr(644,root,root,755)
6657dc05 198%attr(755,root,root) %{_bindir}/leaf
b848eaf8
JB
199%{_mandir}/man1/leaf.1*
200%dir %{_docdir}/%{name}
201%{_docdir}/%{name}/leaf.html
This page took 0.117513 seconds and 4 git commands to generate.