]> git.pld-linux.org Git - packages/cone.git/blame - cone.spec
Release 2 (by relup.sh)
[packages/cone.git] / cone.spec
CommitLineData
147daf49 1#
b848eaf8
JB
2# Conditional build:
3%bcond_without tests # "make check"
4%bcond_with gnutls # GnuTLS instead of OpenSSL
5%bcond_with socks # (Courier) Socks support
6
6657dc05 7Summary: CONE - Console Newsreader and Emailer
28d6cad6 8Summary(pl.UTF-8): CONE - tekstowy klient poczty i czytnik newsów
f976440c 9Name: cone
56116331 10Version: 1.2
88addbba 11Release: 2
b848eaf8 12License: GPL v3 with OpenSSL exception
f976440c 13Group: Applications/Mail
31f2e7d7 14Source0: http://downloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
56116331 15# Source0-md5: a845692b6d50fc8b58df2f1b99344623
ad21e748 16Patch0: %{name}-maildir.patch
b848eaf8 17Patch1: %{name}-curses.patch
509212ad 18URL: http://www.courier-mta.org/cone/
f976440c 19BuildRequires: aspell-devel
b848eaf8 20BuildRequires: autoconf >= 2.59
6657dc05 21BuildRequires: automake
b848eaf8 22%{?with_socks:BuildRequires: courier-sox-devel}
56116331 23BuildRequires: courier-unicode-devel >= 2.1
b848eaf8
JB
24# or gnupg2 --with-gpg2, will use the same at runtime
25BuildRequires: gnupg
26%{?with_gnutls:BuildRequires: gnutls-devel >= 3.0}
27%{?with_gnutls:BuildRequires: libgcrypt-devel}
28%{?with_gnutls:BuildRequires: libgpg-error-devel}
29BuildRequires: libidn-devel >= 0.0.0
f976440c 30BuildRequires: libstdc++-devel
b848eaf8
JB
31BuildRequires: libtool >= 2:1.5
32BuildRequires: libxml2-devel >= 2.0
33BuildRequires: ncurses-devel >= 5
34BuildRequires: openldap-devel
35%{!?with_gnutls:BuildRequires: openssl-devel >= 0.9.7d}
36BuildRequires: pcre-devel
509212ad 37BuildRequires: perl-base
b848eaf8
JB
38BuildRequires: pkgconfig
39BuildRequires: procps
48814c1c 40BuildRequires: sysconftool
f976440c 41BuildRequires: zlib-devel
31f2e7d7 42Requires: ca-certificates
b848eaf8 43Suggests: gnupg
ae636a87
JB
44Conflicts: courier-imap < 5
45Conflicts: courier-imapd < 1
46Conflicts: maildrop < 3
f976440c
AA
47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49%description
509212ad
JB
50CONE is a simple, text-based E-mail reader and writer, and a simple
51newsreader.
f976440c 52
8628d5b4
JR
53%description -l pl.UTF-8
54CONE jest prostym, tekstowym klientem pocztowym, a także prostym
55czytnikiem newsów.
f976440c 56
509212ad 57%package devel
b848eaf8
JB
58Summary: Header files and static LibMAIL library
59Summary(pl.UTF-8): Pliki nagłówkowe i biblioteka statyczna LibMAIL
60Group: Development/Libraries
61Requires: courier-unicode-devel >= 2.0
62%{?with_gnutls:Requires: gnutls-devel >= 3.0}
63Requires: libidn-devel >= 0.0.0
64Requires: libstdc++-devel
65%{!?with_gnutls:Requires: openssl-devel >= 0.9.7d}
66Obsoletes: cone-static < 0.96
f976440c
AA
67
68%description devel
b848eaf8
JB
69This package includes the header files and static library for
70developing applications using LibMAIL - a high level, C++ OO library
71for mail clients.
f976440c 72
8628d5b4 73%description devel -l pl.UTF-8
b848eaf8
JB
74Ten pakiet zawiera pliki nagłówkowe i bibliotekę statyczną do
75tworzenia aplikacji z użyciem LibMAIL - wysokopoziomowej,
76zorientowanej obiektowo biblioteki C++ dla klientów pocztowych.
f976440c 77
6657dc05
AA
78%package -n leaf
79Summary: Console text file editor
28d6cad6 80Summary(pl.UTF-8): Konsolowy edytor plików tekstowych
6657dc05
AA
81Group: Applications/Editors
82
83%description -n leaf
b78eacde
ER
84Leaf is a simple console text file editor, with paragraph
85word-wrapping and spell checking. Leaf is based on the text editor in
86the Cone mail reader and composer.
6657dc05 87
8628d5b4 88%description -n leaf -l pl.UTF-8
b848eaf8
JB
89Leaf jest prostym konsolowym edytorem plików tekstowych, z zawijaniem
90wierszy w akapitach i sprawdzaniem pisowni. Jest oparty na edytorze
91używanym w czytniku poczty Cone.
6657dc05 92
f976440c
AA
93%prep
94%setup -q
ad21e748 95%patch0 -p1
f976440c
AA
96
97%build
b848eaf8
JB
98%{__libtoolize}
99for d in $(sed -ne 's/.*AC_CONFIG_SUBDIRS(\([^)]*\))/\1/p' configure.ac) . ; do
100 if [ -d "$d" ]; then
101 cd $d
102 %{__aclocal}
103 %{__autoconf}
104 if grep -q AC_CONFIG_HEADER configure.ac ; then
105 %{__autoheader}
106 fi
107 %{__automake}
108 cd -
109 fi
110done
111
f976440c 112%configure \
b848eaf8 113 SENDMAIL=/usr/lib/sendmail \
a3ca27dd 114 --with-certdb=%{_sysconfdir}/certs/ca-certificates.crt \
b848eaf8 115 --with-devel \
ae636a87
JB
116 %{?with_gnutls:--with-gnutls} \
117 --with-notice=unicode
f976440c
AA
118
119%{__make}
120
b848eaf8
JB
121%if %{with tests}
122%{__make} check
123%endif
f976440c
AA
124
125%install
126rm -rf $RPM_BUILD_ROOT
127
128%{__make} install \
129 DESTDIR=$RPM_BUILD_ROOT
130
b848eaf8 131%{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/cone.dist $RPM_BUILD_ROOT%{_sysconfdir}/cone
6657dc05 132
b848eaf8
JB
133# move docs to more specific location
134install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
135%{__mv} $RPM_BUILD_ROOT%{_datadir}/cone/{*.html,manpage.css} $RPM_BUILD_ROOT%{_docdir}/%{name}
f976440c 136
f976440c
AA
137%clean
138rm -rf $RPM_BUILD_ROOT
139
ae636a87
JB
140%triggerpostun -- %{name} < 1
141%banner -e cone-unicode <<EOF
142WARNING: you have to convert any existing maildirs to Unicode naming scheme.
143See INSTALL file for details.
144EOF
145
f976440c
AA
146%files
147%defattr(644,root,root,755)
b848eaf8
JB
148%doc AUTHORS COPYING ChangeLog NEWS README
149%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cone
509212ad 150%attr(755,root,root) %{_bindir}/cone
509212ad 151%attr(755,root,root) %{_bindir}/mailtool
b848eaf8 152%attr(755,root,root) %{_libexecdir}/cone
f976440c 153%{_datadir}/cone
b848eaf8
JB
154%{_mandir}/man1/cone.1*
155%{_mandir}/man1/mailtool.1*
156%dir %{_docdir}/%{name}
157%{_docdir}/%{name}/FAQ.html
158%{_docdir}/%{name}/INSTALL.html
159%{_docdir}/%{name}/README.html
160%{_docdir}/%{name}/add.html
161%{_docdir}/%{name}/attributes.html
162%{_docdir}/%{name}/bk01-toc.html
163%{_docdir}/%{name}/cone*.html
164%{_docdir}/%{name}/conn.html
165%{_docdir}/%{name}/index.html
166%{_docdir}/%{name}/maillist.html
167%{_docdir}/%{name}/mailtool.html
168%{_docdir}/%{name}/manpage.css
169%{_docdir}/%{name}/moredocs.html
170%{_docdir}/%{name}/search.html
171%{_docdir}/%{name}/smap*.html
172%{_docdir}/%{name}/store.html
f976440c
AA
173
174%files devel
175%defattr(644,root,root,755)
b848eaf8 176%{_libdir}/libmail.a
b41719b0 177%{_libdir}/libmail.la
f976440c 178%{_includedir}/libmail
b848eaf8
JB
179%{_mandir}/man3/mail::*.3x*
180%dir %{_docdir}/%{name}
181%{_docdir}/%{name}/account-*.html
182%{_docdir}/%{name}/address.html
183%{_docdir}/%{name}/cppnamespace.html
184%{_docdir}/%{name}/emailaddress.html
185%{_docdir}/%{name}/envelope.html
186%{_docdir}/%{name}/folder-*.html
187%{_docdir}/%{name}/header-*.html
188%{_docdir}/%{name}/libmail*.html
189%{_docdir}/%{name}/mail-*.html
190%{_docdir}/%{name}/mimestruct.html
191%{_docdir}/%{name}/misc.html
192%{_docdir}/%{name}/native.html
193%{_docdir}/%{name}/synchronous.html
6657dc05
AA
194
195%files -n leaf
196%defattr(644,root,root,755)
6657dc05 197%attr(755,root,root) %{_bindir}/leaf
b848eaf8
JB
198%{_mandir}/man1/leaf.1*
199%dir %{_docdir}/%{name}
200%{_docdir}/%{name}/leaf.html
This page took 0.078288 seconds and 4 git commands to generate.