]> git.pld-linux.org Git - packages/cone.git/blame - cone.spec
- release 2
[packages/cone.git] / cone.spec
CommitLineData
147daf49 1#
2# TODO:
3# - review devel doc files
4#
6657dc05 5Summary: CONE - Console Newsreader and Emailer
28d6cad6 6Summary(pl.UTF-8): CONE - tekstowy klient poczty i czytnik newsów
f976440c 7Name: cone
a3ca27dd 8Version: 0.89
cf50f9e9 9Release: 2
f976440c
AA
10License: GPL
11Group: Applications/Mail
31f2e7d7 12Source0: http://downloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
a3ca27dd 13# Source0-md5: 7ee8b8c0fe89d96bca3e93a2b82adfb9
ad21e748 14Patch0: %{name}-maildir.patch
509212ad 15URL: http://www.courier-mta.org/cone/
f976440c
AA
16BuildRequires: aspell-devel
17BuildRequires: autoconf
6657dc05 18BuildRequires: automake
f976440c 19BuildRequires: fam-devel
f976440c
AA
20BuildRequires: libstdc++-devel
21BuildRequires: libtool
22BuildRequires: libxml2-devel
08ede1b6 23BuildRequires: ncurses-devel
f976440c 24BuildRequires: openssl-devel
e6e42bbf 25BuildRequires: openssl-tools-perl
509212ad 26BuildRequires: perl-base
48814c1c 27BuildRequires: sysconftool
f976440c 28BuildRequires: zlib-devel
31f2e7d7 29Requires: ca-certificates
f976440c
AA
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
509212ad
JB
33CONE is a simple, text-based E-mail reader and writer, and a simple
34newsreader.
f976440c 35
8628d5b4
JR
36%description -l pl.UTF-8
37CONE jest prostym, tekstowym klientem pocztowym, a także prostym
38czytnikiem newsów.
f976440c 39
509212ad 40%package devel
f976440c 41Summary: Header files for LibMAIL
28d6cad6 42Summary(pl.UTF-8): Pliki nagłówkowe LibMAIL
509212ad 43Group: Development/Languages
f976440c
AA
44Requires: %{name} = %{version}-%{release}
45
46%description devel
509212ad 47This package includes the header files for developing applications
e6205d14 48using LibMAIL - a high level, C++ OO library for mail clients.
f976440c 49
8628d5b4 50%description devel -l pl.UTF-8
31f2e7d7 51Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji z
52użyciem LibMAIL - wysokopoziomowej, zorientowanej obiektowo
53biblioteki C++ dla klientów pocztowych.
f976440c 54
509212ad
JB
55%package static
56Summary: Static LibMAIL library
28d6cad6 57Summary(pl.UTF-8): Biblioteka statyczna LibMAIL
f976440c 58Group: Development/Libraries
509212ad 59Requires: %{name}-devel = %{version}-%{release}
f976440c
AA
60
61%description static
509212ad 62This package contains static library for developing application using
f976440c
AA
63LibMAIL - a high level, C++ OO library for mail clients.
64
8628d5b4
JR
65%description static -l pl.UTF-8
66Ten pakiet zawiera statyczną bibliotekę do tworzenia aplikacji z
31f2e7d7 67użyciem LibMAIL - wysokopoziomowej, zorientowanej obiektowo
68biblioteki C++ dla klientów pocztowych.
f976440c 69
6657dc05
AA
70%package -n leaf
71Summary: Console text file editor
28d6cad6 72Summary(pl.UTF-8): Konsolowy edytor plików tekstowych
6657dc05
AA
73Group: Applications/Editors
74
75%description -n leaf
b78eacde
ER
76Leaf is a simple console text file editor, with paragraph
77word-wrapping and spell checking. Leaf is based on the text editor in
78the Cone mail reader and composer.
6657dc05 79
8628d5b4
JR
80%description -n leaf -l pl.UTF-8
81Leaf jest prostym konsolowym edytorem plików tekstowych. Jest oparty
82na edytorze używanym w czytniku poczty Cone.
6657dc05 83
f976440c
AA
84%prep
85%setup -q
ad21e748 86%patch0 -p1
f976440c
AA
87
88%build
a3ca27dd 89#%{__libtoolize}
90#%{__aclocal}
91#%{__autoconf}
92#%{__automake}
93
94#cd cone
95#%{__aclocal}
96#%{__autoconf}
97#%{__automake}
98
99#cd ../libmail
100#%{__aclocal}
101#%{__autoconf}
102#%{__automake}
103
104#cd ../maildir
105#%{__aclocal}
106#%{__autoconf}
107#%{__automake}
108#cd ..
109
b41719b0 110
31f2e7d7 111CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
a3ca27dd 112LDFLAGS="%{rpmldflags} -ltinfow"
31f2e7d7 113PATH=$PATH:%{_prefix}/%{_lib}/openssl; export PATH
f976440c 114%configure \
6657dc05 115 --with-devel \
a3ca27dd 116 --with-certdb=%{_sysconfdir}/certs/ca-certificates.crt \
6657dc05 117 SENDMAIL=%{_sbindir}/sendmail
f976440c
AA
118
119%{__make}
120
a3ca27dd 121#%{__make} check
f976440c
AA
122
123%install
124rm -rf $RPM_BUILD_ROOT
125
126%{__make} install \
127 DESTDIR=$RPM_BUILD_ROOT
128
129# start cone directly
a3ca27dd 130#mv -f $RPM_BUILD_ROOT%{_libdir}/cone $RPM_BUILD_ROOT%{_bindir}
131cp cone.sh $RPM_BUILD_ROOT%{_bindir}/cone
f976440c
AA
132mv -f $RPM_BUILD_ROOT%{_sysconfdir}/cone.dist $RPM_BUILD_ROOT%{_sysconfdir}/cone
133
134# move devel docs from datadir
135mkdir devel
147daf49 136for file in account-* address.html e*.html folder-* \
02559e28 137header* libmail*.html mail-* mimestruct* misc* native* synchronous.html; do
f976440c
AA
138mv -f $RPM_BUILD_ROOT%{_datadir}/cone/$file devel
139done
140
6657dc05
AA
141# leaf doc
142mv -f $RPM_BUILD_ROOT%{_datadir}/cone/leaf.html .
143
f976440c
AA
144# rest *.html will go to primary docs
145mkdir docs
146mv -f $RPM_BUILD_ROOT%{_datadir}/cone/*.html docs
02559e28 147mv -f $RPM_BUILD_ROOT%{_datadir}/cone/manpage.css docs
f976440c 148
f976440c
AA
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%files
153%defattr(644,root,root,755)
5f3b2ed0 154%doc AUTHORS ChangeLog README NEWS docs/
b78eacde 155%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cone
509212ad 156%attr(755,root,root) %{_bindir}/cone
509212ad 157%attr(755,root,root) %{_bindir}/mailtool
a3ca27dd 158%attr(755,root,root) %{_libdir}/cone
f976440c 159%{_datadir}/cone
6657dc05
AA
160%{_mandir}/man1/cone*
161%{_mandir}/man1/mailtool*
f976440c
AA
162
163%files devel
164%defattr(644,root,root,755)
6657dc05 165%doc devel/*
b41719b0 166%{_libdir}/libmail.la
f976440c 167%{_includedir}/libmail
02559e28 168%{_mandir}/man3/*
f976440c
AA
169
170%files static
171%defattr(644,root,root,755)
172%{_libdir}/libmail.a
6657dc05
AA
173
174%files -n leaf
175%defattr(644,root,root,755)
176%doc leaf.html
177%attr(755,root,root) %{_bindir}/leaf
178%{_mandir}/man1/leaf*
This page took 0.097738 seconds and 4 git commands to generate.