]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
update files
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
f684992e 5%bcond_with dev # with dev optimizations (skip clean source)
ba685303 6%bcond_without gconf # with GConf
75f96a39 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 9%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 10%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 11%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
db3fa756 12%bcond_without ninja # use Ninja instead of make to build
ba685303 13%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
14%bcond_without sandboxing # with sandboxing
15%bcond_with selinux # with SELinux (need policy first)
16%bcond_with shared_libs # with shared libs
17%bcond_with sse2 # use SSE2 instructions
ba685303 18%bcond_without system_flac # system flac
a323900c 19%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 20%bcond_without system_harfbuzz # system harfbuzz
ffcc39d4 21%bcond_with system_icu # system icu, disabled: http://bugs.icu-project.org/trac/ticket/11358)
ba685303 22%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
23%bcond_without system_libexif # system libexif
24%bcond_without system_libmtp # system libmtp
3934d767 25%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 26%bcond_without system_libwebp # system libwebp
4884fc99 27%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 28%bcond_with system_mesa # system Mesa
126ea630 29%bcond_without system_minizip # system minizip
62950103 30%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
e7b1e97c
ER
31# protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
32%bcond_with system_protobuf # system protobuf
543e99ac 33%bcond_without system_re2 # system re2
7e634b46 34%bcond_without system_snappy # system snappy
ba685303 35%bcond_without system_speex # system speex
a8f4f3ac 36%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 37%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 38%bcond_with system_v8 # system v8
f047b07c 39%bcond_with system_libvpx # system libvpx
ba685303 40%bcond_without system_yasm # system yasm
1c00315b 41%bcond_without system_zlib # system zlib
14c8ce0e 42%bcond_with tcmalloc # use tcmalloc
7e136323 43%bcond_without verbose # verbose build (V=1)
0c480b89 44
b3fc6cb2
ER
45%ifarch %{ix86}
46# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
47%undefine with_system_mesa
5e3c5baa
ER
48
49# unable build with debuginfo on 32bit build systems
313715ac
ER
50# /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
51%undefine with_debuginfo
52%endif
53
54%ifarch %{x8664}
55# x86_64 systems fail with debugedit crashing
56# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
5e3c5baa 57%undefine with_debuginfo
b3fc6cb2
ER
58%endif
59
6d92f81c 60# TODO
b363f856 61# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 62# - use_system_skia
a3140cd1 63# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 64# - use_system_stlport (android specific)
7b8f219a 65# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 66
e53ecfb5 67# NOTES:
4fe038cb
ER
68# - mute BEEP mixer if you do not want to hear horrible system bell when
69# pressing home/end in url bar or more ^F search results on page.
7c638678 70# - space considerations:
0bb93ab2 71# - unpacked sources: ~490MiB
c1ecd31f 72# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 73# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 74# - to look for new tarball, use update-source.sh script
f1b276d4 75
f5554d90
ER
76%define branch 44.0.2403
77%define basever 9
78#define patchver 118
a3140cd1 79%define gyp_rev 1014
11ad81c4 80Summary: A WebKit powered web browser
05f72ae2 81Name: chromium-browser
f73369da
ER
82%if "%{?patchver}" != ""
83Version: %{branch}.%{patchver}
84%else
85Version: %{branch}.%{basever}
86%endif
9d867387 87Release: 1
5bb99ef4 88License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 89Group: X11/Applications/Networking
f5554d90 90Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/dev/%{name}-%{branch}.%{basever}.tar.gz
34dd729e 91# Source0-md5: 4aa590c1965817cfb693df7f8404e0b6
3c73e180
ER
92%if "%{?patchver}" != ""
93Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
1e007e9c 94# Patch0-md5: 4265bb63c75457923cdbaa15a49a22ae
3c73e180 95%endif
37ceaf05 96Source1: %{name}.default
8b53130d
ER
97Source2: %{name}.sh
98Source3: %{name}.desktop
56c6e811
ER
99Source5: find-lang.sh
100Source6: update-source.sh
101Source7: clean-source.sh
836b1cac 102Source8: get-source.sh
0562b864 103Source9: master_preferences.json
a198be7c 104# https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
706f2712 105Patch2: enable-video-decode-accel.patch
5aa5df39 106Patch7: dlopen_sonamed_gl.patch
4765ddf1 107Patch8: chromium_useragent.patch.in
1347c76c
AM
108# https://bugs.gentoo.org/show_bug.cgi?id=393471
109# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 110Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
111Patch15: nacl-build-irt.patch
112Patch16: nacl-linkingfix.patch
9516ca97 113Patch18: nacl-no-untar.patch
6897926c 114Patch24: nacl-verbose.patch
c5b396f3
ER
115Patch25: gnome3-volume-control.patch
116Patch26: master-prefs-path.patch
25d4e23c 117Patch28: system-mesa.patch
9cce36cb 118Patch31: system-jinja.patch
708e64c2 119Patch32: remove_bundled_libraries-stale.patch
d7fca4aa 120Patch35: etc-dir.patch
6e3c39b4 121Patch36: angle.patch
a20f29ed 122Patch37: %{name}-build.patch
a198be7c 123Patch38: vaapi_include.patch
221355ea 124Patch39: libsecret.patch
750b48f7 125URL: http://www.chromium.org/Home
ae3fe89f 126%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 127%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 128BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 129%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 130%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
131BuildRequires: alsa-lib-devel
132BuildRequires: atk-devel
133BuildRequires: bison
11ad81c4 134BuildRequires: bzip2-devel
5997e180
ER
135%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
136%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
137%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 138%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 139%{?with_cups:BuildRequires: cups-devel}
92965b0e 140BuildRequires: elfutils-devel
77f32fa3 141BuildRequires: expat-devel
7d0dbc8d 142%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 143%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 144BuildRequires: fontconfig-devel
f1b276d4 145BuildRequires: glib2-devel
05f72ae2 146BuildRequires: gperf
71d49434 147%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 148BuildRequires: gtest-devel
8b53130d 149BuildRequires: gtk+2-devel
01b4dc8e 150%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 151%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 152%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 153BuildRequires: hicolor-icon-theme
ed514974 154%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 155%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 156BuildRequires: libevent-devel
8456d676 157%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 158%{?with_keyring:BuildRequires: libgnome-keyring-devel}
cb6dde87 159%{?with_system_icu:BuildRequires: libicu-devel >= 4.6}
39c71b4c 160%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 161%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 162%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 163BuildRequires: libpng-devel
221355ea 164BuildRequires: libsecret-devel
e266589e 165%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 166BuildRequires: libstdc++-devel
ba685303 167%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
5f786a22 168%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.4.0}
88171dca 169%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 170BuildRequires: libxml2-devel
11ad81c4 171BuildRequires: libxslt-devel
535cb410 172BuildRequires: man-db
62950103 173%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 174%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 175BuildRequires: nspr-devel
f1b276d4 176BuildRequires: nss-devel >= 1:3.12.3
8456d676 177%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 178BuildRequires: pam-devel
f1b276d4 179BuildRequires: pango-devel
ef121064 180BuildRequires: pciutils-devel
3a3b7da9 181BuildRequires: perl-JSON
48b341f5 182BuildRequires: perl-modules
183BuildRequires: pkgconfig
75a27c2e 184%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 185%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 186BuildRequires: python
e2f921c3 187BuildRequires: python-BeautifulSoup
46cdefee 188#BuildRequires: python-gyp >= 1-%{gyp_rev}
9cce36cb 189BuildRequires: python-jinja2 >= 2.7
48b341f5 190BuildRequires: python-modules
e0a7fe40 191BuildRequires: python-ply >= 3.4
543e99ac 192%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 193BuildRequires: rpm >= 4.4.9-56
f1b276d4 194BuildRequires: rpmbuild(macros) >= 1.453
f099161f 195%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 196BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 197%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 198%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 199%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 200BuildRequires: tar >= 1:1.22
0a424ee2 201BuildRequires: udev-devel
7d1152d4 202BuildRequires: usbutils
2303ed45 203BuildRequires: util-linux
c14cd342 204%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 205BuildRequires: which
f1b276d4 206BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 207BuildRequires: xorg-lib-libXtst-devel
836b1cac 208BuildRequires: xz
a3140cd1 209%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 210%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 211Requires: browser-plugins >= 2.0
0cad051b 212Requires: desktop-file-utils
8f5f6775 213%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
214# crashes if no fontconfig font present
215Requires: fonts-Type1-urw
0eb19b0b 216Requires: hicolor-icon-theme
56403697 217Requires: libevent >= 2.0.21
c1edaafa 218%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
5f786a22 219%{?with_system_libvpx:Requires: libvpx >= 1.4.0}
b809ab60 220Requires: lsb-release
b2c4ae39 221%{?with_system_re2:Requires: re2 >= 20130115-2}
4b2f9b57 222%{?with_system_protobuf:Requires: protobuf-libs >= 2.5.0-2}
3700ba38 223Requires: shared-mime-info
f7b16691 224%{?with_system_sqlite:Requires: sqlite3(icu)}
5c9227ee 225Requires: uname(release) >= 3.17
4dc49133 226Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 227Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 228Provides: wwwbrowser
c3582150 229Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 230Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 231ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 232BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 233
319f81f7
ER
234# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
235# Note: these are for PLD Linux use ONLY.
236# For your own distribution, please get your own set of keys.
237%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
238%define google_default_client_id 724288223830.apps.googleusercontent.com
239%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
240
7ebeabb6 241%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 242
e7fa0817
ER
243# Usage: gyp_with BCOND_NAME [OPTION_NAME]
244%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 245
a323900c
ER
246%ifarch %{ix86}
247%define target_arch ia32
248%endif
249%ifarch %{x8664}
250%define target_arch x64
251%endif
252
f8597c6e
ER
253%define buildtype %{?debug:Debug}%{!?debug:Release}
254%define builddir out/%{buildtype}
255
6b113615
ER
256%if %{without debuginfo}
257%define _enable_debug_packages 0
258%endif
259
11ad81c4 260%description
80838854
ER
261Chromium is an open-source browser project that aims to build a safer,
262faster, and more stable way for all Internet users to experience the
263web.
264
265Chromium serves as a base for Google Chrome, which is Chromium
266rebranded (name and logo) with very few additions such as usage
267tracking and an auto-updater system.
268
f1b276d4
ER
269%package l10n
270Summary: chromium-browser language packages
271Group: I18n
272Requires: %{name} = %{version}-%{release}
8da7b90b
ER
273%if "%{_rpmversion}" >= "5"
274BuildArch: noarch
275%endif
f1b276d4
ER
276
277%description l10n
278Chromium is an open-source browser project that aims to build a safer,
279faster, and more stable way for all Internet users to experience the
280web.
281
282This package contains language packages for 50 languages:
283
e7fa0817
ER
284ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
285he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
286pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
287zh-TW
f1b276d4
ER
288
289%prep
3c73e180
ER
290%setup -qc
291%if "%{?patchver}" != ""
77bd7e0a 292cd chromium*-%{branch}.%{basever}
3c73e180
ER
293%patch0 -p1
294cd ..
295%endif
77bd7e0a 296mv chromium*-%{branch}.%{basever}/* .
589d90ea 297
05f72ae2
ER
298# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
299# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 300. ./chrome/VERSION
e00e4177
ER
301chrome=$MAJOR.$MINOR.$BUILD.$PATCH
302test "$chrome" = %{version}
a3140cd1 303
75f96a39 304gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 305test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 306
4765ddf1
ER
307# add chromium and pld to useragent
308%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
309sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
310 -e 's/@BUILD_DIST_NAME@/PLD/g' \
311 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 312 < %{PATCH8} | %{__patch} -p1
4765ddf1 313
8da7b90b 314%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
315ln -s %{SOURCE7} .
316
810e0294 317#%patch2 -p1 CHECK
7879021e 318%patch7 -p1
75f96a39 319%patch15 -p2
f4a8da6a 320%{!?with_libjpegturbo:%patch11 -p0}
5997e180 321%patch16 -p1
41d6a4b1 322%patch28 -p1
a323900c 323%patch25 -p1
3aa67e11 324%{?with_nacl:%patch18 -p1}
ffb05754 325%patch24 -p1
75f96a39 326%patch26 -p2
cb6dde87 327%patch31 -p0
708e64c2 328%patch32 -p1
d7fca4aa 329%patch35 -p1
6e3c39b4 330%patch36 -p1
a20f29ed 331%patch37 -p1
810e0294 332#%patch38 -p1 CHECK
deef15b4 333%patch39 -p1
e9abb380 334
f684992e
ER
335%{?with_dev:exit 0}
336
75a27c2e
ER
337sh -x clean-source.sh \
338 %{!?with_nacl:nacl=0} \
bbdce24d
ER
339 %{!?with_system_libvpx:libvpx=0} \
340 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 341 %{!?with_system_mesa:mesa=0} \
75a27c2e 342 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 343 %{!?with_system_re2:re2=0} \
7e634b46 344 %{!?with_system_snappy:snappy=0} \
5048b37a 345 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 346 %{!?with_system_v8:v8=0} \
0767a7a0 347 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 348 %{!?with_system_zlib:zlib=0} \
f177fdad 349 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 350 %{nil}
fded59be 351
e266589e 352%build
5997e180 353%if %{with nacl}
108c5f7c 354rm -rf native_client/toolchain/linux_x86_newlib
fded59be 355if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 356# Make symlinks for NaCL
108c5f7c 357install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 358
108c5f7c
ER
359cd native_client/toolchain/linux_x86_newlib
360ln -s x86_64-nacl/bin bin
361cd x86_64-nacl/bin
2e4113fd 362__cc='%{__cc}'
f64e73f6 363if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
364 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
365 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
366 %{__sed} -i -e '1i#!/bin/sh' gcc g++
367 chmod +x gcc g++
368else
369 ln -s %{_bindir}/x86_64-nacl-gcc gcc
370 ln -s %{_bindir}/x86_64-nacl-g++ g++
371fi
108c5f7c
ER
372ln -s gcc x86_64-nacl-gcc
373ln -s g++ x86_64-nacl-g++
374ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
375ln -s %{_bindir}/x86_64-nacl-ar ar
376ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 377ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 378ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 379ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 380ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 381ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
382ln -s %{_prefix}/x86_64-nacl/lib ../lib
383ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
384ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
385cd ../../../../..
fded59be 386fi
5997e180
ER
387%endif
388
a323900c 389%if %{without system_ffmpeg}
f8597c6e
ER
390if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
391 # Re-configure bundled ffmpeg
392 cd third_party/ffmpeg
50d701c6
ER
393 chromium/scripts/build_ffmpeg.py linux %{target_arch} \
394 --branding Chromium
f8597c6e 395 chromium/scripts/copy_config.sh
6e3c39b4 396 chromium/scripts/generate_gyp.py
f8597c6e
ER
397 cd -
398fi
0c480b89 399%endif
a323900c 400
6e3c39b4
ER
401third_party/libaddressinput/chromium/tools/update-strings.py
402
a323900c
ER
403flags="
404 -Dtarget_arch=%{target_arch} \
405 -Dpython_arch=%{target_arch} \
12687dbd 406 -Dproprietary_codecs=1 \
6e3c39b4 407 -Dffmpeg_branding=Chromium \
b91ce587 408 -Dsystem_libdir=%{_lib} \
a323900c 409 -Dpython_ver=%{py_ver} \
7b454a31
AM
410%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
411 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4 412%endif
f047b07c 413 %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
c980b122 414 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 415 %{?with_shared_libs:-Dlibrary=shared_library} \
b6942fc6 416 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
77bd7e0a 417 -Dinclude_tests__=0 \
c0808220 418%if %{with nacl}
038f76b9 419 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
420 -Ddisable_glibc_untar=1 \
421 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
422 -Ddisable_glibc=1 \
423 -Ddisable_pnacl=1 \
424 -Dbuild_pnacl_newlib=0 \
c0808220 425%else
8fb1dc98 426 -Ddisable_pnacl_untar=1 \
c0808220
ER
427 -Ddisable_nacl=1 \
428%endif
a3140cd1
ER
429 %{!?with_sse2:-Ddisable_sse2=1} \
430 %{?with_selinux:-Dselinux=1} \
7d1152d4 431 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 432 -Dlinux_link_libpci=1 \
7879021e 433 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
14c8ce0e 434 -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
71d49434 435 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
2983aa41
ER
436 -Dclang=0 \
437 -Dhost_clang=0 \
14c8ce0e
ER
438 -Dlinux_use_bundled_binutils=0 \
439 -Dlinux_use_bundled_gold=0 \
05998197 440 -Dlinux_use_gold_flags=0 \
71581184 441 -Dlogging_like_official_build=1 \
319f81f7
ER
442 -Dgoogle_api_key=%{google_api_key} \
443 -Dgoogle_default_client_id=%{google_default_client_id} \
444 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 445 %{gyp_with cups} \
8dda6bbc 446 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 447 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
448 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
449 %{gyp_with pulseaudio} \
41d6a4b1 450 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 451 %{gyp_with system_flac} \
01b4dc8e 452 %{gyp_with system_harfbuzz} \
cb6dde87 453 %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
2d65d095 454 %{gyp_with system_jsoncpp} \
62950103
ER
455 %{gyp_with system_libexif} \
456 %{gyp_with system_libmtp} \
9bd2659c 457 %{gyp_with system_libsrtp} \
581aec44 458 %{gyp_with system_libusb} \
88171dca 459 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 460 %{gyp_with system_libwebp} \
4884fc99 461 %{gyp_with system_libxnvctrl} \
7b8f219a 462 %{gyp_with system_mesa} \
126ea630 463 %{gyp_with system_minizip} \
62950103 464 %{gyp_with system_opus} \
75a27c2e 465 %{gyp_with system_protobuf} \
bbdce24d 466 %{gyp_with system_re2} \
7e634b46 467 %{gyp_with system_snappy} \
e7fa0817 468 %{gyp_with system_speex} \
914ee37c 469 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
470 %{gyp_with system_v8} \
471 %{gyp_with system_yasm} \
472 %{gyp_with system_zlib} \
0c480b89 473 -Duse_system_bzip2=1 \
62950103 474 -Duse_system_expat=1 \
f1b276d4 475 -Duse_system_libevent=1 \
0c480b89 476 -Duse_system_libjpeg=1 \
f1b276d4
ER
477 -Duse_system_libpng=1 \
478 -Duse_system_libxml=1 \
479 -Duse_system_libxslt=1 \
b363f856 480 -Duse_system_nspr=1 \
7f40f3f4 481 -Duse_system_xdg_utils=1 \
7879021e
ER
482"
483
484build/linux/unbundle/replace_gyp_files.py $flags
485
f8597c6e
ER
486%if %{with ninja}
487chkfile=%{builddir}/build.ninja
488%else
489chkfile=Makefile
490%endif
491test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
492test -e $chkfile || \
7879021e
ER
493 CC="%{__cc}" \
494 CXX="%{__cxx}" \
495 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
496 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
497 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
498 CC_host="%{__cc}" \
499 CXX_host="%{__cxx}" \
500 LD_host="%{__cxx}" \
501%{__python} build/gyp_chromium \
f8597c6e 502 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
503 --depth=. \
504 build/all.gyp \
505 $flags
11ad81c4 506
f8597c6e
ER
507%if %{with ninja}
508ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
509%else
b4d75247 510# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
511%{__make} -r \
512 BUILDTYPE=%{buildtype} \
f1b276d4 513 %{?with_verbose:V=1} \
f1b276d4
ER
514 CC.host="%{__cc}" \
515 CXX.host="%{__cxx}" \
b4d75247 516 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
517%endif
518 chrome %{?with_sandboxing:chrome_sandbox} \
519 %{nil}
11ad81c4 520
f8597c6e 521cd %{builddir}
535cb410
ER
522MANWIDTH=80 man ./chrome.1 > man.out
523%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
524
11ad81c4
AM
525%install
526rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
527install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
528 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
3b9998d5
ER
529 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
530 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
e266589e 531
f8597c6e 532cd %{builddir}
37ceaf05 533cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 534install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
535%{__sed} -i -e '
536 s,@libdir@,%{_libdir}/%{name},
537
538 /@OPTIONS@/ {
539 r options.txt
540 d
541 }
542' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b 543cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
fa8317a0 544cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
8da7b90b
ER
545ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
546ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 547cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 548install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 549install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
fcc48c19 550%if %{without system_ffmpeg}
f1b276d4 551install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 552%endif
e7fa0817 553cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 554cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 555
8da7b90b 556%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 557
164020eb
ER
558%if %{with nacl}
559# Install Native Client files on platforms that support it.
560install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
561install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
562%ifarch %{x8664}
563install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
564%endif
565%ifarch %{ix86}
566install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
567%endif
568%endif
569
0c480b89
ER
570cd -
571
75f96a39 572for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
573 size=${icon##*/product_logo_}
574 size=${size%.png}
575
576 # this will skip non-numeric (22_mono_invert, 22_mono)
577 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
578 test -d "$dir" || continue
579
580 install -d $RPM_BUILD_ROOT$dir
581 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
582done
7f40f3f4 583
13840bc2
AM
584%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
585# http://code.google.com/p/chromium/issues/detail?id=24507
586gecko-mediaplayer*.so
587EOF
11ad81c4 588
589d90ea
ER
589# find locales
590%find_lang %{name}.lang
e7fa0817 591# always package en-US
f1b276d4 592%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 593
11ad81c4
AM
594%clean
595rm -rf $RPM_BUILD_ROOT
596
8da7b90b
ER
597%pretrans
598for d in locales resources; do
599 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
600 install -d %{_datadir}/%{name}
601 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
602 fi
603done
604exit 0
605
f1b276d4 606%post
0eb19b0b 607%update_icon_cache hicolor
b7a6e4ee 608%update_desktop_database
f1b276d4
ER
609%update_browser_plugins
610
611%postun
612if [ "$1" = 0 ]; then
0eb19b0b 613 %update_icon_cache hicolor
f1b276d4
ER
614 %update_browser_plugins
615fi
616
1d2b9616 617%files
11ad81c4 618%defattr(644,root,root,755)
75f96a39 619%doc AUTHORS LICENSE
f1b276d4
ER
620%{_browserpluginsconfdir}/browsers.d/%{name}.*
621%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
622%dir %{_sysconfdir}/%{name}
623%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 624%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
3b9998d5
ER
625%dir %{_sysconfdir}/%{name}/native-messaging-hosts
626%dir %{_sysconfdir}/%{name}/policies
627%dir %{_sysconfdir}/%{name}/policies/managed
f1b276d4
ER
628%attr(755,root,root) %{_bindir}/%{name}
629%{_mandir}/man1/%{name}.1*
11ad81c4 630%{_desktopdir}/*.desktop
0eb19b0b 631%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 632%dir %{_libdir}/%{name}
e9abb380 633%{_libdir}/%{name}/chrome*.pak
c14cd342 634%{_libdir}/%{name}/content_resources.pak
f047b07c 635%{_libdir}/%{name}/keyboard_resources.pak
97fac491 636%{_libdir}/%{name}/resources.pak
fa8317a0
ER
637%{_libdir}/%{name}/natives_blob.bin
638%{_libdir}/%{name}/snapshot_blob.bin
8da7b90b
ER
639%{_libdir}/%{name}/locales
640%{_libdir}/%{name}/resources
641
642%dir %{_datadir}/%{name}
643%dir %{_datadir}/%{name}/locales
644%{_datadir}/%{name}/locales/en-US.pak
645%dir %{_datadir}/%{name}/resources
646%{_datadir}/%{name}/resources/inspector
647
f1b276d4
ER
648%dir %{_libdir}/%{name}/plugins
649%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 650# These unique permissions are intentional and necessary for the sandboxing
d1a83042 651%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
652
653# ffmpeg libs
fcc48c19 654%if %{without system_ffmpeg}
f1b276d4 655%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 656%endif
f1b276d4 657
164020eb
ER
658%if %{with nacl}
659%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
660%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
661%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
662%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
663%endif
664
f1b276d4
ER
665%files l10n -f %{name}.lang
666%defattr(644,root,root,755)
This page took 0.216941 seconds and 4 git commands to generate.