]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 39.0.2171.99
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
f684992e 5%bcond_with dev # with dev optimizations (skip clean source)
ba685303 6%bcond_without gconf # with GConf
75f96a39 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 9%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 10%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 11%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
db3fa756 12%bcond_without ninja # use Ninja instead of make to build
ba685303 13%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
14%bcond_without sandboxing # with sandboxing
15%bcond_with selinux # with SELinux (need policy first)
16%bcond_with shared_libs # with shared libs
17%bcond_with sse2 # use SSE2 instructions
ba685303 18%bcond_without system_flac # system flac
a323900c 19%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 20%bcond_without system_harfbuzz # system harfbuzz
cb6dde87 21%bcond_without system_icu # system icu
ba685303 22%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
23%bcond_without system_libexif # system libexif
24%bcond_without system_libmtp # system libmtp
3934d767 25%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 26%bcond_without system_libwebp # system libwebp
4884fc99 27%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 28%bcond_with system_mesa # system Mesa
126ea630 29%bcond_without system_minizip # system minizip
62950103 30%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 31%bcond_without system_protobuf # system protobuf
543e99ac 32%bcond_without system_re2 # system re2
7e634b46 33%bcond_without system_snappy # system snappy
ba685303 34%bcond_without system_speex # system speex
a8f4f3ac 35%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 36%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 37%bcond_with system_v8 # system v8
f047b07c 38%bcond_with system_libvpx # system libvpx
ba685303 39%bcond_without system_yasm # system yasm
1c00315b 40%bcond_without system_zlib # system zlib
14c8ce0e 41%bcond_with tcmalloc # use tcmalloc
7e136323 42%bcond_without verbose # verbose build (V=1)
0c480b89 43
b3fc6cb2
ER
44%ifarch %{ix86}
45# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
46%undefine with_system_mesa
5e3c5baa
ER
47
48# unable build with debuginfo on 32bit build systems
313715ac
ER
49# /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
50%undefine with_debuginfo
51%endif
52
53%ifarch %{x8664}
54# x86_64 systems fail with debugedit crashing
55# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
5e3c5baa 56%undefine with_debuginfo
b3fc6cb2
ER
57%endif
58
6d92f81c 59# TODO
b363f856 60# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 61# - use_system_skia
a3140cd1 62# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 63# - use_system_stlport (android specific)
7b8f219a 64# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 65
e53ecfb5 66# NOTES:
4fe038cb
ER
67# - mute BEEP mixer if you do not want to hear horrible system bell when
68# pressing home/end in url bar or more ^F search results on page.
7c638678 69# - space considerations:
0bb93ab2 70# - unpacked sources: ~490MiB
c1ecd31f 71# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 72# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 73# - to look for new tarball, use update-source.sh script
f1b276d4 74
cb6dde87
ER
75%define branch 39.0.2171
76%define basever 71
e5c41622 77%define patchver 99
a3140cd1 78%define gyp_rev 1014
11ad81c4 79Summary: A WebKit powered web browser
05f72ae2 80Name: chromium-browser
f73369da
ER
81%if "%{?patchver}" != ""
82Version: %{branch}.%{patchver}
83%else
84Version: %{branch}.%{basever}
85%endif
cb6dde87 86Release: 1
5bb99ef4 87License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 88Group: X11/Applications/Networking
f177fdad 89Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
cb6dde87 90# Source0-md5: 238cbf816f3d3c01a58894a32eb9995d
3c73e180
ER
91%if "%{?patchver}" != ""
92Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
e5c41622 93# Patch0-md5: d127c9de90e4b146b78b3000afc4dc1e
3c73e180 94%endif
37ceaf05 95Source1: %{name}.default
8b53130d
ER
96Source2: %{name}.sh
97Source3: %{name}.desktop
56c6e811
ER
98Source5: find-lang.sh
99Source6: update-source.sh
100Source7: clean-source.sh
836b1cac 101Source8: get-source.sh
0562b864 102Source9: master_preferences.json
627e6027 103Patch2: enable-video-decode-accel.patch
72cb20c1 104Patch4: path-libpdf.patch
5aa5df39 105Patch7: dlopen_sonamed_gl.patch
4765ddf1 106Patch8: chromium_useragent.patch.in
1347c76c
AM
107# https://bugs.gentoo.org/show_bug.cgi?id=393471
108# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 109Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
110Patch15: nacl-build-irt.patch
111Patch16: nacl-linkingfix.patch
9516ca97 112Patch18: nacl-no-untar.patch
6897926c 113Patch24: nacl-verbose.patch
c5b396f3
ER
114Patch25: gnome3-volume-control.patch
115Patch26: master-prefs-path.patch
25d4e23c 116Patch28: system-mesa.patch
9cce36cb 117Patch31: system-jinja.patch
708e64c2 118Patch32: remove_bundled_libraries-stale.patch
d7fca4aa 119Patch35: etc-dir.patch
6e3c39b4 120Patch36: angle.patch
a20f29ed 121Patch37: %{name}-build.patch
750b48f7 122URL: http://www.chromium.org/Home
ae3fe89f 123%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 124%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 125BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 126%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 127%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
128BuildRequires: alsa-lib-devel
129BuildRequires: atk-devel
130BuildRequires: bison
11ad81c4 131BuildRequires: bzip2-devel
5997e180
ER
132%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
133%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
134%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 135%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 136%{?with_cups:BuildRequires: cups-devel}
92965b0e 137BuildRequires: elfutils-devel
77f32fa3 138BuildRequires: expat-devel
7d0dbc8d 139%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 140%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 141BuildRequires: fontconfig-devel
f1b276d4 142BuildRequires: glib2-devel
05f72ae2 143BuildRequires: gperf
71d49434 144%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 145BuildRequires: gtest-devel
8b53130d 146BuildRequires: gtk+2-devel
01b4dc8e 147%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 148%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 149%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 150BuildRequires: hicolor-icon-theme
ed514974 151%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 152%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 153BuildRequires: libevent-devel
8456d676 154%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 155%{?with_keyring:BuildRequires: libgnome-keyring-devel}
cb6dde87 156%{?with_system_icu:BuildRequires: libicu-devel >= 4.6}
39c71b4c 157%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 158%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 159%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 160BuildRequires: libpng-devel
e266589e 161%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 162BuildRequires: libstdc++-devel
ba685303 163%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
88171dca
ER
164%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.3.0}
165%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 166BuildRequires: libxml2-devel
11ad81c4 167BuildRequires: libxslt-devel
535cb410 168BuildRequires: man-db
62950103 169%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 170%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 171BuildRequires: nspr-devel
f1b276d4 172BuildRequires: nss-devel >= 1:3.12.3
8456d676 173%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 174BuildRequires: pam-devel
f1b276d4 175BuildRequires: pango-devel
ef121064 176BuildRequires: pciutils-devel
3a3b7da9 177BuildRequires: perl-JSON
48b341f5 178BuildRequires: perl-modules
179BuildRequires: pkgconfig
75a27c2e 180%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 181%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 182BuildRequires: python
e2f921c3 183BuildRequires: python-BeautifulSoup
46cdefee 184#BuildRequires: python-gyp >= 1-%{gyp_rev}
9cce36cb 185BuildRequires: python-jinja2 >= 2.7
48b341f5 186BuildRequires: python-modules
e0a7fe40 187BuildRequires: python-ply >= 3.4
543e99ac 188%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 189BuildRequires: rpm >= 4.4.9-56
f1b276d4 190BuildRequires: rpmbuild(macros) >= 1.453
f099161f 191%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 192BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 193%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 194%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 195%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 196BuildRequires: tar >= 1:1.22
0a424ee2 197BuildRequires: udev-devel
7d1152d4 198BuildRequires: usbutils
2303ed45 199BuildRequires: util-linux
c14cd342 200%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 201BuildRequires: which
f1b276d4 202BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 203BuildRequires: xorg-lib-libXtst-devel
836b1cac 204BuildRequires: xz
a3140cd1 205%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 206%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 207Requires: browser-plugins >= 2.0
0cad051b 208Requires: desktop-file-utils
8f5f6775 209%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
210# crashes if no fontconfig font present
211Requires: fonts-Type1-urw
0eb19b0b 212Requires: hicolor-icon-theme
56403697 213Requires: libevent >= 2.0.21
c1edaafa 214%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
88171dca 215%{?with_system_libvpx:Requires: libvpx >= 1.3.0}
b809ab60 216Requires: lsb-release
b2c4ae39 217%{?with_system_re2:Requires: re2 >= 20130115-2}
4b2f9b57 218%{?with_system_protobuf:Requires: protobuf-libs >= 2.5.0-2}
3700ba38 219Requires: shared-mime-info
f7b16691 220%{?with_system_sqlite:Requires: sqlite3(icu)}
4dc49133 221Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 222Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 223Provides: wwwbrowser
c3582150 224Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 225Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 226ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 227BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 228
319f81f7
ER
229# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
230# Note: these are for PLD Linux use ONLY.
231# For your own distribution, please get your own set of keys.
232%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
233%define google_default_client_id 724288223830.apps.googleusercontent.com
234%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
235
7ebeabb6 236%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 237
e7fa0817
ER
238# Usage: gyp_with BCOND_NAME [OPTION_NAME]
239%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 240
a323900c
ER
241%ifarch %{ix86}
242%define target_arch ia32
243%endif
244%ifarch %{x8664}
245%define target_arch x64
246%endif
247
f8597c6e
ER
248%define buildtype %{?debug:Debug}%{!?debug:Release}
249%define builddir out/%{buildtype}
250
6b113615
ER
251%if %{without debuginfo}
252%define _enable_debug_packages 0
253%endif
254
11ad81c4 255%description
80838854
ER
256Chromium is an open-source browser project that aims to build a safer,
257faster, and more stable way for all Internet users to experience the
258web.
259
260Chromium serves as a base for Google Chrome, which is Chromium
261rebranded (name and logo) with very few additions such as usage
262tracking and an auto-updater system.
263
f1b276d4
ER
264%package l10n
265Summary: chromium-browser language packages
266Group: I18n
267Requires: %{name} = %{version}-%{release}
8da7b90b
ER
268%if "%{_rpmversion}" >= "5"
269BuildArch: noarch
270%endif
f1b276d4
ER
271
272%description l10n
273Chromium is an open-source browser project that aims to build a safer,
274faster, and more stable way for all Internet users to experience the
275web.
276
277This package contains language packages for 50 languages:
278
e7fa0817
ER
279ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
280he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
281pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
282zh-TW
f1b276d4
ER
283
284%prep
3c73e180
ER
285%setup -qc
286%if "%{?patchver}" != ""
77bd7e0a 287cd chromium*-%{branch}.%{basever}
3c73e180
ER
288%patch0 -p1
289cd ..
290%endif
77bd7e0a 291mv chromium*-%{branch}.%{basever}/* .
589d90ea 292
05f72ae2
ER
293# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
294# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 295. ./chrome/VERSION
e00e4177
ER
296chrome=$MAJOR.$MINOR.$BUILD.$PATCH
297test "$chrome" = %{version}
a3140cd1 298
75f96a39 299gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 300test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 301
4765ddf1
ER
302# add chromium and pld to useragent
303%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
304sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
305 -e 's/@BUILD_DIST_NAME@/PLD/g' \
306 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 307 < %{PATCH8} | %{__patch} -p1
4765ddf1 308
8da7b90b 309%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
310ln -s %{SOURCE7} .
311
12dc0aee 312#%patch2 -p1 NOT COMPILING
75f96a39 313%patch4 -p3
7879021e 314%patch7 -p1
75f96a39 315%patch15 -p2
f4a8da6a 316%{!?with_libjpegturbo:%patch11 -p0}
5997e180 317%patch16 -p1
41d6a4b1 318%patch28 -p1
a323900c 319%patch25 -p1
3aa67e11 320%{?with_nacl:%patch18 -p1}
ffb05754 321%patch24 -p1
75f96a39 322%patch26 -p2
cb6dde87 323%patch31 -p0
708e64c2 324%patch32 -p1
d7fca4aa 325%patch35 -p1
6e3c39b4 326%patch36 -p1
a20f29ed 327%patch37 -p1
e9abb380 328
f684992e
ER
329%{?with_dev:exit 0}
330
75a27c2e
ER
331sh -x clean-source.sh \
332 %{!?with_nacl:nacl=0} \
bbdce24d
ER
333 %{!?with_system_libvpx:libvpx=0} \
334 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 335 %{!?with_system_mesa:mesa=0} \
75a27c2e 336 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 337 %{!?with_system_re2:re2=0} \
7e634b46 338 %{!?with_system_snappy:snappy=0} \
5048b37a 339 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 340 %{!?with_system_v8:v8=0} \
0767a7a0 341 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 342 %{!?with_system_zlib:zlib=0} \
f177fdad 343 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 344 %{nil}
fded59be 345
e266589e 346%build
5997e180 347%if %{with nacl}
108c5f7c 348rm -rf native_client/toolchain/linux_x86_newlib
fded59be 349if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 350# Make symlinks for NaCL
108c5f7c 351install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 352
108c5f7c
ER
353cd native_client/toolchain/linux_x86_newlib
354ln -s x86_64-nacl/bin bin
355cd x86_64-nacl/bin
2e4113fd 356__cc='%{__cc}'
f64e73f6 357if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
358 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
359 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
360 %{__sed} -i -e '1i#!/bin/sh' gcc g++
361 chmod +x gcc g++
362else
363 ln -s %{_bindir}/x86_64-nacl-gcc gcc
364 ln -s %{_bindir}/x86_64-nacl-g++ g++
365fi
108c5f7c
ER
366ln -s gcc x86_64-nacl-gcc
367ln -s g++ x86_64-nacl-g++
368ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
369ln -s %{_bindir}/x86_64-nacl-ar ar
370ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 371ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 372ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 373ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 374ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 375ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
376ln -s %{_prefix}/x86_64-nacl/lib ../lib
377ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
378ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
379cd ../../../../..
fded59be 380fi
5997e180
ER
381%endif
382
a323900c 383%if %{without system_ffmpeg}
f8597c6e
ER
384if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
385 # Re-configure bundled ffmpeg
386 cd third_party/ffmpeg
50d701c6
ER
387 chromium/scripts/build_ffmpeg.py linux %{target_arch} \
388 --branding Chromium
f8597c6e 389 chromium/scripts/copy_config.sh
6e3c39b4 390 chromium/scripts/generate_gyp.py
f8597c6e
ER
391 cd -
392fi
0c480b89 393%endif
a323900c 394
6e3c39b4
ER
395third_party/libaddressinput/chromium/tools/update-strings.py
396
a323900c
ER
397flags="
398 -Dtarget_arch=%{target_arch} \
399 -Dpython_arch=%{target_arch} \
6e3c39b4 400 -Dffmpeg_branding=Chromium \
b91ce587 401 -Dsystem_libdir=%{_lib} \
a323900c 402 -Dpython_ver=%{py_ver} \
7b454a31
AM
403%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
404 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4 405%endif
f047b07c 406 %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
c980b122 407 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 408 %{?with_shared_libs:-Dlibrary=shared_library} \
b6942fc6 409 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
77bd7e0a 410 -Dinclude_tests__=0 \
c0808220 411%if %{with nacl}
038f76b9 412 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
413 -Ddisable_glibc_untar=1 \
414 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
415 -Ddisable_glibc=1 \
416 -Ddisable_pnacl=1 \
417 -Dbuild_pnacl_newlib=0 \
c0808220 418%else
8fb1dc98 419 -Ddisable_pnacl_untar=1 \
c0808220
ER
420 -Ddisable_nacl=1 \
421%endif
a3140cd1
ER
422 %{!?with_sse2:-Ddisable_sse2=1} \
423 %{?with_selinux:-Dselinux=1} \
7d1152d4 424 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 425 -Dlinux_link_libpci=1 \
7879021e 426 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
14c8ce0e 427 -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
71d49434 428 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
2983aa41
ER
429 -Dclang=0 \
430 -Dhost_clang=0 \
14c8ce0e
ER
431 -Dlinux_use_bundled_binutils=0 \
432 -Dlinux_use_bundled_gold=0 \
05998197 433 -Dlinux_use_gold_flags=0 \
71581184 434 -Dlogging_like_official_build=1 \
319f81f7
ER
435 -Dgoogle_api_key=%{google_api_key} \
436 -Dgoogle_default_client_id=%{google_default_client_id} \
437 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 438 %{gyp_with cups} \
8dda6bbc 439 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 440 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
441 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
442 %{gyp_with pulseaudio} \
41d6a4b1 443 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 444 %{gyp_with system_flac} \
01b4dc8e 445 %{gyp_with system_harfbuzz} \
cb6dde87 446 %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
2d65d095 447 %{gyp_with system_jsoncpp} \
62950103
ER
448 %{gyp_with system_libexif} \
449 %{gyp_with system_libmtp} \
9bd2659c 450 %{gyp_with system_libsrtp} \
581aec44 451 %{gyp_with system_libusb} \
88171dca 452 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 453 %{gyp_with system_libwebp} \
4884fc99 454 %{gyp_with system_libxnvctrl} \
7b8f219a 455 %{gyp_with system_mesa} \
126ea630 456 %{gyp_with system_minizip} \
62950103 457 %{gyp_with system_opus} \
75a27c2e 458 %{gyp_with system_protobuf} \
bbdce24d 459 %{gyp_with system_re2} \
7e634b46 460 %{gyp_with system_snappy} \
e7fa0817 461 %{gyp_with system_speex} \
914ee37c 462 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
463 %{gyp_with system_v8} \
464 %{gyp_with system_yasm} \
465 %{gyp_with system_zlib} \
0c480b89 466 -Duse_system_bzip2=1 \
62950103 467 -Duse_system_expat=1 \
f1b276d4 468 -Duse_system_libevent=1 \
0c480b89 469 -Duse_system_libjpeg=1 \
f1b276d4
ER
470 -Duse_system_libpng=1 \
471 -Duse_system_libxml=1 \
472 -Duse_system_libxslt=1 \
b363f856 473 -Duse_system_nspr=1 \
7f40f3f4 474 -Duse_system_xdg_utils=1 \
7879021e
ER
475"
476
477build/linux/unbundle/replace_gyp_files.py $flags
478
f8597c6e
ER
479%if %{with ninja}
480chkfile=%{builddir}/build.ninja
481%else
482chkfile=Makefile
483%endif
484test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
485test -e $chkfile || \
7879021e
ER
486 CC="%{__cc}" \
487 CXX="%{__cxx}" \
488 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
489 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
490 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
491 CC_host="%{__cc}" \
492 CXX_host="%{__cxx}" \
493 LD_host="%{__cxx}" \
494%{__python} build/gyp_chromium \
f8597c6e 495 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
496 --depth=. \
497 build/all.gyp \
498 $flags
11ad81c4 499
f8597c6e
ER
500%if %{with ninja}
501ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
502%else
b4d75247 503# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
504%{__make} -r \
505 BUILDTYPE=%{buildtype} \
f1b276d4 506 %{?with_verbose:V=1} \
f1b276d4
ER
507 CC.host="%{__cc}" \
508 CXX.host="%{__cxx}" \
b4d75247 509 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
510%endif
511 chrome %{?with_sandboxing:chrome_sandbox} \
512 %{nil}
11ad81c4 513
f8597c6e 514cd %{builddir}
535cb410
ER
515MANWIDTH=80 man ./chrome.1 > man.out
516%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
517
11ad81c4
AM
518%install
519rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
520install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
521 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
3b9998d5
ER
522 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
523 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
e266589e 524
f8597c6e 525cd %{builddir}
37ceaf05 526cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 527install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
528%{__sed} -i -e '
529 s,@libdir@,%{_libdir}/%{name},
530
531 /@OPTIONS@/ {
532 r options.txt
533 d
534 }
535' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b 536cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
c925a554 537cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
8da7b90b
ER
538ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
539ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 540cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 541install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 542install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
fcc48c19 543%if %{without system_ffmpeg}
f1b276d4 544install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 545%endif
6e3c39b4 546install -p libpdf.so $RPM_BUILD_ROOT%{_libdir}/%{name}
e7fa0817 547cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 548cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 549
8da7b90b 550%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 551
164020eb
ER
552%if %{with nacl}
553# Install Native Client files on platforms that support it.
554install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
555install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
556%ifarch %{x8664}
557install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
558%endif
559%ifarch %{ix86}
560install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
561%endif
562%endif
563
0c480b89
ER
564cd -
565
75f96a39 566for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
567 size=${icon##*/product_logo_}
568 size=${size%.png}
569
570 # this will skip non-numeric (22_mono_invert, 22_mono)
571 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
572 test -d "$dir" || continue
573
574 install -d $RPM_BUILD_ROOT$dir
575 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
576done
7f40f3f4 577
13840bc2
AM
578%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
579# http://code.google.com/p/chromium/issues/detail?id=24507
580gecko-mediaplayer*.so
581EOF
11ad81c4 582
589d90ea
ER
583# find locales
584%find_lang %{name}.lang
e7fa0817 585# always package en-US
f1b276d4 586%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 587
11ad81c4
AM
588%clean
589rm -rf $RPM_BUILD_ROOT
590
8da7b90b
ER
591%pretrans
592for d in locales resources; do
593 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
594 install -d %{_datadir}/%{name}
595 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
596 fi
597done
598exit 0
599
f1b276d4 600%post
0eb19b0b 601%update_icon_cache hicolor
b7a6e4ee 602%update_desktop_database
f1b276d4
ER
603%update_browser_plugins
604
605%postun
606if [ "$1" = 0 ]; then
0eb19b0b 607 %update_icon_cache hicolor
f1b276d4
ER
608 %update_browser_plugins
609fi
610
1d2b9616 611%files
11ad81c4 612%defattr(644,root,root,755)
75f96a39 613%doc AUTHORS LICENSE
f1b276d4
ER
614%{_browserpluginsconfdir}/browsers.d/%{name}.*
615%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
616%dir %{_sysconfdir}/%{name}
617%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 618%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
3b9998d5
ER
619%dir %{_sysconfdir}/%{name}/native-messaging-hosts
620%dir %{_sysconfdir}/%{name}/policies
621%dir %{_sysconfdir}/%{name}/policies/managed
f1b276d4
ER
622%attr(755,root,root) %{_bindir}/%{name}
623%{_mandir}/man1/%{name}.1*
11ad81c4 624%{_desktopdir}/*.desktop
0eb19b0b 625%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 626%dir %{_libdir}/%{name}
e9abb380 627%{_libdir}/%{name}/chrome*.pak
c14cd342 628%{_libdir}/%{name}/content_resources.pak
f047b07c 629%{_libdir}/%{name}/keyboard_resources.pak
97fac491 630%{_libdir}/%{name}/resources.pak
8da7b90b
ER
631%{_libdir}/%{name}/locales
632%{_libdir}/%{name}/resources
633
4b5c45ee
ER
634# conflicts with browser-plugin-chrome-pdf?
635%attr(755,root,root) %{_libdir}/%{name}/libpdf.so
636
8da7b90b
ER
637%dir %{_datadir}/%{name}
638%dir %{_datadir}/%{name}/locales
639%{_datadir}/%{name}/locales/en-US.pak
640%dir %{_datadir}/%{name}/resources
641%{_datadir}/%{name}/resources/inspector
642
f1b276d4
ER
643%dir %{_libdir}/%{name}/plugins
644%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 645# These unique permissions are intentional and necessary for the sandboxing
d1a83042 646%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
647
648# ffmpeg libs
fcc48c19 649%if %{without system_ffmpeg}
f1b276d4 650%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 651%endif
f1b276d4 652
164020eb
ER
653%if %{with nacl}
654%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
655%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
656%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
657%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
658%endif
659
f1b276d4
ER
660%files l10n -f %{name}.lang
661%defattr(644,root,root,755)
This page took 0.241209 seconds and 4 git commands to generate.