]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 43.0.2357.134
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
f684992e 5%bcond_with dev # with dev optimizations (skip clean source)
ba685303 6%bcond_without gconf # with GConf
75f96a39 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 9%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 10%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 11%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
db3fa756 12%bcond_without ninja # use Ninja instead of make to build
ba685303 13%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
14%bcond_without sandboxing # with sandboxing
15%bcond_with selinux # with SELinux (need policy first)
16%bcond_with shared_libs # with shared libs
17%bcond_with sse2 # use SSE2 instructions
ba685303 18%bcond_without system_flac # system flac
a323900c 19%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 20%bcond_without system_harfbuzz # system harfbuzz
cb6dde87 21%bcond_without system_icu # system icu
ba685303 22%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
23%bcond_without system_libexif # system libexif
24%bcond_without system_libmtp # system libmtp
3934d767 25%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 26%bcond_without system_libwebp # system libwebp
4884fc99 27%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 28%bcond_with system_mesa # system Mesa
126ea630 29%bcond_without system_minizip # system minizip
62950103 30%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
e7b1e97c
ER
31# protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
32%bcond_with system_protobuf # system protobuf
543e99ac 33%bcond_without system_re2 # system re2
7e634b46 34%bcond_without system_snappy # system snappy
ba685303 35%bcond_without system_speex # system speex
a8f4f3ac 36%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 37%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 38%bcond_with system_v8 # system v8
f047b07c 39%bcond_with system_libvpx # system libvpx
ba685303 40%bcond_without system_yasm # system yasm
1c00315b 41%bcond_without system_zlib # system zlib
14c8ce0e 42%bcond_with tcmalloc # use tcmalloc
7e136323 43%bcond_without verbose # verbose build (V=1)
0c480b89 44
b3fc6cb2
ER
45%ifarch %{ix86}
46# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
47%undefine with_system_mesa
5e3c5baa
ER
48
49# unable build with debuginfo on 32bit build systems
313715ac
ER
50# /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
51%undefine with_debuginfo
52%endif
53
54%ifarch %{x8664}
55# x86_64 systems fail with debugedit crashing
56# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
5e3c5baa 57%undefine with_debuginfo
b3fc6cb2
ER
58%endif
59
6d92f81c 60# TODO
b363f856 61# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 62# - use_system_skia
a3140cd1 63# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 64# - use_system_stlport (android specific)
7b8f219a 65# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 66
e53ecfb5 67# NOTES:
4fe038cb
ER
68# - mute BEEP mixer if you do not want to hear horrible system bell when
69# pressing home/end in url bar or more ^F search results on page.
7c638678 70# - space considerations:
0bb93ab2 71# - unpacked sources: ~490MiB
c1ecd31f 72# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 73# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 74# - to look for new tarball, use update-source.sh script
f1b276d4 75
7324ed5c 76%define branch 43.0.2357
34dd729e 77%define basever 65
72c57d7e 78%define patchver 134
a3140cd1 79%define gyp_rev 1014
11ad81c4 80Summary: A WebKit powered web browser
05f72ae2 81Name: chromium-browser
f73369da
ER
82%if "%{?patchver}" != ""
83Version: %{branch}.%{patchver}
84%else
85Version: %{branch}.%{basever}
86%endif
9d867387 87Release: 1
5bb99ef4 88License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 89Group: X11/Applications/Networking
34dd729e
ER
90Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
91# Source0-md5: 4aa590c1965817cfb693df7f8404e0b6
3c73e180
ER
92%if "%{?patchver}" != ""
93Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
72c57d7e 94# Patch0-md5: 0cfc52a089350571474c308dab1327ee
3c73e180 95%endif
37ceaf05 96Source1: %{name}.default
8b53130d
ER
97Source2: %{name}.sh
98Source3: %{name}.desktop
56c6e811
ER
99Source5: find-lang.sh
100Source6: update-source.sh
101Source7: clean-source.sh
836b1cac 102Source8: get-source.sh
0562b864 103Source9: master_preferences.json
a198be7c 104# https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
706f2712 105Patch2: enable-video-decode-accel.patch
5aa5df39 106Patch7: dlopen_sonamed_gl.patch
4765ddf1 107Patch8: chromium_useragent.patch.in
1347c76c
AM
108# https://bugs.gentoo.org/show_bug.cgi?id=393471
109# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 110Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
111Patch15: nacl-build-irt.patch
112Patch16: nacl-linkingfix.patch
9516ca97 113Patch18: nacl-no-untar.patch
6897926c 114Patch24: nacl-verbose.patch
c5b396f3
ER
115Patch25: gnome3-volume-control.patch
116Patch26: master-prefs-path.patch
25d4e23c 117Patch28: system-mesa.patch
9cce36cb 118Patch31: system-jinja.patch
708e64c2 119Patch32: remove_bundled_libraries-stale.patch
d7fca4aa 120Patch35: etc-dir.patch
6e3c39b4 121Patch36: angle.patch
a20f29ed 122Patch37: %{name}-build.patch
a198be7c 123Patch38: vaapi_include.patch
221355ea 124Patch39: libsecret.patch
12687dbd 125Patch40: system-libvpx.patch
750b48f7 126URL: http://www.chromium.org/Home
ae3fe89f 127%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 128%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 129BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 130%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 131%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
132BuildRequires: alsa-lib-devel
133BuildRequires: atk-devel
134BuildRequires: bison
11ad81c4 135BuildRequires: bzip2-devel
5997e180
ER
136%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
137%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
138%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 139%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 140%{?with_cups:BuildRequires: cups-devel}
92965b0e 141BuildRequires: elfutils-devel
77f32fa3 142BuildRequires: expat-devel
7d0dbc8d 143%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 144%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 145BuildRequires: fontconfig-devel
f1b276d4 146BuildRequires: glib2-devel
05f72ae2 147BuildRequires: gperf
71d49434 148%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 149BuildRequires: gtest-devel
8b53130d 150BuildRequires: gtk+2-devel
01b4dc8e 151%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 152%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 153%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 154BuildRequires: hicolor-icon-theme
ed514974 155%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 156%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 157BuildRequires: libevent-devel
8456d676 158%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 159%{?with_keyring:BuildRequires: libgnome-keyring-devel}
cb6dde87 160%{?with_system_icu:BuildRequires: libicu-devel >= 4.6}
39c71b4c 161%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 162%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 163%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 164BuildRequires: libpng-devel
221355ea 165BuildRequires: libsecret-devel
e266589e 166%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 167BuildRequires: libstdc++-devel
ba685303 168%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
5f786a22 169%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.4.0}
88171dca 170%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 171BuildRequires: libxml2-devel
11ad81c4 172BuildRequires: libxslt-devel
535cb410 173BuildRequires: man-db
62950103 174%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 175%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 176BuildRequires: nspr-devel
f1b276d4 177BuildRequires: nss-devel >= 1:3.12.3
8456d676 178%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 179BuildRequires: pam-devel
f1b276d4 180BuildRequires: pango-devel
ef121064 181BuildRequires: pciutils-devel
3a3b7da9 182BuildRequires: perl-JSON
48b341f5 183BuildRequires: perl-modules
184BuildRequires: pkgconfig
75a27c2e 185%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 186%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 187BuildRequires: python
e2f921c3 188BuildRequires: python-BeautifulSoup
46cdefee 189#BuildRequires: python-gyp >= 1-%{gyp_rev}
9cce36cb 190BuildRequires: python-jinja2 >= 2.7
48b341f5 191BuildRequires: python-modules
e0a7fe40 192BuildRequires: python-ply >= 3.4
543e99ac 193%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 194BuildRequires: rpm >= 4.4.9-56
f1b276d4 195BuildRequires: rpmbuild(macros) >= 1.453
f099161f 196%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 197BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 198%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 199%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 200%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 201BuildRequires: tar >= 1:1.22
0a424ee2 202BuildRequires: udev-devel
7d1152d4 203BuildRequires: usbutils
2303ed45 204BuildRequires: util-linux
c14cd342 205%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 206BuildRequires: which
f1b276d4 207BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 208BuildRequires: xorg-lib-libXtst-devel
836b1cac 209BuildRequires: xz
a3140cd1 210%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 211%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 212Requires: browser-plugins >= 2.0
0cad051b 213Requires: desktop-file-utils
8f5f6775 214%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
215# crashes if no fontconfig font present
216Requires: fonts-Type1-urw
0eb19b0b 217Requires: hicolor-icon-theme
56403697 218Requires: libevent >= 2.0.21
c1edaafa 219%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
5f786a22 220%{?with_system_libvpx:Requires: libvpx >= 1.4.0}
b809ab60 221Requires: lsb-release
b2c4ae39 222%{?with_system_re2:Requires: re2 >= 20130115-2}
4b2f9b57 223%{?with_system_protobuf:Requires: protobuf-libs >= 2.5.0-2}
3700ba38 224Requires: shared-mime-info
f7b16691 225%{?with_system_sqlite:Requires: sqlite3(icu)}
5c9227ee 226Requires: uname(release) >= 3.17
4dc49133 227Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 228Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 229Provides: wwwbrowser
c3582150 230Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 231Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 232ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 233BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 234
319f81f7
ER
235# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
236# Note: these are for PLD Linux use ONLY.
237# For your own distribution, please get your own set of keys.
238%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
239%define google_default_client_id 724288223830.apps.googleusercontent.com
240%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
241
7ebeabb6 242%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 243
e7fa0817
ER
244# Usage: gyp_with BCOND_NAME [OPTION_NAME]
245%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 246
a323900c
ER
247%ifarch %{ix86}
248%define target_arch ia32
249%endif
250%ifarch %{x8664}
251%define target_arch x64
252%endif
253
f8597c6e
ER
254%define buildtype %{?debug:Debug}%{!?debug:Release}
255%define builddir out/%{buildtype}
256
6b113615
ER
257%if %{without debuginfo}
258%define _enable_debug_packages 0
259%endif
260
11ad81c4 261%description
80838854
ER
262Chromium is an open-source browser project that aims to build a safer,
263faster, and more stable way for all Internet users to experience the
264web.
265
266Chromium serves as a base for Google Chrome, which is Chromium
267rebranded (name and logo) with very few additions such as usage
268tracking and an auto-updater system.
269
f1b276d4
ER
270%package l10n
271Summary: chromium-browser language packages
272Group: I18n
273Requires: %{name} = %{version}-%{release}
8da7b90b
ER
274%if "%{_rpmversion}" >= "5"
275BuildArch: noarch
276%endif
f1b276d4
ER
277
278%description l10n
279Chromium is an open-source browser project that aims to build a safer,
280faster, and more stable way for all Internet users to experience the
281web.
282
283This package contains language packages for 50 languages:
284
e7fa0817
ER
285ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
286he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
287pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
288zh-TW
f1b276d4
ER
289
290%prep
3c73e180
ER
291%setup -qc
292%if "%{?patchver}" != ""
77bd7e0a 293cd chromium*-%{branch}.%{basever}
3c73e180
ER
294%patch0 -p1
295cd ..
296%endif
77bd7e0a 297mv chromium*-%{branch}.%{basever}/* .
589d90ea 298
05f72ae2
ER
299# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
300# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 301. ./chrome/VERSION
e00e4177
ER
302chrome=$MAJOR.$MINOR.$BUILD.$PATCH
303test "$chrome" = %{version}
a3140cd1 304
75f96a39 305gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 306test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 307
4765ddf1
ER
308# add chromium and pld to useragent
309%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
310sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
311 -e 's/@BUILD_DIST_NAME@/PLD/g' \
312 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 313 < %{PATCH8} | %{__patch} -p1
4765ddf1 314
8da7b90b 315%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
316ln -s %{SOURCE7} .
317
810e0294 318#%patch2 -p1 CHECK
7879021e 319%patch7 -p1
75f96a39 320%patch15 -p2
f4a8da6a 321%{!?with_libjpegturbo:%patch11 -p0}
5997e180 322%patch16 -p1
41d6a4b1 323%patch28 -p1
a323900c 324%patch25 -p1
3aa67e11 325%{?with_nacl:%patch18 -p1}
ffb05754 326%patch24 -p1
75f96a39 327%patch26 -p2
cb6dde87 328%patch31 -p0
708e64c2 329%patch32 -p1
d7fca4aa 330%patch35 -p1
6e3c39b4 331%patch36 -p1
a20f29ed 332%patch37 -p1
810e0294 333#%patch38 -p1 CHECK
deef15b4 334%patch39 -p1
12687dbd 335%patch40 -p0
e9abb380 336
f684992e
ER
337%{?with_dev:exit 0}
338
75a27c2e
ER
339sh -x clean-source.sh \
340 %{!?with_nacl:nacl=0} \
bbdce24d
ER
341 %{!?with_system_libvpx:libvpx=0} \
342 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 343 %{!?with_system_mesa:mesa=0} \
75a27c2e 344 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 345 %{!?with_system_re2:re2=0} \
7e634b46 346 %{!?with_system_snappy:snappy=0} \
5048b37a 347 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 348 %{!?with_system_v8:v8=0} \
0767a7a0 349 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 350 %{!?with_system_zlib:zlib=0} \
f177fdad 351 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 352 %{nil}
fded59be 353
e266589e 354%build
5997e180 355%if %{with nacl}
108c5f7c 356rm -rf native_client/toolchain/linux_x86_newlib
fded59be 357if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 358# Make symlinks for NaCL
108c5f7c 359install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 360
108c5f7c
ER
361cd native_client/toolchain/linux_x86_newlib
362ln -s x86_64-nacl/bin bin
363cd x86_64-nacl/bin
2e4113fd 364__cc='%{__cc}'
f64e73f6 365if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
366 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
367 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
368 %{__sed} -i -e '1i#!/bin/sh' gcc g++
369 chmod +x gcc g++
370else
371 ln -s %{_bindir}/x86_64-nacl-gcc gcc
372 ln -s %{_bindir}/x86_64-nacl-g++ g++
373fi
108c5f7c
ER
374ln -s gcc x86_64-nacl-gcc
375ln -s g++ x86_64-nacl-g++
376ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
377ln -s %{_bindir}/x86_64-nacl-ar ar
378ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 379ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 380ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 381ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 382ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 383ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
384ln -s %{_prefix}/x86_64-nacl/lib ../lib
385ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
386ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
387cd ../../../../..
fded59be 388fi
5997e180
ER
389%endif
390
a323900c 391%if %{without system_ffmpeg}
f8597c6e
ER
392if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
393 # Re-configure bundled ffmpeg
394 cd third_party/ffmpeg
50d701c6
ER
395 chromium/scripts/build_ffmpeg.py linux %{target_arch} \
396 --branding Chromium
f8597c6e 397 chromium/scripts/copy_config.sh
6e3c39b4 398 chromium/scripts/generate_gyp.py
f8597c6e
ER
399 cd -
400fi
0c480b89 401%endif
a323900c 402
6e3c39b4
ER
403third_party/libaddressinput/chromium/tools/update-strings.py
404
a323900c
ER
405flags="
406 -Dtarget_arch=%{target_arch} \
407 -Dpython_arch=%{target_arch} \
12687dbd 408 -Dproprietary_codecs=1 \
6e3c39b4 409 -Dffmpeg_branding=Chromium \
b91ce587 410 -Dsystem_libdir=%{_lib} \
a323900c 411 -Dpython_ver=%{py_ver} \
7b454a31
AM
412%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
413 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4 414%endif
f047b07c 415 %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
c980b122 416 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 417 %{?with_shared_libs:-Dlibrary=shared_library} \
b6942fc6 418 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
77bd7e0a 419 -Dinclude_tests__=0 \
c0808220 420%if %{with nacl}
038f76b9 421 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
422 -Ddisable_glibc_untar=1 \
423 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
424 -Ddisable_glibc=1 \
425 -Ddisable_pnacl=1 \
426 -Dbuild_pnacl_newlib=0 \
c0808220 427%else
8fb1dc98 428 -Ddisable_pnacl_untar=1 \
c0808220
ER
429 -Ddisable_nacl=1 \
430%endif
a3140cd1
ER
431 %{!?with_sse2:-Ddisable_sse2=1} \
432 %{?with_selinux:-Dselinux=1} \
7d1152d4 433 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 434 -Dlinux_link_libpci=1 \
7879021e 435 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
14c8ce0e 436 -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
71d49434 437 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
2983aa41
ER
438 -Dclang=0 \
439 -Dhost_clang=0 \
14c8ce0e
ER
440 -Dlinux_use_bundled_binutils=0 \
441 -Dlinux_use_bundled_gold=0 \
05998197 442 -Dlinux_use_gold_flags=0 \
71581184 443 -Dlogging_like_official_build=1 \
319f81f7
ER
444 -Dgoogle_api_key=%{google_api_key} \
445 -Dgoogle_default_client_id=%{google_default_client_id} \
446 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 447 %{gyp_with cups} \
8dda6bbc 448 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 449 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
450 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
451 %{gyp_with pulseaudio} \
41d6a4b1 452 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 453 %{gyp_with system_flac} \
01b4dc8e 454 %{gyp_with system_harfbuzz} \
cb6dde87 455 %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
2d65d095 456 %{gyp_with system_jsoncpp} \
62950103
ER
457 %{gyp_with system_libexif} \
458 %{gyp_with system_libmtp} \
9bd2659c 459 %{gyp_with system_libsrtp} \
581aec44 460 %{gyp_with system_libusb} \
88171dca 461 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 462 %{gyp_with system_libwebp} \
4884fc99 463 %{gyp_with system_libxnvctrl} \
7b8f219a 464 %{gyp_with system_mesa} \
126ea630 465 %{gyp_with system_minizip} \
62950103 466 %{gyp_with system_opus} \
75a27c2e 467 %{gyp_with system_protobuf} \
bbdce24d 468 %{gyp_with system_re2} \
7e634b46 469 %{gyp_with system_snappy} \
e7fa0817 470 %{gyp_with system_speex} \
914ee37c 471 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
472 %{gyp_with system_v8} \
473 %{gyp_with system_yasm} \
474 %{gyp_with system_zlib} \
0c480b89 475 -Duse_system_bzip2=1 \
62950103 476 -Duse_system_expat=1 \
f1b276d4 477 -Duse_system_libevent=1 \
0c480b89 478 -Duse_system_libjpeg=1 \
f1b276d4
ER
479 -Duse_system_libpng=1 \
480 -Duse_system_libxml=1 \
481 -Duse_system_libxslt=1 \
b363f856 482 -Duse_system_nspr=1 \
7f40f3f4 483 -Duse_system_xdg_utils=1 \
7879021e
ER
484"
485
486build/linux/unbundle/replace_gyp_files.py $flags
487
f8597c6e
ER
488%if %{with ninja}
489chkfile=%{builddir}/build.ninja
490%else
491chkfile=Makefile
492%endif
493test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
494test -e $chkfile || \
7879021e
ER
495 CC="%{__cc}" \
496 CXX="%{__cxx}" \
497 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
498 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
499 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
500 CC_host="%{__cc}" \
501 CXX_host="%{__cxx}" \
502 LD_host="%{__cxx}" \
503%{__python} build/gyp_chromium \
f8597c6e 504 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
505 --depth=. \
506 build/all.gyp \
507 $flags
11ad81c4 508
f8597c6e
ER
509%if %{with ninja}
510ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
511%else
b4d75247 512# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
513%{__make} -r \
514 BUILDTYPE=%{buildtype} \
f1b276d4 515 %{?with_verbose:V=1} \
f1b276d4
ER
516 CC.host="%{__cc}" \
517 CXX.host="%{__cxx}" \
b4d75247 518 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
519%endif
520 chrome %{?with_sandboxing:chrome_sandbox} \
521 %{nil}
11ad81c4 522
f8597c6e 523cd %{builddir}
535cb410
ER
524MANWIDTH=80 man ./chrome.1 > man.out
525%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
526
11ad81c4
AM
527%install
528rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
529install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
530 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
3b9998d5
ER
531 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
532 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
e266589e 533
f8597c6e 534cd %{builddir}
37ceaf05 535cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 536install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
537%{__sed} -i -e '
538 s,@libdir@,%{_libdir}/%{name},
539
540 /@OPTIONS@/ {
541 r options.txt
542 d
543 }
544' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b 545cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
fa8317a0 546cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
8da7b90b
ER
547ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
548ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 549cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 550install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 551install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
fcc48c19 552%if %{without system_ffmpeg}
f1b276d4 553install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 554%endif
e7fa0817 555cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 556cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 557
8da7b90b 558%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 559
164020eb
ER
560%if %{with nacl}
561# Install Native Client files on platforms that support it.
562install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
563install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
564%ifarch %{x8664}
565install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
566%endif
567%ifarch %{ix86}
568install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
569%endif
570%endif
571
0c480b89
ER
572cd -
573
75f96a39 574for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
575 size=${icon##*/product_logo_}
576 size=${size%.png}
577
578 # this will skip non-numeric (22_mono_invert, 22_mono)
579 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
580 test -d "$dir" || continue
581
582 install -d $RPM_BUILD_ROOT$dir
583 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
584done
7f40f3f4 585
13840bc2
AM
586%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
587# http://code.google.com/p/chromium/issues/detail?id=24507
588gecko-mediaplayer*.so
589EOF
11ad81c4 590
589d90ea
ER
591# find locales
592%find_lang %{name}.lang
e7fa0817 593# always package en-US
f1b276d4 594%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 595
11ad81c4
AM
596%clean
597rm -rf $RPM_BUILD_ROOT
598
8da7b90b
ER
599%pretrans
600for d in locales resources; do
601 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
602 install -d %{_datadir}/%{name}
603 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
604 fi
605done
606exit 0
607
f1b276d4 608%post
0eb19b0b 609%update_icon_cache hicolor
b7a6e4ee 610%update_desktop_database
f1b276d4
ER
611%update_browser_plugins
612
613%postun
614if [ "$1" = 0 ]; then
0eb19b0b 615 %update_icon_cache hicolor
f1b276d4
ER
616 %update_browser_plugins
617fi
618
1d2b9616 619%files
11ad81c4 620%defattr(644,root,root,755)
75f96a39 621%doc AUTHORS LICENSE
f1b276d4
ER
622%{_browserpluginsconfdir}/browsers.d/%{name}.*
623%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
624%dir %{_sysconfdir}/%{name}
625%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 626%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
3b9998d5
ER
627%dir %{_sysconfdir}/%{name}/native-messaging-hosts
628%dir %{_sysconfdir}/%{name}/policies
629%dir %{_sysconfdir}/%{name}/policies/managed
f1b276d4
ER
630%attr(755,root,root) %{_bindir}/%{name}
631%{_mandir}/man1/%{name}.1*
11ad81c4 632%{_desktopdir}/*.desktop
0eb19b0b 633%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 634%dir %{_libdir}/%{name}
e9abb380 635%{_libdir}/%{name}/chrome*.pak
c14cd342 636%{_libdir}/%{name}/content_resources.pak
f047b07c 637%{_libdir}/%{name}/keyboard_resources.pak
97fac491 638%{_libdir}/%{name}/resources.pak
fa8317a0
ER
639%{_libdir}/%{name}/natives_blob.bin
640%{_libdir}/%{name}/snapshot_blob.bin
8da7b90b
ER
641%{_libdir}/%{name}/locales
642%{_libdir}/%{name}/resources
643
644%dir %{_datadir}/%{name}
645%dir %{_datadir}/%{name}/locales
646%{_datadir}/%{name}/locales/en-US.pak
647%dir %{_datadir}/%{name}/resources
648%{_datadir}/%{name}/resources/inspector
649
f1b276d4
ER
650%dir %{_libdir}/%{name}/plugins
651%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 652# These unique permissions are intentional and necessary for the sandboxing
d1a83042 653%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
654
655# ffmpeg libs
fcc48c19 656%if %{without system_ffmpeg}
f1b276d4 657%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 658%endif
f1b276d4 659
164020eb
ER
660%if %{with nacl}
661%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
662%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
663%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
664%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
665%endif
666
f1b276d4
ER
667%files l10n -f %{name}.lang
668%defattr(644,root,root,755)
This page took 0.362247 seconds and 4 git commands to generate.