]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
fix build
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
f684992e 5%bcond_with dev # with dev optimizations (skip clean source)
ba685303 6%bcond_without gconf # with GConf
75f96a39 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 9%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 10%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 11%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
db3fa756 12%bcond_without ninja # use Ninja instead of make to build
ba685303 13%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
14%bcond_without sandboxing # with sandboxing
15%bcond_with selinux # with SELinux (need policy first)
16%bcond_with shared_libs # with shared libs
17%bcond_with sse2 # use SSE2 instructions
ba685303 18%bcond_without system_flac # system flac
7b0b1eb2 19%bcond_without system_ffmpeg # system ffmpeg
108c5f7c 20%bcond_without system_harfbuzz # system harfbuzz
9a65d3be 21%bcond_without system_icu # system icu
ba685303 22%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
23%bcond_without system_libexif # system libexif
24%bcond_without system_libmtp # system libmtp
3934d767 25%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 26%bcond_without system_libwebp # system libwebp
4884fc99 27%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 28%bcond_with system_mesa # system Mesa
126ea630 29%bcond_without system_minizip # system minizip
62950103 30%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
e7b1e97c
ER
31# protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
32%bcond_with system_protobuf # system protobuf
543e99ac 33%bcond_without system_re2 # system re2
7e634b46 34%bcond_without system_snappy # system snappy
ba685303 35%bcond_without system_speex # system speex
a8f4f3ac 36%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9a65d3be 37%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle), http://bugs.gentoo.org/459932
ba685303 38%bcond_with system_v8 # system v8
2b086f74 39%bcond_with system_libvpx # system libvpx, http://crbug.com/494939
ba685303 40%bcond_without system_yasm # system yasm
1c00315b 41%bcond_without system_zlib # system zlib
14c8ce0e 42%bcond_with tcmalloc # use tcmalloc
7e136323 43%bcond_without verbose # verbose build (V=1)
0c480b89 44
b3fc6cb2
ER
45%ifarch %{ix86}
46# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
47%undefine with_system_mesa
5e3c5baa
ER
48
49# unable build with debuginfo on 32bit build systems
313715ac
ER
50# /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
51%undefine with_debuginfo
52%endif
53
54%ifarch %{x8664}
55# x86_64 systems fail with debugedit crashing
56# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
5e3c5baa 57%undefine with_debuginfo
b3fc6cb2
ER
58%endif
59
6d92f81c 60# TODO
b363f856 61# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 62# - use_system_skia
a3140cd1 63# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 64# - use_system_stlport (android specific)
a3140cd1 65
e53ecfb5 66# NOTES:
4fe038cb
ER
67# - mute BEEP mixer if you do not want to hear horrible system bell when
68# pressing home/end in url bar or more ^F search results on page.
7c638678 69# - space considerations:
0bb93ab2 70# - unpacked sources: ~490MiB
57a3f726 71# - built code: ~1.1GiB (x86_64/i686)
f1b276d4 72# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 73# - to look for new tarball, use update-source.sh script
f1b276d4 74
105cedc0 75%define branch 47.0.2526
e2a26231 76%define basever 69
9a65d3be 77#define patchver 130
a3140cd1 78%define gyp_rev 1014
11ad81c4 79Summary: A WebKit powered web browser
05f72ae2 80Name: chromium-browser
f73369da
ER
81%if "%{?patchver}" != ""
82Version: %{branch}.%{patchver}
83%else
84Version: %{branch}.%{basever}
85%endif
57a3f726 86Release: 1
5bb99ef4 87License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 88Group: X11/Applications/Networking
105cedc0 89Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.gz
e2a26231 90# Source0-md5: fd02450421899fb410fa70352a611c31
3c73e180
ER
91%if "%{?patchver}" != ""
92Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
2e48195e 93# Patch0-md5: 02973b87b9564ed36220497b4bf83109
3c73e180 94%endif
37ceaf05 95Source1: %{name}.default
8b53130d
ER
96Source2: %{name}.sh
97Source3: %{name}.desktop
56c6e811
ER
98Source5: find-lang.sh
99Source6: update-source.sh
100Source7: clean-source.sh
836b1cac 101Source8: get-source.sh
0562b864 102Source9: master_preferences.json
a198be7c 103# https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
706f2712 104Patch2: enable-video-decode-accel.patch
5aa5df39 105Patch7: dlopen_sonamed_gl.patch
4765ddf1 106Patch8: chromium_useragent.patch.in
1347c76c
AM
107# https://bugs.gentoo.org/show_bug.cgi?id=393471
108# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 109Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
110Patch15: nacl-build-irt.patch
111Patch16: nacl-linkingfix.patch
9516ca97 112Patch18: nacl-no-untar.patch
6897926c 113Patch24: nacl-verbose.patch
c5b396f3
ER
114Patch25: gnome3-volume-control.patch
115Patch26: master-prefs-path.patch
25d4e23c 116Patch28: system-mesa.patch
9cce36cb 117Patch31: system-jinja.patch
708e64c2 118Patch32: remove_bundled_libraries-stale.patch
d7fca4aa 119Patch35: etc-dir.patch
6e3c39b4 120Patch36: angle.patch
a20f29ed 121Patch37: %{name}-build.patch
a198be7c 122Patch38: vaapi_include.patch
221355ea 123Patch39: libsecret.patch
f0db7b91
ER
124Patch40: ffmpeg-generate-errors.patch
125Patch41: ffmpeg-generate.patch
8a0c4436 126Patch42: system-ffmpeg.patch
750b48f7 127URL: http://www.chromium.org/Home
ae3fe89f 128%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 129%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 130BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 131%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 132%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
133BuildRequires: alsa-lib-devel
134BuildRequires: atk-devel
135BuildRequires: bison
11ad81c4 136BuildRequires: bzip2-devel
5997e180
ER
137%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
138%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
139%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 140%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 141%{?with_cups:BuildRequires: cups-devel}
92965b0e 142BuildRequires: elfutils-devel
77f32fa3 143BuildRequires: expat-devel
7b0b1eb2 144%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 2.7.2}
8f5f6775 145%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 146BuildRequires: fontconfig-devel
f1b276d4 147BuildRequires: glib2-devel
05f72ae2 148BuildRequires: gperf
71d49434 149%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 150BuildRequires: gtest-devel
8b53130d 151BuildRequires: gtk+2-devel
01b4dc8e 152%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 153%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 154%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 155BuildRequires: hicolor-icon-theme
ed514974 156%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 157%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 158BuildRequires: libevent-devel
8456d676 159%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 160%{?with_keyring:BuildRequires: libgnome-keyring-devel}
cb6dde87 161%{?with_system_icu:BuildRequires: libicu-devel >= 4.6}
39c71b4c 162%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 163%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 164%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 165BuildRequires: libpng-devel
221355ea 166BuildRequires: libsecret-devel
e266589e 167%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 168BuildRequires: libstdc++-devel
ba685303 169%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
7b0b1eb2 170%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.5.0}
88171dca 171%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 172BuildRequires: libxml2-devel
11ad81c4 173BuildRequires: libxslt-devel
535cb410 174BuildRequires: man-db
62950103 175%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 176%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 177BuildRequires: nspr-devel
f1b276d4 178BuildRequires: nss-devel >= 1:3.12.3
8456d676 179%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 180BuildRequires: pam-devel
f1b276d4 181BuildRequires: pango-devel
ef121064 182BuildRequires: pciutils-devel
3a3b7da9 183BuildRequires: perl-JSON
48b341f5 184BuildRequires: perl-modules
185BuildRequires: pkgconfig
75a27c2e 186%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 187%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 188BuildRequires: python
e2f921c3 189BuildRequires: python-BeautifulSoup
46cdefee 190#BuildRequires: python-gyp >= 1-%{gyp_rev}
7791e59a 191BuildRequires: python-html5lib
9cce36cb 192BuildRequires: python-jinja2 >= 2.7
48b341f5 193BuildRequires: python-modules
e0a7fe40 194BuildRequires: python-ply >= 3.4
543e99ac 195%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 196BuildRequires: rpm >= 4.4.9-56
f1b276d4 197BuildRequires: rpmbuild(macros) >= 1.453
f099161f 198%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 199BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 200%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 201%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 202%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 203BuildRequires: tar >= 1:1.22
0a424ee2 204BuildRequires: udev-devel
7d1152d4 205BuildRequires: usbutils
2303ed45 206BuildRequires: util-linux
c14cd342 207%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 208BuildRequires: which
f1b276d4 209BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 210BuildRequires: xorg-lib-libXtst-devel
836b1cac 211BuildRequires: xz
a3140cd1 212%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 213%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 214Requires: browser-plugins >= 2.0
0cad051b 215Requires: desktop-file-utils
8f5f6775 216%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
217# crashes if no fontconfig font present
218Requires: fonts-Type1-urw
0eb19b0b 219Requires: hicolor-icon-theme
56403697 220Requires: libevent >= 2.0.21
c1edaafa 221%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
5f786a22 222%{?with_system_libvpx:Requires: libvpx >= 1.4.0}
b809ab60 223Requires: lsb-release
b2c4ae39 224%{?with_system_re2:Requires: re2 >= 20130115-2}
4b2f9b57 225%{?with_system_protobuf:Requires: protobuf-libs >= 2.5.0-2}
3700ba38 226Requires: shared-mime-info
f7b16691 227%{?with_system_sqlite:Requires: sqlite3(icu)}
5c9227ee 228Requires: uname(release) >= 3.17
4dc49133 229Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 230Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 231Provides: wwwbrowser
c3582150 232Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 233Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 234ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 235BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 236
319f81f7
ER
237# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
238# Note: these are for PLD Linux use ONLY.
239# For your own distribution, please get your own set of keys.
240%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
241%define google_default_client_id 724288223830.apps.googleusercontent.com
242%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
243
7ebeabb6 244%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 245
e7fa0817
ER
246# Usage: gyp_with BCOND_NAME [OPTION_NAME]
247%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 248
a323900c
ER
249%ifarch %{ix86}
250%define target_arch ia32
251%endif
252%ifarch %{x8664}
253%define target_arch x64
254%endif
255
f8597c6e
ER
256%define buildtype %{?debug:Debug}%{!?debug:Release}
257%define builddir out/%{buildtype}
258
6b113615
ER
259%if %{without debuginfo}
260%define _enable_debug_packages 0
261%endif
262
11ad81c4 263%description
80838854
ER
264Chromium is an open-source browser project that aims to build a safer,
265faster, and more stable way for all Internet users to experience the
266web.
267
268Chromium serves as a base for Google Chrome, which is Chromium
269rebranded (name and logo) with very few additions such as usage
270tracking and an auto-updater system.
271
f1b276d4
ER
272%package l10n
273Summary: chromium-browser language packages
274Group: I18n
275Requires: %{name} = %{version}-%{release}
8da7b90b
ER
276%if "%{_rpmversion}" >= "5"
277BuildArch: noarch
278%endif
f1b276d4
ER
279
280%description l10n
281Chromium is an open-source browser project that aims to build a safer,
282faster, and more stable way for all Internet users to experience the
283web.
284
285This package contains language packages for 50 languages:
286
e7fa0817
ER
287ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
288he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
289pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
290zh-TW
f1b276d4
ER
291
292%prep
3c73e180
ER
293%setup -qc
294%if "%{?patchver}" != ""
77bd7e0a 295cd chromium*-%{branch}.%{basever}
3c73e180
ER
296%patch0 -p1
297cd ..
298%endif
77bd7e0a 299mv chromium*-%{branch}.%{basever}/* .
589d90ea 300
05f72ae2
ER
301# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
302# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 303. ./chrome/VERSION
e00e4177
ER
304chrome=$MAJOR.$MINOR.$BUILD.$PATCH
305test "$chrome" = %{version}
a3140cd1 306
75f96a39 307gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 308test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 309
4765ddf1
ER
310# add chromium and pld to useragent
311%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
312sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
313 -e 's/@BUILD_DIST_NAME@/PLD/g' \
314 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 315 < %{PATCH8} | %{__patch} -p1
4765ddf1 316
8da7b90b 317%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
318ln -s %{SOURCE7} .
319
810e0294 320#%patch2 -p1 CHECK
7879021e 321%patch7 -p1
75f96a39 322%patch15 -p2
f4a8da6a 323%{!?with_libjpegturbo:%patch11 -p0}
5997e180 324%patch16 -p1
41d6a4b1 325%patch28 -p1
a323900c 326%patch25 -p1
3aa67e11 327%{?with_nacl:%patch18 -p1}
ffb05754 328%patch24 -p1
75f96a39 329%patch26 -p2
cb6dde87 330%patch31 -p0
708e64c2 331%patch32 -p1
d7fca4aa 332%patch35 -p1
6e3c39b4 333%patch36 -p1
a20f29ed 334%patch37 -p1
810e0294 335#%patch38 -p1 CHECK
deef15b4 336%patch39 -p1
f0db7b91
ER
337%patch40 -p1
338%patch41 -p1
8a0c4436 339%patch42 -p1
e9abb380 340
308e6041 341# https://groups.google.com/a/chromium.org/forum/#!topic/chromium-packagers/9JX1N2nf4PU
ff7c827f 342install -d chrome/test/data/webui
308e6041
ER
343touch chrome/test/data/webui/i18n_process_css_test.html
344
f684992e
ER
345%{?with_dev:exit 0}
346
75a27c2e
ER
347sh -x clean-source.sh \
348 %{!?with_nacl:nacl=0} \
bbdce24d
ER
349 %{!?with_system_libvpx:libvpx=0} \
350 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 351 %{!?with_system_mesa:mesa=0} \
75a27c2e 352 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 353 %{!?with_system_re2:re2=0} \
7e634b46 354 %{!?with_system_snappy:snappy=0} \
5048b37a 355 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 356 %{!?with_system_v8:v8=0} \
0767a7a0 357 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 358 %{!?with_system_zlib:zlib=0} \
f177fdad 359 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 360 %{nil}
fded59be 361
e266589e 362%build
5997e180 363%if %{with nacl}
108c5f7c 364rm -rf native_client/toolchain/linux_x86_newlib
fded59be 365if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 366# Make symlinks for NaCL
108c5f7c 367install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 368
108c5f7c
ER
369cd native_client/toolchain/linux_x86_newlib
370ln -s x86_64-nacl/bin bin
371cd x86_64-nacl/bin
2e4113fd 372__cc='%{__cc}'
f64e73f6 373if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
374 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
375 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
376 %{__sed} -i -e '1i#!/bin/sh' gcc g++
377 chmod +x gcc g++
378else
379 ln -s %{_bindir}/x86_64-nacl-gcc gcc
380 ln -s %{_bindir}/x86_64-nacl-g++ g++
381fi
108c5f7c
ER
382ln -s gcc x86_64-nacl-gcc
383ln -s g++ x86_64-nacl-g++
384ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
385ln -s %{_bindir}/x86_64-nacl-ar ar
386ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 387ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 388ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 389ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 390ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 391ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
392ln -s %{_prefix}/x86_64-nacl/lib ../lib
393ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
394ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
395cd ../../../../..
fded59be 396fi
5997e180
ER
397%endif
398
a323900c 399%if %{without system_ffmpeg}
f8597c6e
ER
400if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
401 # Re-configure bundled ffmpeg
402 cd third_party/ffmpeg
50d701c6
ER
403 chromium/scripts/build_ffmpeg.py linux %{target_arch} \
404 --branding Chromium
f8597c6e 405 chromium/scripts/copy_config.sh
6e3c39b4 406 chromium/scripts/generate_gyp.py
f8597c6e
ER
407 cd -
408fi
0c480b89 409%endif
a323900c 410
6e3c39b4
ER
411third_party/libaddressinput/chromium/tools/update-strings.py
412
a323900c
ER
413flags="
414 -Dtarget_arch=%{target_arch} \
415 -Dpython_arch=%{target_arch} \
12687dbd 416 -Dproprietary_codecs=1 \
6e3c39b4 417 -Dffmpeg_branding=Chromium \
b91ce587 418 -Dsystem_libdir=%{_lib} \
a323900c 419 -Dpython_ver=%{py_ver} \
7b454a31
AM
420%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
421 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4 422%endif
f047b07c 423 %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
c980b122 424 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 425 %{?with_shared_libs:-Dlibrary=shared_library} \
b6942fc6 426 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
77bd7e0a 427 -Dinclude_tests__=0 \
c0808220 428%if %{with nacl}
038f76b9 429 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
430 -Ddisable_glibc_untar=1 \
431 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
432 -Ddisable_glibc=1 \
433 -Ddisable_pnacl=1 \
434 -Dbuild_pnacl_newlib=0 \
c0808220 435%else
8fb1dc98 436 -Ddisable_pnacl_untar=1 \
c0808220
ER
437 -Ddisable_nacl=1 \
438%endif
a3140cd1
ER
439 %{!?with_sse2:-Ddisable_sse2=1} \
440 %{?with_selinux:-Dselinux=1} \
7d1152d4 441 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 442 -Dlinux_link_libpci=1 \
7879021e 443 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
14c8ce0e 444 -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
71d49434 445 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
2983aa41
ER
446 -Dclang=0 \
447 -Dhost_clang=0 \
14c8ce0e
ER
448 -Dlinux_use_bundled_binutils=0 \
449 -Dlinux_use_bundled_gold=0 \
05998197 450 -Dlinux_use_gold_flags=0 \
71581184 451 -Dlogging_like_official_build=1 \
319f81f7
ER
452 -Dgoogle_api_key=%{google_api_key} \
453 -Dgoogle_default_client_id=%{google_default_client_id} \
454 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 455 %{gyp_with cups} \
8dda6bbc 456 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 457 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
458 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
459 %{gyp_with pulseaudio} \
41d6a4b1 460 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 461 %{gyp_with system_flac} \
01b4dc8e 462 %{gyp_with system_harfbuzz} \
cb6dde87 463 %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
2d65d095 464 %{gyp_with system_jsoncpp} \
62950103
ER
465 %{gyp_with system_libexif} \
466 %{gyp_with system_libmtp} \
9bd2659c 467 %{gyp_with system_libsrtp} \
581aec44 468 %{gyp_with system_libusb} \
88171dca 469 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 470 %{gyp_with system_libwebp} \
4884fc99 471 %{gyp_with system_libxnvctrl} \
7b8f219a 472 %{gyp_with system_mesa} \
126ea630 473 %{gyp_with system_minizip} \
62950103 474 %{gyp_with system_opus} \
75a27c2e 475 %{gyp_with system_protobuf} \
bbdce24d 476 %{gyp_with system_re2} \
7e634b46 477 %{gyp_with system_snappy} \
e7fa0817 478 %{gyp_with system_speex} \
914ee37c 479 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
480 %{gyp_with system_v8} \
481 %{gyp_with system_yasm} \
482 %{gyp_with system_zlib} \
0c480b89 483 -Duse_system_bzip2=1 \
62950103 484 -Duse_system_expat=1 \
f1b276d4 485 -Duse_system_libevent=1 \
0c480b89 486 -Duse_system_libjpeg=1 \
f1b276d4
ER
487 -Duse_system_libpng=1 \
488 -Duse_system_libxml=1 \
489 -Duse_system_libxslt=1 \
b363f856 490 -Duse_system_nspr=1 \
7f40f3f4 491 -Duse_system_xdg_utils=1 \
7879021e
ER
492"
493
494build/linux/unbundle/replace_gyp_files.py $flags
495
f8597c6e
ER
496%if %{with ninja}
497chkfile=%{builddir}/build.ninja
498%else
499chkfile=Makefile
500%endif
501test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
502test -e $chkfile || \
7879021e
ER
503 CC="%{__cc}" \
504 CXX="%{__cxx}" \
505 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
506 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
507 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
508 CC_host="%{__cc}" \
509 CXX_host="%{__cxx}" \
510 LD_host="%{__cxx}" \
511%{__python} build/gyp_chromium \
f8597c6e 512 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
513 --depth=. \
514 build/all.gyp \
515 $flags
11ad81c4 516
f8597c6e
ER
517%if %{with ninja}
518ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
519%else
b4d75247 520# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
521%{__make} -r \
522 BUILDTYPE=%{buildtype} \
f1b276d4 523 %{?with_verbose:V=1} \
f1b276d4
ER
524 CC.host="%{__cc}" \
525 CXX.host="%{__cxx}" \
b4d75247 526 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
527%endif
528 chrome %{?with_sandboxing:chrome_sandbox} \
529 %{nil}
11ad81c4 530
f8597c6e 531cd %{builddir}
535cb410
ER
532MANWIDTH=80 man ./chrome.1 > man.out
533%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
534
11ad81c4
AM
535%install
536rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
537install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
538 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
3b9998d5
ER
539 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
540 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
e266589e 541
c9ba2fd5
ER
542%if %{without system_icu}
543cp -p third_party/icu/source/data/in/icudtl.dat $RPM_BUILD_ROOT%{_libdir}/%{name}
544%endif
545
f8597c6e 546cd %{builddir}
37ceaf05 547cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 548install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
549%{__sed} -i -e '
550 s,@libdir@,%{_libdir}/%{name},
551
552 /@OPTIONS@/ {
553 r options.txt
554 d
555 }
556' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b 557cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
fa8317a0 558cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
8da7b90b
ER
559ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
560ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 561cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 562install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 563install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
f0db7b91 564%if %{without system_ffmpeg} && 0
f1b276d4 565install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 566%endif
e7fa0817 567cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 568cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 569
8da7b90b 570%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 571
164020eb
ER
572%if %{with nacl}
573# Install Native Client files on platforms that support it.
574install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
575install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
576%ifarch %{x8664}
577install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
578%endif
579%ifarch %{ix86}
580install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
581%endif
582%endif
583
0c480b89
ER
584cd -
585
75f96a39 586for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
587 size=${icon##*/product_logo_}
588 size=${size%.png}
589
590 # this will skip non-numeric (22_mono_invert, 22_mono)
591 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
592 test -d "$dir" || continue
593
594 install -d $RPM_BUILD_ROOT$dir
595 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
596done
7f40f3f4 597
13840bc2
AM
598%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
599# http://code.google.com/p/chromium/issues/detail?id=24507
600gecko-mediaplayer*.so
601EOF
11ad81c4 602
589d90ea
ER
603# find locales
604%find_lang %{name}.lang
e7fa0817 605# always package en-US
f1b276d4 606%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 607
11ad81c4
AM
608%clean
609rm -rf $RPM_BUILD_ROOT
610
8da7b90b
ER
611%pretrans
612for d in locales resources; do
613 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
614 install -d %{_datadir}/%{name}
615 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
616 fi
617done
618exit 0
619
f1b276d4 620%post
0eb19b0b 621%update_icon_cache hicolor
b7a6e4ee 622%update_desktop_database
f1b276d4
ER
623%update_browser_plugins
624
625%postun
626if [ "$1" = 0 ]; then
0eb19b0b 627 %update_icon_cache hicolor
f1b276d4
ER
628 %update_browser_plugins
629fi
630
1d2b9616 631%files
11ad81c4 632%defattr(644,root,root,755)
75f96a39 633%doc AUTHORS LICENSE
f1b276d4
ER
634%{_browserpluginsconfdir}/browsers.d/%{name}.*
635%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
636%dir %{_sysconfdir}/%{name}
637%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 638%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
3b9998d5
ER
639%dir %{_sysconfdir}/%{name}/native-messaging-hosts
640%dir %{_sysconfdir}/%{name}/policies
641%dir %{_sysconfdir}/%{name}/policies/managed
f1b276d4
ER
642%attr(755,root,root) %{_bindir}/%{name}
643%{_mandir}/man1/%{name}.1*
11ad81c4 644%{_desktopdir}/*.desktop
0eb19b0b 645%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 646%dir %{_libdir}/%{name}
e9abb380 647%{_libdir}/%{name}/chrome*.pak
c9ba2fd5 648%{!?with_system_icu:%{_libdir}/%{name}/icudtl.dat}
c14cd342 649%{_libdir}/%{name}/content_resources.pak
f047b07c 650%{_libdir}/%{name}/keyboard_resources.pak
97fac491 651%{_libdir}/%{name}/resources.pak
fa8317a0
ER
652%{_libdir}/%{name}/natives_blob.bin
653%{_libdir}/%{name}/snapshot_blob.bin
8da7b90b
ER
654%{_libdir}/%{name}/locales
655%{_libdir}/%{name}/resources
656
657%dir %{_datadir}/%{name}
658%dir %{_datadir}/%{name}/locales
659%{_datadir}/%{name}/locales/en-US.pak
660%dir %{_datadir}/%{name}/resources
661%{_datadir}/%{name}/resources/inspector
662
f1b276d4
ER
663%dir %{_libdir}/%{name}/plugins
664%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 665# These unique permissions are intentional and necessary for the sandboxing
d1a83042 666%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
667
668# ffmpeg libs
f0db7b91 669%if %{without system_ffmpeg} && 0
f1b276d4 670%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 671%endif
f1b276d4 672
164020eb
ER
673%if %{with nacl}
674%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
675%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
676%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
677%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
678%endif
679
f1b276d4
ER
680%files l10n -f %{name}.lang
681%defattr(644,root,root,755)
This page took 1.257431 seconds and 4 git commands to generate.