]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 34.0.1847.116
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
75f96a39 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 8%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 10%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
41a57b3c 11%bcond_with ninja # use Ninja instead of make to build
ba685303 12%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
13%bcond_without sandboxing # with sandboxing
14%bcond_with selinux # with SELinux (need policy first)
15%bcond_with shared_libs # with shared libs
16%bcond_with sse2 # use SSE2 instructions
ba685303 17%bcond_without system_flac # system flac
a323900c 18%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 19%bcond_without system_harfbuzz # system harfbuzz
ba685303 20%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
21%bcond_without system_libexif # system libexif
22%bcond_without system_libmtp # system libmtp
3934d767 23%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 24%bcond_without system_libwebp # system libwebp
4884fc99 25%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 26%bcond_with system_mesa # system Mesa
126ea630 27%bcond_without system_minizip # system minizip
62950103 28%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 29%bcond_without system_protobuf # system protobuf
543e99ac 30%bcond_without system_re2 # system re2
7e634b46 31%bcond_without system_snappy # system snappy
ba685303 32%bcond_without system_speex # system speex
a8f4f3ac 33%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9bd2659c 34%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 35%bcond_with system_v8 # system v8
4b411ffe 36%bcond_without system_libvpx # system libvpx
ba685303 37%bcond_without system_yasm # system yasm
1c00315b 38%bcond_without system_zlib # system zlib
d2781a31 39%bcond_without tcmalloc # use tcmalloc
7e136323 40%bcond_without verbose # verbose build (V=1)
0c480b89 41
b3fc6cb2
ER
42%ifarch %{ix86}
43# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
44%undefine with_system_mesa
45%endif
46
6d92f81c 47# TODO
b363f856 48# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 49# - use_system_skia
a3140cd1 50# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 51# - use_system_stlport (android specific)
7b8f219a 52# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 53
e53ecfb5 54# NOTES:
4fe038cb
ER
55# - mute BEEP mixer if you do not want to hear horrible system bell when
56# pressing home/end in url bar or more ^F search results on page.
7c638678 57# - space considerations:
0bb93ab2 58# - unpacked sources: ~490MiB
c1ecd31f 59# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 60# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 61# - to look for new tarball, use update-source.sh script
f1b276d4 62
c6a6fa95
ER
63%define branch 34.0.1847
64%define basever 116
65#define patchver 152
a3140cd1 66%define gyp_rev 1014
11ad81c4 67Summary: A WebKit powered web browser
05f72ae2 68Name: chromium-browser
f73369da
ER
69%if "%{?patchver}" != ""
70Version: %{branch}.%{patchver}
71%else
72Version: %{branch}.%{basever}
73%endif
537abf9b 74Release: 1
5bb99ef4 75License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 76Group: X11/Applications/Networking
f177fdad 77Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
8debb5ff 78# Source0-md5: a9b5e04e9a5d45154de1f5dfeb5bf98c
3c73e180
ER
79%if "%{?patchver}" != ""
80Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
44c11196 81# Patch0-md5: 194579901c234fbce9e1538e7956d36c
3c73e180 82%endif
37ceaf05 83Source1: %{name}.default
8b53130d
ER
84Source2: %{name}.sh
85Source3: %{name}.desktop
56c6e811
ER
86Source5: find-lang.sh
87Source6: update-source.sh
88Source7: clean-source.sh
836b1cac 89Source8: get-source.sh
0562b864 90Source9: master_preferences.json
48b341f5 91Patch1: plugin-searchdirs.patch
627e6027 92Patch2: enable-video-decode-accel.patch
72cb20c1 93Patch4: path-libpdf.patch
5aa5df39 94Patch7: dlopen_sonamed_gl.patch
4765ddf1 95Patch8: chromium_useragent.patch.in
1347c76c
AM
96# https://bugs.gentoo.org/show_bug.cgi?id=393471
97# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 98Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
99Patch15: nacl-build-irt.patch
100Patch16: nacl-linkingfix.patch
9516ca97 101Patch18: nacl-no-untar.patch
6897926c 102Patch24: nacl-verbose.patch
c5b396f3
ER
103Patch25: gnome3-volume-control.patch
104Patch26: master-prefs-path.patch
25d4e23c 105Patch28: system-mesa.patch
e0a7fe40 106Patch30: system-ply.patch
9cce36cb 107Patch31: system-jinja.patch
708e64c2 108Patch32: remove_bundled_libraries-stale.patch
a323900c 109Patch33: gn.patch
77bd7e0a 110Patch34: depot-tools.patch
750b48f7 111URL: http://www.chromium.org/Home
ae3fe89f 112%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 113%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 114BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 115%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 116%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
117BuildRequires: alsa-lib-devel
118BuildRequires: atk-devel
119BuildRequires: bison
11ad81c4 120BuildRequires: bzip2-devel
5997e180
ER
121%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
122%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
123%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 124%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 125%{?with_cups:BuildRequires: cups-devel}
92965b0e 126BuildRequires: elfutils-devel
77f32fa3 127BuildRequires: expat-devel
7d0dbc8d 128%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 129%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 130BuildRequires: fontconfig-devel
f1b276d4 131BuildRequires: glib2-devel
05f72ae2 132BuildRequires: gperf
71d49434 133%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 134BuildRequires: gtest-devel
8b53130d 135BuildRequires: gtk+2-devel
01b4dc8e 136%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 137%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 138%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 139BuildRequires: hicolor-icon-theme
ed514974 140%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 141%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 142BuildRequires: libevent-devel
8456d676 143%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 144%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 145BuildRequires: libicu-devel >= 4.6
39c71b4c 146%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 147%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 148%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 149BuildRequires: libpng-devel
e266589e 150%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 151BuildRequires: libstdc++-devel
ba685303 152%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
88171dca
ER
153%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.3.0}
154%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 155BuildRequires: libxml2-devel
11ad81c4 156BuildRequires: libxslt-devel
535cb410 157BuildRequires: man-db
62950103 158%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 159%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 160BuildRequires: nspr-devel
f1b276d4 161BuildRequires: nss-devel >= 1:3.12.3
8456d676 162%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 163BuildRequires: pam-devel
f1b276d4 164BuildRequires: pango-devel
ef121064 165BuildRequires: pciutils-devel
3a3b7da9 166BuildRequires: perl-JSON
48b341f5 167BuildRequires: perl-modules
168BuildRequires: pkgconfig
75a27c2e 169%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 170%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 171BuildRequires: python
46cdefee 172#BuildRequires: python-gyp >= 1-%{gyp_rev}
9cce36cb 173BuildRequires: python-jinja2 >= 2.7
48b341f5 174BuildRequires: python-modules
e0a7fe40 175BuildRequires: python-ply >= 3.4
543e99ac 176%{?with_system_re2:BuildRequires: re2-devel >= 20130115-2}
0cad051b 177BuildRequires: rpm >= 4.4.9-56
f1b276d4 178BuildRequires: rpmbuild(macros) >= 1.453
f099161f 179%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 180BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 181%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 182%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 183%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 184BuildRequires: tar >= 1:1.22
0a424ee2 185BuildRequires: udev-devel
7d1152d4 186BuildRequires: usbutils
2303ed45 187BuildRequires: util-linux
c14cd342 188%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 189BuildRequires: which
f1b276d4 190BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 191BuildRequires: xorg-lib-libXtst-devel
836b1cac 192BuildRequires: xz
a3140cd1 193%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 194%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 195Requires: browser-plugins >= 2.0
0cad051b 196Requires: desktop-file-utils
8f5f6775 197%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
198# crashes if no fontconfig font present
199Requires: fonts-Type1-urw
0eb19b0b 200Requires: hicolor-icon-theme
56403697 201Requires: libevent >= 2.0.21
c1edaafa 202%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
88171dca 203%{?with_system_libvpx:Requires: libvpx >= 1.3.0}
b809ab60 204Requires: lsb-release
b2c4ae39 205%{?with_system_re2:Requires: re2 >= 20130115-2}
3700ba38 206Requires: shared-mime-info
f7b16691 207%{?with_system_sqlite:Requires: sqlite3(icu)}
4dc49133 208Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 209Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 210Provides: wwwbrowser
c3582150 211Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 212Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 213ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 214BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 215
319f81f7
ER
216# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
217# Note: these are for PLD Linux use ONLY.
218# For your own distribution, please get your own set of keys.
219%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
220%define google_default_client_id 724288223830.apps.googleusercontent.com
221%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
222
7ebeabb6 223%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 224
e7fa0817
ER
225# Usage: gyp_with BCOND_NAME [OPTION_NAME]
226%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 227
a323900c
ER
228%ifarch %{ix86}
229%define target_arch ia32
230%endif
231%ifarch %{x8664}
232%define target_arch x64
233%endif
234
f8597c6e
ER
235%define buildtype %{?debug:Debug}%{!?debug:Release}
236%define builddir out/%{buildtype}
237
6b113615
ER
238%if %{without debuginfo}
239%define _enable_debug_packages 0
240%endif
241
11ad81c4 242%description
80838854
ER
243Chromium is an open-source browser project that aims to build a safer,
244faster, and more stable way for all Internet users to experience the
245web.
246
247Chromium serves as a base for Google Chrome, which is Chromium
248rebranded (name and logo) with very few additions such as usage
249tracking and an auto-updater system.
250
f1b276d4
ER
251%package l10n
252Summary: chromium-browser language packages
253Group: I18n
254Requires: %{name} = %{version}-%{release}
8da7b90b
ER
255%if "%{_rpmversion}" >= "5"
256BuildArch: noarch
257%endif
f1b276d4
ER
258
259%description l10n
260Chromium is an open-source browser project that aims to build a safer,
261faster, and more stable way for all Internet users to experience the
262web.
263
264This package contains language packages for 50 languages:
265
e7fa0817
ER
266ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
267he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
268pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
269zh-TW
f1b276d4
ER
270
271%prep
3c73e180
ER
272%setup -qc
273%if "%{?patchver}" != ""
77bd7e0a 274cd chromium*-%{branch}.%{basever}
3c73e180
ER
275%patch0 -p1
276cd ..
277%endif
77bd7e0a 278mv chromium*-%{branch}.%{basever}/* .
589d90ea 279
05f72ae2
ER
280# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
281# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 282. ./chrome/VERSION
e00e4177
ER
283chrome=$MAJOR.$MINOR.$BUILD.$PATCH
284test "$chrome" = %{version}
a3140cd1 285
75f96a39 286gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 287test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 288
4765ddf1
ER
289# add chromium and pld to useragent
290%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
291sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
292 -e 's/@BUILD_DIST_NAME@/PLD/g' \
293 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 294 < %{PATCH8} | %{__patch} -p1
4765ddf1 295
8da7b90b 296%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
297ln -s %{SOURCE7} .
298
fb336f24 299%patch1 -p1
12dc0aee 300#%patch2 -p1 NOT COMPILING
75f96a39 301%patch4 -p3
7879021e 302%patch7 -p1
75f96a39 303%patch15 -p2
f4a8da6a 304%{!?with_libjpegturbo:%patch11 -p0}
5997e180 305%patch16 -p1
41d6a4b1 306%patch28 -p1
a323900c 307%patch25 -p1
3aa67e11 308%{?with_nacl:%patch18 -p1}
75f96a39
ER
309%patch24 -p2
310%patch26 -p2
77bd7e0a
ER
311#%patch30 -p1
312#%patch31 -p0
708e64c2 313%patch32 -p1
77bd7e0a
ER
314%patch33 -p1
315%patch34 -p0
e9abb380 316
75a27c2e
ER
317sh -x clean-source.sh \
318 %{!?with_nacl:nacl=0} \
bbdce24d
ER
319 %{!?with_system_libvpx:libvpx=0} \
320 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 321 %{!?with_system_mesa:mesa=0} \
75a27c2e 322 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 323 %{!?with_system_re2:re2=0} \
7e634b46 324 %{!?with_system_snappy:snappy=0} \
5048b37a 325 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 326 %{!?with_system_v8:v8=0} \
0767a7a0 327 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 328 %{!?with_system_zlib:zlib=0} \
f177fdad 329 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 330 %{nil}
fded59be 331
e266589e 332%build
5997e180 333%if %{with nacl}
108c5f7c 334rm -rf native_client/toolchain/linux_x86_newlib
fded59be 335if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 336# Make symlinks for NaCL
108c5f7c 337install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 338
108c5f7c
ER
339cd native_client/toolchain/linux_x86_newlib
340ln -s x86_64-nacl/bin bin
341cd x86_64-nacl/bin
2e4113fd 342__cc='%{__cc}'
f64e73f6 343if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
344 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
345 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
346 %{__sed} -i -e '1i#!/bin/sh' gcc g++
347 chmod +x gcc g++
348else
349 ln -s %{_bindir}/x86_64-nacl-gcc gcc
350 ln -s %{_bindir}/x86_64-nacl-g++ g++
351fi
108c5f7c
ER
352ln -s gcc x86_64-nacl-gcc
353ln -s g++ x86_64-nacl-g++
354ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
355ln -s %{_bindir}/x86_64-nacl-ar ar
356ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 357ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 358ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 359ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 360ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 361ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
362ln -s %{_prefix}/x86_64-nacl/lib ../lib
363ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
364ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
365cd ../../../../..
fded59be 366fi
5997e180
ER
367%endif
368
a323900c 369%if %{without system_ffmpeg}
f8597c6e
ER
370if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
371 # Re-configure bundled ffmpeg
372 cd third_party/ffmpeg
373 chromium/scripts/build_ffmpeg.sh linux %{target_arch} "$PWD" config-only
374 chromium/scripts/copy_config.sh
375 cd -
376fi
0c480b89 377%endif
a323900c
ER
378
379flags="
380 -Dtarget_arch=%{target_arch} \
381 -Dpython_arch=%{target_arch} \
b91ce587 382 -Dsystem_libdir=%{_lib} \
a323900c 383 -Dpython_ver=%{py_ver} \
7b454a31
AM
384%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
385 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
386%endif
387 %{!?debug:-Dwerror=} \
c980b122 388 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 389 %{?with_shared_libs:-Dlibrary=shared_library} \
9da385b7 390 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
77bd7e0a 391 -Dinclude_tests__=0 \
c0808220 392%if %{with nacl}
038f76b9 393 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
394 -Ddisable_glibc_untar=1 \
395 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
396 -Ddisable_glibc=1 \
397 -Ddisable_pnacl=1 \
398 -Dbuild_pnacl_newlib=0 \
c0808220 399%else
8fb1dc98 400 -Ddisable_pnacl_untar=1 \
c0808220
ER
401 -Ddisable_nacl=1 \
402%endif
a3140cd1
ER
403 %{!?with_sse2:-Ddisable_sse2=1} \
404 %{?with_selinux:-Dselinux=1} \
7d1152d4 405 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 406 -Dlinux_link_libpci=1 \
7879021e 407 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
05998197 408 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
71d49434 409 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
05998197
ER
410 -Dlinux_use_gold_binary=0 \
411 -Dlinux_use_gold_flags=0 \
71581184 412 -Dlogging_like_official_build=1 \
319f81f7
ER
413 -Dgoogle_api_key=%{google_api_key} \
414 -Dgoogle_default_client_id=%{google_default_client_id} \
415 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 416 %{gyp_with cups} \
8dda6bbc 417 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 418 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
419 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
420 %{gyp_with pulseaudio} \
41d6a4b1 421 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 422 %{gyp_with system_flac} \
01b4dc8e 423 %{gyp_with system_harfbuzz} \
2d65d095 424 %{gyp_with system_jsoncpp} \
62950103
ER
425 %{gyp_with system_libexif} \
426 %{gyp_with system_libmtp} \
9bd2659c 427 %{gyp_with system_libsrtp} \
581aec44 428 %{gyp_with system_libusb} \
88171dca 429 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 430 %{gyp_with system_libwebp} \
4884fc99 431 %{gyp_with system_libxnvctrl} \
7b8f219a 432 %{gyp_with system_mesa} \
126ea630 433 %{gyp_with system_minizip} \
62950103 434 %{gyp_with system_opus} \
75a27c2e 435 %{gyp_with system_protobuf} \
bbdce24d 436 %{gyp_with system_re2} \
7e634b46 437 %{gyp_with system_snappy} \
e7fa0817 438 %{gyp_with system_speex} \
914ee37c 439 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
440 %{gyp_with system_v8} \
441 %{gyp_with system_yasm} \
442 %{gyp_with system_zlib} \
0c480b89 443 -Duse_system_bzip2=1 \
62950103 444 -Duse_system_expat=1 \
0b214002 445 -Duse_system_icu=1 \
f1b276d4 446 -Duse_system_libevent=1 \
0c480b89 447 -Duse_system_libjpeg=1 \
f1b276d4
ER
448 -Duse_system_libpng=1 \
449 -Duse_system_libxml=1 \
450 -Duse_system_libxslt=1 \
b363f856 451 -Duse_system_nspr=1 \
7f40f3f4 452 -Duse_system_xdg_utils=1 \
7879021e
ER
453"
454
455build/linux/unbundle/replace_gyp_files.py $flags
456
f8597c6e
ER
457%if %{with ninja}
458chkfile=%{builddir}/build.ninja
459%else
460chkfile=Makefile
461%endif
462test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
463test -e $chkfile || \
7879021e
ER
464 CC="%{__cc}" \
465 CXX="%{__cxx}" \
466 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
467 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
468 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
469 CC_host="%{__cc}" \
470 CXX_host="%{__cxx}" \
471 LD_host="%{__cxx}" \
472%{__python} build/gyp_chromium \
f8597c6e 473 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
474 --depth=. \
475 build/all.gyp \
476 $flags
11ad81c4 477
f8597c6e
ER
478%if %{with ninja}
479ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
480%else
b4d75247 481# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
482%{__make} -r \
483 BUILDTYPE=%{buildtype} \
f1b276d4 484 %{?with_verbose:V=1} \
f1b276d4
ER
485 CC.host="%{__cc}" \
486 CXX.host="%{__cxx}" \
b4d75247 487 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
488%endif
489 chrome %{?with_sandboxing:chrome_sandbox} \
490 %{nil}
11ad81c4 491
f8597c6e 492cd %{builddir}
535cb410
ER
493MANWIDTH=80 man ./chrome.1 > man.out
494%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
495
11ad81c4
AM
496%install
497rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
498install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
499 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
37ceaf05 500 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 501
f8597c6e 502cd %{builddir}
37ceaf05 503cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 504install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
505%{__sed} -i -e '
506 s,@libdir@,%{_libdir}/%{name},
507
508 /@OPTIONS@/ {
509 r options.txt
510 d
511 }
512' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b
ER
513cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
514cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
515ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
516ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 517cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 518install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 519install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
fcc48c19 520%if %{without system_ffmpeg}
f1b276d4 521install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 522%endif
e7fa0817 523cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 524cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 525
8da7b90b 526%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 527
164020eb
ER
528%if %{with nacl}
529# Install Native Client files on platforms that support it.
530install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
531install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
532%ifarch %{x8664}
533install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
534%endif
535%ifarch %{ix86}
536install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
537%endif
538%endif
539
0c480b89
ER
540cd -
541
75f96a39 542for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
543 size=${icon##*/product_logo_}
544 size=${size%.png}
545
546 # this will skip non-numeric (22_mono_invert, 22_mono)
547 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
548 test -d "$dir" || continue
549
550 install -d $RPM_BUILD_ROOT$dir
551 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
552done
7f40f3f4 553
13840bc2
AM
554%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
555# http://code.google.com/p/chromium/issues/detail?id=24507
556gecko-mediaplayer*.so
557EOF
11ad81c4 558
589d90ea
ER
559# find locales
560%find_lang %{name}.lang
e7fa0817 561# always package en-US
f1b276d4 562%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 563
11ad81c4
AM
564%clean
565rm -rf $RPM_BUILD_ROOT
566
8da7b90b
ER
567%pretrans
568for d in locales resources; do
569 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
570 install -d %{_datadir}/%{name}
571 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
572 fi
573done
574exit 0
575
f1b276d4 576%post
0eb19b0b 577%update_icon_cache hicolor
b7a6e4ee 578%update_desktop_database
f1b276d4
ER
579%update_browser_plugins
580
581%postun
582if [ "$1" = 0 ]; then
0eb19b0b 583 %update_icon_cache hicolor
f1b276d4
ER
584 %update_browser_plugins
585fi
586
1d2b9616 587%files
11ad81c4 588%defattr(644,root,root,755)
75f96a39 589%doc AUTHORS LICENSE
f1b276d4
ER
590%{_browserpluginsconfdir}/browsers.d/%{name}.*
591%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
592%dir %{_sysconfdir}/%{name}
593%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 594%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
595%attr(755,root,root) %{_bindir}/%{name}
596%{_mandir}/man1/%{name}.1*
11ad81c4 597%{_desktopdir}/*.desktop
0eb19b0b 598%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 599%dir %{_libdir}/%{name}
e9abb380 600%{_libdir}/%{name}/chrome*.pak
c14cd342 601%{_libdir}/%{name}/content_resources.pak
97fac491 602%{_libdir}/%{name}/resources.pak
8da7b90b
ER
603%{_libdir}/%{name}/locales
604%{_libdir}/%{name}/resources
605
606%dir %{_datadir}/%{name}
607%dir %{_datadir}/%{name}/locales
608%{_datadir}/%{name}/locales/en-US.pak
609%dir %{_datadir}/%{name}/resources
610%{_datadir}/%{name}/resources/inspector
611
f1b276d4
ER
612%dir %{_libdir}/%{name}/plugins
613%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 614# These unique permissions are intentional and necessary for the sandboxing
d1a83042 615%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
616
617# ffmpeg libs
fcc48c19 618%if %{without system_ffmpeg}
f1b276d4 619%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 620%endif
f1b276d4 621
164020eb
ER
622%if %{with nacl}
623%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
624%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
625%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
626%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
627%endif
628
f1b276d4
ER
629%files l10n -f %{name}.lang
630%defattr(644,root,root,755)
This page took 0.200697 seconds and 4 git commands to generate.