]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
up to 49.0.2623.110
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
f684992e 5%bcond_with dev # with dev optimizations (skip clean source)
ba685303 6%bcond_without gconf # with GConf
75f96a39 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 9%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 10%bcond_without libjpegturbo # use libjpeg-turbo features
3aa67e11 11%bcond_with nacl # build Native Client support, disabled: http://crbug.com/269560
db3fa756 12%bcond_without ninja # use Ninja instead of make to build
ba685303 13%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
14%bcond_without sandboxing # with sandboxing
15%bcond_with selinux # with SELinux (need policy first)
16%bcond_with shared_libs # with shared libs
17%bcond_with sse2 # use SSE2 instructions
ba685303 18%bcond_without system_flac # system flac
7b0b1eb2 19%bcond_without system_ffmpeg # system ffmpeg
108c5f7c 20%bcond_without system_harfbuzz # system harfbuzz
9a65d3be 21%bcond_without system_icu # system icu
ba685303 22%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
23%bcond_without system_libexif # system libexif
24%bcond_without system_libmtp # system libmtp
3934d767 25%bcond_with system_libusb # system libusb-1, disabled: http://crbug.com/266149
88171dca 26%bcond_without system_libwebp # system libwebp
4884fc99 27%bcond_without system_libxnvctrl # system libxnvctrl
cca42012 28%bcond_with system_mesa # system Mesa
126ea630 29%bcond_without system_minizip # system minizip
62950103 30%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
e7b1e97c
ER
31# protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
32%bcond_with system_protobuf # system protobuf
be84bbd9 33%bcond_with system_re2 # system re2
7e634b46 34%bcond_without system_snappy # system snappy
ba685303 35%bcond_without system_speex # system speex
a8f4f3ac 36%bcond_with system_sqlite # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
9a65d3be 37%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle), http://bugs.gentoo.org/459932
ba685303 38%bcond_with system_v8 # system v8
2b086f74 39%bcond_with system_libvpx # system libvpx, http://crbug.com/494939
ba685303 40%bcond_without system_yasm # system yasm
1c00315b 41%bcond_without system_zlib # system zlib
14c8ce0e 42%bcond_with tcmalloc # use tcmalloc
7e136323 43%bcond_without verbose # verbose build (V=1)
0c480b89 44
b3fc6cb2
ER
45%ifarch %{ix86}
46# GLsizeiptr different size, track: http://bugs.gentoo.org/457130
47%undefine with_system_mesa
5e3c5baa
ER
48
49# unable build with debuginfo on 32bit build systems
313715ac
ER
50# /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
51%undefine with_debuginfo
52%endif
53
54%ifarch %{x8664}
55# x86_64 systems fail with debugedit crashing
56# /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
5e3c5baa 57%undefine with_debuginfo
b3fc6cb2
ER
58%endif
59
6d92f81c 60# TODO
b363f856 61# - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
b363f856 62# - use_system_skia
a3140cd1 63# - use_system_ssl (use_openssl: http://crbug.com/62803)
b363f856 64# - use_system_stlport (android specific)
a3140cd1 65
e53ecfb5 66# NOTES:
4fe038cb
ER
67# - mute BEEP mixer if you do not want to hear horrible system bell when
68# pressing home/end in url bar or more ^F search results on page.
7c638678 69# - space considerations:
0bb93ab2 70# - unpacked sources: ~490MiB
57a3f726 71# - built code: ~1.1GiB (x86_64/i686)
f1b276d4 72# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 73# - to look for new tarball, use update-source.sh script
f1b276d4 74
be84bbd9 75%define branch 49.0.2623
bdfc9581 76%define basever 87
22720e8b 77%define patchver 110
a3140cd1 78%define gyp_rev 1014
11ad81c4 79Summary: A WebKit powered web browser
05f72ae2 80Name: chromium-browser
f73369da
ER
81%if "%{?patchver}" != ""
82Version: %{branch}.%{patchver}
83%else
84Version: %{branch}.%{basever}
85%endif
57a3f726 86Release: 1
5bb99ef4 87License: BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
e53ecfb5 88Group: X11/Applications/Networking
e0a6770a 89Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
c90d5eb0 90# Source0-md5: 75f28841d204632fb6de5375af28535a
bdfc9581 91#Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
3c73e180
ER
92%if "%{?patchver}" != ""
93Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
22720e8b 94# Patch0-md5: 02e4940cb19dd8da22a60df0abd77233
3c73e180 95%endif
37ceaf05 96Source1: %{name}.default
8b53130d
ER
97Source2: %{name}.sh
98Source3: %{name}.desktop
56c6e811
ER
99Source5: find-lang.sh
100Source6: update-source.sh
101Source7: clean-source.sh
836b1cac 102Source8: get-source.sh
0562b864 103Source9: master_preferences.json
a198be7c 104# https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
706f2712 105Patch2: enable-video-decode-accel.patch
5aa5df39 106Patch7: dlopen_sonamed_gl.patch
4765ddf1 107Patch8: chromium_useragent.patch.in
1347c76c
AM
108# https://bugs.gentoo.org/show_bug.cgi?id=393471
109# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 110Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
111Patch15: nacl-build-irt.patch
112Patch16: nacl-linkingfix.patch
9516ca97 113Patch18: nacl-no-untar.patch
6897926c 114Patch24: nacl-verbose.patch
c5b396f3
ER
115Patch25: gnome3-volume-control.patch
116Patch26: master-prefs-path.patch
25d4e23c 117Patch28: system-mesa.patch
9cce36cb 118Patch31: system-jinja.patch
708e64c2 119Patch32: remove_bundled_libraries-stale.patch
d7fca4aa 120Patch35: etc-dir.patch
6e3c39b4 121Patch36: angle.patch
a20f29ed 122Patch37: %{name}-build.patch
a198be7c 123Patch38: vaapi_include.patch
221355ea 124Patch39: libsecret.patch
f0db7b91
ER
125Patch40: ffmpeg-generate-errors.patch
126Patch41: ffmpeg-generate.patch
8a0c4436 127Patch42: system-ffmpeg.patch
750b48f7 128URL: http://www.chromium.org/Home
ae3fe89f 129%{?with_gconf:BuildRequires: GConf2-devel}
a28c0ac3 130%{?with_system_mesa:BuildRequires: Mesa-libGL-devel >= 9.1}
3a3b7da9 131BuildRequires: Mesa-libGLES-devel >= 9.1
7b8f219a 132%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
a28c0ac3 133%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel >= 9.1}
05f72ae2
ER
134BuildRequires: alsa-lib-devel
135BuildRequires: atk-devel
136BuildRequires: bison
11ad81c4 137BuildRequires: bzip2-devel
5997e180
ER
138%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
139%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
140%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 141%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 142%{?with_cups:BuildRequires: cups-devel}
92965b0e 143BuildRequires: elfutils-devel
77f32fa3 144BuildRequires: expat-devel
7b0b1eb2 145%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 2.7.2}
8f5f6775 146%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 147BuildRequires: fontconfig-devel
f1b276d4 148BuildRequires: glib2-devel
05f72ae2 149BuildRequires: gperf
71d49434 150%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 151BuildRequires: gtest-devel
8b53130d 152BuildRequires: gtk+2-devel
01b4dc8e 153%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
7ebeabb6 154%{?with_system_harfbuzz:BuildRequires: harfbuzz-icu-devel}
a3140cd1 155%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 156BuildRequires: hicolor-icon-theme
ed514974 157%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 158%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 159BuildRequires: libevent-devel
8456d676 160%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 161%{?with_keyring:BuildRequires: libgnome-keyring-devel}
cb6dde87 162%{?with_system_icu:BuildRequires: libicu-devel >= 4.6}
39c71b4c 163%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 164%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 165%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 166BuildRequires: libpng-devel
221355ea 167BuildRequires: libsecret-devel
e266589e 168%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 169BuildRequires: libstdc++-devel
ba685303 170%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
7b0b1eb2 171%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.5.0}
88171dca 172%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.4.0}
f1b276d4 173BuildRequires: libxml2-devel
11ad81c4 174BuildRequires: libxslt-devel
535cb410 175BuildRequires: man-db
62950103 176%{?with_system_minizip:BuildRequires: minizip-devel}
f8597c6e 177%{?with_ninja:BuildRequires: ninja >= 1.3.0}
05f72ae2 178BuildRequires: nspr-devel
f1b276d4 179BuildRequires: nss-devel >= 1:3.12.3
8456d676 180%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 181BuildRequires: pam-devel
f1b276d4 182BuildRequires: pango-devel
ef121064 183BuildRequires: pciutils-devel
3a3b7da9 184BuildRequires: perl-JSON
48b341f5 185BuildRequires: perl-modules
186BuildRequires: pkgconfig
75a27c2e 187%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 188%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 189BuildRequires: python
e2f921c3 190BuildRequires: python-BeautifulSoup
46cdefee 191#BuildRequires: python-gyp >= 1-%{gyp_rev}
7791e59a 192BuildRequires: python-html5lib
9cce36cb 193BuildRequires: python-jinja2 >= 2.7
48b341f5 194BuildRequires: python-modules
e0a7fe40 195BuildRequires: python-ply >= 3.4
42d59afd 196%{?with_system_re2:BuildRequires: re2-devel >= 20151101}
0cad051b 197BuildRequires: rpm >= 4.4.9-56
f1b276d4 198BuildRequires: rpmbuild(macros) >= 1.453
f099161f 199%{?with_system_snappy:BuildRequires: snappy-devel}
eda1bb04 200BuildRequires: speech-dispatcher-devel >= 0.8
0cad051b 201%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
5048b37a 202%{?with_system_sqlite:BuildRequires: sqlite3-devel >= 3.7}
9bd2659c 203%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
0cad051b 204BuildRequires: tar >= 1:1.22
0a424ee2 205BuildRequires: udev-devel
7d1152d4 206BuildRequires: usbutils
2303ed45 207BuildRequires: util-linux
c14cd342 208%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 209BuildRequires: which
f1b276d4 210BuildRequires: xorg-lib-libXScrnSaver-devel
3a3b7da9 211BuildRequires: xorg-lib-libXtst-devel
836b1cac 212BuildRequires: xz
a3140cd1 213%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 214%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 215Requires: browser-plugins >= 2.0
0cad051b 216Requires: desktop-file-utils
8f5f6775 217%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
218# crashes if no fontconfig font present
219Requires: fonts-Type1-urw
0eb19b0b 220Requires: hicolor-icon-theme
56403697 221Requires: libevent >= 2.0.21
c1edaafa 222%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
5f786a22 223%{?with_system_libvpx:Requires: libvpx >= 1.4.0}
b809ab60 224Requires: lsb-release
42d59afd 225%{?with_system_re2:Requires: re2 >= 20151101}
4b2f9b57 226%{?with_system_protobuf:Requires: protobuf-libs >= 2.5.0-2}
3700ba38 227Requires: shared-mime-info
f7b16691 228%{?with_system_sqlite:Requires: sqlite3(icu)}
5c9227ee 229Requires: uname(release) >= 3.17
4dc49133 230Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 231Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 232Provides: wwwbrowser
c3582150 233Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 234Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 235ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 236BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 237
319f81f7
ER
238# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
239# Note: these are for PLD Linux use ONLY.
240# For your own distribution, please get your own set of keys.
241%define google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
242%define google_default_client_id 724288223830.apps.googleusercontent.com
243%define google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
244
7ebeabb6 245%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 246
e7fa0817
ER
247# Usage: gyp_with BCOND_NAME [OPTION_NAME]
248%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 249
a323900c
ER
250%ifarch %{ix86}
251%define target_arch ia32
252%endif
253%ifarch %{x8664}
254%define target_arch x64
255%endif
256
f8597c6e
ER
257%define buildtype %{?debug:Debug}%{!?debug:Release}
258%define builddir out/%{buildtype}
259
6b113615
ER
260%if %{without debuginfo}
261%define _enable_debug_packages 0
262%endif
263
11ad81c4 264%description
80838854
ER
265Chromium is an open-source browser project that aims to build a safer,
266faster, and more stable way for all Internet users to experience the
267web.
268
269Chromium serves as a base for Google Chrome, which is Chromium
270rebranded (name and logo) with very few additions such as usage
271tracking and an auto-updater system.
272
f1b276d4
ER
273%package l10n
274Summary: chromium-browser language packages
275Group: I18n
276Requires: %{name} = %{version}-%{release}
8da7b90b
ER
277%if "%{_rpmversion}" >= "5"
278BuildArch: noarch
279%endif
f1b276d4
ER
280
281%description l10n
282Chromium is an open-source browser project that aims to build a safer,
283faster, and more stable way for all Internet users to experience the
284web.
285
286This package contains language packages for 50 languages:
287
e7fa0817
ER
288ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
289he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
290pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
291zh-TW
f1b276d4
ER
292
293%prep
3c73e180
ER
294%setup -qc
295%if "%{?patchver}" != ""
77bd7e0a 296cd chromium*-%{branch}.%{basever}
3c73e180
ER
297%patch0 -p1
298cd ..
299%endif
77bd7e0a 300mv chromium*-%{branch}.%{basever}/* .
589d90ea 301
05f72ae2
ER
302# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
303# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
75f96a39 304. ./chrome/VERSION
e00e4177
ER
305chrome=$MAJOR.$MINOR.$BUILD.$PATCH
306test "$chrome" = %{version}
a3140cd1 307
75f96a39 308gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 309test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 310
4765ddf1
ER
311# add chromium and pld to useragent
312%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
313sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
314 -e 's/@BUILD_DIST_NAME@/PLD/g' \
315 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
71581184 316 < %{PATCH8} | %{__patch} -p1
4765ddf1 317
8da7b90b 318%{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
75f96a39
ER
319ln -s %{SOURCE7} .
320
810e0294 321#%patch2 -p1 CHECK
7879021e 322%patch7 -p1
75f96a39 323%patch15 -p2
f4a8da6a 324%{!?with_libjpegturbo:%patch11 -p0}
5997e180 325%patch16 -p1
41d6a4b1 326%patch28 -p1
a323900c 327%patch25 -p1
3aa67e11 328%{?with_nacl:%patch18 -p1}
ffb05754 329%patch24 -p1
75f96a39 330%patch26 -p2
cb6dde87 331%patch31 -p0
708e64c2 332%patch32 -p1
d7fca4aa 333%patch35 -p1
6e3c39b4 334%patch36 -p1
a20f29ed 335%patch37 -p1
810e0294 336#%patch38 -p1 CHECK
deef15b4 337%patch39 -p1
f0db7b91
ER
338%patch40 -p1
339%patch41 -p1
8a0c4436 340%patch42 -p1
e9abb380 341
308e6041 342# https://groups.google.com/a/chromium.org/forum/#!topic/chromium-packagers/9JX1N2nf4PU
ff7c827f 343install -d chrome/test/data/webui
308e6041 344touch chrome/test/data/webui/i18n_process_css_test.html
e9abb380 345
f684992e
ER
346%{?with_dev:exit 0}
347
75a27c2e
ER
348sh -x clean-source.sh \
349 %{!?with_nacl:nacl=0} \
bbdce24d
ER
350 %{!?with_system_libvpx:libvpx=0} \
351 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 352 %{!?with_system_mesa:mesa=0} \
75a27c2e 353 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 354 %{!?with_system_re2:re2=0} \
7e634b46 355 %{!?with_system_snappy:snappy=0} \
5048b37a 356 %{!?with_system_sqlite:sqlite=0} \
75a27c2e 357 %{!?with_system_v8:v8=0} \
0767a7a0 358 %{!?with_system_libwebp:libwebp=0} \
75a27c2e 359 %{!?with_system_zlib:zlib=0} \
f177fdad 360 %{!?with_system_ffmpeg:ffmpeg=0} \
75a27c2e 361 %{nil}
fded59be 362
e266589e 363%build
5997e180 364%if %{with nacl}
108c5f7c 365rm -rf native_client/toolchain/linux_x86_newlib
fded59be 366if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 367# Make symlinks for NaCL
108c5f7c 368install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 369
108c5f7c
ER
370cd native_client/toolchain/linux_x86_newlib
371ln -s x86_64-nacl/bin bin
372cd x86_64-nacl/bin
2e4113fd 373__cc='%{__cc}'
f64e73f6 374if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
375 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
376 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
377 %{__sed} -i -e '1i#!/bin/sh' gcc g++
378 chmod +x gcc g++
379else
380 ln -s %{_bindir}/x86_64-nacl-gcc gcc
381 ln -s %{_bindir}/x86_64-nacl-g++ g++
382fi
108c5f7c
ER
383ln -s gcc x86_64-nacl-gcc
384ln -s g++ x86_64-nacl-g++
385ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
386ln -s %{_bindir}/x86_64-nacl-ar ar
387ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 388ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 389ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 390ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 391ln -s %{_bindir}/x86_64-nacl-strip strip
1ed01da3 392ln -s %{_bindir}/x86_64-nacl-objcopy .
108c5f7c
ER
393ln -s %{_prefix}/x86_64-nacl/lib ../lib
394ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
395ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
396cd ../../../../..
fded59be 397fi
5997e180
ER
398%endif
399
a323900c 400%if %{without system_ffmpeg}
f8597c6e
ER
401if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
402 # Re-configure bundled ffmpeg
403 cd third_party/ffmpeg
50d701c6
ER
404 chromium/scripts/build_ffmpeg.py linux %{target_arch} \
405 --branding Chromium
f8597c6e 406 chromium/scripts/copy_config.sh
6e3c39b4 407 chromium/scripts/generate_gyp.py
f8597c6e
ER
408 cd -
409fi
0c480b89 410%endif
a323900c 411
6e3c39b4
ER
412third_party/libaddressinput/chromium/tools/update-strings.py
413
a323900c
ER
414flags="
415 -Dtarget_arch=%{target_arch} \
416 -Dpython_arch=%{target_arch} \
12687dbd 417 -Dproprietary_codecs=1 \
6e3c39b4 418 -Dffmpeg_branding=Chromium \
b91ce587 419 -Dsystem_libdir=%{_lib} \
a323900c 420 -Dpython_ver=%{py_ver} \
7b454a31
AM
421%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
422 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4 423%endif
f047b07c 424 %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
c980b122 425 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 426 %{?with_shared_libs:-Dlibrary=shared_library} \
b6942fc6 427 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
77bd7e0a 428 -Dinclude_tests__=0 \
c0808220 429%if %{with nacl}
038f76b9 430 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
431 -Ddisable_glibc_untar=1 \
432 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
433 -Ddisable_glibc=1 \
434 -Ddisable_pnacl=1 \
435 -Dbuild_pnacl_newlib=0 \
c0808220 436%else
8fb1dc98 437 -Ddisable_pnacl_untar=1 \
c0808220
ER
438 -Ddisable_nacl=1 \
439%endif
a3140cd1
ER
440 %{!?with_sse2:-Ddisable_sse2=1} \
441 %{?with_selinux:-Dselinux=1} \
7d1152d4 442 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197 443 -Dlinux_link_libpci=1 \
7879021e 444 -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
14c8ce0e 445 -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
71d49434 446 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
2983aa41
ER
447 -Dclang=0 \
448 -Dhost_clang=0 \
be84bbd9 449 -Dsysroot= \
14c8ce0e
ER
450 -Dlinux_use_bundled_binutils=0 \
451 -Dlinux_use_bundled_gold=0 \
05998197 452 -Dlinux_use_gold_flags=0 \
71581184 453 -Dlogging_like_official_build=1 \
319f81f7
ER
454 -Dgoogle_api_key=%{google_api_key} \
455 -Dgoogle_default_client_id=%{google_default_client_id} \
456 -Dgoogle_default_client_secret=%{google_default_client_secret} \
e7fa0817 457 %{gyp_with cups} \
8dda6bbc 458 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
bd827d58 459 %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
e7fa0817
ER
460 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
461 %{gyp_with pulseaudio} \
41d6a4b1 462 %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
8f5f6775 463 %{gyp_with system_flac} \
01b4dc8e 464 %{gyp_with system_harfbuzz} \
cb6dde87 465 %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
2d65d095 466 %{gyp_with system_jsoncpp} \
62950103
ER
467 %{gyp_with system_libexif} \
468 %{gyp_with system_libmtp} \
9bd2659c 469 %{gyp_with system_libsrtp} \
581aec44 470 %{gyp_with system_libusb} \
88171dca 471 %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
ba685303 472 %{gyp_with system_libwebp} \
4884fc99 473 %{gyp_with system_libxnvctrl} \
7b8f219a 474 %{gyp_with system_mesa} \
126ea630 475 %{gyp_with system_minizip} \
62950103 476 %{gyp_with system_opus} \
75a27c2e 477 %{gyp_with system_protobuf} \
bbdce24d 478 %{gyp_with system_re2} \
7e634b46 479 %{gyp_with system_snappy} \
e7fa0817 480 %{gyp_with system_speex} \
914ee37c 481 %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
e7fa0817
ER
482 %{gyp_with system_v8} \
483 %{gyp_with system_yasm} \
484 %{gyp_with system_zlib} \
0c480b89 485 -Duse_system_bzip2=1 \
62950103 486 -Duse_system_expat=1 \
f1b276d4 487 -Duse_system_libevent=1 \
0c480b89 488 -Duse_system_libjpeg=1 \
f1b276d4
ER
489 -Duse_system_libpng=1 \
490 -Duse_system_libxml=1 \
491 -Duse_system_libxslt=1 \
b363f856 492 -Duse_system_nspr=1 \
7f40f3f4 493 -Duse_system_xdg_utils=1 \
7879021e
ER
494"
495
496build/linux/unbundle/replace_gyp_files.py $flags
497
f8597c6e
ER
498%if %{with ninja}
499chkfile=%{builddir}/build.ninja
500%else
501chkfile=Makefile
502%endif
503test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
504test -e $chkfile || \
7879021e
ER
505 CC="%{__cc}" \
506 CXX="%{__cxx}" \
507 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
508 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
509 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
510 CC_host="%{__cc}" \
511 CXX_host="%{__cxx}" \
512 LD_host="%{__cxx}" \
513%{__python} build/gyp_chromium \
f8597c6e 514 --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
7879021e
ER
515 --depth=. \
516 build/all.gyp \
517 $flags
11ad81c4 518
f8597c6e
ER
519%if %{with ninja}
520ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
521%else
b4d75247 522# need {CC/CXX/LDFLAGS}.host overrides for v8 build
f8597c6e
ER
523%{__make} -r \
524 BUILDTYPE=%{buildtype} \
f1b276d4 525 %{?with_verbose:V=1} \
f1b276d4
ER
526 CC.host="%{__cc}" \
527 CXX.host="%{__cxx}" \
b4d75247 528 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
f8597c6e
ER
529%endif
530 chrome %{?with_sandboxing:chrome_sandbox} \
531 %{nil}
11ad81c4 532
f8597c6e 533cd %{builddir}
535cb410
ER
534MANWIDTH=80 man ./chrome.1 > man.out
535%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
536
11ad81c4
AM
537%install
538rm -rf $RPM_BUILD_ROOT
8da7b90b
ER
539install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
540 $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
3b9998d5
ER
541 $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
542 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
e266589e 543
c9ba2fd5
ER
544%if %{without system_icu}
545cp -p third_party/icu/source/data/in/icudtl.dat $RPM_BUILD_ROOT%{_libdir}/%{name}
546%endif
547
f8597c6e 548cd %{builddir}
37ceaf05 549cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 550install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
551%{__sed} -i -e '
552 s,@libdir@,%{_libdir}/%{name},
553
554 /@OPTIONS@/ {
555 r options.txt
556 d
557 }
558' $RPM_BUILD_ROOT%{_bindir}/%{name}
8da7b90b 559cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
fa8317a0 560cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
8da7b90b
ER
561ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
562ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
7f40f3f4 563cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 564install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
d1a83042 565install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
f0db7b91 566%if %{without system_ffmpeg} && 0
f1b276d4 567install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 568%endif
e7fa0817 569cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 570cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 571
8da7b90b 572%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
c0808220 573
164020eb
ER
574%if %{with nacl}
575# Install Native Client files on platforms that support it.
576install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
577install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
578%ifarch %{x8664}
579install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
580%endif
581%ifarch %{ix86}
582install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
583%endif
584%endif
585
0c480b89
ER
586cd -
587
75f96a39 588for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
0eb19b0b
ER
589 size=${icon##*/product_logo_}
590 size=${size%.png}
591
592 # this will skip non-numeric (22_mono_invert, 22_mono)
593 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
594 test -d "$dir" || continue
595
596 install -d $RPM_BUILD_ROOT$dir
597 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
598done
7f40f3f4 599
13840bc2
AM
600%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
601# http://code.google.com/p/chromium/issues/detail?id=24507
602gecko-mediaplayer*.so
603EOF
11ad81c4 604
589d90ea
ER
605# find locales
606%find_lang %{name}.lang
e7fa0817 607# always package en-US
f1b276d4 608%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 609
11ad81c4
AM
610%clean
611rm -rf $RPM_BUILD_ROOT
612
8da7b90b
ER
613%pretrans
614for d in locales resources; do
615 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
616 install -d %{_datadir}/%{name}
617 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
618 fi
619done
620exit 0
621
f1b276d4 622%post
0eb19b0b 623%update_icon_cache hicolor
b7a6e4ee 624%update_desktop_database
f1b276d4
ER
625%update_browser_plugins
626
627%postun
628if [ "$1" = 0 ]; then
0eb19b0b 629 %update_icon_cache hicolor
b0f560cc 630 %update_desktop_database
f1b276d4
ER
631 %update_browser_plugins
632fi
633
1d2b9616 634%files
11ad81c4 635%defattr(644,root,root,755)
75f96a39 636%doc AUTHORS LICENSE
f1b276d4
ER
637%{_browserpluginsconfdir}/browsers.d/%{name}.*
638%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
639%dir %{_sysconfdir}/%{name}
640%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 641%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
3b9998d5
ER
642%dir %{_sysconfdir}/%{name}/native-messaging-hosts
643%dir %{_sysconfdir}/%{name}/policies
644%dir %{_sysconfdir}/%{name}/policies/managed
f1b276d4
ER
645%attr(755,root,root) %{_bindir}/%{name}
646%{_mandir}/man1/%{name}.1*
11ad81c4 647%{_desktopdir}/*.desktop
0eb19b0b 648%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 649%dir %{_libdir}/%{name}
e9abb380 650%{_libdir}/%{name}/chrome*.pak
c9ba2fd5 651%{!?with_system_icu:%{_libdir}/%{name}/icudtl.dat}
c14cd342 652%{_libdir}/%{name}/content_resources.pak
f047b07c 653%{_libdir}/%{name}/keyboard_resources.pak
97fac491 654%{_libdir}/%{name}/resources.pak
fa8317a0
ER
655%{_libdir}/%{name}/natives_blob.bin
656%{_libdir}/%{name}/snapshot_blob.bin
8da7b90b
ER
657%{_libdir}/%{name}/locales
658%{_libdir}/%{name}/resources
659
660%dir %{_datadir}/%{name}
661%dir %{_datadir}/%{name}/locales
662%{_datadir}/%{name}/locales/en-US.pak
663%dir %{_datadir}/%{name}/resources
664%{_datadir}/%{name}/resources/inspector
665
f1b276d4
ER
666%dir %{_libdir}/%{name}/plugins
667%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 668# These unique permissions are intentional and necessary for the sandboxing
d1a83042 669%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
f1b276d4
ER
670
671# ffmpeg libs
f0db7b91 672%if %{without system_ffmpeg} && 0
f1b276d4 673%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 674%endif
f1b276d4 675
164020eb
ER
676%if %{with nacl}
677%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
678%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
679%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
680%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
681%endif
682
f1b276d4
ER
683%files l10n -f %{name}.lang
684%defattr(644,root,root,755)
This page took 0.405423 seconds and 4 git commands to generate.