]> git.pld-linux.org Git - packages/chef.git/blob - chef.spec
add platform pld support, packages installed with yum
[packages/chef.git] / chef.spec
1 # TODO
2 # - try not to use /var/chef
3 Summary:        A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
4 Name:           chef
5 Version:        11.4.0
6 Release:        0.7
7 License:        Apache v2.0
8 Group:          Development/Languages
9 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
10 # Source0-md5:  1ebabd6fdeae44a99d5cb199c38adc15
11 Patch0:         platform-pld.patch
12 URL:            http://wiki.opscode.com/display/chef
13 BuildRequires:  rpm-rubyprov
14 BuildRequires:  rpmbuild(macros) >= 1.656
15 Requires:       lsb-release
16 Requires:       ruby >= 1:1.8.7
17 Requires:       ruby-erubis
18 Requires:       ruby-highline >= 1.6.9
19 Requires:       ruby-json <= 1.7.7
20 Requires:       ruby-json >= 1.4.4
21 Requires:       ruby-mixlib-authentication >= 1.3.0
22 Requires:       ruby-mixlib-cli >= 1.3.0
23 Requires:       ruby-mixlib-config >= 1.1.2
24 Requires:       ruby-mixlib-log >= 1.3.0
25 Requires:       ruby-mixlib-shellout
26 Requires:       ruby-net-ssh >= 2.6
27 Requires:       ruby-net-ssh-multi >= 1.1.0
28 Requires:       ruby-ohai >= 0.6.0
29 Requires:       ruby-rest-client < 1.7.0
30 Requires:       ruby-rest-client >= 1.0.4
31 Requires:       ruby-rubygems
32 Requires:       ruby-yajl >= 1.1
33 Requires:       yum
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 A systems integration framework, built to bring the benefits of
39 configuration management to your entire infrastructure.
40
41 %prep
42 %setup -q
43 %patch0 -p1
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{_bindir}}
48 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
49 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
50
51 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/var}/%{name}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc README.md CONTRIBUTING.md
59 %dir %{_sysconfdir}/%{name}
60 %attr(755,root,root) %{_bindir}/chef-apply
61 %attr(755,root,root) %{_bindir}/chef-client
62 %attr(755,root,root) %{_bindir}/chef-shell
63 %attr(755,root,root) %{_bindir}/chef-solo
64 %attr(755,root,root) %{_bindir}/knife
65 %attr(755,root,root) %{_bindir}/shef
66 %{ruby_rubylibdir}/chef.rb
67 %{ruby_rubylibdir}/chef
68
69 # FIXME: FHS
70 %dir /var/%{name}
This page took 0.070195 seconds and 3 git commands to generate.