]> git.pld-linux.org Git - packages/ccrtp.git/blob - ccrtp.spec
- added am patch (fixes build with automake 1.13+)
[packages/ccrtp.git] / ccrtp.spec
1 #
2 # Conditional build:
3 %bcond_with     gcrypt  # use libgcrypt instead of OpenSSL (ucommon in PLD uses OpenSSL by default)
4 #
5 Summary:        Common C++ class framework for RTP packets
6 Summary(pl.UTF-8):      Szkielet klas C++ dla pakietów RTP
7 Name:           ccrtp
8 Version:        2.0.6
9 Release:        1
10 License:        GPL v2+ with runtime exception
11 Group:          Libraries
12 Source0:        http://ftp.gnu.org/gnu/ccrtp/%{name}-%{version}.tar.gz
13 # Source0-md5:  ca0a7a184b242d660d81caf6101a2c0c
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-openssl.patch
16 Patch2:         %{name}-am.patch
17 URL:            http://www.gnu.org/software/ccrtp/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  doxygen >= 1.8.0
21 %{?with_gcrypt:BuildRequires:   libgcrypt-devel >= 1.2.3}
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:1.5
24 %{!?with_gcrypt:BuildRequires:  openssl-devel}
25 BuildRequires:  pkgconfig
26 BuildRequires:  ucommon-devel >= 5.0.0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 ccRTP is a generic, extensible and efficient C++ framework for
31 developing applications based on the Real-Time Transport Protocol
32 (RTP) from the IETF. It is based on Common C++ and provides a full
33 RTP/RTCP stack for sending and receiving of realtime data by the use
34 of send and receive packet queues. ccRTP supports unicast,
35 multi-unicast and multicast, manages multiple sources, handles RTCP
36 automatically, supports different threading models and is generic as
37 for underlying network and transport protocols.
38
39 %description -l pl.UTF-8
40 ccRTP jest ogólnym, rozszerzalnym i efektywnym szkieletem C++ do
41 rozwijania aplikacji bazujących na transporcie czasu rzeczywistego
42 (RTP) z IETF. Bazuje na Common C++ i udostępnia pełen stos RTP/RTCP do
43 wysyłania i odbierania danych w czasie rzeczywistym z użyciem kolejek
44 wysyłania i odbierania pakietów. ccRTP obsługuje unicasty,
45 multi-unicasty i multicasty, zarządza wieloma źródłami, obsługuje
46 automatycznie RTCP, wspiera różne modele wątkowania i jest ogólny dla
47 podstawowych sieci i protokołów transportowych.
48
49 %package devel
50 Summary:        Header files for ccrtp library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ccrtp
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 %{?with_gcrypt:Requires:        libgcrypt-devel >= 1.2.3}
55 Requires:       libstdc++-devel
56 %{!?with_gcrypt:Requires:       openssl-devel}
57 Requires:       ucommon-devel >= 5.0.0
58
59 %description devel
60 Header files for ccrtp library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki ccrtp.
64
65 %package static
66 Summary:        Static ccrtp library
67 Summary(pl.UTF-8):      Statyczna biblioteka ccrtp
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static ccrtp library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka ccrtp.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %patch1 -p1
81 %patch2 -p1
82
83 %build
84 %{__libtoolize}
85 %{__aclocal} -I m4
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 # LIBGCRYPT_CONFIG is a hack to disable libgcrypt and pass to openssl detection
90 %configure \
91         %{!?with_gcrypt:LIBGCRYPT_CONFIG=/nonexisting}
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc AUTHORS COPYING.addendum ChangeLog NEWS README TODO
109 %attr(755,root,root) %{_libdir}/libccrtp.so.*.*.*
110 %attr(755,root,root) %ghost %{_libdir}/libccrtp.so.0
111
112 %files devel
113 %defattr(644,root,root,755)
114 %doc doc/html/*.{css,html,js,png}
115 %attr(755,root,root) %{_libdir}/libccrtp.so
116 %{_libdir}/libccrtp.la
117 %{_includedir}/ccrtp
118 %{_pkgconfigdir}/libccrtp.pc
119 %{_infodir}/ccrtp.info*
120
121 %files static
122 %defattr(644,root,root,755)
123 %{_libdir}/libccrtp.a
This page took 0.149121 seconds and 3 git commands to generate.