]> git.pld-linux.org Git - packages/ccrtp.git/blame - ccrtp.spec
- added am patch (fixes build with automake 1.13+)
[packages/ccrtp.git] / ccrtp.spec
CommitLineData
69d0628f
JB
1#
2# Conditional build:
3%bcond_with gcrypt # use libgcrypt instead of OpenSSL (ucommon in PLD uses OpenSSL by default)
4#
5Summary: Common C++ class framework for RTP packets
6Summary(pl.UTF-8): Szkielet klas C++ dla pakietów RTP
23152de5 7Name: ccrtp
f2a021e2 8Version: 2.0.6
6084ac89 9Release: 1
69d0628f 10License: GPL v2+ with runtime exception
23152de5 11Group: Libraries
8a4ce148 12Source0: http://ftp.gnu.org/gnu/ccrtp/%{name}-%{version}.tar.gz
f2a021e2 13# Source0-md5: ca0a7a184b242d660d81caf6101a2c0c
69d0628f
JB
14Patch0: %{name}-info.patch
15Patch1: %{name}-openssl.patch
30b0987c 16Patch2: %{name}-am.patch
e101e907 17URL: http://www.gnu.org/software/ccrtp/
69d0628f 18BuildRequires: autoconf >= 2.50
695e1afd 19BuildRequires: automake
b749edf7 20BuildRequires: doxygen >= 1.8.0
69d0628f
JB
21%{?with_gcrypt:BuildRequires: libgcrypt-devel >= 1.2.3}
22BuildRequires: libstdc++-devel
23BuildRequires: libtool >= 2:1.5
24%{!?with_gcrypt:BuildRequires: openssl-devel}
25BuildRequires: pkgconfig
26BuildRequires: ucommon-devel >= 5.0.0
23152de5 27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30ccRTP is a generic, extensible and efficient C++ framework for
31developing applications based on the Real-Time Transport Protocol
32(RTP) from the IETF. It is based on Common C++ and provides a full
33RTP/RTCP stack for sending and receiving of realtime data by the use
34of send and receive packet queues. ccRTP supports unicast,
35multi-unicast and multicast, manages multiple sources, handles RTCP
36automatically, supports different threading models and is generic as
37for underlying network and transport protocols.
38
0c6db567
JR
39%description -l pl.UTF-8
40ccRTP jest ogólnym, rozszerzalnym i efektywnym szkieletem C++ do
41rozwijania aplikacji bazujących na transporcie czasu rzeczywistego
42(RTP) z IETF. Bazuje na Common C++ i udostępnia pełen stos RTP/RTCP do
43wysyłania i odbierania danych w czasie rzeczywistym z użyciem kolejek
44wysyłania i odbierania pakietów. ccRTP obsługuje unicasty,
45multi-unicasty i multicasty, zarządza wieloma źródłami, obsługuje
46automatycznie RTCP, wspiera różne modele wątkowania i jest ogólny dla
47podstawowych sieci i protokołów transportowych.
382d8e6d 48
23152de5 49%package devel
50Summary: Header files for ccrtp library
152d52c0 51Summary(pl.UTF-8): Pliki nagłówkowe biblioteki ccrtp
23152de5 52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
69d0628f
JB
54%{?with_gcrypt:Requires: libgcrypt-devel >= 1.2.3}
55Requires: libstdc++-devel
56%{!?with_gcrypt:Requires: openssl-devel}
57Requires: ucommon-devel >= 5.0.0
23152de5 58
59%description devel
60Header files for ccrtp library.
61
0c6db567
JR
62%description devel -l pl.UTF-8
63Pliki nagłówkowe biblioteki ccrtp.
23152de5 64
65%package static
66Summary: Static ccrtp library
152d52c0 67Summary(pl.UTF-8): Statyczna biblioteka ccrtp
23152de5 68Group: Development/Libraries
69Requires: %{name}-devel = %{version}-%{release}
70
71%description static
72Static ccrtp library.
73
0c6db567 74%description static -l pl.UTF-8
23152de5 75Statyczna biblioteka ccrtp.
76
77%prep
78%setup -q
6716a349 79%patch0 -p1
5eac4eea 80%patch1 -p1
30b0987c 81%patch2 -p1
23152de5 82
83%build
695e1afd 84%{__libtoolize}
85%{__aclocal} -I m4
86%{__autoconf}
87%{__autoheader}
88%{__automake}
69d0628f
JB
89# LIBGCRYPT_CONFIG is a hack to disable libgcrypt and pass to openssl detection
90%configure \
1db38f71 91 %{!?with_gcrypt:LIBGCRYPT_CONFIG=/nonexisting}
23152de5 92%{__make}
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97%{__make} install \
98 DESTDIR=$RPM_BUILD_ROOT
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%post -p /sbin/ldconfig
104%postun -p /sbin/ldconfig
105
106%files
107%defattr(644,root,root,755)
69d0628f
JB
108%doc AUTHORS COPYING.addendum ChangeLog NEWS README TODO
109%attr(755,root,root) %{_libdir}/libccrtp.so.*.*.*
110%attr(755,root,root) %ghost %{_libdir}/libccrtp.so.0
23152de5 111
112%files devel
113%defattr(644,root,root,755)
69d0628f
JB
114%doc doc/html/*.{css,html,js,png}
115%attr(755,root,root) %{_libdir}/libccrtp.so
116%{_libdir}/libccrtp.la
23152de5 117%{_includedir}/ccrtp
69d0628f
JB
118%{_pkgconfigdir}/libccrtp.pc
119%{_infodir}/ccrtp.info*
23152de5 120
121%files static
122%defattr(644,root,root,755)
69d0628f 123%{_libdir}/libccrtp.a
This page took 0.266276 seconds and 4 git commands to generate.