]> git.pld-linux.org Git - packages/ccrtp.git/blame - ccrtp.spec
- updated to 2.0.2
[packages/ccrtp.git] / ccrtp.spec
CommitLineData
69d0628f
JB
1#
2# Conditional build:
3%bcond_with gcrypt # use libgcrypt instead of OpenSSL (ucommon in PLD uses OpenSSL by default)
4#
5Summary: Common C++ class framework for RTP packets
6Summary(pl.UTF-8): Szkielet klas C++ dla pakietów RTP
23152de5 7Name: ccrtp
69d0628f 8Version: 2.0.2
5eac4eea 9Release: 1
69d0628f 10License: GPL v2+ with runtime exception
23152de5 11Group: Libraries
8a4ce148 12Source0: http://ftp.gnu.org/gnu/ccrtp/%{name}-%{version}.tar.gz
69d0628f
JB
13# Source0-md5: dd676a6359e549b5a45ed3992e8a7056
14Patch0: %{name}-info.patch
15Patch1: %{name}-openssl.patch
e101e907 16URL: http://www.gnu.org/software/ccrtp/
69d0628f 17BuildRequires: autoconf >= 2.50
695e1afd 18BuildRequires: automake
23152de5 19BuildRequires: doxygen
69d0628f
JB
20%{?with_gcrypt:BuildRequires: libgcrypt-devel >= 1.2.3}
21BuildRequires: libstdc++-devel
22BuildRequires: libtool >= 2:1.5
23%{!?with_gcrypt:BuildRequires: openssl-devel}
24BuildRequires: pkgconfig
25BuildRequires: ucommon-devel >= 5.0.0
23152de5 26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29ccRTP is a generic, extensible and efficient C++ framework for
30developing applications based on the Real-Time Transport Protocol
31(RTP) from the IETF. It is based on Common C++ and provides a full
32RTP/RTCP stack for sending and receiving of realtime data by the use
33of send and receive packet queues. ccRTP supports unicast,
34multi-unicast and multicast, manages multiple sources, handles RTCP
35automatically, supports different threading models and is generic as
36for underlying network and transport protocols.
37
0c6db567
JR
38%description -l pl.UTF-8
39ccRTP jest ogólnym, rozszerzalnym i efektywnym szkieletem C++ do
40rozwijania aplikacji bazujących na transporcie czasu rzeczywistego
41(RTP) z IETF. Bazuje na Common C++ i udostępnia pełen stos RTP/RTCP do
42wysyłania i odbierania danych w czasie rzeczywistym z użyciem kolejek
43wysyłania i odbierania pakietów. ccRTP obsługuje unicasty,
44multi-unicasty i multicasty, zarządza wieloma źródłami, obsługuje
45automatycznie RTCP, wspiera różne modele wątkowania i jest ogólny dla
46podstawowych sieci i protokołów transportowych.
382d8e6d 47
23152de5 48%package devel
49Summary: Header files for ccrtp library
152d52c0 50Summary(pl.UTF-8): Pliki nagłówkowe biblioteki ccrtp
23152de5 51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
69d0628f
JB
53%{?with_gcrypt:Requires: libgcrypt-devel >= 1.2.3}
54Requires: libstdc++-devel
55%{!?with_gcrypt:Requires: openssl-devel}
56Requires: ucommon-devel >= 5.0.0
23152de5 57
58%description devel
59Header files for ccrtp library.
60
0c6db567
JR
61%description devel -l pl.UTF-8
62Pliki nagłówkowe biblioteki ccrtp.
23152de5 63
64%package static
65Summary: Static ccrtp library
152d52c0 66Summary(pl.UTF-8): Statyczna biblioteka ccrtp
23152de5 67Group: Development/Libraries
68Requires: %{name}-devel = %{version}-%{release}
69
70%description static
71Static ccrtp library.
72
0c6db567 73%description static -l pl.UTF-8
23152de5 74Statyczna biblioteka ccrtp.
75
76%prep
77%setup -q
6716a349 78%patch0 -p1
5eac4eea 79%patch1 -p1
23152de5 80
81%build
695e1afd 82%{__libtoolize}
83%{__aclocal} -I m4
84%{__autoconf}
85%{__autoheader}
86%{__automake}
69d0628f
JB
87# LIBGCRYPT_CONFIG is a hack to disable libgcrypt and pass to openssl detection
88%configure \
89 %{!?with_gcrypt:LIBGCRYPT_CONFIG=/bin/false}
23152de5 90%{__make}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95%{__make} install \
96 DESTDIR=$RPM_BUILD_ROOT
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post -p /sbin/ldconfig
102%postun -p /sbin/ldconfig
103
104%files
105%defattr(644,root,root,755)
69d0628f
JB
106%doc AUTHORS COPYING.addendum ChangeLog NEWS README TODO
107%attr(755,root,root) %{_libdir}/libccrtp.so.*.*.*
108%attr(755,root,root) %ghost %{_libdir}/libccrtp.so.0
23152de5 109
110%files devel
111%defattr(644,root,root,755)
69d0628f
JB
112%doc doc/html/*.{css,html,js,png}
113%attr(755,root,root) %{_libdir}/libccrtp.so
114%{_libdir}/libccrtp.la
23152de5 115%{_includedir}/ccrtp
69d0628f
JB
116%{_pkgconfigdir}/libccrtp.pc
117%{_infodir}/ccrtp.info*
23152de5 118
119%files static
120%defattr(644,root,root,755)
69d0628f 121%{_libdir}/libccrtp.a
This page took 1.014027 seconds and 4 git commands to generate.