]> git.pld-linux.org Git - packages/byobu.git/blame - byobu.spec
Use python3 dependencies
[packages/byobu.git] / byobu.spec
CommitLineData
2b3e186c
ZU
1Summary: A set of useful profiles and a profile-switcher for GNU screen
2Summary(hu.UTF-8): Hasznos profilok és profilváltó gyűjteménye a GNU screen-hez
2e06fbbb 3Summary(pl.UTF-8): Zestaw przydatnych profili oraz przełącznik profili dla GNU screena
2b3e186c 4Name: byobu
a896e0c8 5Version: 5.133
d677ca1f 6Release: 2
f896fdc8 7License: GPL v3
2b3e186c 8Group: Applications/System
f896fdc8 9Source0: https://code.launchpad.net/byobu/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
a896e0c8 10# Source0-md5: 0ff03f3795cc08aae50c1ab117c03261
62082d7d 11Patch0: desktop.patch
41e69901 12Patch1: pld-logo.patch
f896fdc8 13URL: https://launchpad.net/byobu
d420996e 14BuildRequires: gettext-tools
d3ce91ff 15BuildRequires: rpm-pythonprov
f896fdc8
ER
16BuildRequires: rpmbuild(macros) >= 1.596
17Requires: desktop-file-utils
d677ca1f
ER
18Requires: python3
19Requires: python3-snack
58a24a03 20Suggests: screen
f1b85bf3 21Suggests: tmux >= 1.5
2b3e186c
ZU
22BuildArch: noarch
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
a90e290a
ER
25%define _noautocompressdoc '*.txt'
26
f896fdc8
ER
27%define _libexecdir %{_prefix}/lib
28
2b3e186c
ZU
29%description
30Byobu is an elegant enhancement of the otherwise functional, plain,
31practical GNU Screen. Byobu includes an enhanced profile and
32configuration utilities for the GNU screen window manager, such as
33toggle-able system status notifications.
34
35%description -l hu.UTF-8
36Byobu egy elegáns kiterjesztése az amúgy használható, egyszerű,
37praktikus GNU screen-nek. A Byobu tartalmaz egy kiterjesztett profilt
38és konfigurációs eszközöket a GNU screen ablakkezelőhöz, pl. a
39ki/bekapcsolható rendszer státusz jelentéseket.
40
2e06fbbb
JB
41%description -l pl.UTF-8
42Byobu to eleganckie rozszerzenie dla funkcjonalnego, zwykłego,
43praktycznego GNU screena. Byobu zawiera rozszerzony profil oraz
44narzędzia konfiguracyjne dla zarządcy okien, jakim jest GNU screen
45- takie jak przełączane powiadomienia o stanie systemu.
46
2b3e186c 47%prep
f896fdc8 48%setup -q
62082d7d 49%patch0 -p1
41e69901 50%patch1 -p1
2b3e186c 51
a90e290a
ER
52%{__sed} -i -e '
53 s#/share/doc/byobu#/share/doc/%{name}-%{version}#
54' usr/share/byobu/keybindings/*
55
a896e0c8
ER
56%{__sed} -i -e '1s,^#!.*python3,#!%{__python3},' usr/lib/byobu/include/*.py{,.in}
57
a90e290a
ER
58# cleanup backups after patching
59find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
60
2b3e186c 61%build
f896fdc8
ER
62%configure
63%{__make}
64
65for po in po/*.po; do
66 lang=${po#po/}
67 lang=${lang%.po}
68 mkdir -p locale/${lang}/LC_MESSAGES/
69 msgfmt ${po} -o locale/${lang}/LC_MESSAGES/%{name}.mo
70done
2b3e186c
ZU
71
72%install
73rm -rf $RPM_BUILD_ROOT
f896fdc8
ER
74%{__make} install \
75 INSTALL="install -p" \
76 CP="cp -p" \
f896fdc8
ER
77 DESTDIR=$RPM_BUILD_ROOT
78
bf09bee7
ER
79# some debian hackery, just use the "current" one for pld
80install -d $RPM_BUILD_ROOT%{_desktopdir}
81mv $RPM_BUILD_ROOT{%{_datadir}/%{name}/desktop,%{_desktopdir}}/%{name}.desktop
bf09bee7 82
f896fdc8 83%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
2b3e186c 84
f896fdc8
ER
85install -d $RPM_BUILD_ROOT%{_localedir}
86cp -a locale/* $RPM_BUILD_ROOT%{_localedir}
2b3e186c
ZU
87
88%find_lang %{name}
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
f896fdc8
ER
93%post
94%update_desktop_database
95
96%postun
97%update_desktop_database
98
2b3e186c
ZU
99%files -f %{name}.lang
100%defattr(644,root,root,755)
a896e0c8 101%doc README.md
f896fdc8
ER
102%doc usr/share/doc/byobu/*.txt
103%dir %{_sysconfdir}/%{name}
104%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/backend
105%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/socketdir
2b3e186c
ZU
106%attr(755,root,root) %{_bindir}/byobu
107%attr(755,root,root) %{_bindir}/byobu-config
f896fdc8
ER
108%attr(755,root,root) %{_bindir}/byobu-ctrl-a
109%attr(755,root,root) %{_bindir}/byobu-disable
110%attr(755,root,root) %{_bindir}/byobu-disable-prompt
111%attr(755,root,root) %{_bindir}/byobu-enable
112%attr(755,root,root) %{_bindir}/byobu-enable-prompt
2b3e186c 113%attr(755,root,root) %{_bindir}/byobu-export
f896fdc8
ER
114%attr(755,root,root) %{_bindir}/byobu-janitor
115%attr(755,root,root) %{_bindir}/byobu-keybindings
116%attr(755,root,root) %{_bindir}/byobu-launch
117%attr(755,root,root) %{_bindir}/byobu-launcher
118%attr(755,root,root) %{_bindir}/byobu-launcher-install
119%attr(755,root,root) %{_bindir}/byobu-launcher-uninstall
120%attr(755,root,root) %{_bindir}/byobu-layout
121%attr(755,root,root) %{_bindir}/byobu-prompt
122%attr(755,root,root) %{_bindir}/byobu-quiet
123%attr(755,root,root) %{_bindir}/byobu-reconnect-sockets
124%attr(755,root,root) %{_bindir}/byobu-screen
125%attr(755,root,root) %{_bindir}/byobu-select-backend
126%attr(755,root,root) %{_bindir}/byobu-select-profile
127%attr(755,root,root) %{_bindir}/byobu-select-session
128%attr(755,root,root) %{_bindir}/byobu-shell
129%attr(755,root,root) %{_bindir}/byobu-silent
2b3e186c
ZU
130%attr(755,root,root) %{_bindir}/byobu-status
131%attr(755,root,root) %{_bindir}/byobu-status-detail
f896fdc8
ER
132%attr(755,root,root) %{_bindir}/byobu-tmux
133%attr(755,root,root) %{_bindir}/byobu-ugraph
134%attr(755,root,root) %{_bindir}/byobu-ulevel
135%attr(755,root,root) %{_bindir}/col1
136%attr(755,root,root) %{_bindir}/ctail
bf09bee7
ER
137%attr(755,root,root) %{_bindir}/manifest
138%attr(755,root,root) %{_bindir}/purge-old-kernels
f896fdc8
ER
139%attr(755,root,root) %{_bindir}/vigpg
140%attr(755,root,root) %{_bindir}/wifi-status
141%{_mandir}/man1/*.1*
bf09bee7
ER
142/etc/profile.d/Z97-byobu.sh
143%{_datadir}/dbus-1/services/us.kirkland.terminals.byobu.service
50e506b4
ER
144%{_desktopdir}/%{name}.desktop
145# preserve +x bits where needed
146%defattr(-,root,root,-)
f896fdc8
ER
147%{_libexecdir}/%{name}
148%{_datadir}/%{name}
This page took 0.094667 seconds and 4 git commands to generate.