]> git.pld-linux.org Git - packages/byobu.git/blob - byobu.spec
Use python3 dependencies
[packages/byobu.git] / byobu.spec
1 Summary:        A set of useful profiles and a profile-switcher for GNU screen
2 Summary(hu.UTF-8):      Hasznos profilok és profilváltó gyűjteménye a GNU screen-hez
3 Summary(pl.UTF-8):      Zestaw przydatnych profili oraz przełącznik profili dla GNU screena
4 Name:           byobu
5 Version:        5.112
6 Release:        2
7 License:        GPL v3
8 Group:          Applications/System
9 Source0:        https://code.launchpad.net/byobu/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
10 # Source0-md5:  69d0681d83a2811e59642d5ebaa94670
11 Patch0:         desktop.patch
12 Patch1:         pld-logo.patch
13 URL:            https://launchpad.net/byobu
14 BuildRequires:  gettext-tools
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.596
17 Requires:       desktop-file-utils
18 Requires:       python >= 1:2.5
19 Requires:       python-snack
20 Suggests:       screen
21 Suggests:       tmux >= 1.5
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _noautocompressdoc '*.txt'
26
27 %define         _libexecdir     %{_prefix}/lib
28
29 %description
30 Byobu is an elegant enhancement of the otherwise functional, plain,
31 practical GNU Screen. Byobu includes an enhanced profile and
32 configuration utilities for the GNU screen window manager, such as
33 toggle-able system status notifications.
34
35 %description -l hu.UTF-8
36 Byobu egy elegáns kiterjesztése az amúgy használható, egyszerű,
37 praktikus GNU screen-nek. A Byobu tartalmaz egy kiterjesztett profilt
38 és konfigurációs eszközöket a GNU screen ablakkezelőhöz, pl. a
39 ki/bekapcsolható rendszer státusz jelentéseket.
40
41 %description -l pl.UTF-8
42 Byobu to eleganckie rozszerzenie dla funkcjonalnego, zwykłego,
43 praktycznego GNU screena. Byobu zawiera rozszerzony profil oraz
44 narzędzia konfiguracyjne dla zarządcy okien, jakim jest GNU screen
45 - takie jak przełączane powiadomienia o stanie systemu.
46
47 %prep
48 %setup -q
49 %patch0 -p1
50 %patch1 -p1
51
52 %{__sed} -i -e '
53         s#/share/doc/byobu#/share/doc/%{name}-%{version}#
54 ' usr/share/byobu/keybindings/*
55
56 # cleanup backups after patching
57 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
58
59 %build
60 %configure
61 %{__make}
62
63 for po in po/*.po; do
64         lang=${po#po/}
65         lang=${lang%.po}
66         mkdir -p locale/${lang}/LC_MESSAGES/
67         msgfmt ${po} -o locale/${lang}/LC_MESSAGES/%{name}.mo
68 done
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 %{__make} install \
73         INSTALL="install -p" \
74         CP="cp -p" \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 # some debian hackery, just use the "current" one for pld
78 install -d $RPM_BUILD_ROOT%{_desktopdir}
79 mv $RPM_BUILD_ROOT{%{_datadir}/%{name}/desktop,%{_desktopdir}}/%{name}.desktop
80
81 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
82
83 install -d $RPM_BUILD_ROOT%{_localedir}
84 cp -a locale/* $RPM_BUILD_ROOT%{_localedir}
85
86 %find_lang %{name}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post
92 %update_desktop_database
93
94 %postun
95 %update_desktop_database
96
97 %files -f %{name}.lang
98 %defattr(644,root,root,755)
99 %doc README
100 %doc usr/share/doc/byobu/*.txt
101 %dir %{_sysconfdir}/%{name}
102 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/backend
103 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/socketdir
104 %attr(755,root,root) %{_bindir}/byobu
105 %attr(755,root,root) %{_bindir}/byobu-config
106 %attr(755,root,root) %{_bindir}/byobu-ctrl-a
107 %attr(755,root,root) %{_bindir}/byobu-disable
108 %attr(755,root,root) %{_bindir}/byobu-disable-prompt
109 %attr(755,root,root) %{_bindir}/byobu-enable
110 %attr(755,root,root) %{_bindir}/byobu-enable-prompt
111 %attr(755,root,root) %{_bindir}/byobu-export
112 %attr(755,root,root) %{_bindir}/byobu-janitor
113 %attr(755,root,root) %{_bindir}/byobu-keybindings
114 %attr(755,root,root) %{_bindir}/byobu-launch
115 %attr(755,root,root) %{_bindir}/byobu-launcher
116 %attr(755,root,root) %{_bindir}/byobu-launcher-install
117 %attr(755,root,root) %{_bindir}/byobu-launcher-uninstall
118 %attr(755,root,root) %{_bindir}/byobu-layout
119 %attr(755,root,root) %{_bindir}/byobu-prompt
120 %attr(755,root,root) %{_bindir}/byobu-quiet
121 %attr(755,root,root) %{_bindir}/byobu-reconnect-sockets
122 %attr(755,root,root) %{_bindir}/byobu-screen
123 %attr(755,root,root) %{_bindir}/byobu-select-backend
124 %attr(755,root,root) %{_bindir}/byobu-select-profile
125 %attr(755,root,root) %{_bindir}/byobu-select-session
126 %attr(755,root,root) %{_bindir}/byobu-shell
127 %attr(755,root,root) %{_bindir}/byobu-silent
128 %attr(755,root,root) %{_bindir}/byobu-status
129 %attr(755,root,root) %{_bindir}/byobu-status-detail
130 %attr(755,root,root) %{_bindir}/byobu-tmux
131 %attr(755,root,root) %{_bindir}/byobu-ugraph
132 %attr(755,root,root) %{_bindir}/byobu-ulevel
133 %attr(755,root,root) %{_bindir}/col1
134 %attr(755,root,root) %{_bindir}/ctail
135 %attr(755,root,root) %{_bindir}/manifest
136 %attr(755,root,root) %{_bindir}/purge-old-kernels
137 %attr(755,root,root) %{_bindir}/vigpg
138 %attr(755,root,root) %{_bindir}/wifi-status
139 %{_mandir}/man1/*.1*
140 /etc/profile.d/Z97-byobu.sh
141 %{_datadir}/dbus-1/services/us.kirkland.terminals.byobu.service
142 %{_desktopdir}/%{name}.desktop
143 # preserve +x bits where needed
144 %defattr(-,root,root,-)
145 %{_libexecdir}/%{name}
146 %{_datadir}/%{name}
This page took 0.079989 seconds and 3 git commands to generate.