]> git.pld-linux.org Git - packages/byobu.git/blame - byobu.spec
requires snack python module (from newt)
[packages/byobu.git] / byobu.spec
CommitLineData
2b3e186c
ZU
1Summary: A set of useful profiles and a profile-switcher for GNU screen
2Summary(hu.UTF-8): Hasznos profilok és profilváltó gyűjteménye a GNU screen-hez
2e06fbbb 3Summary(pl.UTF-8): Zestaw przydatnych profili oraz przełącznik profili dla GNU screena
2b3e186c 4Name: byobu
f896fdc8 5Version: 5.97
dcd70459 6Release: 0.3
f896fdc8 7License: GPL v3
2b3e186c 8Group: Applications/System
f896fdc8
ER
9Source0: https://code.launchpad.net/byobu/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
10# Source0-md5: 06fc9398700de1ecba576e0819fe5626
11URL: https://launchpad.net/byobu
d420996e 12BuildRequires: gettext-tools
d3ce91ff 13BuildRequires: rpm-pythonprov
f896fdc8
ER
14BuildRequires: rpmbuild(macros) >= 1.596
15Requires: desktop-file-utils
2e06fbbb 16Requires: python >= 1:2.5
dcd70459 17Requires: python-snack
58a24a03
ER
18Suggests: screen
19Suggests: tmux
2b3e186c
ZU
20BuildArch: noarch
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
f896fdc8
ER
23%define _libexecdir %{_prefix}/lib
24
2b3e186c
ZU
25%description
26Byobu is an elegant enhancement of the otherwise functional, plain,
27practical GNU Screen. Byobu includes an enhanced profile and
28configuration utilities for the GNU screen window manager, such as
29toggle-able system status notifications.
30
31%description -l hu.UTF-8
32Byobu egy elegáns kiterjesztése az amúgy használható, egyszerű,
33praktikus GNU screen-nek. A Byobu tartalmaz egy kiterjesztett profilt
34és konfigurációs eszközöket a GNU screen ablakkezelőhöz, pl. a
35ki/bekapcsolható rendszer státusz jelentéseket.
36
2e06fbbb
JB
37%description -l pl.UTF-8
38Byobu to eleganckie rozszerzenie dla funkcjonalnego, zwykłego,
39praktycznego GNU screena. Byobu zawiera rozszerzony profil oraz
40narzędzia konfiguracyjne dla zarządcy okien, jakim jest GNU screen
41- takie jak przełączane powiadomienia o stanie systemu.
42
2b3e186c 43%prep
f896fdc8 44%setup -q
2b3e186c
ZU
45
46%build
f896fdc8
ER
47%configure
48%{__make}
49
50for po in po/*.po; do
51 lang=${po#po/}
52 lang=${lang%.po}
53 mkdir -p locale/${lang}/LC_MESSAGES/
54 msgfmt ${po} -o locale/${lang}/LC_MESSAGES/%{name}.mo
55done
2b3e186c
ZU
56
57%install
58rm -rf $RPM_BUILD_ROOT
f896fdc8
ER
59%{__make} install \
60 INSTALL="install -p" \
61 CP="cp -p" \
62 docdir=%{_docdir}/%{name} \
63 DESTDIR=$RPM_BUILD_ROOT
64
65%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
2b3e186c 66
f896fdc8
ER
67install -d $RPM_BUILD_ROOT%{_localedir}
68cp -a locale/* $RPM_BUILD_ROOT%{_localedir}
2b3e186c
ZU
69
70%find_lang %{name}
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
f896fdc8
ER
75%post
76%update_desktop_database
77
78%postun
79%update_desktop_database
80
2b3e186c
ZU
81%files -f %{name}.lang
82%defattr(644,root,root,755)
f896fdc8
ER
83%doc README
84%doc usr/share/doc/byobu/*.txt
85%dir %{_sysconfdir}/%{name}
86%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/backend
87%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/socketdir
2b3e186c
ZU
88%attr(755,root,root) %{_bindir}/byobu
89%attr(755,root,root) %{_bindir}/byobu-config
f896fdc8
ER
90%attr(755,root,root) %{_bindir}/byobu-ctrl-a
91%attr(755,root,root) %{_bindir}/byobu-disable
92%attr(755,root,root) %{_bindir}/byobu-disable-prompt
93%attr(755,root,root) %{_bindir}/byobu-enable
94%attr(755,root,root) %{_bindir}/byobu-enable-prompt
2b3e186c 95%attr(755,root,root) %{_bindir}/byobu-export
f896fdc8
ER
96%attr(755,root,root) %{_bindir}/byobu-janitor
97%attr(755,root,root) %{_bindir}/byobu-keybindings
98%attr(755,root,root) %{_bindir}/byobu-launch
99%attr(755,root,root) %{_bindir}/byobu-launcher
100%attr(755,root,root) %{_bindir}/byobu-launcher-install
101%attr(755,root,root) %{_bindir}/byobu-launcher-uninstall
102%attr(755,root,root) %{_bindir}/byobu-layout
103%attr(755,root,root) %{_bindir}/byobu-prompt
104%attr(755,root,root) %{_bindir}/byobu-quiet
105%attr(755,root,root) %{_bindir}/byobu-reconnect-sockets
106%attr(755,root,root) %{_bindir}/byobu-screen
107%attr(755,root,root) %{_bindir}/byobu-select-backend
108%attr(755,root,root) %{_bindir}/byobu-select-profile
109%attr(755,root,root) %{_bindir}/byobu-select-session
110%attr(755,root,root) %{_bindir}/byobu-shell
111%attr(755,root,root) %{_bindir}/byobu-silent
2b3e186c
ZU
112%attr(755,root,root) %{_bindir}/byobu-status
113%attr(755,root,root) %{_bindir}/byobu-status-detail
f896fdc8
ER
114%attr(755,root,root) %{_bindir}/byobu-tmux
115%attr(755,root,root) %{_bindir}/byobu-ugraph
116%attr(755,root,root) %{_bindir}/byobu-ulevel
117%attr(755,root,root) %{_bindir}/col1
118%attr(755,root,root) %{_bindir}/ctail
119%attr(755,root,root) %{_bindir}/vigpg
120%attr(755,root,root) %{_bindir}/wifi-status
121%{_mandir}/man1/*.1*
50e506b4
ER
122%{_desktopdir}/%{name}.desktop
123# preserve +x bits where needed
124%defattr(-,root,root,-)
f896fdc8
ER
125%{_libexecdir}/%{name}
126%{_datadir}/%{name}
This page took 0.361905 seconds and 4 git commands to generate.