]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- don't degrade to C++ 11 from default C++ >= 14 when using gcc 6 or higher
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #
6 # Conditional build:
7 %bcond_without  python2         # boost-python[2] support
8 %bcond_without  python3         # boost-python3 support
9 %bcond_without  numpy           # boost-numpy support
10
11 %define         fver    %(echo %{version} | tr . _)
12 Summary:        The Boost C++ Libraries
13 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
14 Name:           boost
15 Version:        1.68.0
16 Release:        1
17 License:        Boost Software License and others
18 Group:          Libraries
19 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
20 # Source0-md5:  7fbd1890f571051f2a209681d57d486a
21 Patch0:         %{name}-link.patch
22 Patch1:         %{name}-x32-context.patch
23 Patch2:         %{name}-clean-gcc-flags.patch
24 # FC Patches:
25 Patch201:       %{name}-python-abi_letters.patch
26 # https://svn.boost.org/trac/boost/ticket/5637
27 Patch203:       %{name}-1.54.0-mpl-print.patch
28 # https://svn.boost.org/trac/boost/ticket/8881
29 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
30 URL:            http://www.boost.org/
31 BuildRequires:  bzip2-devel
32 BuildRequires:  expat-devel
33 BuildRequires:  libicu-devel
34 BuildRequires:  libstdc++-devel >= 6:4.7
35 BuildRequires:  perl-base
36 %if %{with python}
37 BuildRequires:  python-devel >= 2.2
38 %{?with_numpy:BuildRequires:    python-numpy-devel}
39 %endif
40 %if %{with python3}
41 BuildRequires:  python3-devel
42 %{?with_numpy:BuildRequires:    python3-numpy-devel}
43 %endif
44 BuildRequires:  rpm-pythonprov
45 BuildRequires:  rpmbuild(macros) >= 1.734
46 BuildRequires:  zlib-devel
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
50
51 %define         py2v %(echo %{py_ver} | tr -d .)
52 %define         py3v %(echo %{py3_ver} | tr -d .)
53
54 %description
55 The Boost web site provides free peer-reviewed portable C++ source
56 libraries. The emphasis is on libraries which work well with the C++
57 Standard Library. One goal is to establish "existing practice" and
58 provide reference implementations so that the Boost libraries are
59 suitable for eventual standardization. Some of the libraries have
60 already been proposed for inclusion in the C++ Standards Committee's
61 upcoming C++ Standard Library Technical Report.
62
63 %description -l pl.UTF-8
64 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
65 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
66 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
67 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
68 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
69 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
70 Raporcie Technicznym Biblioteki Standardowej C++.
71
72 %package devel
73 Summary:        Boost C++ development headers
74 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       %{name}-chrono = %{version}-%{release}
78 Requires:       %{name}-context = %{version}-%{release}
79 Requires:       %{name}-date_time = %{version}-%{release}
80 Requires:       %{name}-fiber = %{version}-%{release}
81 Requires:       %{name}-filesystem = %{version}-%{release}
82 Requires:       %{name}-graph = %{version}-%{release}
83 Requires:       %{name}-locale = %{version}-%{release}
84 Requires:       %{name}-log = %{version}-%{release}
85 Requires:       %{name}-program_options = %{version}-%{release}
86 Requires:       %{name}-regex = %{version}-%{release}
87 Requires:       %{name}-signals = %{version}-%{release}
88 Requires:       %{name}-system = %{version}-%{release}
89 Requires:       %{name}-test = %{version}-%{release}
90 Requires:       %{name}-thread = %{version}-%{release}
91 Requires:       %{name}-timer = %{version}-%{release}
92 Requires:       %{name}-wave = %{version}-%{release}
93 Requires:       libstdc++-devel >= 6:4.7
94 Obsoletes:      boost-any-devel
95 Obsoletes:      boost-array-devel
96 Obsoletes:      boost-asio
97 Obsoletes:      boost-bind-devel
98 Obsoletes:      boost-call_traits-devel
99 Obsoletes:      boost-compatibility-devel
100 Obsoletes:      boost-compose-devel
101 Obsoletes:      boost-compressed_pair-devel
102 Obsoletes:      boost-concept_check-devel
103 Obsoletes:      boost-conversion-devel
104 Obsoletes:      boost-crc-devel
105 Obsoletes:      boost-date_time-devel
106 Obsoletes:      boost-filesystem-devel
107 Obsoletes:      boost-graph-devel
108 Obsoletes:      boost-mem_fn-devel
109 Obsoletes:      boost-mpl-devel
110 Obsoletes:      boost-preprocessor-devel
111 Obsoletes:      boost-program_options-devel
112 Obsoletes:      boost-ref-devel
113 Obsoletes:      boost-regex-devel
114 Obsoletes:      boost-signals-devel
115 Obsoletes:      boost-spirit-devel
116 Obsoletes:      boost-statechart-devel
117 Obsoletes:      boost-static_assert-devel
118 Obsoletes:      boost-test-devel
119 Obsoletes:      boost-thread-devel
120 Obsoletes:      boost-tr1-devel
121 Obsoletes:      boost-type_traits-devel
122 Obsoletes:      boost-typeof-devel
123 Obsoletes:      boost-uBLAS-devel
124 Obsoletes:      boost-utility-devel
125 Obsoletes:      boost-wave-devel
126 Obsoletes:      boost-xpressive-devel
127
128 %description devel
129 Header files for the Boost C++ libraries.
130
131 %description devel -l pl.UTF-8
132 Pliki nagłówkowe bibliotek C++ Boost.
133
134 %package static
135 Summary:        Static version of base Boost C++ libraries
136 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
137 Group:          Development/Libraries
138 Requires:       %{name}-devel = %{version}-%{release}
139 Obsoletes:      boost-static < 1.33
140
141 %description static
142 Static version of base Boost C++ libraries.
143
144 %description static -l pl.UTF-8
145 Statyczne wersje podstawowych bibliotek C++ Boost.
146
147 %package python-devel-common
148 Summary:        Boost.Python development headers
149 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Boost.Python
150 Group:          Development/Libraries
151 Requires:       %{name}-devel = %{version}-%{release}
152
153 %description python-devel-common
154 Headers for the Boost.Python library.
155
156 %description python-devel-common -l pl.UTF-8
157 Pliki nagłówkowe biblioteki Boost.Python.
158
159 %package python
160 Summary:        Boost.Python library for Python 2
161 Summary(pl.UTF-8):      Biblioteka Boost.Python dla Pythona 2
162 Group:          Libraries
163 Requires:       python-libs
164
165 %description python
166 Use the Boost Python Library to quickly and easily export a C++
167 library to Python 2 such that the Python 2 interface is very similar
168 to the C++ interface. It is designed to be minimally intrusive on your
169 C++ design. In most cases, you should not have to alter your C++
170 classes in any way in order to use them with Boost.Python. The system
171 should simply ``reflect'' your C++ classes and functions into Python
172 3.
173
174 %description python -l pl.UTF-8
175 Biblioteka Boost Python służy do szybkiego i prostego eksportu
176 biblioteki C++ do Pythona 2, tak że interfejs Pythona 2 jest bardzo
177 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
178 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
179 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
180 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
181 klasy C++ i funkcje do Pythona 3.
182
183 %package python-devel
184 Summary:        Boost.Python development files for Python 2
185 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 2
186 Group:          Development/Libraries
187 Requires:       %{name}-devel = %{version}-%{release}
188 Requires:       %{name}-python = %{version}-%{release}
189 Requires:       %{name}-python-devel-common = %{version}-%{release}
190
191 %description python-devel
192 Boost.Python development files for Python 2.
193
194 %description python-devel -l pl.UTF-8
195 Pliki programistyczne biblioteki Boost.Python dla Pythona 2.
196
197 %package python-static
198 Summary:        Static version of Boost.Python library for Python 2
199 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 2
200 Group:          Development/Libraries
201 Requires:       %{name}-python-devel = %{version}-%{release}
202
203 %description python-static
204 Static version of Boost.Python library for Python 2.
205
206 %description python-static -l pl.UTF-8
207 Statyczna wersja biblioteki Boost.Python dla Pythona 2.
208
209 %package python3
210 Summary:        Boost.Python library for Python 3
211 Summary(pl.UTF-8):      biblioteka Boost.Python dla Pythona 3
212 Group:          Libraries
213 Requires:       python3-libs
214
215 %description python3
216 Use the Boost Python Library to quickly and easily export a C++
217 library to Python 3 such that the Python 3 interface is very similar
218 to the C++ interface. It is designed to be minimally intrusive on your
219 C++ design. In most cases, you should not have to alter your C++
220 classes in any way in order to use them with Boost.Python. The system
221 should simply ``reflect'' your C++ classes and functions into Python
222 3.
223
224 %description python3 -l pl.UTF-8
225 Biblioteka Boost Python służy do szybkiego i prostego eksportu
226 biblioteki C++ do Pythona 3, tak że interfejs Pythona 3 jest bardzo
227 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
228 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
229 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
230 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
231 klasy C++ i funkcje do Pythona 3.
232
233 %package python3-devel
234 Summary:        Boost.Python development files for Python 3
235 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 3
236 Group:          Development/Libraries
237 Requires:       %{name}-devel = %{version}-%{release}
238 Requires:       %{name}-python-devel-common = %{version}-%{release}
239 Requires:       %{name}-python3 = %{version}-%{release}
240
241 %description python3-devel
242 Boost.Python development files for Python 3.
243
244 %description python3-devel -l pl.UTF-8
245 Pliki programistyczne biblioteki Boost.Python dla Pythona 3.
246
247 %package python3-static
248 Summary:        Static version of Boost.Python library for Python 3
249 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 3
250 Group:          Development/Libraries
251 Requires:       %{name}-python3-devel = %{version}-%{release}
252
253 %description python3-static
254 Static version of Boost.Python library for Python 3.
255
256 %description python3-static -l pl.UTF-8
257 Statyczna wersja biblioteki Boost.Python dla Pythona 3.
258
259 %package chrono
260 Summary:        Useful time utilities
261 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
262 Group:          Libraries
263 Obsoletes:      boost < 1.33
264
265 %description chrono
266 Useful time utilities.
267
268 %description chrono -l pl.UTF-8
269 Przydatne funkcje związane z czasem.
270
271 %package context
272 Summary:        Boost.Context - context switching library
273 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
274 Group:          Libraries
275
276 %description context
277 Boost.Context - context switching library, providing a sort of
278 cooperative multitasking on a single thread.
279
280 %description context -l pl.UTF-8
281 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
282 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
283
284 %package date_time
285 Summary:        Date-Time library
286 Summary(pl.UTF-8):      Biblioteka daty-czasu
287 Group:          Libraries
288 Obsoletes:      boost < 1.33
289
290 %description date_time
291 A set of date-time libraries.
292
293 %description date_time -l pl.UTF-8
294 Zbiór bibliotek daty-czasu.
295
296 %package fiber
297 Summary:        A framework for micro-/userland-threads (fibers) scheduled cooperatively
298 Summary(pl.UTF-8):      Szkielet mikrowątków przestrzeni użytkownika (fibers), szeregowanych kooperacyjnie
299 Group:          Libraries
300
301 %description fiber
302 boost::fiber provides a framework for micro-/userland-threads (fibers)
303 scheduled cooperatively. The API contains classes and functions
304 to manage and synchronize fibers similiar to boost.thread.
305
306 %description fiber -l pl.UTF-8
307 boost::fiber to szkielt mikrowątków przestrzeni użytkownika (fibers)
308 szeregowanych kooperacyjnie. API zawiera klasy i funkcje służące do
309 zarządzania i synchronizacji wątków podobne do boost.thread.
310
311 %package filesystem
312 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
313 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
314 Group:          Libraries
315 Requires:       %{name}-system = %{version}-%{release}
316 Obsoletes:      boost < 1.33
317
318 %description filesystem
319 The boost::filesystem library provides portable facilities to query
320 and manipulate paths, files, and directories.
321
322 %description filesystem -l pl.UTF-8
323 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
324 operacjach na ścieżkach, plikach i katalogach.
325
326 %package graph
327 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
328 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
329 Group:          Libraries
330
331 %description graph
332 The boost::graph library provides portable facilities to operate on
333 graph data structures using graph algorithms.
334
335 %description graph -l pl.UTF-8
336 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
337 strukturach danych typu graf za pomocą algorytmów związanych z
338 grafami.
339
340 %package locale
341 Summary:        Provide localization and Unicode handling tools for C++
342 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
343 Group:          Libraries
344
345 %description locale
346 Provide localization and Unicode handling tools for C++.
347
348 %description locale -l pl.UTF-8
349 Narzędzia do obsługi lokalizacji i Unikodu w C++.
350
351 %package log
352 Summary:        Provide logging tools for C++
353 Summary(pl.UTF-8):      Narzędzia do logowania w C++
354 Group:          Libraries
355
356 %description log
357 Provide logging tools for C++.
358
359 %description log -l pl.UTF-8
360 Narzędzia do logowania w C++.
361
362 %package program_options
363 Summary:        Access to program options, via conventional methods such as command line and config file
364 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
365 Group:          Libraries
366
367 %description program_options
368 The program_options library allows program developers to obtain
369 program options, that is (name, value) pairs from the user, via
370 conventional methods such as command line and config file.
371
372 %description program_options -l pl.UTF-8
373 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
374 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
375 jak linia poleceń, czy plik konfiguracyjny.
376
377 %package regex
378 Summary:        Boost C++ regular expressions library
379 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
380 Group:          Libraries
381
382 %description regex
383 Shared library for Boost C++ regular expressions.
384
385 %description regex -l pl.UTF-8
386 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
387
388 %package signals
389 Summary:        Signals & slots callback implementation
390 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
391 Group:          Libraries
392 Obsoletes:      boost < 1.33
393
394 %description signals
395 The boost::signals library is an implementation of a signals and slots
396 system.
397
398 %description signals -l pl.UTF-8
399 Biblioteka boost::signals jest implementacją systemu sygnałów i
400 slotów.
401
402 %package system
403 Summary:        Support for getting system specific error codes
404 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
405 Group:          Libraries
406
407 %description system
408 The Boost System library provides simple, light-weight error_code
409 objects that encapsulate system-specific error code values, yet also
410 provide access to more abstract and portable error conditions objects.
411
412 %description system -l pl.UTF-8
413 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
414 obudowujące wartości kodów błędów specyficznych dla systemu, dając
415 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
416 błędów.
417
418 %package test
419 Summary:        Support for program testing and execution monitoring
420 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
421 Group:          Libraries
422 Obsoletes:      boost < 1.33
423
424 %description test
425 Support for simple program testing, full unit testing, and for program
426 execution monitoring.
427
428 %description test -l pl.UTF-8
429 Wsparcie dla prostego testowania programu, pełnego testowania i
430 monitorowania wykonania programu.
431
432 %package thread
433 Summary:        Portable C++ threads library
434 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
435 Group:          Libraries
436 Obsoletes:      boost < 1.33
437
438 %description thread
439 Portable C++ threads library - shared library.
440
441 %description thread -l pl.UTF-8
442 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
443
444 %package timer
445 Summary:        Event timer, progress timer, and progress display classes
446 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
447 Group:          Libraries
448 Obsoletes:      boost < 1.33
449
450 %description timer
451 Event timer, progress timer, and progress display classes.
452
453 %description timer -l pl.UTF-8
454 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
455
456 %package wave
457 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
458 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
459 Group:          Development/Libraries
460
461 %description wave
462 Boost.Wave - a standard compliant C++ preprocessor library.
463
464 %description wave -l pl.UTF-8
465 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
466
467 %package doc
468 Summary:        Boost C++ Library documentation
469 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
470 Group:          Documentation
471 %if "%{_rpmversion}" >= "5"
472 BuildArch:      noarch
473 %endif
474
475 %description doc
476 Documentation for the Boost C++ Library.
477
478 %description doc -l pl.UTF-8
479 Dokumentacja dla biblioteki Boost C++.
480
481 %prep
482 %setup -q -n %{name}_%{fver}
483 %patch0 -p1
484 %patch1 -p1
485 %patch2 -p1
486
487 %patch201 -p1
488 %patch203 -p0
489 %patch221 -p1
490
491 %if "%{cc_version}" < "6.0"
492 CPPSTD="-std=c++11"
493 %else
494 CPPSTD=
495 %endif
496 cat << EOF > tools/build/src/user-config.jam
497 using gcc : %{cxx_version} : %{__cxx} : <cflags>"%{rpmcflags} -fPIC" <cxxflags>"%{rpmcxxflags} $CPPSTD -fPIC" <linkflags>"%{rpmldflags}" ;
498 EOF
499
500 # cleanup backups after patching
501 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
502
503 %build
504 EXPAT_INCLUDE=%{_includedir} \
505 EXPAT_LIBPATH=%{_libdir} \
506 ICU_PATH=%{_prefix} \
507 ./bootstrap.sh \
508         --prefix=%{_prefix} \
509         -without-libraries=python
510
511 ./b2 \
512         -d2 --toolset=gcc \
513         variant=release \
514         debug-symbols=on \
515         inlining=on \
516         link=static,shared \
517         threading=multi
518
519 %if %{with python3}
520 echo "using python : %{py3_ver} : %{py3_prefix} : %{py3_incdir} : : : : m ;" >> project-config.jam
521 ./b2 \
522         --with-python python=%{py3_ver} \
523         -a -d2 --toolset=gcc \
524         variant=release \
525         debug-symbols=on \
526         inlining=on \
527         link=static,shared \
528         threading=multi
529 %endif
530
531 %if %{with python2}
532 %{__sed} -i -e '/^using python : 3/d' project-config.jam
533 echo "using python : %{py_ver} : %{py_prefix} : %{py_incdir} ;" >> project-config.jam
534 ./b2 \
535         --with-python python=%{py_ver} \
536         -a -d2 --toolset=gcc \
537         variant=release \
538         debug-symbols=on \
539         inlining=on \
540         link=static,shared \
541         threading=multi
542 %endif
543
544 %install
545 rm -rf $RPM_BUILD_ROOT
546 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
547
548 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
549
550 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
551 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
552 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
553
554 # documentation
555 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
556
557 # as the documentation doesn't completely reside in a directory of its
558 # own, we need to find out ourselves... this looks for HTML files and
559 # then collects everything linked from those.  this is certainly quite
560 # unoptimized wrt mkdir calls, but does it really matter?
561 installdocs() {
562 for i in $(find -type f -name '*.htm*'); do
563         # bjam docu is included in the boost-jam RPM
564         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
565                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
566                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
567                         sub rewrite_link
568                         {
569                                 my $link = shift;
570                                 # rewrite links from boost/* to %{_includedir}/boost/* and
571                                 # ignore external links as well as document-internal ones.
572                                 # HTML files are also ignored as they get installed anyway.
573                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
574                                 {
575                                         (my $file = $link) =~ s/\#.*//;
576                                         print "$file\n";
577                                 }
578                                 $link;
579                         }
580                         open IN, @ARGV[0];
581                         open OUT, ">@ARGV[1]";
582                         my $in_link;
583                         while (<IN>)
584                         {
585                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
586                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
587                                 print OUT;
588                                 $in_link = /href|src=\s*$/;
589                         }
590 EOT`; do
591                         TARGET=${i%/*}/$LINKED
592                         # ignore non-existant linked files
593                         if test -f $TARGET; then
594                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
595                         fi
596                 done
597         fi
598 done
599 }; installdocs
600
601 %clean
602 rm -rf $RPM_BUILD_ROOT
603
604 %post   -p /sbin/ldconfig
605 %postun -p /sbin/ldconfig
606
607 %post   chrono -p /sbin/ldconfig
608 %postun chrono -p /sbin/ldconfig
609
610 %post   context -p /sbin/ldconfig
611 %postun context -p /sbin/ldconfig
612
613 %post   date_time -p /sbin/ldconfig
614 %postun date_time -p /sbin/ldconfig
615
616 %post   fiber -p /sbin/ldconfig
617 %postun fiber -p /sbin/ldconfig
618
619 %post   filesystem -p /sbin/ldconfig
620 %postun filesystem -p /sbin/ldconfig
621
622 %post   graph -p /sbin/ldconfig
623 %postun graph -p /sbin/ldconfig
624
625 %post   locale -p /sbin/ldconfig
626 %postun locale -p /sbin/ldconfig
627
628 %post   python -p /sbin/ldconfig
629 %postun python -p /sbin/ldconfig
630
631 %post   python3 -p /sbin/ldconfig
632 %postun python3 -p /sbin/ldconfig
633
634 %post   program_options -p /sbin/ldconfig
635 %postun program_options -p /sbin/ldconfig
636
637 %post   regex -p /sbin/ldconfig
638 %postun regex -p /sbin/ldconfig
639
640 %post   signals -p /sbin/ldconfig
641 %postun signals -p /sbin/ldconfig
642
643 %post   system -p /sbin/ldconfig
644 %postun system -p /sbin/ldconfig
645
646 %post   test -p /sbin/ldconfig
647 %postun test -p /sbin/ldconfig
648
649 %post   thread -p /sbin/ldconfig
650 %postun thread -p /sbin/ldconfig
651
652 %post   timer -p /sbin/ldconfig
653 %postun timer -p /sbin/ldconfig
654
655 %post   wave -p /sbin/ldconfig
656 %postun wave -p /sbin/ldconfig
657
658 %files
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
661 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
662 %attr(755,root,root) %{_libdir}/libboost_contract.so.*.*.*
663 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
664 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
665 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
666 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
667 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
668 %attr(755,root,root) %{_libdir}/libboost_stacktrace_*.so.*.*.*
669 %attr(755,root,root) %{_libdir}/libboost_type_erasure.so.*.*.*
670 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
671
672 %files devel
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_libdir}/libboost_atomic.so
675 %attr(755,root,root) %{_libdir}/libboost_chrono.so
676 %attr(755,root,root) %{_libdir}/libboost_container.so
677 %attr(755,root,root) %{_libdir}/libboost_context.so
678 %attr(755,root,root) %{_libdir}/libboost_contract.so
679 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
680 %attr(755,root,root) %{_libdir}/libboost_date_time.so
681 %attr(755,root,root) %{_libdir}/libboost_fiber.so
682 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
683 %attr(755,root,root) %{_libdir}/libboost_graph.so
684 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
685 %attr(755,root,root) %{_libdir}/libboost_locale.so
686 %attr(755,root,root) %{_libdir}/libboost_log.so
687 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
688 %attr(755,root,root) %{_libdir}/libboost_math_*.so
689 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
690 %attr(755,root,root) %{_libdir}/libboost_program_options.so
691 %attr(755,root,root) %{_libdir}/libboost_regex.so
692 %attr(755,root,root) %{_libdir}/libboost_random.so
693 %attr(755,root,root) %{_libdir}/libboost_serialization.so
694 %attr(755,root,root) %{_libdir}/libboost_signals.so
695 %attr(755,root,root) %{_libdir}/libboost_stacktrace_*.so
696 %attr(755,root,root) %{_libdir}/libboost_system.so
697 %attr(755,root,root) %{_libdir}/libboost_thread.so
698 %attr(755,root,root) %{_libdir}/libboost_timer.so
699 %attr(755,root,root) %{_libdir}/libboost_type_erasure.so
700 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
701 %attr(755,root,root) %{_libdir}/libboost_wave.so
702 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
703 %{_includedir}/boost
704 %exclude %{_includedir}/boost/python
705 %exclude %{_includedir}/boost/python.hpp
706
707 %files static
708 %defattr(644,root,root,755)
709 %{_libdir}/libboost_atomic.a
710 %{_libdir}/libboost_chrono.a
711 %{_libdir}/libboost_container.a
712 %{_libdir}/libboost_context.a
713 %{_libdir}/libboost_contract.a
714 %{_libdir}/libboost_coroutine.a
715 %{_libdir}/libboost_date_time.a
716 %{_libdir}/libboost_exception.a
717 %{_libdir}/libboost_fiber.a
718 %{_libdir}/libboost_filesystem.a
719 %{_libdir}/libboost_graph.a
720 %{_libdir}/libboost_iostreams.a
721 %{_libdir}/libboost_locale.a
722 %{_libdir}/libboost_log.a
723 %{_libdir}/libboost_log_setup.a
724 %{_libdir}/libboost_math_*.a
725 %{_libdir}/libboost_prg_exec_monitor.a
726 %{_libdir}/libboost_program_options.a
727 %{_libdir}/libboost_random.a
728 %{_libdir}/libboost_regex.a
729 %{_libdir}/libboost_serialization.a
730 %{_libdir}/libboost_signals.a
731 %{_libdir}/libboost_stacktrace_*.a
732 %{_libdir}/libboost_system.a
733 %{_libdir}/libboost_test_exec_monitor.a
734 %{_libdir}/libboost_timer.a
735 %{_libdir}/libboost_thread.a
736 %{_libdir}/libboost_type_erasure.a
737 %{_libdir}/libboost_unit_test_framework.a
738 %{_libdir}/libboost_wave.a
739 %{_libdir}/libboost_wserialization.a
740
741 %if %{with python2} || %{with python3}
742 %files python-devel-common
743 %defattr(644,root,root,755)
744 %{_includedir}/boost/python
745 %{_includedir}/boost/python.hpp
746 %endif
747
748 %if %{with python2}
749 %files python
750 %defattr(644,root,root,755)
751 %if %{with numpy}
752 %attr(755,root,root) %{_libdir}/libboost_numpy%{py2v}.so.*.*.*
753 %endif
754 %attr(755,root,root) %{_libdir}/libboost_python%{py2v}.so.*.*.*
755
756 %files python-devel
757 %defattr(644,root,root,755)
758 %if %{with numpy}
759 %attr(755,root,root) %{_libdir}/libboost_numpy%{py2v}.so
760 %endif
761 %attr(755,root,root) %{_libdir}/libboost_python%{py2v}.so
762
763 %files python-static
764 %defattr(644,root,root,755)
765 %if %{with numpy}
766 %{_libdir}/libboost_numpy%{py2v}.a
767 %endif
768 %{_libdir}/libboost_python%{py2v}.a
769 %endif
770
771 %if %{with python3}
772 %files python3
773 %defattr(644,root,root,755)
774 %if %{with numpy}
775 %attr(755,root,root) %{_libdir}/libboost_numpy%{py3v}.so.*.*.*
776 %endif
777 %attr(755,root,root) %{_libdir}/libboost_python%{py3v}.so.*.*.*
778
779 %files python3-devel
780 %defattr(644,root,root,755)
781 %if %{with numpy}
782 %attr(755,root,root) %{_libdir}/libboost_numpy%{py3v}.so
783 %endif
784 %attr(755,root,root) %{_libdir}/libboost_python%{py3v}.so
785
786 %files python3-static
787 %defattr(644,root,root,755)
788 %if %{with numpy}
789 %{_libdir}/libboost_numpy%{py3v}.a
790 %endif
791 %{_libdir}/libboost_python%{py3v}.a
792 %endif
793
794 %files chrono
795 %defattr(644,root,root,755)
796 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
797
798 %files context
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
801
802 %files date_time
803 %defattr(644,root,root,755)
804 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
805
806 %files fiber
807 %defattr(644,root,root,755)
808 %attr(755,root,root) %{_libdir}/libboost_fiber.so.*.*.*
809
810 %files filesystem
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
813
814 %files graph
815 %defattr(644,root,root,755)
816 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
817
818 %files locale
819 %defattr(644,root,root,755)
820 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
821
822 %files log
823 %defattr(644,root,root,755)
824 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
825 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
826
827 %files program_options
828 %defattr(644,root,root,755)
829 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
830
831 %files regex
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
834
835 %files signals
836 %defattr(644,root,root,755)
837 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
838
839 %files system
840 %defattr(644,root,root,755)
841 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
842
843 %files test
844 %defattr(644,root,root,755)
845 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
846 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
847
848 %files thread
849 %defattr(644,root,root,755)
850 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
851
852 %files timer
853 %defattr(644,root,root,755)
854 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
855
856 %files wave
857 %defattr(644,root,root,755)
858 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
859
860 %files doc
861 %defattr(644,root,root,755)
862 %{_docdir}/%{name}-%{version}
This page took 0.129932 seconds and 3 git commands to generate.