]> git.pld-linux.org Git - packages/boost.git/commitdiff
- don't degrade to C++ 11 from default C++ >= 14 when using gcc 6 or higher DEVEL-boost-1.68
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 12 Oct 2018 19:30:20 +0000 (21:30 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 12 Oct 2018 19:30:20 +0000 (21:30 +0200)
boost.spec

index 9fba0b1656267c81af19aa4436b0bd0096fa38f9..e28c0d582a1ba2a57de384dd6009ee69f6a13aaa 100644 (file)
@@ -488,8 +488,13 @@ Dokumentacja dla biblioteki Boost C++.
 %patch203 -p0
 %patch221 -p1
 
+%if "%{cc_version}" < "6.0"
+CPPSTD="-std=c++11"
+%else
+CPPSTD=
+%endif
 cat << EOF > tools/build/src/user-config.jam
-using gcc : %{cxx_version} : %{__cxx} : <cflags>"%{rpmcflags} -fPIC" <cxxflags>"%{rpmcxxflags} -std=c++11 -fPIC" <linkflags>"%{rpmldflags}" ;
+using gcc : %{cxx_version} : %{__cxx} : <cflags>"%{rpmcflags} -fPIC" <cxxflags>"%{rpmcxxflags} $CPPSTD -fPIC" <linkflags>"%{rpmldflags}" ;
 EOF
 
 # cleanup backups after patching
This page took 0.231508 seconds and 4 git commands to generate.