]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- updated to 1.50
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #
6 # Conditional build:
7 %bcond_without  python  # without boost-python support
8 #
9 %define         fver    %(echo %{version} | tr . _)
10 Summary:        The Boost C++ Libraries
11 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
12 Name:           boost
13 Version:        1.50.0
14 Release:        0.1
15 License:        Boost Software License and others
16 Group:          Libraries
17 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
18 # Source0-md5:  52dd00be775e689f55a987baebccc462
19 Patch0:         %{name}-link.patch
20 URL:            http://www.boost.org/
21 BuildRequires:  bzip2-devel
22 BuildRequires:  expat-devel
23 BuildRequires:  libicu-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  perl-base
26 %{?with_python:BuildRequires:   python-devel >= 2.2}
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  zlib-devel
29 BuildConflicts: gcc = 5:3.3.1
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The Boost web site provides free peer-reviewed portable C++ source
34 libraries. The emphasis is on libraries which work well with the C++
35 Standard Library. One goal is to establish "existing practice" and
36 provide reference implementations so that the Boost libraries are
37 suitable for eventual standardization. Some of the libraries have
38 already been proposed for inclusion in the C++ Standards Committee's
39 upcoming C++ Standard Library Technical Report.
40
41 %description -l pl.UTF-8
42 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
43 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
44 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
45 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
46 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
47 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
48 Raporcie Technicznym Biblioteki Standardowej C++.
49
50 %package devel
51 Summary:        Boost C++ development headers
52 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       %{name}-date_time = %{version}-%{release}
56 Requires:       %{name}-filesystem = %{version}-%{release}
57 Requires:       %{name}-graph = %{version}-%{release}
58 Requires:       %{name}-program_options = %{version}-%{release}
59 Requires:       %{name}-regex = %{version}-%{release}
60 Requires:       %{name}-signals = %{version}-%{release}
61 Requires:       %{name}-system = %{version}-%{release}
62 Requires:       %{name}-test = %{version}-%{release}
63 Requires:       %{name}-thread = %{version}-%{release}
64 Requires:       %{name}-wave = %{version}-%{release}
65 Requires:       libstdc++-devel
66 Obsoletes:      boost-any-devel
67 Obsoletes:      boost-array-devel
68 Obsoletes:      boost-asio
69 Obsoletes:      boost-bind-devel
70 Obsoletes:      boost-call_traits-devel
71 Obsoletes:      boost-compatibility-devel
72 Obsoletes:      boost-compose-devel
73 Obsoletes:      boost-compressed_pair-devel
74 Obsoletes:      boost-concept_check-devel
75 Obsoletes:      boost-conversion-devel
76 Obsoletes:      boost-crc-devel
77 Obsoletes:      boost-date_time-devel
78 Obsoletes:      boost-filesystem-devel
79 Obsoletes:      boost-graph-devel
80 Obsoletes:      boost-mem_fn-devel
81 Obsoletes:      boost-mpl-devel
82 Obsoletes:      boost-preprocessor-devel
83 Obsoletes:      boost-program_options-devel
84 Obsoletes:      boost-ref-devel
85 Obsoletes:      boost-regex-devel
86 Obsoletes:      boost-signals-devel
87 Obsoletes:      boost-spirit-devel
88 Obsoletes:      boost-statechart-devel
89 Obsoletes:      boost-static_assert-devel
90 Obsoletes:      boost-test-devel
91 Obsoletes:      boost-thread-devel
92 Obsoletes:      boost-tr1-devel
93 Obsoletes:      boost-type_traits-devel
94 Obsoletes:      boost-typeof-devel
95 Obsoletes:      boost-uBLAS-devel
96 Obsoletes:      boost-utility-devel
97 Obsoletes:      boost-wave-devel
98 Obsoletes:      boost-xpressive-devel
99
100 %description devel
101 Header files for the Boost C++ libraries.
102
103 %description devel -l pl.UTF-8
104 Pliki nagłówkowe bibliotek C++ Boost.
105
106 %package static
107 Summary:        Static version of base Boost C++ libraries
108 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{version}-%{release}
111 Obsoletes:      boost-static < 1.33
112
113 %description static
114 Static version of base Boost C++ libraries.
115
116 %description static -l pl.UTF-8
117 Statyczne wersje podstawowych bibliotek C++ Boost.
118
119 %package python
120 Summary:        Boost.Python library
121 Summary(pl.UTF-8):      biblioteka Boost.Python
122 Group:          Libraries
123 %pyrequires_eq  python
124
125 %description python
126 Use the Boost Python Library to quickly and easily export a C++
127 library to Python such that the Python interface is very similar to
128 the C++ interface. It is designed to be minimally intrusive on your
129 C++ design. In most cases, you should not have to alter your C++
130 classes in any way in order to use them with Boost.Python. The system
131 should simply ``reflect'' your C++ classes and functions into Python.
132
133 %description python -l pl.UTF-8
134 Biblioteka Boost Python służy do szybkiego i prostego eksportu
135 biblioteki C++ do Pythona, tak że interfejs Pythona jest bardzo
136 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
137 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
138 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
139 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
140 klasy C++ i funkcje do Pythona.
141
142 %package python-devel
143 Summary:        Boost.Python development headers
144 Summary(pl.UTF-8):      Pliki nagłówkowe dla Boost.Python
145 Group:          Development/Libraries
146 Requires:       %{name}-devel = %{version}-%{release}
147 Requires:       %{name}-python = %{version}-%{release}
148
149 %description python-devel
150 Headers for the Boost.Python library.
151
152 %description python-devel -l pl.UTF-8
153 Pliki nagłówkowe dla biblioteki Boost.Python.
154
155 %package python-static
156 Summary:        Static version of Boost.Python library
157 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python
158 Group:          Development/Libraries
159 Requires:       %{name}-python-devel = %{version}-%{release}
160
161 %description python-static
162 Static version of Boost.Python library.
163
164 %description python-static -l pl.UTF-8
165 Statyczna wersja biblioteki Boost.Python.
166
167 %package chrono
168 Summary:        Useful time utilities
169 Group:          Libraries
170 Obsoletes:      boost < 1.33
171
172 %description chrono
173 Useful time utilities.
174
175 %package date_time
176 Summary:        Date-Time library
177 Summary(pl.UTF-8):      Biblioteka daty-czasu
178 Group:          Libraries
179 Obsoletes:      boost < 1.33
180
181 %description date_time
182 A set of date-time libraries.
183
184 %description date_time -l pl.UTF-8
185 Zbiór bibliotek daty-czasu.
186
187 %package filesystem
188 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
189 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
190 Group:          Libraries
191 Requires:       %{name}-system = %{version}-%{release}
192 Obsoletes:      boost < 1.33
193
194 %description filesystem
195 The boost::filesystem library provides portable facilities to query
196 and manipulate paths, files, and directories.
197
198 %description filesystem -l pl.UTF-8
199 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
200 operacjach na ścieżkach, plikach i katalogach.
201
202 %package graph
203 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
204 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
205 Group:          Libraries
206
207 %description graph
208 The boost::graph library provides portable facilities to operate on
209 graph data structures using graph algorithms.
210
211 %description graph -l pl.UTF-8
212 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
213 strukturach danych typu graf za pomocą algorytmów związanych z
214 grafami.
215
216 %package locale
217 Summary:        Provide localization and Unicode handling tools for C++
218 Group:          Libraries
219
220 %description locale
221 Provide localization and Unicode handling tools for C++.
222
223 %package program_options
224 Summary:        Access to program options, via conventional methods such as command line and config file
225 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
226 Group:          Libraries
227
228 %description program_options
229 The program_options library allows program developers to obtain
230 program options, that is (name, value) pairs from the user, via
231 conventional methods such as command line and config file.
232
233 %description program_options -l pl.UTF-8
234 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
235 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
236 jak linia poleceń, czy plik konfiguracyjny.
237
238 %package regex
239 Summary:        Boost C++ regular expressions library
240 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
241 Group:          Libraries
242
243 %description regex
244 Shared library for Boost C++ regular expressions.
245
246 %description regex -l pl.UTF-8
247 Biblioteka wyrażeń regularnych dla C++, biblioteki dzielone.
248
249 %package signals
250 Summary:        Signals & slots callback implementation
251 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
252 Group:          Libraries
253 Obsoletes:      boost < 1.33
254
255 %description signals
256 The boost::signals library is an implementation of a signals and slots
257 system.
258
259 %description signals -l pl.UTF-8
260 Biblioteka boost::signals jest implementacją systemu sygnałów i
261 slotów.
262
263 %package system
264 Summary:        Support for getting system specific error codes
265 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
266 Group:          Libraries
267
268 %description system
269 The Boost System library provides simple, light-weight error_code
270 objects that encapsulate system-specific error code values, yet also
271 provide access to more abstract and portable error conditions objects.
272
273 %description system -l pl.UTF-8
274 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
275 obudowujące wartości kodów błędów specyficznych dla systemu, dając
276 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
277 błędów.
278
279 %package test
280 Summary:        Support for program testing and execution monitoring
281 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
282 Group:          Libraries
283 Obsoletes:      boost < 1.33
284
285 %description test
286 Support for simple program testing, full unit testing, and for program
287 execution monitoring.
288
289 %description test -l pl.UTF-8
290 Wsparcie dla prostego testowania programu, pełnego testowania i
291 monitorowania wykonania programu.
292
293 %package timer
294 Summary:        Event timer, progress timer, and progress display classes
295 Group:          Libraries
296 Obsoletes:      boost < 1.33
297
298 %description timer
299 Event timer, progress timer, and progress display classes.
300
301 %package thread
302 Summary:        Portable C++ threads library
303 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
304 Group:          Libraries
305 Obsoletes:      boost < 1.33
306
307 %description thread
308 Portable C++ threads library - shared library.
309
310 %description thread -l pl.UTF-8
311 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
312
313 %package wave
314 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
315 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
316 Group:          Development/Libraries
317
318 %description wave
319 Boost.Wave - a standard compliant C++ preprocessor library.
320
321 %description wave -l pl.UTF-8
322 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
323
324 %package doc
325 Summary:        Boost C++ Library documentation
326 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
327 Group:          Documentation
328 Requires:       %{name}-devel = %{version}-%{release}
329
330 %description doc
331 Documentation for the Boost C++ Library.
332
333 %description doc -l pl.UTF-8
334 Dokumentacja dla biblioteki Boost C++.
335
336 %prep
337 %setup -q -n %{name}_%{fver}
338 %patch0 -p1
339
340 # - don't know how to pass it through (b)jam -s (no way?)
341 #   due to oversophisticated build flags system.
342 # - pass -fPIC due to <shared-linkable> removal.
343 %{__sed} -i "s/<optimization>speed : -O3/<optimization>speed : ${CXXFLAGS:-%rpmcxxflags} -fPIC/" tools/build/v2/tools/gcc.jam
344
345 # cleanup -g switch to avoid override debuginfocflags.
346 %{__sed} -i 's/<debug-symbols>on : -g/<debug-symbols>on :/' tools/build/v2/tools/gcc.jam
347 # link against shared expat library.
348 %{__sed} -i 's:find-static:find-shared:' libs/graph/build/Jamfile.v2
349
350 cat << EOF > tools/build/v2/user-config.jam
351 using gcc : %(%{__cxx} -dumpversion) : %{__cxx} ;
352 EOF
353
354 %build
355 %if %{with python}
356 PYTHON_VERSION=$(%{__python} -c 'import sys; print sys.version[0:3]')
357 PYTHON_ROOT=%{_prefix}
358 %else
359 PYTHON_ROOT=
360 PYTHON_VERSION=
361 %endif
362 EXPAT_INCLUDE=%{_includedir} \
363 EXPAT_LIBPATH=%{_libdir} \
364 ICU_PATH=%{_prefix} \
365 ./bootstrap.sh --prefix=%{_prefix}
366 ./b2 \
367         -d2 --toolset=gcc \
368         variant=release debug-symbols=on inlining=on link=static,shared threading=multi
369
370 %install
371 rm -rf $RPM_BUILD_ROOT
372 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
373
374 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
375
376 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
377 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
378 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
379
380 # documentation
381 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
382
383 # as the documentation doesn't completely reside in a directory of its
384 # own, we need to find out ourselves... this looks for HTML files and
385 # then collects everything linked from those.  this is certainly quite
386 # unoptimized wrt mkdir calls, but does it really matter?
387 installdocs() {
388 for i in $(find -type f -name '*.htm*'); do
389         # bjam docu is included in the boost-jam RPM
390         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
391                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
392                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
393                         sub rewrite_link
394                         {
395                                 my $link = shift;
396                                 # rewrite links from boost/* to %{_includedir}/boost/* and
397                                 # ignore external links as well as document-internal ones.
398                                 # HTML files are also ignored as they get installed anyway.
399                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
400                                 {
401                                         (my $file = $link) =~ s/\#.*//;
402                                         print "$file\n";
403                                 }
404                                 $link;
405                         }
406                         open IN, @ARGV[0];
407                         open OUT, ">@ARGV[1]";
408                         my $in_link;
409                         while (<IN>)
410                         {
411                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
412                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
413                                 print OUT;
414                                 $in_link = /href|src=\s*$/;
415                         }
416 EOT`; do
417                         TARGET=${i%/*}/$LINKED
418                         # ignore non-existant linked files
419                         if test -f $TARGET; then
420                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
421                         fi
422                 done
423         fi
424 done
425 }; installdocs
426
427 %clean
428 rm -rf $RPM_BUILD_ROOT
429
430 %post   -p /sbin/ldconfig
431 %postun -p /sbin/ldconfig
432
433 %post   chrono -p /sbin/ldconfig
434 %postun chrono -p /sbin/ldconfig
435
436 %post   date_time -p /sbin/ldconfig
437 %postun date_time -p /sbin/ldconfig
438
439 %post   filesystem -p /sbin/ldconfig
440 %postun filesystem -p /sbin/ldconfig
441
442 %post   graph -p /sbin/ldconfig
443 %postun graph -p /sbin/ldconfig
444
445 %post   locale -p /sbin/ldconfig
446 %postun locale -p /sbin/ldconfig
447
448 %post   python -p /sbin/ldconfig
449 %postun python -p /sbin/ldconfig
450
451 %post   program_options -p /sbin/ldconfig
452 %postun program_options -p /sbin/ldconfig
453
454 %post   regex -p /sbin/ldconfig
455 %postun regex -p /sbin/ldconfig
456
457 %post   signals -p /sbin/ldconfig
458 %postun signals -p /sbin/ldconfig
459
460 %post   system -p /sbin/ldconfig
461 %postun system -p /sbin/ldconfig
462
463 %post   test -p /sbin/ldconfig
464 %postun test -p /sbin/ldconfig
465
466 %post   wave -p /sbin/ldconfig
467 %postun wave -p /sbin/ldconfig
468
469 %post   timer -p /sbin/ldconfig
470 %postun timer -p /sbin/ldconfig
471
472 %post   thread -p /sbin/ldconfig
473 %postun thread -p /sbin/ldconfig
474
475 %files
476 %defattr(644,root,root,755)
477 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
478 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
479 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
480 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
481 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
482
483 %files devel
484 %defattr(644,root,root,755)
485 %attr(755,root,root) %{_libdir}/libboost_chrono.so
486 %attr(755,root,root) %{_libdir}/libboost_date_time.so
487 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
488 %attr(755,root,root) %{_libdir}/libboost_graph.so
489 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
490 %attr(755,root,root) %{_libdir}/libboost_locale.so
491 %attr(755,root,root) %{_libdir}/libboost_math_*.so
492 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
493 %attr(755,root,root) %{_libdir}/libboost_program_options.so
494 %attr(755,root,root) %{_libdir}/libboost_regex.so
495 %attr(755,root,root) %{_libdir}/libboost_random.so
496 %attr(755,root,root) %{_libdir}/libboost_serialization.so
497 %attr(755,root,root) %{_libdir}/libboost_signals.so
498 %attr(755,root,root) %{_libdir}/libboost_system.so
499 %attr(755,root,root) %{_libdir}/libboost_thread.so
500 %attr(755,root,root) %{_libdir}/libboost_timer.so
501 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
502 %attr(755,root,root) %{_libdir}/libboost_wave.so
503 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
504 %{_includedir}/boost
505 %exclude %{_includedir}/boost/python
506 %exclude %{_includedir}/boost/python.hpp
507
508 %files static
509 %defattr(644,root,root,755)
510 %{_libdir}/libboost_chrono.a
511 %{_libdir}/libboost_date_time.a
512 %{_libdir}/libboost_exception.a
513 %{_libdir}/libboost_filesystem.a
514 %{_libdir}/libboost_graph.a
515 %{_libdir}/libboost_iostreams.a
516 %{_libdir}/libboost_locale.a
517 %{_libdir}/libboost_math_*.a
518 %{_libdir}/libboost_prg_exec_monitor.a
519 %{_libdir}/libboost_program_options.a
520 %{_libdir}/libboost_random.a
521 %{_libdir}/libboost_regex.a
522 %{_libdir}/libboost_serialization.a
523 %{_libdir}/libboost_signals.a
524 %{_libdir}/libboost_system.a
525 %{_libdir}/libboost_test_exec_monitor.a
526 %{_libdir}/libboost_timer.a
527 %{_libdir}/libboost_thread.a
528 %{_libdir}/libboost_unit_test_framework.a
529 %{_libdir}/libboost_wave.a
530 %{_libdir}/libboost_wserialization.a
531
532 %if %{with python}
533 %files python
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
536
537 %files python-devel
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{_libdir}/libboost_python.so
540 %{_includedir}/boost/python
541 %{_includedir}/boost/python.hpp
542
543 %files python-static
544 %defattr(644,root,root,755)
545 %{_libdir}/libboost_python.a
546 %endif
547
548 %files chrono
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
551
552 %files date_time
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
555
556 %files filesystem
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
559
560 %files graph
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
563
564 %files locale
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
567
568 %files program_options
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
571
572 %files regex
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
575
576 %files signals
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
579
580 %files system
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
583
584 %files test
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
587 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
588
589 %files timer
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
592
593 %files thread
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
596
597 %files wave
598 %defattr(644,root,root,755)
599 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
600
601 %files doc
602 %defattr(644,root,root,755)
603 %{_docdir}/%{name}-%{version}
This page took 0.143212 seconds and 3 git commands to generate.