]> git.pld-linux.org Git - packages/boost.git/blame - boost.spec
- updated to 1.50
[packages/boost.git] / boost.spec
CommitLineData
c6874538 1#
bde731a5 2# TODO:
09e2803f
PS
3# - think about building MPI.
4# - split shared libs from core package into -iostreams/-serialization.
bde731a5 5#
c6874538 6# Conditional build:
65d4777a 7%bcond_without python # without boost-python support
c6874538 8#
8b623265 9%define fver %(echo %{version} | tr . _)
c6874538 10Summary: The Boost C++ Libraries
aa63c3d9 11Summary(pl.UTF-8): Biblioteki C++ "Boost"
49f48a3b 12Name: boost
17ef6e53
JR
13Version: 1.50.0
14Release: 0.1
db639b8e 15License: Boost Software License and others
c6874538 16Group: Libraries
8b623265 17Source0: http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
17ef6e53 18# Source0-md5: 52dd00be775e689f55a987baebccc462
8b623265 19Patch0: %{name}-link.patch
49f48a3b 20URL: http://www.boost.org/
afbf1450 21BuildRequires: bzip2-devel
09e2803f 22BuildRequires: expat-devel
7c12a8f9 23BuildRequires: libicu-devel
49f48a3b 24BuildRequires: libstdc++-devel
30964b71 25BuildRequires: perl-base
6725319f 26%{?with_python:BuildRequires: python-devel >= 2.2}
dbf04d57 27BuildRequires: rpm-pythonprov
afbf1450 28BuildRequires: zlib-devel
c6874538 29BuildConflicts: gcc = 5:3.3.1
49f48a3b 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
c6874538 31
32%description
33The Boost web site provides free peer-reviewed portable C++ source
34libraries. The emphasis is on libraries which work well with the C++
35Standard Library. One goal is to establish "existing practice" and
36provide reference implementations so that the Boost libraries are
37suitable for eventual standardization. Some of the libraries have
38already been proposed for inclusion in the C++ Standards Committee's
39upcoming C++ Standard Library Technical Report.
40
4c35df9e 41%description -l pl.UTF-8
49f48a3b 42Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
4c35df9e
JR
43kodem źródłowym. Nacisk położono na biblioteki, które dobrze
44współpracują ze standardową biblioteką C++. Celem jest ustanowienie
45"istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
46"Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
47już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
2b583775 48Raporcie Technicznym Biblioteki Standardowej C++.
c6874538 49
49f48a3b 50%package devel
000cd675 51Summary: Boost C++ development headers
aa63c3d9 52Summary(pl.UTF-8): Pliki nagłówkowe bibliotek C++ Boost
49f48a3b 53Group: Development/Libraries
000cd675 54Requires: %{name} = %{version}-%{release}
09e2803f
PS
55Requires: %{name}-date_time = %{version}-%{release}
56Requires: %{name}-filesystem = %{version}-%{release}
57Requires: %{name}-graph = %{version}-%{release}
58Requires: %{name}-program_options = %{version}-%{release}
59Requires: %{name}-regex = %{version}-%{release}
60Requires: %{name}-signals = %{version}-%{release}
69912bfb 61Requires: %{name}-system = %{version}-%{release}
09e2803f
PS
62Requires: %{name}-test = %{version}-%{release}
63Requires: %{name}-thread = %{version}-%{release}
64Requires: %{name}-wave = %{version}-%{release}
49f48a3b 65Requires: libstdc++-devel
09e2803f
PS
66Obsoletes: boost-any-devel
67Obsoletes: boost-array-devel
875f51e3 68Obsoletes: boost-asio
09e2803f 69Obsoletes: boost-bind-devel
05b0e240 70Obsoletes: boost-call_traits-devel
09e2803f 71Obsoletes: boost-compatibility-devel
470f1aae 72Obsoletes: boost-compose-devel
09e2803f 73Obsoletes: boost-compressed_pair-devel
89fd45a2
JB
74Obsoletes: boost-concept_check-devel
75Obsoletes: boost-conversion-devel
09e2803f
PS
76Obsoletes: boost-crc-devel
77Obsoletes: boost-date_time-devel
78Obsoletes: boost-filesystem-devel
79Obsoletes: boost-graph-devel
80Obsoletes: boost-mem_fn-devel
89fd45a2
JB
81Obsoletes: boost-mpl-devel
82Obsoletes: boost-preprocessor-devel
09e2803f 83Obsoletes: boost-program_options-devel
7c797e1a 84Obsoletes: boost-ref-devel
09e2803f
PS
85Obsoletes: boost-regex-devel
86Obsoletes: boost-signals-devel
87Obsoletes: boost-spirit-devel
88Obsoletes: boost-statechart-devel
89fd45a2 89Obsoletes: boost-static_assert-devel
09e2803f
PS
90Obsoletes: boost-test-devel
91Obsoletes: boost-thread-devel
92Obsoletes: boost-tr1-devel
89fd45a2 93Obsoletes: boost-type_traits-devel
09e2803f
PS
94Obsoletes: boost-typeof-devel
95Obsoletes: boost-uBLAS-devel
89fd45a2 96Obsoletes: boost-utility-devel
09e2803f
PS
97Obsoletes: boost-wave-devel
98Obsoletes: boost-xpressive-devel
49f48a3b
JB
99
100%description devel
000cd675 101Header files for the Boost C++ libraries.
49f48a3b 102
4c35df9e
JR
103%description devel -l pl.UTF-8
104Pliki nagłówkowe bibliotek C++ Boost.
000cd675
JB
105
106%package static
107Summary: Static version of base Boost C++ libraries
aa63c3d9 108Summary(pl.UTF-8): Statyczne wersje podstawowych bibliotek C++ Boost
000cd675
JB
109Group: Development/Libraries
110Requires: %{name}-devel = %{version}-%{release}
09e2803f 111Obsoletes: boost-static < 1.33
000cd675
JB
112
113%description static
114Static version of base Boost C++ libraries.
115
4c35df9e 116%description static -l pl.UTF-8
000cd675 117Statyczne wersje podstawowych bibliotek C++ Boost.
49f48a3b 118
c6874538 119%package python
120Summary: Boost.Python library
aa63c3d9 121Summary(pl.UTF-8): biblioteka Boost.Python
c6874538 122Group: Libraries
6725319f 123%pyrequires_eq python
c6874538 124
125%description python
126Use the Boost Python Library to quickly and easily export a C++
127library to Python such that the Python interface is very similar to
128the C++ interface. It is designed to be minimally intrusive on your
129C++ design. In most cases, you should not have to alter your C++
130classes in any way in order to use them with Boost.Python. The system
131should simply ``reflect'' your C++ classes and functions into Python.
132
4c35df9e
JR
133%description python -l pl.UTF-8
134Biblioteka Boost Python służy do szybkiego i prostego eksportu
135biblioteki C++ do Pythona, tak że interfejs Pythona jest bardzo
136podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
137narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
138większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
139żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
66ac0d93 140klasy C++ i funkcje do Pythona.
c6874538 141
142%package python-devel
143Summary: Boost.Python development headers
aa63c3d9 144Summary(pl.UTF-8): Pliki nagłówkowe dla Boost.Python
49f48a3b
JB
145Group: Development/Libraries
146Requires: %{name}-devel = %{version}-%{release}
6725319f 147Requires: %{name}-python = %{version}-%{release}
c6874538 148
149%description python-devel
66ac0d93 150Headers for the Boost.Python library.
c6874538 151
4c35df9e
JR
152%description python-devel -l pl.UTF-8
153Pliki nagłówkowe dla biblioteki Boost.Python.
c6874538 154
6725319f
JB
155%package python-static
156Summary: Static version of Boost.Python library
aa63c3d9 157Summary(pl.UTF-8): Statyczna wersja biblioteki Boost.Python
6725319f
JB
158Group: Development/Libraries
159Requires: %{name}-python-devel = %{version}-%{release}
160
161%description python-static
162Static version of Boost.Python library.
163
4c35df9e 164%description python-static -l pl.UTF-8
6725319f
JB
165Statyczna wersja biblioteki Boost.Python.
166
17e8d8c2
ŁK
167%package chrono
168Summary: Useful time utilities
169Group: Libraries
170Obsoletes: boost < 1.33
171
172%description chrono
173Useful time utilities.
174
02c23151 175%package date_time
d143171f 176Summary: Date-Time library
aa63c3d9 177Summary(pl.UTF-8): Biblioteka daty-czasu
02c23151 178Group: Libraries
000cd675 179Obsoletes: boost < 1.33
02c23151 180
181%description date_time
182A set of date-time libraries.
183
4c35df9e
JR
184%description date_time -l pl.UTF-8
185Zbiór bibliotek daty-czasu.
02c23151 186
31026e88 187%package filesystem
188Summary: Portable paths, iteration over directories, and other useful filesystem operations
aa63c3d9 189Summary(pl.UTF-8): Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
31026e88 190Group: Libraries
69912bfb 191Requires: %{name}-system = %{version}-%{release}
000cd675 192Obsoletes: boost < 1.33
31026e88 193
194%description filesystem
04846599
JB
195The boost::filesystem library provides portable facilities to query
196and manipulate paths, files, and directories.
31026e88 197
4c35df9e
JR
198%description filesystem -l pl.UTF-8
199Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
200operacjach na ścieżkach, plikach i katalogach.
31026e88 201
06ed6468
AM
202%package graph
203Summary: General purpose, generic C++ library for graph data structures and graph algorithms
204Summary(pl.UTF-8): Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
205Group: Libraries
206
207%description graph
208The boost::graph library provides portable facilities to operate on
209graph data structures using graph algorithms.
210
211%description graph -l pl.UTF-8
212Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
213strukturach danych typu graf za pomocą algorytmów związanych z
214grafami.
215
17e8d8c2
ŁK
216%package locale
217Summary: Provide localization and Unicode handling tools for C++
218Group: Libraries
219
220%description locale
221Provide localization and Unicode handling tools for C++.
222
99f4684a 223%package program_options
224Summary: Access to program options, via conventional methods such as command line and config file
aa63c3d9 225Summary(pl.UTF-8): Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
99f4684a 226Group: Libraries
227
228%description program_options
229The program_options library allows program developers to obtain
230program options, that is (name, value) pairs from the user, via
231conventional methods such as command line and config file.
232
4c35df9e
JR
233%description program_options -l pl.UTF-8
234Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
235programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
236jak linia poleceń, czy plik konfiguracyjny.
99f4684a 237
09e2803f
PS
238%package regex
239Summary: Boost C++ regular expressions library
240Summary(pl.UTF-8): Biblioteka wyrażeń regularnych Boost C++
241Group: Libraries
99f4684a 242
09e2803f
PS
243%description regex
244Shared library for Boost C++ regular expressions.
99f4684a 245
09e2803f
PS
246%description regex -l pl.UTF-8
247Biblioteka wyrażeń regularnych dla C++, biblioteki dzielone.
99f4684a 248
db639b8e 249%package signals
75f9f612 250Summary: Signals & slots callback implementation
aa63c3d9 251Summary(pl.UTF-8): Implementacja sygnałów i slotów
db639b8e 252Group: Libraries
000cd675 253Obsoletes: boost < 1.33
db639b8e 254
255%description signals
256The boost::signals library is an implementation of a signals and slots
257system.
258
4c35df9e
JR
259%description signals -l pl.UTF-8
260Biblioteka boost::signals jest implementacją systemu sygnałów i
261slotów.
db639b8e 262
09e2803f
PS
263%package system
264Summary: Support for getting system specific error codes
265Summary(pl.UTF-8): Wsparcie dla pobierania specyficznych dla systemu kodów błędów
266Group: Libraries
06ed6468 267
09e2803f
PS
268%description system
269The Boost System library provides simple, light-weight error_code
270objects that encapsulate system-specific error code values, yet also
271provide access to more abstract and portable error conditions objects.
0651a785 272
2b583775
JB
273%description system -l pl.UTF-8
274Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
275obudowujące wartości kodów błędów specyficznych dla systemu, dając
276jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
277błędów.
278
c0536c7f 279%package test
09e2803f 280Summary: Support for program testing and execution monitoring
aa63c3d9 281Summary(pl.UTF-8): Wsparcie dla testowania i monitorowania programu
c0536c7f 282Group: Libraries
000cd675 283Obsoletes: boost < 1.33
c0536c7f 284
285%description test
286Support for simple program testing, full unit testing, and for program
287execution monitoring.
288
4c35df9e
JR
289%description test -l pl.UTF-8
290Wsparcie dla prostego testowania programu, pełnego testowania i
c0536c7f 291monitorowania wykonania programu.
292
17e8d8c2
ŁK
293%package timer
294Summary: Event timer, progress timer, and progress display classes
295Group: Libraries
296Obsoletes: boost < 1.33
297
298%description timer
299Event timer, progress timer, and progress display classes.
300
02c23151 301%package thread
d143171f 302Summary: Portable C++ threads library
aa63c3d9 303Summary(pl.UTF-8): Przenośna biblioteka wątków C++
02c23151 304Group: Libraries
000cd675 305Obsoletes: boost < 1.33
02c23151 306
307%description thread
e4ddb7d1 308Portable C++ threads library - shared library.
02c23151 309
4c35df9e
JR
310%description thread -l pl.UTF-8
311Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
02c23151 312
06ed6468
AM
313%package wave
314Summary: Boost.Wave - a standard compliant C++ preprocessor library
315Summary(pl.UTF-8): Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
316Group: Development/Libraries
06ed6468
AM
317
318%description wave
319Boost.Wave - a standard compliant C++ preprocessor library.
320
321%description wave -l pl.UTF-8
322Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
323
c6874538 324%package doc
325Summary: Boost C++ Library documentation
aa63c3d9 326Summary(pl.UTF-8): Dokumentacja dla biblioteki Boost C++
49f48a3b 327Group: Documentation
b0977fb8 328Requires: %{name}-devel = %{version}-%{release}
c6874538 329
330%description doc
66ac0d93 331Documentation for the Boost C++ Library.
c6874538 332
4c35df9e 333%description doc -l pl.UTF-8
66ac0d93 334Dokumentacja dla biblioteki Boost C++.
c6874538 335
336%prep
8b623265 337%setup -q -n %{name}_%{fver}
09e2803f 338%patch0 -p1
c6874538 339
9b1806d5
PS
340# - don't know how to pass it through (b)jam -s (no way?)
341# due to oversophisticated build flags system.
342# - pass -fPIC due to <shared-linkable> removal.
0c1a0872 343%{__sed} -i "s/<optimization>speed : -O3/<optimization>speed : ${CXXFLAGS:-%rpmcxxflags} -fPIC/" tools/build/v2/tools/gcc.jam
09e2803f
PS
344
345# cleanup -g switch to avoid override debuginfocflags.
346%{__sed} -i 's/<debug-symbols>on : -g/<debug-symbols>on :/' tools/build/v2/tools/gcc.jam
347# link against shared expat library.
348%{__sed} -i 's:find-static:find-shared:' libs/graph/build/Jamfile.v2
502f5d36 349
09e2803f
PS
350cat << EOF > tools/build/v2/user-config.jam
351using gcc : %(%{__cxx} -dumpversion) : %{__cxx} ;
352EOF
353
c6874538 354%build
49f48a3b 355%if %{with python}
7c12a8f9 356PYTHON_VERSION=$(%{__python} -c 'import sys; print sys.version[0:3]')
c6874538 357PYTHON_ROOT=%{_prefix}
358%else
359PYTHON_ROOT=
360PYTHON_VERSION=
361%endif
09e2803f
PS
362EXPAT_INCLUDE=%{_includedir} \
363EXPAT_LIBPATH=%{_libdir} \
364ICU_PATH=%{_prefix} \
17e8d8c2
ŁK
365./bootstrap.sh --prefix=%{_prefix}
366./b2 \
9b1806d5 367 -d2 --toolset=gcc \
09e2803f 368 variant=release debug-symbols=on inlining=on link=static,shared threading=multi
9b1806d5 369
c6874538 370%install
371rm -rf $RPM_BUILD_ROOT
30964b71 372install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
c6874538 373
30964b71 374cp -rf boost $RPM_BUILD_ROOT%{_includedir}
c6874538 375
8b623265
JB
376install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
377install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
378cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
fa767695 379
c6874538 380# documentation
381install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
c6874538 382
383# as the documentation doesn't completely reside in a directory of its
384# own, we need to find out ourselves... this looks for HTML files and
385# then collects everything linked from those. this is certainly quite
386# unoptimized wrt mkdir calls, but does it really matter?
7c12a8f9
ER
387installdocs() {
388for i in $(find -type f -name '*.htm*'); do
c6874538 389 # bjam docu is included in the boost-jam RPM
390 if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
7c12a8f9 391 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
30964b71 392 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
c6874538 393 sub rewrite_link
394 {
395 my $link = shift;
396 # rewrite links from boost/* to %{_includedir}/boost/* and
397 # ignore external links as well as document-internal ones.
398 # HTML files are also ignored as they get installed anyway.
399 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
400 {
401 (my $file = $link) =~ s/\#.*//;
402 print "$file\n";
403 }
404 $link;
405 }
406 open IN, @ARGV[0];
407 open OUT, ">@ARGV[1]";
66ac0d93 408 my $in_link;
c6874538 409 while (<IN>)
410 {
66ac0d93 411 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
c6874538 412 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
413 print OUT;
d143171f 414 $in_link = /href|src=\s*$/;
c6874538 415 }
416EOT`; do
7c12a8f9 417 TARGET=${i%/*}/$LINKED
c6874538 418 # ignore non-existant linked files
419 if test -f $TARGET; then
7c12a8f9 420 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
c6874538 421 fi
422 done
423 fi
424done
7c12a8f9 425}; installdocs
c6874538 426
427%clean
428rm -rf $RPM_BUILD_ROOT
429
000cd675
JB
430%post -p /sbin/ldconfig
431%postun -p /sbin/ldconfig
432
17e8d8c2
ŁK
433%post chrono -p /sbin/ldconfig
434%postun chrono -p /sbin/ldconfig
435
3d8dd501
JB
436%post date_time -p /sbin/ldconfig
437%postun date_time -p /sbin/ldconfig
438
04846599
JB
439%post filesystem -p /sbin/ldconfig
440%postun filesystem -p /sbin/ldconfig
441
06ed6468
AM
442%post graph -p /sbin/ldconfig
443%postun graph -p /sbin/ldconfig
444
17e8d8c2
ŁK
445%post locale -p /sbin/ldconfig
446%postun locale -p /sbin/ldconfig
447
09e2803f
PS
448%post python -p /sbin/ldconfig
449%postun python -p /sbin/ldconfig
450
451%post program_options -p /sbin/ldconfig
452%postun program_options -p /sbin/ldconfig
c6874538 453
09e2803f
PS
454%post regex -p /sbin/ldconfig
455%postun regex -p /sbin/ldconfig
290ca6f4 456
09e2803f
PS
457%post signals -p /sbin/ldconfig
458%postun signals -p /sbin/ldconfig
c6874538 459
09e2803f
PS
460%post system -p /sbin/ldconfig
461%postun system -p /sbin/ldconfig
3d8dd501 462
09e2803f
PS
463%post test -p /sbin/ldconfig
464%postun test -p /sbin/ldconfig
c0536c7f 465
09e2803f
PS
466%post wave -p /sbin/ldconfig
467%postun wave -p /sbin/ldconfig
06ed6468 468
17e8d8c2
ŁK
469%post timer -p /sbin/ldconfig
470%postun timer -p /sbin/ldconfig
471
09e2803f
PS
472%post thread -p /sbin/ldconfig
473%postun thread -p /sbin/ldconfig
3d8dd501 474
000cd675
JB
475%files
476%defattr(644,root,root,755)
8b623265 477%attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
e019306a 478%attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
8b623265
JB
479%attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
480%attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
481%attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
000cd675 482
30964b71
JB
483%files devel
484%defattr(644,root,root,755)
17e8d8c2 485%attr(755,root,root) %{_libdir}/libboost_chrono.so
8b623265
JB
486%attr(755,root,root) %{_libdir}/libboost_date_time.so
487%attr(755,root,root) %{_libdir}/libboost_filesystem.so
488%attr(755,root,root) %{_libdir}/libboost_graph.so
489%attr(755,root,root) %{_libdir}/libboost_iostreams.so
17e8d8c2 490%attr(755,root,root) %{_libdir}/libboost_locale.so
e019306a 491%attr(755,root,root) %{_libdir}/libboost_math_*.so
8b623265
JB
492%attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
493%attr(755,root,root) %{_libdir}/libboost_program_options.so
494%attr(755,root,root) %{_libdir}/libboost_regex.so
495%attr(755,root,root) %{_libdir}/libboost_random.so
496%attr(755,root,root) %{_libdir}/libboost_serialization.so
497%attr(755,root,root) %{_libdir}/libboost_signals.so
498%attr(755,root,root) %{_libdir}/libboost_system.so
499%attr(755,root,root) %{_libdir}/libboost_thread.so
17e8d8c2 500%attr(755,root,root) %{_libdir}/libboost_timer.so
8b623265
JB
501%attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
502%attr(755,root,root) %{_libdir}/libboost_wave.so
503%attr(755,root,root) %{_libdir}/libboost_wserialization.so
504%{_includedir}/boost
505%exclude %{_includedir}/boost/python
506%exclude %{_includedir}/boost/python.hpp
99f4684a 507
000cd675
JB
508%files static
509%defattr(644,root,root,755)
17e8d8c2 510%{_libdir}/libboost_chrono.a
8b623265 511%{_libdir}/libboost_date_time.a
17e8d8c2 512%{_libdir}/libboost_exception.a
8b623265
JB
513%{_libdir}/libboost_filesystem.a
514%{_libdir}/libboost_graph.a
515%{_libdir}/libboost_iostreams.a
17e8d8c2 516%{_libdir}/libboost_locale.a
e019306a 517%{_libdir}/libboost_math_*.a
8b623265
JB
518%{_libdir}/libboost_prg_exec_monitor.a
519%{_libdir}/libboost_program_options.a
520%{_libdir}/libboost_random.a
521%{_libdir}/libboost_regex.a
522%{_libdir}/libboost_serialization.a
523%{_libdir}/libboost_signals.a
524%{_libdir}/libboost_system.a
525%{_libdir}/libboost_test_exec_monitor.a
17e8d8c2 526%{_libdir}/libboost_timer.a
8b623265
JB
527%{_libdir}/libboost_thread.a
528%{_libdir}/libboost_unit_test_framework.a
529%{_libdir}/libboost_wave.a
530%{_libdir}/libboost_wserialization.a
db639b8e 531
49f48a3b 532%if %{with python}
30964b71 533%files python
49f48a3b 534%defattr(644,root,root,755)
8b623265 535%attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
49f48a3b 536
30964b71 537%files python-devel
c6874538 538%defattr(644,root,root,755)
8b623265 539%attr(755,root,root) %{_libdir}/libboost_python.so
30964b71
JB
540%{_includedir}/boost/python
541%{_includedir}/boost/python.hpp
542
6725319f
JB
543%files python-static
544%defattr(644,root,root,755)
8b623265 545%{_libdir}/libboost_python.a
c6874538 546%endif
547
17e8d8c2
ŁK
548%files chrono
549%defattr(644,root,root,755)
550%attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
551
02c23151 552%files date_time
553%defattr(644,root,root,755)
8b623265 554%attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
02c23151 555
31026e88 556%files filesystem
557%defattr(644,root,root,755)
8b623265 558%attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
31026e88 559
06ed6468
AM
560%files graph
561%defattr(644,root,root,755)
8b623265 562%attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
06ed6468 563
17e8d8c2
ŁK
564%files locale
565%defattr(644,root,root,755)
566%attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
567
99f4684a 568%files program_options
569%defattr(644,root,root,755)
8b623265 570%attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
99f4684a 571
09e2803f 572%files regex
99f4684a 573%defattr(644,root,root,755)
8b623265 574%attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
99f4684a 575
db639b8e 576%files signals
577%defattr(644,root,root,755)
8b623265 578%attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
db639b8e 579
09e2803f 580%files system
db639b8e 581%defattr(644,root,root,755)
8b623265 582%attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
06ed6468 583
c0536c7f 584%files test
585%defattr(644,root,root,755)
8b623265
JB
586%attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
587%attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
c0536c7f 588
17e8d8c2
ŁK
589%files timer
590%defattr(644,root,root,755)
591%attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
592
02c23151 593%files thread
594%defattr(644,root,root,755)
8b623265 595%attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
02c23151 596
06ed6468
AM
597%files wave
598%defattr(644,root,root,755)
8b623265 599%attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
06ed6468 600
30964b71 601%files doc
fe815c68 602%defattr(644,root,root,755)
75f9f612 603%{_docdir}/%{name}-%{version}
This page took 0.186151 seconds and 4 git commands to generate.