]> git.pld-linux.org Git - packages/boost.git/blame - boost.spec
- rel.3
[packages/boost.git] / boost.spec
CommitLineData
c6874538 1#
bde731a5 2# TODO:
09e2803f
PS
3# - think about building MPI.
4# - split shared libs from core package into -iostreams/-serialization.
bde731a5 5#
c6874538 6# Conditional build:
65d4777a 7%bcond_without python # without boost-python support
c6874538 8#
09e2803f 9%define _fver %(echo %{version} | tr . _)
c6874538 10Summary: The Boost C++ Libraries
aa63c3d9 11Summary(pl.UTF-8): Biblioteki C++ "Boost"
49f48a3b 12Name: boost
09e2803f 13Version: 1.35.0
3ad2b52f 14Release: 3
db639b8e 15License: Boost Software License and others
c6874538 16Group: Libraries
db639b8e 17Source0: http://dl.sourceforge.net/boost/%{name}_%{_fver}.tar.bz2
09e2803f
PS
18# Source0-md5: dce952a7214e72d6597516bcac84048b
19Patch0: %{name}-climits.patch
49f48a3b 20URL: http://www.boost.org/
fe68e457 21BuildRequires: boost-jam >= 3.1.12
afbf1450 22BuildRequires: bzip2-devel
09e2803f 23BuildRequires: expat-devel
7c12a8f9 24BuildRequires: libicu-devel
49f48a3b 25BuildRequires: libstdc++-devel
30964b71 26BuildRequires: perl-base
6725319f 27%{?with_python:BuildRequires: python-devel >= 2.2}
dbf04d57 28BuildRequires: rpm-pythonprov
afbf1450 29BuildRequires: zlib-devel
c6874538 30BuildConflicts: gcc = 5:3.3.1
49f48a3b 31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
c6874538 32
33%description
34The Boost web site provides free peer-reviewed portable C++ source
35libraries. The emphasis is on libraries which work well with the C++
36Standard Library. One goal is to establish "existing practice" and
37provide reference implementations so that the Boost libraries are
38suitable for eventual standardization. Some of the libraries have
39already been proposed for inclusion in the C++ Standards Committee's
40upcoming C++ Standard Library Technical Report.
41
4c35df9e 42%description -l pl.UTF-8
49f48a3b 43Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
4c35df9e
JR
44kodem źródłowym. Nacisk położono na biblioteki, które dobrze
45współpracują ze standardową biblioteką C++. Celem jest ustanowienie
46"istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
47"Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
48już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
c6874538 49Raporcie Technicznym Biblioteki Standardowej C++
50
49f48a3b 51%package devel
000cd675 52Summary: Boost C++ development headers
aa63c3d9 53Summary(pl.UTF-8): Pliki nagłówkowe bibliotek C++ Boost
49f48a3b 54Group: Development/Libraries
000cd675 55Requires: %{name} = %{version}-%{release}
09e2803f
PS
56Requires: %{name}-date_time = %{version}-%{release}
57Requires: %{name}-filesystem = %{version}-%{release}
58Requires: %{name}-graph = %{version}-%{release}
59Requires: %{name}-program_options = %{version}-%{release}
60Requires: %{name}-regex = %{version}-%{release}
61Requires: %{name}-signals = %{version}-%{release}
69912bfb 62Requires: %{name}-system = %{version}-%{release}
09e2803f
PS
63Requires: %{name}-test = %{version}-%{release}
64Requires: %{name}-thread = %{version}-%{release}
65Requires: %{name}-wave = %{version}-%{release}
49f48a3b 66Requires: libstdc++-devel
09e2803f
PS
67Obsoletes: boost-any-devel
68Obsoletes: boost-array-devel
69Obsoletes: boost-bind-devel
05b0e240 70Obsoletes: boost-call_traits-devel
09e2803f 71Obsoletes: boost-compatibility-devel
470f1aae 72Obsoletes: boost-compose-devel
09e2803f 73Obsoletes: boost-compressed_pair-devel
89fd45a2
JB
74Obsoletes: boost-concept_check-devel
75Obsoletes: boost-conversion-devel
09e2803f
PS
76Obsoletes: boost-crc-devel
77Obsoletes: boost-date_time-devel
78Obsoletes: boost-filesystem-devel
79Obsoletes: boost-graph-devel
80Obsoletes: boost-mem_fn-devel
89fd45a2
JB
81Obsoletes: boost-mpl-devel
82Obsoletes: boost-preprocessor-devel
09e2803f 83Obsoletes: boost-program_options-devel
7c797e1a 84Obsoletes: boost-ref-devel
09e2803f
PS
85Obsoletes: boost-regex-devel
86Obsoletes: boost-signals-devel
87Obsoletes: boost-spirit-devel
88Obsoletes: boost-statechart-devel
89fd45a2 89Obsoletes: boost-static_assert-devel
09e2803f
PS
90Obsoletes: boost-test-devel
91Obsoletes: boost-thread-devel
92Obsoletes: boost-tr1-devel
89fd45a2 93Obsoletes: boost-type_traits-devel
09e2803f
PS
94Obsoletes: boost-typeof-devel
95Obsoletes: boost-uBLAS-devel
89fd45a2 96Obsoletes: boost-utility-devel
09e2803f
PS
97Obsoletes: boost-wave-devel
98Obsoletes: boost-xpressive-devel
49f48a3b
JB
99
100%description devel
000cd675 101Header files for the Boost C++ libraries.
49f48a3b 102
4c35df9e
JR
103%description devel -l pl.UTF-8
104Pliki nagłówkowe bibliotek C++ Boost.
000cd675
JB
105
106%package static
107Summary: Static version of base Boost C++ libraries
aa63c3d9 108Summary(pl.UTF-8): Statyczne wersje podstawowych bibliotek C++ Boost
000cd675
JB
109Group: Development/Libraries
110Requires: %{name}-devel = %{version}-%{release}
09e2803f 111Obsoletes: boost-static < 1.33
000cd675
JB
112
113%description static
114Static version of base Boost C++ libraries.
115
4c35df9e 116%description static -l pl.UTF-8
000cd675 117Statyczne wersje podstawowych bibliotek C++ Boost.
49f48a3b 118
c6874538 119%package python
120Summary: Boost.Python library
aa63c3d9 121Summary(pl.UTF-8): biblioteka Boost.Python
c6874538 122Group: Libraries
6725319f 123%pyrequires_eq python
c6874538 124
125%description python
126Use the Boost Python Library to quickly and easily export a C++
127library to Python such that the Python interface is very similar to
128the C++ interface. It is designed to be minimally intrusive on your
129C++ design. In most cases, you should not have to alter your C++
130classes in any way in order to use them with Boost.Python. The system
131should simply ``reflect'' your C++ classes and functions into Python.
132
4c35df9e
JR
133%description python -l pl.UTF-8
134Biblioteka Boost Python służy do szybkiego i prostego eksportu
135biblioteki C++ do Pythona, tak że interfejs Pythona jest bardzo
136podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
137narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
138większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
139żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
66ac0d93 140klasy C++ i funkcje do Pythona.
c6874538 141
142%package python-devel
143Summary: Boost.Python development headers
aa63c3d9 144Summary(pl.UTF-8): Pliki nagłówkowe dla Boost.Python
49f48a3b
JB
145Group: Development/Libraries
146Requires: %{name}-devel = %{version}-%{release}
6725319f 147Requires: %{name}-python = %{version}-%{release}
c6874538 148
149%description python-devel
66ac0d93 150Headers for the Boost.Python library.
c6874538 151
4c35df9e
JR
152%description python-devel -l pl.UTF-8
153Pliki nagłówkowe dla biblioteki Boost.Python.
c6874538 154
6725319f
JB
155%package python-static
156Summary: Static version of Boost.Python library
aa63c3d9 157Summary(pl.UTF-8): Statyczna wersja biblioteki Boost.Python
6725319f
JB
158Group: Development/Libraries
159Requires: %{name}-python-devel = %{version}-%{release}
160
161%description python-static
162Static version of Boost.Python library.
163
4c35df9e 164%description python-static -l pl.UTF-8
6725319f
JB
165Statyczna wersja biblioteki Boost.Python.
166
02c23151 167%package date_time
d143171f 168Summary: Date-Time library
aa63c3d9 169Summary(pl.UTF-8): Biblioteka daty-czasu
02c23151 170Group: Libraries
000cd675 171Obsoletes: boost < 1.33
02c23151 172
173%description date_time
174A set of date-time libraries.
175
4c35df9e
JR
176%description date_time -l pl.UTF-8
177Zbiór bibliotek daty-czasu.
02c23151 178
31026e88 179%package filesystem
180Summary: Portable paths, iteration over directories, and other useful filesystem operations
aa63c3d9 181Summary(pl.UTF-8): Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
31026e88 182Group: Libraries
69912bfb 183Requires: %{name}-system = %{version}-%{release}
000cd675 184Obsoletes: boost < 1.33
31026e88 185
186%description filesystem
04846599
JB
187The boost::filesystem library provides portable facilities to query
188and manipulate paths, files, and directories.
31026e88 189
4c35df9e
JR
190%description filesystem -l pl.UTF-8
191Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
192operacjach na ścieżkach, plikach i katalogach.
31026e88 193
06ed6468
AM
194%package graph
195Summary: General purpose, generic C++ library for graph data structures and graph algorithms
196Summary(pl.UTF-8): Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
197Group: Libraries
198
199%description graph
200The boost::graph library provides portable facilities to operate on
201graph data structures using graph algorithms.
202
203%description graph -l pl.UTF-8
204Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
205strukturach danych typu graf za pomocą algorytmów związanych z
206grafami.
207
99f4684a 208%package program_options
209Summary: Access to program options, via conventional methods such as command line and config file
aa63c3d9 210Summary(pl.UTF-8): Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
99f4684a 211Group: Libraries
212
213%description program_options
214The program_options library allows program developers to obtain
215program options, that is (name, value) pairs from the user, via
216conventional methods such as command line and config file.
217
4c35df9e
JR
218%description program_options -l pl.UTF-8
219Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
220programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
221jak linia poleceń, czy plik konfiguracyjny.
99f4684a 222
09e2803f
PS
223%package regex
224Summary: Boost C++ regular expressions library
225Summary(pl.UTF-8): Biblioteka wyrażeń regularnych Boost C++
226Group: Libraries
99f4684a 227
09e2803f
PS
228%description regex
229Shared library for Boost C++ regular expressions.
99f4684a 230
09e2803f
PS
231%description regex -l pl.UTF-8
232Biblioteka wyrażeń regularnych dla C++, biblioteki dzielone.
99f4684a 233
db639b8e 234%package signals
75f9f612 235Summary: Signals & slots callback implementation
aa63c3d9 236Summary(pl.UTF-8): Implementacja sygnałów i slotów
db639b8e 237Group: Libraries
000cd675 238Obsoletes: boost < 1.33
db639b8e 239
240%description signals
241The boost::signals library is an implementation of a signals and slots
242system.
243
4c35df9e
JR
244%description signals -l pl.UTF-8
245Biblioteka boost::signals jest implementacją systemu sygnałów i
246slotów.
db639b8e 247
09e2803f
PS
248%package system
249Summary: Support for getting system specific error codes
250Summary(pl.UTF-8): Wsparcie dla pobierania specyficznych dla systemu kodów błędów
251Group: Libraries
06ed6468 252
09e2803f
PS
253%description system
254The Boost System library provides simple, light-weight error_code
255objects that encapsulate system-specific error code values, yet also
256provide access to more abstract and portable error conditions objects.
0651a785 257
c0536c7f 258%package test
09e2803f 259Summary: Support for program testing and execution monitoring
aa63c3d9 260Summary(pl.UTF-8): Wsparcie dla testowania i monitorowania programu
c0536c7f 261Group: Libraries
000cd675 262Obsoletes: boost < 1.33
c0536c7f 263
264%description test
265Support for simple program testing, full unit testing, and for program
266execution monitoring.
267
4c35df9e
JR
268%description test -l pl.UTF-8
269Wsparcie dla prostego testowania programu, pełnego testowania i
c0536c7f 270monitorowania wykonania programu.
271
02c23151 272%package thread
d143171f 273Summary: Portable C++ threads library
aa63c3d9 274Summary(pl.UTF-8): Przenośna biblioteka wątków C++
02c23151 275Group: Libraries
000cd675 276Obsoletes: boost < 1.33
02c23151 277
278%description thread
e4ddb7d1 279Portable C++ threads library - shared library.
02c23151 280
4c35df9e
JR
281%description thread -l pl.UTF-8
282Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
02c23151 283
06ed6468
AM
284%package wave
285Summary: Boost.Wave - a standard compliant C++ preprocessor library
286Summary(pl.UTF-8): Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
287Group: Development/Libraries
06ed6468
AM
288
289%description wave
290Boost.Wave - a standard compliant C++ preprocessor library.
291
292%description wave -l pl.UTF-8
293Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
294
c6874538 295%package doc
296Summary: Boost C++ Library documentation
aa63c3d9 297Summary(pl.UTF-8): Dokumentacja dla biblioteki Boost C++
49f48a3b 298Group: Documentation
b0977fb8 299Requires: %{name}-devel = %{version}-%{release}
c6874538 300
301%description doc
66ac0d93 302Documentation for the Boost C++ Library.
c6874538 303
4c35df9e 304%description doc -l pl.UTF-8
66ac0d93 305Dokumentacja dla biblioteki Boost C++.
c6874538 306
307%prep
db639b8e 308%setup -q -n %{name}_%{_fver}
09e2803f 309%patch0 -p1
c6874538 310
9b1806d5
PS
311# - don't know how to pass it through (b)jam -s (no way?)
312# due to oversophisticated build flags system.
313# - pass -fPIC due to <shared-linkable> removal.
09e2803f
PS
314%{__sed} -i 's/<optimization>speed : -O3/<optimization>speed : %{rpmcxxflags} -fPIC/' tools/build/v2/tools/gcc.jam
315
316# cleanup -g switch to avoid override debuginfocflags.
317%{__sed} -i 's/<debug-symbols>on : -g/<debug-symbols>on :/' tools/build/v2/tools/gcc.jam
318# link against shared expat library.
319%{__sed} -i 's:find-static:find-shared:' libs/graph/build/Jamfile.v2
502f5d36 320
9b9b3ef7
JB
321%ifarch alpha
322# -pthread gcc parameter doesn't add _REENTRANT to cpp macros on alpha (only)
323# don't know, is it gcc bug or intentional omission?
324# anyway, boost check of -D_REENTRANT in its headers, so it's needed here
325%{__perl} -pi -e 's/(CFLAGS.*-pthread)/$1 -D_REENTRANT/' tools/build/v1/gcc-tools.jam
326%endif
327
09e2803f
PS
328cat << EOF > tools/build/v2/user-config.jam
329using gcc : %(%{__cxx} -dumpversion) : %{__cxx} ;
330EOF
331
c6874538 332%build
49f48a3b 333%if %{with python}
7c12a8f9 334PYTHON_VERSION=$(%{__python} -c 'import sys; print sys.version[0:3]')
c6874538 335PYTHON_ROOT=%{_prefix}
336%else
337PYTHON_ROOT=
338PYTHON_VERSION=
339%endif
09e2803f
PS
340EXPAT_INCLUDE=%{_includedir} \
341EXPAT_LIBPATH=%{_libdir} \
342ICU_PATH=%{_prefix} \
49f48a3b 343bjam \
9b1806d5 344 -d2 --toolset=gcc \
09e2803f 345 variant=release debug-symbols=on inlining=on link=static,shared threading=multi
9b1806d5 346
c6874538 347%install
348rm -rf $RPM_BUILD_ROOT
30964b71 349install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
c6874538 350
30964b71 351cp -rf boost $RPM_BUILD_ROOT%{_includedir}
c6874538 352
9b1806d5
PS
353install bin.v2/libs/*/build/gcc-*/release/debug-symbols-on/inlining-on/link-static/threading-multi/lib*.a $RPM_BUILD_ROOT%{_libdir}
354install bin.v2/libs/*/build/gcc-*/release/debug-symbols-on/inlining-on/threading-multi/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
fe815c68 355
8dcb94bd 356# create symlinks without -gccXX-mt-* things in names
9b1806d5 357for f in $RPM_BUILD_ROOT%{_libdir}/*.so.*.*.*; do
835aa2c4 358 [ -f "$f" ] || continue
fa767695 359 f=$(basename "$f")
8dcb94bd 360 soname=$(basename "$f" | sed -e 's#-gcc..-mt-.*#.so#g')
9b1806d5 361 ln -s "$f" "$RPM_BUILD_ROOT%{_libdir}/$soname"
fa767695
AM
362done
363for f in $RPM_BUILD_ROOT%{_libdir}/*.a; do
835aa2c4 364 [ -f "$f" ] || continue
fa767695 365 f=$(basename "$f")
8dcb94bd 366 soname=$(basename "$f" | sed -e 's#-gcc..-mt-.*#.a#g')
9b1806d5 367 ln -s "$f" "$RPM_BUILD_ROOT%{_libdir}/$soname"
fa767695
AM
368done
369
c6874538 370# documentation
371install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
c6874538 372
373# as the documentation doesn't completely reside in a directory of its
374# own, we need to find out ourselves... this looks for HTML files and
375# then collects everything linked from those. this is certainly quite
376# unoptimized wrt mkdir calls, but does it really matter?
7c12a8f9
ER
377installdocs() {
378for i in $(find -type f -name '*.htm*'); do
c6874538 379 # bjam docu is included in the boost-jam RPM
380 if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
7c12a8f9 381 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
30964b71 382 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
c6874538 383 sub rewrite_link
384 {
385 my $link = shift;
386 # rewrite links from boost/* to %{_includedir}/boost/* and
387 # ignore external links as well as document-internal ones.
388 # HTML files are also ignored as they get installed anyway.
389 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
390 {
391 (my $file = $link) =~ s/\#.*//;
392 print "$file\n";
393 }
394 $link;
395 }
396 open IN, @ARGV[0];
397 open OUT, ">@ARGV[1]";
66ac0d93 398 my $in_link;
c6874538 399 while (<IN>)
400 {
66ac0d93 401 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
c6874538 402 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
403 print OUT;
d143171f 404 $in_link = /href|src=\s*$/;
c6874538 405 }
406EOT`; do
7c12a8f9 407 TARGET=${i%/*}/$LINKED
c6874538 408 # ignore non-existant linked files
409 if test -f $TARGET; then
7c12a8f9 410 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
c6874538 411 fi
412 done
413 fi
414done
7c12a8f9 415}; installdocs
c6874538 416
417%clean
418rm -rf $RPM_BUILD_ROOT
419
000cd675
JB
420%post -p /sbin/ldconfig
421%postun -p /sbin/ldconfig
422
3d8dd501
JB
423%post date_time -p /sbin/ldconfig
424%postun date_time -p /sbin/ldconfig
425
04846599
JB
426%post filesystem -p /sbin/ldconfig
427%postun filesystem -p /sbin/ldconfig
428
06ed6468
AM
429%post graph -p /sbin/ldconfig
430%postun graph -p /sbin/ldconfig
431
09e2803f
PS
432%post python -p /sbin/ldconfig
433%postun python -p /sbin/ldconfig
434
435%post program_options -p /sbin/ldconfig
436%postun program_options -p /sbin/ldconfig
c6874538 437
09e2803f
PS
438%post regex -p /sbin/ldconfig
439%postun regex -p /sbin/ldconfig
290ca6f4 440
09e2803f
PS
441%post signals -p /sbin/ldconfig
442%postun signals -p /sbin/ldconfig
c6874538 443
09e2803f
PS
444%post system -p /sbin/ldconfig
445%postun system -p /sbin/ldconfig
3d8dd501 446
09e2803f
PS
447%post test -p /sbin/ldconfig
448%postun test -p /sbin/ldconfig
c0536c7f 449
09e2803f
PS
450%post wave -p /sbin/ldconfig
451%postun wave -p /sbin/ldconfig
06ed6468 452
09e2803f
PS
453%post thread -p /sbin/ldconfig
454%postun thread -p /sbin/ldconfig
3d8dd501 455
000cd675
JB
456%files
457%defattr(644,root,root,755)
458%attr(755,root,root) %{_libdir}/libboost_iostreams*.so.*.*.*
459%attr(755,root,root) %{_libdir}/libboost_serialization*.so.*.*.*
460%attr(755,root,root) %{_libdir}/libboost_wserialization*.so.*.*.*
461
30964b71
JB
462%files devel
463%defattr(644,root,root,755)
09e2803f
PS
464%{_includedir}/boost
465%attr(755,root,root) %{_libdir}/libboost_date_time*.so
466%attr(755,root,root) %{_libdir}/libboost_filesystem*.so
467%attr(755,root,root) %{_libdir}/libboost_graph*.so
000cd675 468%attr(755,root,root) %{_libdir}/libboost_iostreams*.so
09e2803f
PS
469%attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor*.so
470%attr(755,root,root) %{_libdir}/libboost_program_options*.so
471%attr(755,root,root) %{_libdir}/libboost_regex*.so
000cd675 472%attr(755,root,root) %{_libdir}/libboost_serialization*.so
09e2803f
PS
473%attr(755,root,root) %{_libdir}/libboost_signals*.so
474%attr(755,root,root) %{_libdir}/libboost_system*.so
475%attr(755,root,root) %{_libdir}/libboost_thread*.so
476%attr(755,root,root) %{_libdir}/libboost_unit_test_framework*.so
477%attr(755,root,root) %{_libdir}/libboost_wave*.so
000cd675 478%attr(755,root,root) %{_libdir}/libboost_wserialization*.so
99f4684a 479
000cd675
JB
480%files static
481%defattr(644,root,root,755)
09e2803f
PS
482%{_libdir}/libboost_date_time*.a
483%{_libdir}/libboost_filesystem*.a
484%{_libdir}/libboost_grap*.a
000cd675 485%{_libdir}/libboost_iostreams*.a
09e2803f
PS
486%{_libdir}/libboost_prg_exec_monitor*.a
487%{_libdir}/libboost_program_options*.a
488%{_libdir}/libboost_regex*.a
99f4684a 489%{_libdir}/libboost_serialization*.a
09e2803f
PS
490%{_libdir}/libboost_signals*.a
491%{_libdir}/libboost_system*.a
492%{_libdir}/libboost_test_exec_monitor*.a
493%{_libdir}/libboost_thread*.a
494%{_libdir}/libboost_unit_test_framework*.a
495%{_libdir}/libboost_wave*.a
99f4684a 496%{_libdir}/libboost_wserialization*.a
db639b8e 497
49f48a3b 498%if %{with python}
30964b71 499%files python
49f48a3b 500%defattr(644,root,root,755)
fa767695 501%attr(755,root,root) %{_libdir}/libboost_python*.so.*.*.*
49f48a3b 502
30964b71 503%files python-devel
c6874538 504%defattr(644,root,root,755)
fa767695 505%attr(755,root,root) %{_libdir}/libboost_python*.so
30964b71
JB
506%{_includedir}/boost/python
507%{_includedir}/boost/python.hpp
508
6725319f
JB
509%files python-static
510%defattr(644,root,root,755)
fa767695 511%{_libdir}/libboost_python*.a
c6874538 512%endif
513
02c23151 514%files date_time
515%defattr(644,root,root,755)
fa767695 516%attr(755,root,root) %{_libdir}/libboost_date_time*.so.*.*.*
02c23151 517
31026e88 518%files filesystem
519%defattr(644,root,root,755)
fa767695 520%attr(755,root,root) %{_libdir}/libboost_filesystem*.so.*.*.*
31026e88 521
06ed6468
AM
522%files graph
523%defattr(644,root,root,755)
524%attr(755,root,root) %{_libdir}/libboost_graph*.so.*.*.*
525
99f4684a 526%files program_options
527%defattr(644,root,root,755)
528%attr(755,root,root) %{_libdir}/libboost_program_options*.so.*.*.*
529
09e2803f 530%files regex
99f4684a 531%defattr(644,root,root,755)
09e2803f 532%attr(755,root,root) %{_libdir}/libboost_regex*.so.*.*.*
99f4684a 533
db639b8e 534%files signals
535%defattr(644,root,root,755)
fa767695 536%attr(755,root,root) %{_libdir}/libboost_signals*.so.*.*.*
db639b8e 537
09e2803f 538%files system
db639b8e 539%defattr(644,root,root,755)
09e2803f 540%attr(755,root,root) %{_libdir}/libboost_system*.so.*.*.*
06ed6468 541
c0536c7f 542%files test
543%defattr(644,root,root,755)
fa767695 544%attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor*.so.*.*.*
fa767695 545%attr(755,root,root) %{_libdir}/libboost_unit_test_framework*.so.*.*.*
c0536c7f 546
02c23151 547%files thread
548%defattr(644,root,root,755)
fa767695 549%attr(755,root,root) %{_libdir}/libboost_thread*.so.*.*.*
02c23151 550
06ed6468
AM
551%files wave
552%defattr(644,root,root,755)
553%attr(755,root,root) %{_libdir}/libboost_wave*.so.*.*.*
554
30964b71 555%files doc
fe815c68 556%defattr(644,root,root,755)
75f9f612 557%{_docdir}/%{name}-%{version}
This page took 0.252847 seconds and 4 git commands to generate.