]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- restore overwritten compiler flags (fixes #129)
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - enable OpenAL support
4 # - libsolid/libqhull/libode BR ?
5 # - package python scripts
6 Summary:        3D modeling, rendering, animation and game creation package
7 Summary(pl.UTF-8):      Pakiet do tworzenia animacji 3D oraz gier
8 Name:           blender
9 Version:        2.45
10 Release:        3
11 License:        GPL
12 Group:          X11/Applications/Graphics
13 Source0:        http://download.blender.org/source/%{name}-%{version}.tar.gz
14 # Source0-md5:  1358ca481b7f2b8eadd3327ebbd563ef
15 Source1:        %{name}.desktop
16 Source2:        %{name}.png
17 Source4:        %{name}-wrapper
18 Source5:        %{name}.manpage
19 Patch0:         %{name}-po_and_locale_names.patch
20 Patch1:         %{name}-noxml-yafray.patch
21 URL:            http://www.blender.org/
22 BuildRequires:  OpenEXR-devel
23 BuildRequires:  OpenGL-devel
24 BuildRequires:  SDL-devel
25 BuildRequires:  gcc >= 5:3.4.0
26 BuildRequires:  freealut-devel
27 BuildRequires:  freetype-devel
28 BuildRequires:  ftgl-devel
29 BuildRequires:  gettext-devel
30 #BuildRequires: esound-devel
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libpng-devel
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtiff-devel
35 BuildRequires:  libtool
36 BuildRequires:  libvorbis-devel
37 BuildRequires:  openssl-devel >= 0.9.7d
38 BuildRequires:  python-devel >= 1:2.3
39 BuildRequires:  scons
40 BuildRequires:  sed >= 4.0
41 #BuildRequires: smpeg-devel
42 BuildRequires:  zlib-devel
43 Requires:       OpenGL
44 Requires:       freetype
45 Requires:       python-modules
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
49
50 %description
51 Blender is a free and fully functional 3D modeling, rendering,
52 animation and game creation package for Unix, Windows and BeOS
53 systems.
54
55 %description -l pl.UTF-8
56 Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
57 3D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62 %patch1 -p1
63 mv -f po/pt_{br,BR}.po
64
65 rm -f missing
66 rm -f user-config.py
67
68 RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
69 RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
70
71 cat > user-config.py <<END
72 CCFLAGS           = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
73 CXXFLAGS          = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
74 LDFLAGS           = [$RPMLDFLAGS]
75 TARGET_CC         = '%{__cc}'
76 TARGET_CXX        = '%{__cxx}'
77
78 BF_PYTHON_VERSION = '%{py_ver}'
79
80 LCGDIR            = 'lib/linux2'
81 BF_BUILDDIR       = 'build/linux2'
82 BF_INSTALLDIR     = 'install/linux2'
83 END
84
85 %build
86 scons BF_OPENGL_LIBPATH=%{_x_libraries}
87 %{__make} -C po OCGDIR=..
88
89 install -d release/plugins/include
90 install source/blender/blenpluginapi/*.h release/plugins/include
91 chmod +x release/plugins/bmake
92 %{__make} -C release/plugins/
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}} \
97         $RPM_BUILD_ROOT%{_datadir}/blender/bpydata
98
99 install ./install/linux2/blender $RPM_BUILD_ROOT%{_bindir}/blender-bin
100 install %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/blender
101 #install blenderplayer $RPM_BUILD_ROOT%{_bindir}
102 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
103 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
104 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
105 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
106 install ./release/plugins/sequence/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
107 install ./release/plugins/texture/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
108 install -d $RPM_BUILD_ROOT%{_datadir}/blender
109 cp -aR ./release/scripts $RPM_BUILD_ROOT%{_datadir}/blender
110 install ./release/VERSION $RPM_BUILD_ROOT%{_datadir}/blender
111 install ./bin/.blender/.Blanguages $RPM_BUILD_ROOT%{_datadir}/blender
112 install ./bin/.blender/.bfont.ttf $RPM_BUILD_ROOT%{_datadir}/blender
113 cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}/blender
114 install -d $RPM_BUILD_ROOT%{_mandir}/man1
115 install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt
123 %doc release/text/{blender.html,release*.txt}
124 %attr(755,root,root) %{_bindir}/*
125 %attr(755,root,root) %{_datadir}/%{name}
126 %attr(755,root,root) %{_libdir}/%{name}
127 %{_desktopdir}/*.desktop
128 %{_pixmapsdir}/*.png
129 %{_mandir}/man1/*
This page took 0.130434 seconds and 3 git commands to generate.