]> git.pld-linux.org Git - packages/blender.git/blame - blender.spec
- restore overwritten compiler flags (fixes #129)
[packages/blender.git] / blender.spec
CommitLineData
38c09fc8
AF
1# TODO:
2# - enable internalization support (BR libftgl)
3# - enable OpenAL support
4# - libsolid/libqhull/libode BR ?
5# - package python scripts
4d72b1dc 6Summary: 3D modeling, rendering, animation and game creation package
3701d8b9 7Summary(pl.UTF-8): Pakiet do tworzenia animacji 3D oraz gier
4d72b1dc 8Name: blender
c942c06a 9Version: 2.45
cbc6c68b 10Release: 3
d2866530 11License: GPL
12Group: X11/Applications/Graphics
e9e23885 13Source0: http://download.blender.org/source/%{name}-%{version}.tar.gz
c942c06a 14# Source0-md5: 1358ca481b7f2b8eadd3327ebbd563ef
dfc2b368 15Source1: %{name}.desktop
16Source2: %{name}.png
aeb8eec7 17Source4: %{name}-wrapper
b643ae44 18Source5: %{name}.manpage
a374ab50 19Patch0: %{name}-po_and_locale_names.patch
aeb8eec7 20Patch1: %{name}-noxml-yafray.patch
b98aa62c 21URL: http://www.blender.org/
ef63d3ab 22BuildRequires: OpenEXR-devel
9605d1bf 23BuildRequires: OpenGL-devel
24BuildRequires: SDL-devel
8a655622 25BuildRequires: gcc >= 5:3.4.0
fdc7d606 26BuildRequires: freealut-devel
7bc683ce 27BuildRequires: freetype-devel
f313c0b5 28BuildRequires: ftgl-devel
fdc7d606 29BuildRequires: gettext-devel
42794eef 30#BuildRequires: esound-devel
9605d1bf 31BuildRequires: libjpeg-devel
32BuildRequires: libpng-devel
dfc2b368 33BuildRequires: libstdc++-devel
fdc7d606 34BuildRequires: libtiff-devel
ff884909 35BuildRequires: libtool
dfc2b368 36BuildRequires: libvorbis-devel
2a53466d 37BuildRequires: openssl-devel >= 0.9.7d
72944b38 38BuildRequires: python-devel >= 1:2.3
38c09fc8 39BuildRequires: scons
dd78d76e 40BuildRequires: sed >= 4.0
42794eef 41#BuildRequires: smpeg-devel
9605d1bf 42BuildRequires: zlib-devel
ff884909 43Requires: OpenGL
7bc683ce 44Requires: freetype
2c0478d0 45Requires: python-modules
4d72b1dc
JK
46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48%define _noautoreqdep libGL.so.1 libGLU.so.1
4d72b1dc
JK
49
50%description
51Blender is a free and fully functional 3D modeling, rendering,
52animation and game creation package for Unix, Windows and BeOS
9071f685 53systems.
4d72b1dc 54
d3ad026c
JR
55%description -l pl.UTF-8
56Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
573D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
4d72b1dc
JK
58
59%prep
811f0f5d 60%setup -q
a374ab50 61%patch0 -p1
e73b0ea3 62%patch1 -p1
a374ab50 63mv -f po/pt_{br,BR}.po
4d72b1dc 64
dfc2b368 65rm -f missing
811f0f5d 66rm -f user-config.py
8e17c17b 67
38c09fc8
AF
68RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
69RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
70
811f0f5d 71cat > user-config.py <<END
cbc6c68b
MB
72CCFLAGS = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
73CXXFLAGS = [$RPMCFLAGS, "-funsigned-char", "-fPIC"]
811f0f5d 74LDFLAGS = [$RPMLDFLAGS]
75TARGET_CC = '%{__cc}'
76TARGET_CXX = '%{__cxx}'
38c09fc8 77
28353fda 78BF_PYTHON_VERSION = '%{py_ver}'
811f0f5d 79
80LCGDIR = 'lib/linux2'
81BF_BUILDDIR = 'build/linux2'
82BF_INSTALLDIR = 'install/linux2'
83END
f99bddf4 84
c3538bdb 85%build
8a655622 86scons BF_OPENGL_LIBPATH=%{_x_libraries}
71a78563 87%{__make} -C po OCGDIR=..
4d72b1dc 88
aeb8eec7 89install -d release/plugins/include
dd78d76e 90install source/blender/blenpluginapi/*.h release/plugins/include
aeb8eec7 91chmod +x release/plugins/bmake
23e28f47 92%{__make} -C release/plugins/
aeb8eec7 93
4d72b1dc
JK
94%install
95rm -rf $RPM_BUILD_ROOT
811f0f5d 96install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}} \
97 $RPM_BUILD_ROOT%{_datadir}/blender/bpydata
dfc2b368 98
811f0f5d 99install ./install/linux2/blender $RPM_BUILD_ROOT%{_bindir}/blender-bin
dd78d76e 100install %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/blender
811f0f5d 101#install blenderplayer $RPM_BUILD_ROOT%{_bindir}
dd78d76e 102install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
103install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
aeb8eec7
GJ
104install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
105install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
23e28f47
GJ
106install ./release/plugins/sequence/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
107install ./release/plugins/texture/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
dd78d76e 108install -d $RPM_BUILD_ROOT%{_datadir}/blender
4cdc09f2 109cp -aR ./release/scripts $RPM_BUILD_ROOT%{_datadir}/blender
dd78d76e 110install ./release/VERSION $RPM_BUILD_ROOT%{_datadir}/blender
111install ./bin/.blender/.Blanguages $RPM_BUILD_ROOT%{_datadir}/blender
112install ./bin/.blender/.bfont.ttf $RPM_BUILD_ROOT%{_datadir}/blender
aeb8eec7 113cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}/blender
b643ae44 114install -d $RPM_BUILD_ROOT%{_mandir}/man1
23e28f47 115install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
7bc683ce 116
4d72b1dc
JK
117%clean
118rm -rf $RPM_BUILD_ROOT
119
aeb8eec7 120%files
4d72b1dc 121%defattr(644,root,root,755)
7bc683ce 122%doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt
38c09fc8 123%doc release/text/{blender.html,release*.txt}
9605d1bf 124%attr(755,root,root) %{_bindir}/*
961f6430 125%attr(755,root,root) %{_datadir}/%{name}
126%attr(755,root,root) %{_libdir}/%{name}
98471f49 127%{_desktopdir}/*.desktop
128%{_pixmapsdir}/*.png
b643ae44 129%{_mandir}/man1/*
This page took 0.102289 seconds and 4 git commands to generate.