]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- updated to 3.6.11 LTS (fixes build with OpenColorIO 2.3.x)
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - DRACO (requires WITH_PYTHON_INSTALL?)
4 # - OSL, Cycles
5 # - Alembic
6 # - USD
7 # - OpenImageDenoise
8 # - OpenSubdiv
9 # - OptiX >= 7.3.0
10 # - NanoVDB
11 # - OpenPGL
12 #
13 # Conditional build:
14 %bcond_without  openvdb # OpenVDB support
15
16 Summary:        3D modeling, rendering, animation and game creation package
17 Summary(pl.UTF-8):      Pakiet do tworzenia animacji 3D oraz gier
18 Name:           blender
19 # beware: don't use 3.3.17+, they have all the libs packaged (0.5GB compressed)
20 Version:        3.6.11
21 Release:        1
22 License:        GPL v2+
23 Group:          X11/Applications/Graphics
24 Source0:        https://download.blender.org/source/%{name}-%{version}.tar.xz
25 # Source0-md5:  32ec8c8403ead5e843edc1a26bdecb03
26 Patch0:         %{name}-2.76-droid.patch
27 Patch1:         format-security.patch
28 URL:            https://www.blender.org/
29 BuildRequires:  OpenAL-devel
30 BuildRequires:  OpenCOLLADA-devel
31 BuildRequires:  OpenColorIO-devel >= 2.0.0
32 BuildRequires:  OpenEXR-devel
33 BuildRequires:  OpenGL-devel
34 BuildRequires:  OpenGL-GLU-devel
35 BuildRequires:  OpenImageIO-devel
36 BuildRequires:  OpenXR-devel
37 BuildRequires:  SDL2-devel
38 BuildRequires:  boost-devel >= 1.48
39 BuildRequires:  cmake >= 3.10
40 BuildRequires:  embree-devel >= 3.8.0
41 BuildRequires:  ffmpeg-devel >= 0.4.9-4.20080930.1
42 BuildRequires:  fftw3-devel >= 3
43 BuildRequires:  freealut-devel
44 BuildRequires:  freetype-devel >= 2
45 BuildRequires:  ftgl-devel
46 BuildRequires:  gcc >= 5:3.4.0
47 BuildRequires:  gettext-tools
48 BuildRequires:  gmp-devel
49 BuildRequires:  jack-audio-connection-kit-devel
50 BuildRequires:  jemalloc-devel
51 BuildRequires:  libdecor-devel >= 0.1
52 BuildRequires:  libepoxy-devel
53 BuildRequires:  libgomp-devel
54 BuildRequires:  libharu-devel
55 BuildRequires:  libjpeg-devel
56 BuildRequires:  libpng-devel
57 BuildRequires:  libsndfile-devel
58 BuildRequires:  libspnav-devel
59 BuildRequires:  libstdc++-devel
60 BuildRequires:  libtiff-devel
61 BuildRequires:  libvorbis-devel
62 BuildRequires:  libwebp-devel
63 BuildRequires:  libxml2-devel >= 2.0
64 BuildRequires:  openjpeg2-devel >= 2
65 %{?with_openvdb:BuildRequires:  openvdb-devel}
66 BuildRequires:  openssl-devel >= 0.9.7d
67 BuildRequires:  pcre-devel
68 BuildRequires:  pkgconfig
69 BuildRequires:  potrace-devel
70 BuildRequires:  pugixml-devel
71 BuildRequires:  pulseaudio-devel
72 BuildRequires:  python3 >= 1:3.10
73 BuildRequires:  python3-devel >= 1:3.10
74 BuildRequires:  python3-numpy-devel
75 BuildRequires:  rpm-pythonprov
76 BuildRequires:  rpmbuild(macros) >= 1.605
77 BuildRequires:  sed >= 4.0
78 BuildRequires:  tar >= 1:1.22
79 BuildRequires:  tbb-devel
80 # wayland-client, wayland-cursor, wayland-scanner
81 BuildRequires:  wayland-devel >= 1.12
82 BuildRequires:  wayland-egl-devel
83 BuildRequires:  wayland-protocols >= 1.31
84 BuildRequires:  xorg-lib-libX11-devel
85 BuildRequires:  xorg-lib-libXext-devel
86 BuildRequires:  xorg-lib-libXi-devel
87 BuildRequires:  xorg-lib-libxkbcommon-devel
88 BuildRequires:  xz
89 BuildRequires:  zlib-devel
90 BuildRequires:  zstd-devel
91 Requires(post,postun):  desktop-file-utils
92 Requires:       OpenGL
93 Requires:       python3-modules >= 1:3.10
94 ExclusiveArch:  %{x8664}
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %description
98 Blender is a free and fully functional 3D modeling, rendering,
99 animation and game creation package for Unix, Windows and BeOS
100 systems.
101
102 %description -l pl.UTF-8
103 Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
104 3D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p1
110
111 # /usr/bin/env python3
112 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' \
113         scripts/addons/io_curve_svg/svg_util_test.py \
114         scripts/addons/io_scene_fbx/fbx2json.py \
115         scripts/addons/io_scene_fbx/json2fbx.py \
116         scripts/modules/bl_i18n_utils/merge_po.py \
117         scripts/modules/bl_i18n_utils/utils_rtl.py \
118         scripts/modules/blend_render_info.py
119
120 %build
121 install -d build
122 cd build
123 %cmake \
124         -DBOOST_ROOT=%{_prefix} \
125         -DBUILD_SHARED_LIBS:BOOL=OFF \
126         -DCMAKE_SKIP_RPATH:BOOL=ON \
127         -DPYTHON_VERSION:STRING=%{py3_ver} \
128         -DWITH_CODEC_FFMPEG:BOOL=ON \
129         -DWITH_CODEC_SNDFILE:BOOL=ON \
130         -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
131         -DWITH_CYCLES:BOOL=ON \
132         -DWITH_FFTW3:BOOL=ON \
133         -DWITH_IMAGE_OPENJPEG:BOOL=ON \
134         -DWITH_INPUT_NDOF:BOOL=ON \
135         -DWITH_INSTALL_PORTABLE:BOOL=OFF \
136         -DWITH_JACK:BOOL=ON \
137         -DWITH_JACK_DYNLOAD:BOOL=ON \
138         -DWITH_MEM_JEMALLOC:BOOL=ON \
139         -DWITH_MOD_OCEANSIM:BOOL=ON \
140         -DWITH_OPENCOLLADA:BOOL=ON \
141         -DWITH_OPENCOLORIO:BOOL=ON \
142         %{!?with_openvdb:-DWITH_OPENVDB:BOOL=OFF} \
143         -DWITH_PYTHON:BOOL=ON \
144         -DWITH_PYTHON_INSTALL:BOOL=OFF \
145         -DWITH_PYTHON_SAFETY:BOOL=ON \
146         -DWITH_SDL:BOOL=ON \
147         -DWITH_SDL_DYNLOAD:BOOL=ON \
148         ..
149
150 %{__make} V=1
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
155
156 %{__make} -C build install \
157         DESTDIR=$RPM_BUILD_ROOT
158
159 ./doc/manpage/blender.1.py \
160         --blender $RPM_BUILD_ROOT%{_bindir}/blender \
161         --output $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
162
163 #%find_lang %{name}
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post
169 %update_desktop_database_post
170
171 %postun
172 %update_desktop_database_postun
173
174 %files
175 %defattr(644,root,root,755)
176 # -f %{name}.lang
177 %doc doc/license/bf-members.txt doc/guides/*.txt
178 %attr(755,root,root) %{_bindir}/blender
179 %attr(755,root,root) %{_bindir}/blender-thumbnailer
180 %attr(755,root,root) %{_datadir}/%{name}
181 %{_desktopdir}/blender.desktop
182 %{_iconsdir}/hicolor/scalable/apps/blender.svg
183 %{_iconsdir}/hicolor/symbolic/apps/blender-symbolic.svg
184 %{_mandir}/man1/blender.1*
This page took 0.067228 seconds and 4 git commands to generate.