]> git.pld-linux.org Git - packages/bitlbee.git/blob - bitlbee.spec
- enable skype protocol plugin
[packages/bitlbee.git] / bitlbee.spec
1 # TODO
2 # - sync pl
3 # - bilbee user
4 #
5 # Conditional build:
6 %bcond_without  otr             # build without OTR
7
8 Summary:        An IRC to other chat networks gateway
9 Summary(pl.UTF-8):      Bramka pomiędzy IRC-em i innymi sieciami komunikacyjnymi
10 Name:           bitlbee
11 Version:        3.0.5
12 Release:        0.6
13 License:        GPL v2+ and MIT
14 Group:          Daemons
15 Source0:        http://get.bitlbee.org/src/%{name}-%{version}.tar.gz
16 # Source0-md5:  9ff97260a2a7f3a7d102db158a8d9887
17 URL:            http://www.bitlbee.org/
18 BuildRequires:  asciidoc
19 BuildRequires:  gnutls-devel
20 %{?with_otr:BuildRequires:      libotr-devel >= 3.2.0}
21 BuildRequires:  systemd-units
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Bitlbee is an IRC to other chat networks gateway. Bitlbee can be used
26 as an IRC server which forwards everything you say to people on other
27 chat networks like ICQ/AIM, MSN, XMPP/Jabber (including Google Talk),
28 Yahoo or Twitter!
29
30 %description -l pl.UTF-8
31 Bramka pomiędzy IRC-em i innymi sieciami komunikacyjnymi. Ten program
32 może być używany jako serwer IRC przekazujący wszystko co się mówi do
33 ludzi korzystających z innych sieci komunikacyjnych, takich jak
34 MSN/ICQ/Jabber.
35
36 %package devel
37 Summary:        Development files for bitlbee
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 The bitlbee-devel package includes header files necessary for building
43 and developing programs and plugins which use bitlbee.
44
45 %package otr
46 Summary:        OTR plugin for bitlbee
47 Group:          Daemons
48 Requires:       %{name} = %{version}-%{release}
49
50 %description otr
51 The bitlbee-otr package includes OTR plugin for bitlbee. Not
52 completely stable and not 100% foolproof so use at your own risk.
53
54 %package protocol-skype
55 Summary:        Skype protocol support for bitlbee
56 Group:          Daemons
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       python-skype
59
60 %description protocol-skype
61 Skype protocol support for bitlbee.
62
63 %prep
64 %setup -q
65
66 # fix wrong assumption with $DESTDIR
67 %{__sed} -i -e 's,$(shell id -u),0,' Makefile
68
69 # fix #!%{_bindir}/env python -> #!%{__python}:
70 %{__sed} -i -e '1s,^#!.*python.*,#!%{__python},' protocols/skype/*.py
71
72 # fix config path
73 %{__sed} -i -e 's,/usr/local/etc/skyped,%{_sysconfdir}/skyped,' protocols/skype/*.py
74
75 %build
76 CFLAGS="%{rpmcflags}" \
77 ./configure \
78         --prefix=%{_prefix} \
79         --bindir=%{_sbindir} \
80         --etcdir=%{_sysconfdir}/%{name} \
81         --mandir=%{_mandir} \
82         --datadir=%{_datadir}/%{name} \
83         --config=%{_localstatedir}/lib/%{name} \
84         --pcdir=%{_pkgconfigdir} \
85         --plugindir=%{_libdir}/%{name} \
86         --strip=0 \
87         --plugins=1 \
88         --ssl=gnutls \
89 %if %{with otr}
90         --otr=plugin \
91 %endif
92         --skype=plugin \
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}
99 %{__make} install install-dev install-etc install-systemd \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(644,root,root,755)
107 %doc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README}
108 %dir %{_sysconfdir}/%{name}
109 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/bitlbee.conf
110 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/motd.txt
111 %attr(755,root,root) %{_sbindir}/bitlbee
112 %{_mandir}/man5/bitlbee.conf.5*
113 %{_mandir}/man8/bitlbee.8*
114 %{_datadir}/bitlbee
115 %dir %{_libdir}/%{name}
116 %attr(700,root,root) %{_localstatedir}/lib/bitlbee
117 %{systemdunitdir}/bitlbee.service
118 %{systemdunitdir}/bitlbee.socket
119 %{systemdunitdir}/bitlbee@.service
120
121 %files devel
122 %defattr(644,root,root,755)
123 %doc doc/example_plugin.c
124 %{_includedir}/%{name}
125 %{_pkgconfigdir}/%{name}.pc
126
127 %if %{with otr}
128 %files otr
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/%{name}/otr.so
131 %endif
132
133 %files protocol-skype
134 %defattr(644,root,root,755)
135 %doc protocols/skype/{HACKING,NEWS,README,skyped.txt}
136 %dir %{_sysconfdir}/skyped
137 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.cnf
138 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.conf
139 %attr(755,root,root) %{_libdir}/%{name}/skype.so
140 %attr(755,root,root) %{_sbindir}/skyped
141 %{_mandir}/man1/skyped.1*
This page took 0.105331 seconds and 3 git commands to generate.