]> git.pld-linux.org Git - packages/bitlbee.git/blame - bitlbee.spec
- enable skype protocol plugin
[packages/bitlbee.git] / bitlbee.spec
CommitLineData
b8f37917
ER
1# TODO
2# - sync pl
3# - bilbee user
4#
5# Conditional build:
6%bcond_without otr # build without OTR
7
762288ea 8Summary: An IRC to other chat networks gateway
e2723aba 9Summary(pl.UTF-8): Bramka pomiędzy IRC-em i innymi sieciami komunikacyjnymi
762288ea 10Name: bitlbee
b8f37917 11Version: 3.0.5
f5618a74 12Release: 0.6
b8f37917 13License: GPL v2+ and MIT
762288ea 14Group: Daemons
762288ea 15Source0: http://get.bitlbee.org/src/%{name}-%{version}.tar.gz
b8f37917 16# Source0-md5: 9ff97260a2a7f3a7d102db158a8d9887
1b994aca 17URL: http://www.bitlbee.org/
f5618a74 18BuildRequires: asciidoc
1b994aca 19BuildRequires: gnutls-devel
b8f37917
ER
20%{?with_otr:BuildRequires: libotr-devel >= 3.2.0}
21BuildRequires: systemd-units
762288ea 22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
b8f37917
ER
25Bitlbee is an IRC to other chat networks gateway. Bitlbee can be used
26as an IRC server which forwards everything you say to people on other
27chat networks like ICQ/AIM, MSN, XMPP/Jabber (including Google Talk),
28Yahoo or Twitter!
762288ea 29
6b82b92d
JR
30%description -l pl.UTF-8
31Bramka pomiędzy IRC-em i innymi sieciami komunikacyjnymi. Ten program
32może być używany jako serwer IRC przekazujący wszystko co się mówi do
33ludzi korzystających z innych sieci komunikacyjnych, takich jak
1b994aca
JB
34MSN/ICQ/Jabber.
35
b8f37917
ER
36%package devel
37Summary: Development files for bitlbee
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description devel
42The bitlbee-devel package includes header files necessary for building
43and developing programs and plugins which use bitlbee.
44
45%package otr
46Summary: OTR plugin for bitlbee
47Group: Daemons
48Requires: %{name} = %{version}-%{release}
49
50%description otr
51The bitlbee-otr package includes OTR plugin for bitlbee. Not
52completely stable and not 100% foolproof so use at your own risk.
53
f5618a74
ER
54%package protocol-skype
55Summary: Skype protocol support for bitlbee
56Group: Daemons
57Requires: %{name} = %{version}-%{release}
58Requires: python-skype
59
60%description protocol-skype
61Skype protocol support for bitlbee.
62
762288ea 63%prep
64%setup -q
65
b8f37917
ER
66# fix wrong assumption with $DESTDIR
67%{__sed} -i -e 's,$(shell id -u),0,' Makefile
68
f5618a74
ER
69# fix #!%{_bindir}/env python -> #!%{__python}:
70%{__sed} -i -e '1s,^#!.*python.*,#!%{__python},' protocols/skype/*.py
71
72# fix config path
73%{__sed} -i -e 's,/usr/local/etc/skyped,%{_sysconfdir}/skyped,' protocols/skype/*.py
74
762288ea 75%build
b8f37917 76CFLAGS="%{rpmcflags}" \
762288ea 77./configure \
762288ea 78 --prefix=%{_prefix} \
b8f37917
ER
79 --bindir=%{_sbindir} \
80 --etcdir=%{_sysconfdir}/%{name} \
81 --mandir=%{_mandir} \
82 --datadir=%{_datadir}/%{name} \
83 --config=%{_localstatedir}/lib/%{name} \
84 --pcdir=%{_pkgconfigdir} \
85 --plugindir=%{_libdir}/%{name} \
86 --strip=0 \
87 --plugins=1 \
88 --ssl=gnutls \
89%if %{with otr}
90 --otr=plugin \
91%endif
f5618a74 92 --skype=plugin \
f750a0e7
AG
93
94%{__make}
b8f37917 95
762288ea 96%install
97rm -rf $RPM_BUILD_ROOT
b8f37917 98install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}
b8f37917 99%{__make} install install-dev install-etc install-systemd \
1b994aca 100 DESTDIR=$RPM_BUILD_ROOT
762288ea 101
762288ea 102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%files
106%defattr(644,root,root,755)
9cddc25a 107%doc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README}
b6b1ab7d 108%dir %{_sysconfdir}/%{name}
b8f37917
ER
109%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/bitlbee.conf
110%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/motd.txt
111%attr(755,root,root) %{_sbindir}/bitlbee
112%{_mandir}/man5/bitlbee.conf.5*
113%{_mandir}/man8/bitlbee.8*
1b994aca 114%{_datadir}/bitlbee
f5618a74 115%dir %{_libdir}/%{name}
1b994aca 116%attr(700,root,root) %{_localstatedir}/lib/bitlbee
b8f37917
ER
117%{systemdunitdir}/bitlbee.service
118%{systemdunitdir}/bitlbee.socket
119%{systemdunitdir}/bitlbee@.service
120
121%files devel
122%defattr(644,root,root,755)
123%doc doc/example_plugin.c
124%{_includedir}/%{name}
125%{_pkgconfigdir}/%{name}.pc
126
127%if %{with otr}
128%files otr
129%defattr(644,root,root,755)
130%attr(755,root,root) %{_libdir}/%{name}/otr.so
131%endif
f5618a74
ER
132
133%files protocol-skype
134%defattr(644,root,root,755)
135%doc protocols/skype/{HACKING,NEWS,README,skyped.txt}
136%dir %{_sysconfdir}/skyped
137%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.cnf
138%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.conf
139%attr(755,root,root) %{_libdir}/%{name}/skype.so
140%attr(755,root,root) %{_sbindir}/skyped
141%{_mandir}/man1/skyped.1*
This page took 0.045701 seconds and 4 git commands to generate.