]> git.pld-linux.org Git - packages/bitcoin.git/blob - bitcoin.spec
- added -boost.patch and -nostatic.patch
[packages/bitcoin.git] / bitcoin.spec
1 Summary:        Bitcoin is a peer-to-peer currency
2 Name:           bitcoin
3 Version:        0.3.21
4 Release:        0.1
5 License:        MIT/X11
6 Group:          X11/Applications
7 Source0:        http://downloads.sourceforge.net/bitcoin/%{name}-%{version}-linux.tar.gz
8 # Source0-md5:  19e530a9b60e3a0987998a87b30d8cdc
9 Patch0:         %{name}-boost.patch
10 Patch1:         %{name}-nostatic.patch
11 URL:            http://www.bitcoin.org
12 BuildRequires:  boost-devel
13 BuildRequires:  db-cxx-devel
14 BuildRequires:  miniupnpc-devel >= 1.5
15 BuildRequires:  openssl-devel
16 BuildRequires:  wxGTK2-unicode-devel >= 2.9
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Bitcoin is a peer-to-peer currency. Peer-to-peer means that no central
21 authority issues new money or tracks transactions. These tasks are
22 managed collectively by the network.
23
24 %prep
25 %setup -q
26 %patch0 -p1
27 %patch1 -p1
28
29 %build
30 %{__make} -C src -f makefile.unix \
31         CXX="%{__cxx}" \
32         WXINCLUDEPATHS="$(wx-gtk2-unicode-2.9-config --cxxflags)" \
33         WXLIBS="$(wx-gtk2-unicode-2.9-config --libs)" \
34         USE_UPNP=1
35
36 %{__make} -C src -f makefile.unix \
37         CXX="%{__cxx}" \
38         WXINCLUDEPATHS="$(wx-gtk2-unicode-2.9-config --cxxflags)" \
39         WXLIBS="$(wx-gtk2-unicode-2.9-config --libs)" \
40         USE_UPNP=1 \
41         bitcoind
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{_bindir},%{_localedir}}
46
47 install src/{bitcoin,bitcoind} $RPM_BUILD_ROOT%{_bindir}
48
49 # install locales
50 for dir in $(find locale/ -mindepth 1 -maxdepth 1 -type d); do
51         lang=$(basename $dir)
52         
53         install -d $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES
54         install $dir/LC_MESSAGES/bitcoin.mo $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES
55 done
56
57 %find_lang %{name}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files -f %{name}.lang
63 %defattr(644,root,root,755)
64 %attr(755,root,root) %{_bindir}/bitcoin
65 %attr(755,root,root) %{_bindir}/bitcoind
This page took 0.086136 seconds and 4 git commands to generate.