]> git.pld-linux.org Git - packages/bitcoin.git/commitdiff
- added -boost.patch and -nostatic.patch
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Thu, 26 May 2011 16:22:57 +0000 (16:22 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- builds, but needs wxWidgets 2.9 (DEVEL branch)

Changed files:
    bitcoin.spec -> 1.2

bitcoin.spec

index 1b9c87cefe85c8e1835bd90dc19325de8d3d3dd7..cf4497e909d8aeb6016c314eff4e45a18be8280c 100644 (file)
@@ -6,11 +6,14 @@ License:      MIT/X11
 Group:         X11/Applications
 Source0:       http://downloads.sourceforge.net/bitcoin/%{name}-%{version}-linux.tar.gz
 # Source0-md5: 19e530a9b60e3a0987998a87b30d8cdc
+Patch0:                %{name}-boost.patch
+Patch1:                %{name}-nostatic.patch
 URL:           http://www.bitcoin.org
 BuildRequires: boost-devel
-BuildRequires: miniupnpc-devel
+BuildRequires: db-cxx-devel
+BuildRequires: miniupnpc-devel >= 1.5
 BuildRequires: openssl-devel
-BuildRequires: wxGTK2-unicode-devel
+BuildRequires: wxGTK2-unicode-devel >= 2.9
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -20,20 +23,43 @@ managed collectively by the network.
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
 
 %build
 %{__make} -C src -f makefile.unix \
        CXX="%{__cxx}" \
-       WXINCLUDEPATHS="$(wx-gtk2-unicode-config --cxxflags)" \
-       WXLIBS="$(wx-gtk2-unicode-config --libs)" \
+       WXINCLUDEPATHS="$(wx-gtk2-unicode-2.9-config --cxxflags)" \
+       WXLIBS="$(wx-gtk2-unicode-2.9-config --libs)" \
+       USE_UPNP=1
+
+%{__make} -C src -f makefile.unix \
+       CXX="%{__cxx}" \
+       WXINCLUDEPATHS="$(wx-gtk2-unicode-2.9-config --cxxflags)" \
+       WXLIBS="$(wx-gtk2-unicode-2.9-config --libs)" \
        USE_UPNP=1 \
+       bitcoind
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_localedir}}
+
+install src/{bitcoin,bitcoind} $RPM_BUILD_ROOT%{_bindir}
+
+# install locales
+for dir in $(find locale/ -mindepth 1 -maxdepth 1 -type d); do
+       lang=$(basename $dir)
+       
+       install -d $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES
+       install $dir/LC_MESSAGES/bitcoin.mo $RPM_BUILD_ROOT%{_localedir}/$lang/LC_MESSAGES
+done
+
+%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/bitcoin
+%attr(755,root,root) %{_bindir}/bitcoind
This page took 0.139049 seconds and 4 git commands to generate.