]> git.pld-linux.org Git - packages/axis.git/blame - axis.spec
- more TODO
[packages/axis.git] / axis.spec
CommitLineData
952ffbef 1# TODO
952ffbef 2# - castor is needed by axis-1.2.1-0.2jpp.1.noarch
87cd0875 3# - package axis2, axis is obsolete. see NOTE below.
da600252 4# - build samples
5# - package war app
87cd0875 6# NOTE
7# - it won't compile with java 1.6. see:
8# https://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=55862&viewmode=flat&order=ASC&start=20
1c16c204 9
10%bcond_with java_sun
952ffbef
ER
11%define archivever %(echo %{version} | tr . _)
12Summary: A SOAP implementation in Java
d7049fd1 13Summary(pl.UTF-8): Implementacja SOAP w Javie
952ffbef 14Name: axis
3a5f3841 15Version: 1.4
fc8003da 16Release: 0.1
da600252 17License: Apache
952ffbef 18Group: Development/Languages/Java
071c13c6 19Source0: http://ws.apache.org/axis/dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
3a5f3841 20# Source0-md5: 3dcce3cbd37f52d70ebeb858f90608dc
da600252 21Source1: %{name}-build.xml
22Patch0: %{name}-classpath.patch
23Patch1: %{name}-missing_xsd.patch
21fcb34a 24URL: http://ws.apache.org/axis/
2bbdba56 25BuildRequires: ant >= 1.6
3a5f3841 26BuildRequires: ant-nodeps
1c16c204 27%{!?with_java_sun:BuildRequires: java-gcj-compat-devel}
28%{?with_java_sun:BuildRequires: java-sun <= 1.5}
da600252 29# BuildRequires: jimi
30# BuildRequires: jms
31BuildRequires: httpunit
1c16c204 32BuildRequires: jaf
33BuildRequires: java-commons-discovery
34BuildRequires: java-commons-httpclient
35BuildRequires: java-commons-logging
da600252 36BuildRequires: java-commons-net
37BuildRequires: java-oro
38BuildRequires: java-xalan
39BuildRequires: java-xerces
40BuildRequires: java-xml-commons
1c16c204 41BuildRequires: java-xmlbeans
42BuildRequires: javamail
1c16c204 43BuildRequires: jpackage-utils
da600252 44BuildRequires: jsse
45BuildRequires: junit
1c16c204 46BuildRequires: logging-log4j
47BuildRequires: rpmbuild(macros) >= 1.300
48BuildRequires: servletapi5
49BuildRequires: wsdl4j
da600252 50Requires: httpunit
952ffbef 51Requires: jaf
da600252 52Requires: java-commons-discovery
53Requires: java-commons-httpclient
54Requires: java-commons-logging
55Requires: java-commons-net
56Requires: java-oro
57Requires: java-xalan
58Requires: java-xerces
59Requires: java-xml-commons
60Requires: java-xmlbeans
952ffbef 61Requires: javamail
d57efde4 62Requires: jpackage-utils
da600252 63Requires: jsse
64Requires: logging-log4j
65Requires: servletapi5
952ffbef
ER
66Requires: wsdl4j
67BuildArch: noarch
68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70%description
71Apache AXIS is an implementation of the SOAP ("Simple Object Access
72Protocol") submission to W3C.
73
74From the draft W3C specification:
75
76SOAP is a lightweight protocol for exchange of information in a
77decentralized, distributed environment. It is an XML based protocol
78that consists of three parts: an envelope that defines a framework for
79describing what is in a message and how to process it, a set of
80encoding rules for expressing instances of application-defined
81datatypes, and a convention for representing remote procedure calls
82and responses.
83
84This project is a follow-on to the Apache SOAP project.
85
cd04c4e5 86%description -l pl.UTF-8
21fcb34a
JB
87Apache AXIS to implementacja SOAP ("Simple Object Access Protocol")
88przekazanego do W3C.
89
90Z projektu specyfikacji W3C:
91
cd04c4e5
JR
92SOAP to lekki protokół do wymiany informacji w scentralizowanym,
93rozproszonym środowisku. Jest to protokół oparty na XML-u, składający
94się z trzech części: koperty definiującej szkielet do opisu zawartości
95i sposobu przetwarzania komunikatu, zbioru reguł kodowania do
96wyrażania instancji typów danych zdefiniowanych w aplikacji oraz
97konwencji reprezentowania zdalnych wywołań procedur i odpowiedzi.
21fcb34a 98
cd04c4e5 99Ten projekt jest następcą projektu Apache SOAP.
21fcb34a 100
952ffbef
ER
101%package javadoc
102Summary: Javadoc for %{name}
d7049fd1 103Summary(pl.UTF-8): Dokumentacja javadoc dla pakietu %{name}
d57efde4
ER
104Group: Documentation
105Requires: jpackage-utils
952ffbef
ER
106
107%description javadoc
108Javadoc for %{name}.
109
cd04c4e5 110%description javadoc -l pl.UTF-8
21fcb34a
JB
111Dokumentacja javadoc dla pakietu %{name}.
112
952ffbef
ER
113%package manual
114Summary: Manual for %{name}
d7049fd1 115Summary(pl.UTF-8): Podręcznik do pakietu %{name}
952ffbef
ER
116Group: Development/Languages/Java
117
118%description manual
119Documentation for %{name}.
120
cd04c4e5
JR
121%description manual -l pl.UTF-8
122Podręcznik do pakietu %{name}.
21fcb34a 123
952ffbef
ER
124%prep
125%setup -q -n %{name}-%{archivever}
126
127# Remove provided binaries
1c16c204 128find -name '*.jar' | xargs rm -v
d57efde4 129find -name '*.class' | xargs rm -v
952ffbef 130
3a5f3841 131%patch0 -p1
93768a76 132%patch1 -p1
3a5f3841 133
e43ec4b9 134cp %{SOURCE1} build.xml
952ffbef 135
1c16c204 136%build
137export JAVA_HOME=%{java_home}
138echo $JAVA_HOME
139
140activation_jar=$(find-jar activation)
141commons_logging_jar=$(find-jar commons-logging)
142commons_discovery_jar=$(find-jar commons-discovery)
143commons_httpclient_jar=$(find-jar commons-httpclient)
144commons_net_jar=$(find-jar commons-net)
145log4j_core_jar=$(find-jar log4j)
146jsse_jar=$(find-jar jsse)
147junit_jar=$(find-jar junit)
148mailapi_jar=$(find-jar mail)
149regexp_jar=$(find-jar oro)
150servlet_jar=$(find-jar servletapi5)
151tools_jar=$(find-jar tools)
152wsdl4j_jar=$(find-jar wsdl4j)
153xalan_jar=$(find-jar xalan)
154xerces_jar=$(find-jar xerces-j2)
155xercesImpl_jar=$(find-jar xercesImpl)
156xml_apis_jar=$(find-jar xml-commons-apis)
157xmlParsersAPIs_jar=$(find-jar xerces-j2)
158xmlbeans_jar=$(find-jar xmlbeans)
da600252 159%{!?with_java_sun:libgcj_jar=$(find-jar libgcj)}
1c16c204 160
161#httpunit_jar=$(find-jar httpunit)
162#xmlunit_jar=$(find-jar xmlunit)
163#jimi_jar=$(find-jar jimi)
164
165CLASSPATH=$wsdl4j_jar:$commons_logging_jar:$commons_discovery_jar
166%{!?with_java_sun:CLASSPATH=$CLASSPATH:$(build-classpath ecj tools)}
3a5f3841 167export CLASSPATH
1c16c204 168
169%ant dist \
170 -Dactivation.jar=$activation_jar \
171 -Dcommons-logging.jar=$commons_logging_jar \
172 -Dcommons-discovery.jar=$commons_discovery_jar \
173 -Dcommons-httpclient.jar=$commons_httpclient_jar \
174 -Dcommons-net.jar=$commons_net_jar \
175 -Dlog4j-core.jar=$log4j_core_jar \
176 -Djsse.jar=$jsse_jar \
177 -Djunit.jar=$junit_jar \
178 -Dmailapi.jar=$mailapi_jar \
179 -Dregexp.jar=$regexp_jar \
180 -Dservlet.jar=$servlet_jar \
181 -Dtools.jar=$tools_jar \
182 -Dwsdl4j.jar=$wsdl4j_jar \
183 -Dxalan.jar=$xalan_jar \
184 -Dxerces.jar=$xerces_jar \
185 -DxercesImpl.jar=$xercesImpl_jar \
186 -Dxml-apis.jar=$xml_apis_jar \
187 -DxmlParsersAPIs.jar=$xmlParsersAPIs_jar \
188 -Dxmlbeans.jar=$xmlbeans_jar \
da600252 189 %{!?with_java_sun:-Dsun.boot.class.path="$libgcj_jar:[-org.w3c.dom/*]"}
952ffbef
ER
190
191%install
952ffbef 192rm -rf $RPM_BUILD_ROOT
1c16c204 193
194install -d $RPM_BUILD_ROOT%{_javadir}/%{name}
952ffbef
ER
195
196cd build/lib
d57efde4 197install axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
21fcb34a 198 $RPM_BUILD_ROOT%{_javadir}/%{name}
952ffbef
ER
199cd -
200
201cd $RPM_BUILD_ROOT%{_javadir}/%{name}
21fcb34a
JB
202for jar in *.jar ; do
203 vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
204 mv $jar $vjar
205 ln -fs $vjar $jar
206done
952ffbef
ER
207cd -
208
209### Javadoc
952ffbef 210install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
d57efde4
ER
211cp -a build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
212ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
952ffbef
ER
213
214%clean
215rm -rf $RPM_BUILD_ROOT
216
217%post javadoc
d57efde4 218ln -nfs %{name}-%{version} %{_javadocdir}/%{name}
952ffbef
ER
219
220%files
221%defattr(644,root,root,755)
222%doc LICENSE README release-notes.html changelog.html
223%dir %{_javadir}/%{name}
224%{_javadir}/%{name}/*.jar
225
226%files javadoc
227%defattr(644,root,root,755)
d57efde4
ER
228%{_javadocdir}/%{name}-%{version}
229%ghost %{_javadocdir}/%{name}
952ffbef
ER
230
231%files manual
232%defattr(644,root,root,755)
233%doc docs/*
This page took 0.090628 seconds and 4 git commands to generate.