]> git.pld-linux.org Git - packages/axis.git/blame - axis.spec
- now it builds with system libraries.
[packages/axis.git] / axis.spec
CommitLineData
952ffbef 1# TODO
952ffbef 2# - castor is needed by axis-1.2.1-0.2jpp.1.noarch
87cd0875 3# - package axis2, axis is obsolete. see NOTE below.
4# NOTE
5# - it won't compile with java 1.6. see:
6# https://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=55862&viewmode=flat&order=ASC&start=20
1c16c204 7
8%bcond_with java_sun
952ffbef
ER
9%define archivever %(echo %{version} | tr . _)
10Summary: A SOAP implementation in Java
d7049fd1 11Summary(pl.UTF-8): Implementacja SOAP w Javie
952ffbef 12Name: axis
3a5f3841 13Version: 1.4
fc8003da 14Release: 0.1
952ffbef
ER
15License: Apache Software License
16Group: Development/Languages/Java
071c13c6 17Source0: http://ws.apache.org/axis/dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
3a5f3841 18# Source0-md5: 3dcce3cbd37f52d70ebeb858f90608dc
1c16c204 19Source1: axis-build.properties
20Source2: axis-build.xml
3a5f3841 21Patch0: axis-classpath.patch
93768a76 22Patch1: axis-missing_xsd.patch
21fcb34a 23URL: http://ws.apache.org/axis/
2bbdba56 24BuildRequires: ant >= 1.6
3a5f3841 25BuildRequires: ant-nodeps
1c16c204 26%{!?with_java_sun:BuildRequires: java-gcj-compat-devel}
27%{?with_java_sun:BuildRequires: java-sun <= 1.5}
952ffbef 28# Mandatory requires
1c16c204 29BuildRequires: jaf
30BuildRequires: java-commons-discovery
31BuildRequires: java-commons-httpclient
32BuildRequires: java-commons-logging
33BuildRequires: java-xmlbeans
34BuildRequires: javamail
35BuildRequires: jaxp_parser_impl
36BuildRequires: jpackage-utils
37BuildRequires: logging-log4j
38BuildRequires: rpmbuild(macros) >= 1.300
39BuildRequires: servletapi5
40BuildRequires: wsdl4j
41# optional requires
42BuildRequires: castor
43BuildRequires: httpunit
44BuildRequires: jakarta-oro
45# BuildRequires: jimi
46# BuildRequires: jms
47BuildRequires: jsse
48BuildRequires: junit
952ffbef
ER
49Requires: jaf
50Requires: jakarta-commons-discovery
340429f1 51Requires: jakarta-commons-httpclient
952ffbef 52Requires: jakarta-commons-logging
1c16c204 53Requires: java
952ffbef
ER
54Requires: javamail
55Requires: jaxp_parser_impl
56506b98 56Requires: logging-log4j
d57efde4 57Requires: jpackage-utils
952ffbef
ER
58Requires: log4j
59Requires: wsdl4j
60BuildArch: noarch
61BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63%description
64Apache AXIS is an implementation of the SOAP ("Simple Object Access
65Protocol") submission to W3C.
66
67From the draft W3C specification:
68
69SOAP is a lightweight protocol for exchange of information in a
70decentralized, distributed environment. It is an XML based protocol
71that consists of three parts: an envelope that defines a framework for
72describing what is in a message and how to process it, a set of
73encoding rules for expressing instances of application-defined
74datatypes, and a convention for representing remote procedure calls
75and responses.
76
77This project is a follow-on to the Apache SOAP project.
78
cd04c4e5 79%description -l pl.UTF-8
21fcb34a
JB
80Apache AXIS to implementacja SOAP ("Simple Object Access Protocol")
81przekazanego do W3C.
82
83Z projektu specyfikacji W3C:
84
cd04c4e5
JR
85SOAP to lekki protokół do wymiany informacji w scentralizowanym,
86rozproszonym środowisku. Jest to protokół oparty na XML-u, składający
87się z trzech części: koperty definiującej szkielet do opisu zawartości
88i sposobu przetwarzania komunikatu, zbioru reguł kodowania do
89wyrażania instancji typów danych zdefiniowanych w aplikacji oraz
90konwencji reprezentowania zdalnych wywołań procedur i odpowiedzi.
21fcb34a 91
cd04c4e5 92Ten projekt jest następcą projektu Apache SOAP.
21fcb34a 93
952ffbef
ER
94%package javadoc
95Summary: Javadoc for %{name}
d7049fd1 96Summary(pl.UTF-8): Dokumentacja javadoc dla pakietu %{name}
d57efde4
ER
97Group: Documentation
98Requires: jpackage-utils
952ffbef
ER
99
100%description javadoc
101Javadoc for %{name}.
102
cd04c4e5 103%description javadoc -l pl.UTF-8
21fcb34a
JB
104Dokumentacja javadoc dla pakietu %{name}.
105
952ffbef
ER
106%package manual
107Summary: Manual for %{name}
d7049fd1 108Summary(pl.UTF-8): Podręcznik do pakietu %{name}
952ffbef
ER
109Group: Development/Languages/Java
110
111%description manual
112Documentation for %{name}.
113
cd04c4e5
JR
114%description manual -l pl.UTF-8
115Podręcznik do pakietu %{name}.
21fcb34a 116
952ffbef
ER
117%prep
118%setup -q -n %{name}-%{archivever}
119
120# Remove provided binaries
1c16c204 121find -name '*.jar' | xargs rm -v
d57efde4 122find -name '*.class' | xargs rm -v
952ffbef 123
3a5f3841 124%patch0 -p1
93768a76 125%patch1 -p1
3a5f3841 126
1c16c204 127#cp %{SOURCE1} build.properties
128cp %{SOURCE2} build.xml
952ffbef 129
1c16c204 130%build
131export JAVA_HOME=%{java_home}
132echo $JAVA_HOME
133
134activation_jar=$(find-jar activation)
135commons_logging_jar=$(find-jar commons-logging)
136commons_discovery_jar=$(find-jar commons-discovery)
137commons_httpclient_jar=$(find-jar commons-httpclient)
138commons_net_jar=$(find-jar commons-net)
139log4j_core_jar=$(find-jar log4j)
140jsse_jar=$(find-jar jsse)
141junit_jar=$(find-jar junit)
142mailapi_jar=$(find-jar mail)
143regexp_jar=$(find-jar oro)
144servlet_jar=$(find-jar servletapi5)
145tools_jar=$(find-jar tools)
146wsdl4j_jar=$(find-jar wsdl4j)
147xalan_jar=$(find-jar xalan)
148xerces_jar=$(find-jar xerces-j2)
149xercesImpl_jar=$(find-jar xercesImpl)
150xml_apis_jar=$(find-jar xml-commons-apis)
151xmlParsersAPIs_jar=$(find-jar xerces-j2)
152xmlbeans_jar=$(find-jar xmlbeans)
153libgcj_jar=$(find-jar libgcj)
154
155#httpunit_jar=$(find-jar httpunit)
156#xmlunit_jar=$(find-jar xmlunit)
157#jimi_jar=$(find-jar jimi)
158
159CLASSPATH=$wsdl4j_jar:$commons_logging_jar:$commons_discovery_jar
160%{!?with_java_sun:CLASSPATH=$CLASSPATH:$(build-classpath ecj tools)}
3a5f3841 161export CLASSPATH
1c16c204 162
163%ant dist \
164 -Dactivation.jar=$activation_jar \
165 -Dcommons-logging.jar=$commons_logging_jar \
166 -Dcommons-discovery.jar=$commons_discovery_jar \
167 -Dcommons-httpclient.jar=$commons_httpclient_jar \
168 -Dcommons-net.jar=$commons_net_jar \
169 -Dlog4j-core.jar=$log4j_core_jar \
170 -Djsse.jar=$jsse_jar \
171 -Djunit.jar=$junit_jar \
172 -Dmailapi.jar=$mailapi_jar \
173 -Dregexp.jar=$regexp_jar \
174 -Dservlet.jar=$servlet_jar \
175 -Dtools.jar=$tools_jar \
176 -Dwsdl4j.jar=$wsdl4j_jar \
177 -Dxalan.jar=$xalan_jar \
178 -Dxerces.jar=$xerces_jar \
179 -DxercesImpl.jar=$xercesImpl_jar \
180 -Dxml-apis.jar=$xml_apis_jar \
181 -DxmlParsersAPIs.jar=$xmlParsersAPIs_jar \
182 -Dxmlbeans.jar=$xmlbeans_jar \
183 -Dsun.boot.class.path="$libgcj_jar:[-org.w3c.dom/*]"
952ffbef
ER
184
185%install
952ffbef 186rm -rf $RPM_BUILD_ROOT
1c16c204 187
188install -d $RPM_BUILD_ROOT%{_javadir}/%{name}
952ffbef
ER
189
190cd build/lib
d57efde4 191install axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
21fcb34a 192 $RPM_BUILD_ROOT%{_javadir}/%{name}
952ffbef
ER
193cd -
194
195cd $RPM_BUILD_ROOT%{_javadir}/%{name}
21fcb34a
JB
196for jar in *.jar ; do
197 vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
198 mv $jar $vjar
199 ln -fs $vjar $jar
200done
952ffbef
ER
201cd -
202
203### Javadoc
952ffbef 204install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
d57efde4
ER
205cp -a build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
206ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
952ffbef
ER
207
208%clean
209rm -rf $RPM_BUILD_ROOT
210
211%post javadoc
d57efde4 212ln -nfs %{name}-%{version} %{_javadocdir}/%{name}
952ffbef
ER
213
214%files
215%defattr(644,root,root,755)
216%doc LICENSE README release-notes.html changelog.html
217%dir %{_javadir}/%{name}
218%{_javadir}/%{name}/*.jar
219
220%files javadoc
221%defattr(644,root,root,755)
d57efde4
ER
222%{_javadocdir}/%{name}-%{version}
223%ghost %{_javadocdir}/%{name}
952ffbef
ER
224
225%files manual
226%defattr(644,root,root,755)
227%doc docs/*
This page took 0.074233 seconds and 4 git commands to generate.