]> git.pld-linux.org Git - packages/axis.git/blame - axis.spec
- tabs in preamble
[packages/axis.git] / axis.spec
CommitLineData
952ffbef
ER
1# TODO
2# - servletapi5 is needed by axis-1.2.1-0.2jpp.1.noarch
3# - castor is needed by axis-1.2.1-0.2jpp.1.noarch
4%define archivever %(echo %{version} | tr . _)
5Summary: A SOAP implementation in Java
d7049fd1 6Summary(pl.UTF-8): Implementacja SOAP w Javie
952ffbef
ER
7Name: axis
8Version: 1.2.1
f105c4a1 9Release: 0.3
952ffbef
ER
10License: Apache Software License
11Group: Development/Languages/Java
21fcb34a 12Source0: http://ws.apache.org/axis//dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
952ffbef 13# Source0-md5: 157ad070accf373565bce80de1204a4d
21fcb34a 14URL: http://ws.apache.org/axis/
952ffbef 15#BuildRequires: ant-nodeps
2bbdba56 16BuildRequires: ant >= 1.6
952ffbef
ER
17BuildRequires: jdk
18# Mandatory requires
19BuildRequires: jaf
20BuildRequires: jakarta-commons-discovery
21BuildRequires: jakarta-commons-httpclient3
22BuildRequires: jakarta-commons-logging
23BuildRequires: jakarta-log4j
24BuildRequires: javamail
25BuildRequires: jaxp_parser_impl
26BuildRequires: servletapi5
27BuildRequires: wsdl4j
28# optional requires
29BuildRequires: castor
30BuildRequires: httpunit
31BuildRequires: jakarta-oro
32BuildRequires: jimi
33BuildRequires: jms
34BuildRequires: jsse
35BuildRequires: junit
36#BuildRequires: xml-security
37Requires: jaf
38Requires: jakarta-commons-discovery
39Requires: jakarta-commons-httpclient3
40Requires: jakarta-commons-logging
41Requires: java
42Requires: javamail
43Requires: jaxp_parser_impl
44#Requires: jpackage-utils >= 0:1.5
45Requires: log4j
46Requires: wsdl4j
47BuildArch: noarch
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51Apache AXIS is an implementation of the SOAP ("Simple Object Access
52Protocol") submission to W3C.
53
54From the draft W3C specification:
55
56SOAP is a lightweight protocol for exchange of information in a
57decentralized, distributed environment. It is an XML based protocol
58that consists of three parts: an envelope that defines a framework for
59describing what is in a message and how to process it, a set of
60encoding rules for expressing instances of application-defined
61datatypes, and a convention for representing remote procedure calls
62and responses.
63
64This project is a follow-on to the Apache SOAP project.
65
cd04c4e5 66%description -l pl.UTF-8
21fcb34a
JB
67Apache AXIS to implementacja SOAP ("Simple Object Access Protocol")
68przekazanego do W3C.
69
70Z projektu specyfikacji W3C:
71
cd04c4e5
JR
72SOAP to lekki protokół do wymiany informacji w scentralizowanym,
73rozproszonym środowisku. Jest to protokół oparty na XML-u, składający
74się z trzech części: koperty definiującej szkielet do opisu zawartości
75i sposobu przetwarzania komunikatu, zbioru reguł kodowania do
76wyrażania instancji typów danych zdefiniowanych w aplikacji oraz
77konwencji reprezentowania zdalnych wywołań procedur i odpowiedzi.
21fcb34a 78
cd04c4e5 79Ten projekt jest następcą projektu Apache SOAP.
21fcb34a 80
952ffbef
ER
81%package javadoc
82Summary: Javadoc for %{name}
d7049fd1 83Summary(pl.UTF-8): Dokumentacja javadoc dla pakietu %{name}
952ffbef
ER
84Group: Development/Languages/Java
85
86%description javadoc
87Javadoc for %{name}.
88
cd04c4e5 89%description javadoc -l pl.UTF-8
21fcb34a
JB
90Dokumentacja javadoc dla pakietu %{name}.
91
952ffbef
ER
92%package manual
93Summary: Manual for %{name}
d7049fd1 94Summary(pl.UTF-8): Podręcznik do pakietu %{name}
952ffbef
ER
95Group: Development/Languages/Java
96
97%description manual
98Documentation for %{name}.
99
cd04c4e5
JR
100%description manual -l pl.UTF-8
101Podręcznik do pakietu %{name}.
21fcb34a 102
952ffbef
ER
103%prep
104%setup -q -n %{name}-%{archivever}
105
106# Remove provided binaries
107find . -name "*.jar" -exec rm -f {} \;
108find . -name "*.zip" -exec rm -f {} \;
109find . -name "*.class" -exec rm -f {} \;
110
111%build
112
113[ -z "$JAVA_HOME" ] && export JAVA_HOME=%{_jvmdir}/java
114
115CLASSPATH=$(build-classpath wsdl4j jakarta-commons-discovery jakarta-commons-httpclient3 jakarta-commons-logging log4j jaf javamail/mailapi servletapi5)
116export CLASSPATH=$CLASSPATH:$(build-classpath oro junit jimi xml-security jsse httpunit jms castor 2>/dev/null)
117
118export OPT_JAR_LIST="ant/ant-nodeps"
21fcb34a
JB
119ant \
120 -Dcompile.ime=true \
952ffbef
ER
121 -Dwsdl4j.jar=$(build-classpath wsdl4j) \
122 -Dcommons-discovery.jar=$(build-classpath jakarta-commons-discovery) \
123 -Dcommons-logging.jar=$(build-classpath jakarta-commons-logging) \
124 -Dcommons-httpclient.jar=$(build-classpath jakarta-commons-httpclient3) \
125 -Dlog4j-core.jar=$(build-classpath log4j) \
126 -Dactivation.jar=$(build-classpath jaf) \
127 -Dmailapi.jar=$(build-classpath javamail/mailapi) \
128 -Dxerces.jar=$(build-classpath jaxp_parser_impl) \
129 -Dservlet.jar=$(build-classpath servletapi5) \
130 -Dregexp.jar=$(build-classpath oro 2>/dev/null) \
131 -Djunit.jar=$(build-classpath junit 2>/dev/null) \
132 -Djimi.jar=$(build-classpath jimi 2>/dev/null) \
133 -Djsse.jar=$(build-classpath jsse/jsse 2>/dev/null) \
134 clean compile javadocs
135
136%install
952ffbef
ER
137rm -rf $RPM_BUILD_ROOT
138### Jar files
139
140install -d $RPM_BUILD_ROOT%{_javadir}/%{name}
141
142cd build/lib
21fcb34a
JB
143install -m 644 axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
144 $RPM_BUILD_ROOT%{_javadir}/%{name}
952ffbef
ER
145cd -
146
147cd $RPM_BUILD_ROOT%{_javadir}/%{name}
21fcb34a
JB
148for jar in *.jar ; do
149 vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
150 mv $jar $vjar
151 ln -fs $vjar $jar
152done
952ffbef
ER
153cd -
154
155### Javadoc
156
157install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
158cp -pr build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
159
160cd docs
21fcb34a
JB
161rm -fr apiDocs
162ln -fs %{_javadocdir}/%{name} apiDocs
952ffbef
ER
163cd -
164
165%clean
166rm -rf $RPM_BUILD_ROOT
167
168%post javadoc
169rm -f %{_javadocdir}/%{name}
170ln -s %{name}-%{version} %{_javadocdir}/%{name}
171
172%postun javadoc
173if [ "$1" = "0" ]; then
174 rm -f %{_javadocdir}/%{name}
175fi
176
177%files
178%defattr(644,root,root,755)
179%doc LICENSE README release-notes.html changelog.html
180%dir %{_javadir}/%{name}
181%{_javadir}/%{name}/*.jar
182
183%files javadoc
184%defattr(644,root,root,755)
185%dir %{_javadocdir}/%{name}-%{version}
186%{_javadocdir}/%{name}-%{version}/*
187
188%files manual
189%defattr(644,root,root,755)
190%doc docs/*
This page took 0.121515 seconds and 4 git commands to generate.