]> git.pld-linux.org Git - packages/axis.git/blame - axis.spec
- dropped Source1: build.properties
[packages/axis.git] / axis.spec
CommitLineData
952ffbef 1# TODO
952ffbef 2# - castor is needed by axis-1.2.1-0.2jpp.1.noarch
87cd0875 3# - package axis2, axis is obsolete. see NOTE below.
4# NOTE
5# - it won't compile with java 1.6. see:
6# https://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=55862&viewmode=flat&order=ASC&start=20
1c16c204 7
8%bcond_with java_sun
952ffbef
ER
9%define archivever %(echo %{version} | tr . _)
10Summary: A SOAP implementation in Java
d7049fd1 11Summary(pl.UTF-8): Implementacja SOAP w Javie
952ffbef 12Name: axis
3a5f3841 13Version: 1.4
fc8003da 14Release: 0.1
952ffbef
ER
15License: Apache Software License
16Group: Development/Languages/Java
071c13c6 17Source0: http://ws.apache.org/axis/dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
3a5f3841 18# Source0-md5: 3dcce3cbd37f52d70ebeb858f90608dc
e43ec4b9 19Source1: axis-build.xml
3a5f3841 20Patch0: axis-classpath.patch
93768a76 21Patch1: axis-missing_xsd.patch
21fcb34a 22URL: http://ws.apache.org/axis/
2bbdba56 23BuildRequires: ant >= 1.6
3a5f3841 24BuildRequires: ant-nodeps
1c16c204 25%{!?with_java_sun:BuildRequires: java-gcj-compat-devel}
26%{?with_java_sun:BuildRequires: java-sun <= 1.5}
952ffbef 27# Mandatory requires
1c16c204 28BuildRequires: jaf
29BuildRequires: java-commons-discovery
30BuildRequires: java-commons-httpclient
31BuildRequires: java-commons-logging
32BuildRequires: java-xmlbeans
33BuildRequires: javamail
34BuildRequires: jaxp_parser_impl
35BuildRequires: jpackage-utils
36BuildRequires: logging-log4j
37BuildRequires: rpmbuild(macros) >= 1.300
38BuildRequires: servletapi5
39BuildRequires: wsdl4j
40# optional requires
41BuildRequires: castor
42BuildRequires: httpunit
43BuildRequires: jakarta-oro
44# BuildRequires: jimi
45# BuildRequires: jms
46BuildRequires: jsse
47BuildRequires: junit
952ffbef
ER
48Requires: jaf
49Requires: jakarta-commons-discovery
340429f1 50Requires: jakarta-commons-httpclient
952ffbef 51Requires: jakarta-commons-logging
1c16c204 52Requires: java
952ffbef
ER
53Requires: javamail
54Requires: jaxp_parser_impl
56506b98 55Requires: logging-log4j
d57efde4 56Requires: jpackage-utils
952ffbef
ER
57Requires: log4j
58Requires: wsdl4j
59BuildArch: noarch
60BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62%description
63Apache AXIS is an implementation of the SOAP ("Simple Object Access
64Protocol") submission to W3C.
65
66From the draft W3C specification:
67
68SOAP is a lightweight protocol for exchange of information in a
69decentralized, distributed environment. It is an XML based protocol
70that consists of three parts: an envelope that defines a framework for
71describing what is in a message and how to process it, a set of
72encoding rules for expressing instances of application-defined
73datatypes, and a convention for representing remote procedure calls
74and responses.
75
76This project is a follow-on to the Apache SOAP project.
77
cd04c4e5 78%description -l pl.UTF-8
21fcb34a
JB
79Apache AXIS to implementacja SOAP ("Simple Object Access Protocol")
80przekazanego do W3C.
81
82Z projektu specyfikacji W3C:
83
cd04c4e5
JR
84SOAP to lekki protokół do wymiany informacji w scentralizowanym,
85rozproszonym środowisku. Jest to protokół oparty na XML-u, składający
86się z trzech części: koperty definiującej szkielet do opisu zawartości
87i sposobu przetwarzania komunikatu, zbioru reguł kodowania do
88wyrażania instancji typów danych zdefiniowanych w aplikacji oraz
89konwencji reprezentowania zdalnych wywołań procedur i odpowiedzi.
21fcb34a 90
cd04c4e5 91Ten projekt jest następcą projektu Apache SOAP.
21fcb34a 92
952ffbef
ER
93%package javadoc
94Summary: Javadoc for %{name}
d7049fd1 95Summary(pl.UTF-8): Dokumentacja javadoc dla pakietu %{name}
d57efde4
ER
96Group: Documentation
97Requires: jpackage-utils
952ffbef
ER
98
99%description javadoc
100Javadoc for %{name}.
101
cd04c4e5 102%description javadoc -l pl.UTF-8
21fcb34a
JB
103Dokumentacja javadoc dla pakietu %{name}.
104
952ffbef
ER
105%package manual
106Summary: Manual for %{name}
d7049fd1 107Summary(pl.UTF-8): Podręcznik do pakietu %{name}
952ffbef
ER
108Group: Development/Languages/Java
109
110%description manual
111Documentation for %{name}.
112
cd04c4e5
JR
113%description manual -l pl.UTF-8
114Podręcznik do pakietu %{name}.
21fcb34a 115
952ffbef
ER
116%prep
117%setup -q -n %{name}-%{archivever}
118
119# Remove provided binaries
1c16c204 120find -name '*.jar' | xargs rm -v
d57efde4 121find -name '*.class' | xargs rm -v
952ffbef 122
3a5f3841 123%patch0 -p1
93768a76 124%patch1 -p1
3a5f3841 125
e43ec4b9 126cp %{SOURCE1} build.xml
952ffbef 127
1c16c204 128%build
129export JAVA_HOME=%{java_home}
130echo $JAVA_HOME
131
132activation_jar=$(find-jar activation)
133commons_logging_jar=$(find-jar commons-logging)
134commons_discovery_jar=$(find-jar commons-discovery)
135commons_httpclient_jar=$(find-jar commons-httpclient)
136commons_net_jar=$(find-jar commons-net)
137log4j_core_jar=$(find-jar log4j)
138jsse_jar=$(find-jar jsse)
139junit_jar=$(find-jar junit)
140mailapi_jar=$(find-jar mail)
141regexp_jar=$(find-jar oro)
142servlet_jar=$(find-jar servletapi5)
143tools_jar=$(find-jar tools)
144wsdl4j_jar=$(find-jar wsdl4j)
145xalan_jar=$(find-jar xalan)
146xerces_jar=$(find-jar xerces-j2)
147xercesImpl_jar=$(find-jar xercesImpl)
148xml_apis_jar=$(find-jar xml-commons-apis)
149xmlParsersAPIs_jar=$(find-jar xerces-j2)
150xmlbeans_jar=$(find-jar xmlbeans)
151libgcj_jar=$(find-jar libgcj)
152
153#httpunit_jar=$(find-jar httpunit)
154#xmlunit_jar=$(find-jar xmlunit)
155#jimi_jar=$(find-jar jimi)
156
157CLASSPATH=$wsdl4j_jar:$commons_logging_jar:$commons_discovery_jar
158%{!?with_java_sun:CLASSPATH=$CLASSPATH:$(build-classpath ecj tools)}
3a5f3841 159export CLASSPATH
1c16c204 160
161%ant dist \
162 -Dactivation.jar=$activation_jar \
163 -Dcommons-logging.jar=$commons_logging_jar \
164 -Dcommons-discovery.jar=$commons_discovery_jar \
165 -Dcommons-httpclient.jar=$commons_httpclient_jar \
166 -Dcommons-net.jar=$commons_net_jar \
167 -Dlog4j-core.jar=$log4j_core_jar \
168 -Djsse.jar=$jsse_jar \
169 -Djunit.jar=$junit_jar \
170 -Dmailapi.jar=$mailapi_jar \
171 -Dregexp.jar=$regexp_jar \
172 -Dservlet.jar=$servlet_jar \
173 -Dtools.jar=$tools_jar \
174 -Dwsdl4j.jar=$wsdl4j_jar \
175 -Dxalan.jar=$xalan_jar \
176 -Dxerces.jar=$xerces_jar \
177 -DxercesImpl.jar=$xercesImpl_jar \
178 -Dxml-apis.jar=$xml_apis_jar \
179 -DxmlParsersAPIs.jar=$xmlParsersAPIs_jar \
180 -Dxmlbeans.jar=$xmlbeans_jar \
181 -Dsun.boot.class.path="$libgcj_jar:[-org.w3c.dom/*]"
952ffbef
ER
182
183%install
952ffbef 184rm -rf $RPM_BUILD_ROOT
1c16c204 185
186install -d $RPM_BUILD_ROOT%{_javadir}/%{name}
952ffbef
ER
187
188cd build/lib
d57efde4 189install axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
21fcb34a 190 $RPM_BUILD_ROOT%{_javadir}/%{name}
952ffbef
ER
191cd -
192
193cd $RPM_BUILD_ROOT%{_javadir}/%{name}
21fcb34a
JB
194for jar in *.jar ; do
195 vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
196 mv $jar $vjar
197 ln -fs $vjar $jar
198done
952ffbef
ER
199cd -
200
201### Javadoc
952ffbef 202install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
d57efde4
ER
203cp -a build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
204ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
952ffbef
ER
205
206%clean
207rm -rf $RPM_BUILD_ROOT
208
209%post javadoc
d57efde4 210ln -nfs %{name}-%{version} %{_javadocdir}/%{name}
952ffbef
ER
211
212%files
213%defattr(644,root,root,755)
214%doc LICENSE README release-notes.html changelog.html
215%dir %{_javadir}/%{name}
216%{_javadir}/%{name}/*.jar
217
218%files javadoc
219%defattr(644,root,root,755)
d57efde4
ER
220%{_javadocdir}/%{name}-%{version}
221%ghost %{_javadocdir}/%{name}
952ffbef
ER
222
223%files manual
224%defattr(644,root,root,755)
225%doc docs/*
This page took 0.053845 seconds and 4 git commands to generate.