]> git.pld-linux.org Git - packages/aegisub.git/blob - aegisub.spec
don't regenerate autotools files
[packages/aegisub.git] / aegisub.spec
1 # TODO
2 # - unvendor vendor/luabins
3 # - unvendor vendor/luajit
4 # - unvendor vendor/universalchardet
5 # - our cxxflags
6
7 # Conditional build:
8 %bcond_without  ffms2   # build ffms2 A/V provider
9
10 Summary:        Subtitle editor
11 Summary(pl.UTF-8):      Edytor napisów
12 Name:           aegisub
13 Version:        3.2.2
14 Release:        16
15 License:        BSD
16 Group:          X11/Applications
17 Source0:        http://ftp.aegisub.org/pub/releases/%{name}-%{version}.tar.xz
18 # Source0-md5:  d80e852c34811add358c06d77f5cd40d
19 Patch0:         pthread.patch
20 Patch1:         %{name}-icu.patch
21 Patch2:         %{name}-icu64.patch
22 Patch3:         %{name}-boost-1.70.patch
23 Patch4:         make-4.3.patch
24 URL:            http://www.aegisub.org/
25 # AC_AGI_COMPILE tries to run test program which tries to open device and most likely fails
26 #BuildRequires: OpenAL-devel >= 0.0.8
27 BuildRequires:  OpenGL-devel
28 BuildRequires:  alsa-lib-devel
29 BuildRequires:  boost-devel >= 1.50.0
30 %{?with_ffms2:BuildRequires:    ffms2-devel >= 2.16}
31 BuildRequires:  fftw3-devel >= 3.3
32 BuildRequires:  fontconfig-devel >= 1:2.4
33 # pkgconfig(freetype2) >= 9.7.0
34 BuildRequires:  freetype-devel >= 1:2.1.9
35 BuildRequires:  gettext-tools
36 BuildRequires:  hunspell-devel >= 1.2.0
37 BuildRequires:  intltool
38 BuildRequires:  libass-devel >= 0.9.7
39 BuildRequires:  libicu-devel >= 4.8.1.1
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  lua51-devel
42 BuildRequires:  pkgconfig >= 1:0.20
43 BuildRequires:  portaudio-devel >= 19
44 BuildRequires:  pulseaudio-devel >= 0.5
45 BuildRequires:  tar >= 1:1.22
46 BuildRequires:  wxGTK2-unicode-gl-devel >= 3.0.0
47 BuildRequires:  wxWidgets-devel >= 3.0.0
48 BuildRequires:  xz
49 BuildRequires:  zlib-devel
50 Requires(post,postun):  desktop-file-utils
51 Requires(post,postun):  gtk-update-icon-cache
52 Requires:       ffms2 >= 2.16
53 Requires:       fftw3 >= 3.3
54 Requires:       fontconfig-libs >= 1:2.4
55 Requires:       freetype >= 1:2.1.9
56 Requires:       hunspell >= 1.2.0
57 Requires:       libass >= 0.9.7
58 Requires:       libicu >= 4.8.1.1
59 Requires:       pulseaudio-libs >= 0.5
60 # due to luajit usage
61 ExclusiveArch:  %{ix86} %{x8664} arm mips ppc
62 # missing atomic_ops
63 ExcludeArch:    i386 i486
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 Aegisub is an advanced subtitle editor for Windows, and UNIX-like
68 systems, such as Linux, Mac OS X and BSD. It is open source software
69 and free for any use.
70
71 Aegisub natively works with the Advanced SubStation Alpha format
72 (aptly abbreviated ASS) which allows for many advanced effects in the
73 subtitles, apart from just basic timed text. Aegisubs goal is to
74 support using these advanced functions with ease.
75
76 %description -l pl.UTF-8
77 Aegisub to zaawansowany edytor napisów dla Windows oraz systemów
78 uniksowych, takich jak Linux, Mac OS X czy BSD. Jest to program o
79 otwartych źródłach, darmowy do dowolnego użytku.
80
81 Aegisub działa natywnie na formacie Advanced SubStation Alpha (w
82 stosownym skrócie ASS), pozwalającym na wiele zaawansowanych efektów w
83 napisach, poza samym powiązaniem z czasem. Celem Aegisubs jest łatwa
84 obsługa tych zaawansowanych funkcji.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91 %patch3 -p1
92 %patch4 -p1
93
94 %{__mv} vendor{,.keep}
95 mkdir vendor
96 %{__mv} vendor.keep/{luabins,luajit,universalchardet} vendor
97
98 %build
99 %configure \
100         --disable-compiler-flags \
101         --disable-update-checker \
102         %{__with_without ffms2} \
103         --without-oss \
104         --with-player-audio=PulseAudio \
105         --with-wx-config=wx-gtk2-unicode-config
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 ln -s %{name}-3.2 $RPM_BUILD_ROOT%{_bindir}/%{name}
115
116 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
117 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{pt_PT,pt}
118 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}
119 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}@latin
120 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{uk_UA,uk}
121
122 %find_lang %{name}-32
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post
128 %update_desktop_database
129 %update_icon_cache hicolor
130
131 %postun
132 %update_desktop_database
133 %update_icon_cache hicolor
134
135 %files -f %{name}-32.lang
136 %defattr(644,root,root,755)
137 %doc LICENCE README.md
138 %attr(755,root,root) %{_bindir}/%{name}
139 %attr(755,root,root) %{_bindir}/%{name}-3.2
140 %{_datadir}/%{name}
141 %{_desktopdir}/%{name}.desktop
142 %{_iconsdir}/hicolor/*/apps/%{name}.*
This page took 0.09805 seconds and 4 git commands to generate.