]> git.pld-linux.org Git - packages/aegisub.git/blob - aegisub.spec
rebuild with wxWidgets 3.2
[packages/aegisub.git] / aegisub.spec
1 # TODO
2 # - unvendor vendor/luabins
3 # - unvendor vendor/luajit
4 # - unvendor vendor/universalchardet
5 # - our cxxflags
6
7 # Conditional build:
8 %bcond_without  ffms2   # build ffms2 A/V provider
9
10 %define         snap    85f711f
11 %define         gitrev  85f711fccc75f01fd44f25537b8777df10c4b3d1
12
13 Summary:        Subtitle editor
14 Summary(pl.UTF-8):      Edytor napisów
15 Name:           aegisub
16 Version:        3.2.2
17 Release:        22
18 License:        BSD
19 Group:          X11/Applications
20 #Source0:       http://ftp.aegisub.org/pub/releases/%{name}-%{version}.tar.xz
21 Source0:        https://github.com/Aegisub/Aegisub/archive/%{snap}/%{name}-%{version}-%{snap}.tar.gz
22 # Source0-md5:  ecb9b5441ead4135c9b1baec0abdec49
23 Patch0:         make-4.3.patch
24 Patch1:         boost181.patch
25 URL:            http://www.aegisub.org/
26 # AC_AGI_COMPILE tries to run test program which tries to open device and most likely fails
27 #BuildRequires: OpenAL-devel >= 0.0.8
28 BuildRequires:  OpenGL-devel
29 BuildRequires:  alsa-lib-devel
30 BuildRequires:  boost-devel >= 1.50.0
31 %{?with_ffms2:BuildRequires:    ffms2-devel >= 2.16}
32 BuildRequires:  fftw3-devel >= 3.3
33 BuildRequires:  fontconfig-devel >= 1:2.4
34 # pkgconfig(freetype2) >= 9.7.0
35 BuildRequires:  freetype-devel >= 1:2.1.9
36 BuildRequires:  gettext-tools
37 BuildRequires:  hunspell-devel >= 1.2.0
38 BuildRequires:  intltool
39 BuildRequires:  libass-devel >= 0.9.7
40 BuildRequires:  libicu-devel >= 4.8.1.1
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  lua51-devel
43 BuildRequires:  pkgconfig >= 1:0.20
44 BuildRequires:  portaudio-devel >= 19
45 BuildRequires:  pulseaudio-devel >= 0.5
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  uchardet-devel
48 BuildRequires:  wxGTK3-unicode-gl-devel >= 3.0.0
49 BuildRequires:  wxWidgets-devel >= 3.0.0
50 BuildRequires:  xz
51 BuildRequires:  zlib-devel
52 Requires(post,postun):  desktop-file-utils
53 Requires(post,postun):  gtk-update-icon-cache
54 Requires:       ffms2 >= 2.16
55 Requires:       fftw3 >= 3.3
56 Requires:       fontconfig-libs >= 1:2.4
57 Requires:       freetype >= 1:2.1.9
58 Requires:       hunspell >= 1.2.0
59 Requires:       libass >= 0.9.7
60 Requires:       libicu >= 4.8.1.1
61 Requires:       pulseaudio-libs >= 0.5
62 # due to luajit usage
63 ExclusiveArch:  %{ix86} %{x8664} arm mips ppc
64 # missing atomic_ops
65 ExcludeArch:    i386 i486
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 Aegisub is an advanced subtitle editor for Windows, and UNIX-like
70 systems, such as Linux, Mac OS X and BSD. It is open source software
71 and free for any use.
72
73 Aegisub natively works with the Advanced SubStation Alpha format
74 (aptly abbreviated ASS) which allows for many advanced effects in the
75 subtitles, apart from just basic timed text. Aegisubs goal is to
76 support using these advanced functions with ease.
77
78 %description -l pl.UTF-8
79 Aegisub to zaawansowany edytor napisów dla Windows oraz systemów
80 uniksowych, takich jak Linux, Mac OS X czy BSD. Jest to program o
81 otwartych źródłach, darmowy do dowolnego użytku.
82
83 Aegisub działa natywnie na formacie Advanced SubStation Alpha (w
84 stosownym skrócie ASS), pozwalającym na wiele zaawansowanych efektów w
85 napisach, poza samym powiązaniem z czasem. Celem Aegisubs jest łatwa
86 obsługa tych zaawansowanych funkcji.
87
88 %prep
89 %setup -q -n Aegisub-%{gitrev}
90 %patch0 -p1
91 %patch1 -p1
92
93 cat <<'EOF' >build/git_version.h
94 #define BUILD_GIT_VERSION_NUMBER 9010
95 #define BUILD_GIT_VERSION_STRING "3.2.2.6f546951b"
96 #define TAGGED_RELEASE 0
97 #define INSTALLER_VERSION "0.0.0"
98 #define RESOURCE_BASE_VERSION 0, 0, 0
99 EOF
100
101 %{__mv} vendor{,.keep}
102 mkdir vendor
103 %{__mv} vendor.keep/{luabins,luajit} vendor
104
105 %build
106 ./autogen.sh
107 export C
108 %configure \
109         --disable-compiler-flags \
110         --disable-update-checker \
111         --with-boost-libdir=%{_libdir} \
112         %{__with_without ffms2} \
113         --without-oss \
114         --with-player-audio=PulseAudio \
115         --with-wx-config=wx-gtk3-unicode-config
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
125 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{pt_PT,pt}
126 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}
127 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}@latin
128 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{uk_UA,uk}
129
130 %find_lang %{name}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post
136 %update_desktop_database
137 %update_icon_cache hicolor
138
139 %postun
140 %update_desktop_database
141 %update_icon_cache hicolor
142
143 %files -f %{name}.lang
144 %defattr(644,root,root,755)
145 %doc LICENCE README.md
146 %attr(755,root,root) %{_bindir}/%{name}
147 %{_datadir}/%{name}
148 %{_desktopdir}/%{name}.desktop
149 %{_datadir}/metainfo/aegisub.appdata.xml
150 %{_iconsdir}/hicolor/*/apps/%{name}.*
This page took 0.105792 seconds and 4 git commands to generate.