]> git.pld-linux.org Git - packages/aegisub.git/blob - aegisub.spec
- do not override optimization CFLAGS
[packages/aegisub.git] / aegisub.spec
1 # TODO
2 # - unvendor vendor/luabins
3 # - unvendor vendor/luajit
4 # - unvendor vendor/universalchardet
5 # - our cxxflags
6
7 # Conditional build:
8 %bcond_without  ffms2   # build ffms2 A/V provider
9
10 Summary:        Subtitle editor
11 Summary(pl.UTF-8):      Edytor napisów
12 Name:           aegisub
13 Version:        3.2.2
14 Release:        14
15 License:        BSD
16 Group:          X11/Applications
17 Source0:        http://ftp.aegisub.org/pub/releases/%{name}-%{version}.tar.xz
18 # Source0-md5:  d80e852c34811add358c06d77f5cd40d
19 Patch0:         pthread.patch
20 Patch1:         %{name}-icu.patch
21 Patch2:         %{name}-icu64.patch
22 Patch3:         %{name}-boost-1.70.patch
23 Patch4:         cflags.patch
24 URL:            http://www.aegisub.org/
25 # AC_AGI_COMPILE tries to run test program which tries to open device and most likely fails
26 #BuildRequires: OpenAL-devel >= 0.0.8
27 BuildRequires:  OpenGL-devel
28 BuildRequires:  alsa-lib-devel
29 BuildRequires:  autoconf >= 2.57
30 BuildRequires:  automake
31 BuildRequires:  boost-devel >= 1.50.0
32 %{?with_ffms2:BuildRequires:    ffms2-devel >= 2.16}
33 BuildRequires:  fftw3-devel >= 3.3
34 BuildRequires:  fontconfig-devel >= 1:2.4
35 # pkgconfig(freetype2) >= 9.7.0
36 BuildRequires:  freetype-devel >= 1:2.1.9
37 BuildRequires:  gettext-tools
38 BuildRequires:  hunspell-devel >= 1.2.0
39 BuildRequires:  intltool
40 BuildRequires:  libass-devel >= 0.9.7
41 BuildRequires:  libicu-devel >= 4.8.1.1
42 BuildRequires:  libstdc++-devel
43 BuildRequires:  lua51-devel
44 BuildRequires:  pkgconfig >= 1:0.20
45 BuildRequires:  portaudio-devel >= 19
46 BuildRequires:  pulseaudio-devel >= 0.5
47 BuildRequires:  tar >= 1:1.22
48 BuildRequires:  wxGTK2-unicode-gl-devel >= 3.0.0
49 BuildRequires:  wxWidgets-devel >= 3.0.0
50 BuildRequires:  xz
51 BuildRequires:  zlib-devel
52 Requires(post,postun):  desktop-file-utils
53 Requires(post,postun):  gtk-update-icon-cache
54 Requires:       ffms2 >= 2.16
55 Requires:       fftw3 >= 3.3
56 Requires:       fontconfig-libs >= 1:2.4
57 Requires:       freetype >= 1:2.1.9
58 Requires:       hunspell >= 1.2.0
59 Requires:       libass >= 0.9.7
60 Requires:       libicu >= 4.8.1.1
61 Requires:       pulseaudio-libs >= 0.5
62 # due to luajit usage
63 ExclusiveArch:  %{ix86} %{x8664} arm mips ppc
64 # missing atomic_ops
65 ExcludeArch:    i386 i486
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 Aegisub is an advanced subtitle editor for Windows, and UNIX-like
70 systems, such as Linux, Mac OS X and BSD. It is open source software
71 and free for any use.
72
73 Aegisub natively works with the Advanced SubStation Alpha format
74 (aptly abbreviated ASS) which allows for many advanced effects in the
75 subtitles, apart from just basic timed text. Aegisubs goal is to
76 support using these advanced functions with ease.
77
78 %description -l pl.UTF-8
79 Aegisub to zaawansowany edytor napisów dla Windows oraz systemów
80 uniksowych, takich jak Linux, Mac OS X czy BSD. Jest to program o
81 otwartych źródłach, darmowy do dowolnego użytku.
82
83 Aegisub działa natywnie na formacie Advanced SubStation Alpha (w
84 stosownym skrócie ASS), pozwalającym na wiele zaawansowanych efektów w
85 napisach, poza samym powiązaniem z czasem. Celem Aegisubs jest łatwa
86 obsługa tych zaawansowanych funkcji.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93 %patch3 -p1
94 %patch4 -p1
95
96 %{__mv} vendor{,.keep}
97 mkdir vendor
98 %{__mv} vendor.keep/{luabins,luajit,universalchardet} vendor
99
100 %build
101 %{__aclocal} -I m4macros
102 %{__autoconf}
103 %{__autoheader}
104 %configure \
105         --disable-update-checker \
106         %{__with_without ffms2} \
107         --without-oss \
108         --with-player-audio=PulseAudio \
109         --with-wx-config=wx-gtk2-unicode-config
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 ln -s %{name}-3.2 $RPM_BUILD_ROOT%{_bindir}/%{name}
119
120 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
121 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{pt_PT,pt}
122 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}
123 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}@latin
124 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{uk_UA,uk}
125
126 %find_lang %{name}-32
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post
132 %update_desktop_database
133 %update_icon_cache hicolor
134
135 %postun
136 %update_desktop_database
137 %update_icon_cache hicolor
138
139 %files -f %{name}-32.lang
140 %defattr(644,root,root,755)
141 %doc LICENCE README.md
142 %attr(755,root,root) %{_bindir}/%{name}
143 %attr(755,root,root) %{_bindir}/%{name}-3.2
144 %{_datadir}/%{name}
145 %{_desktopdir}/%{name}.desktop
146 %{_iconsdir}/hicolor/*/apps/%{name}.*
This page took 0.062282 seconds and 3 git commands to generate.