]> git.pld-linux.org Git - packages/PackageKit.git/blame - PackageKit.spec
fix build without apidocs and static_libs
[packages/PackageKit.git] / PackageKit.spec
CommitLineData
d05d9108
MB
1# TODO:
2# - BASH command-not-found functionality disabled for now as it needs patched bash
3# (details in bash from Fedora Rawhide)
d05d9108
MB
4#
5# Conditional build:
53810c7c
JB
6%bcond_without doc # build without docs
7%bcond_without introspection # gobject introspection, time to time broken
aa278a7b
JB
8%bcond_without static_libs # static library
9%bcond_without python # Python binding (used by entropy and portage backends)
10%bcond_without vala # Vala binding
11# backends
d06070b1 12%bcond_with alpm # ALPM (Arch Linux package manager) backend
04e18045 13%bcond_with apt # APT (Debian/Ubuntu) backend using C++ API
ea58ad5c 14%bcond_with dnf # DNF (Fedora/RHEL/Mageia/OpenMandriva/OpenSUSE/Rosa) backend
04e18045 15%bcond_with entropy # Entropy (Sabayon) backend (Python)
aa278a7b 16%bcond_with nix # Nix (NixOS) backend [broken as of 1.2.0]
04e18045
JB
17%bcond_without poldek # Poldek (PLD) backend
18%bcond_with portage # portage (Gentoo) backend (Python)
49ea0764 19%bcond_with slack # Slack (Slackware) backend
aa278a7b 20%bcond_with zypp # ZYPP (openSUSE/SLE) backend [broken as of 1.2.0]
0e84469f 21
aa278a7b
JB
22%if %{without python}
23%undefine with_entropy
24%undefine with_portage
04e18045 25%endif
0e84469f 26
85d27e4f
JB
27Summary: System daemon that is a D-Bus abstraction layer for package management
28Summary(pl.UTF-8): Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
a2d83637 29Name: PackageKit
e0e35018 30Version: 1.2.2
783c79a3 31Release: 1
a2d83637 32License: GPL v2+
85d27e4f 33Group: Applications/System
90405068 34Source0: https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
e0e35018 35# Source0-md5: 2bfa2687bcc4e189bb90e2228c11e558
02b3d2d3 36Patch0: %{name}-poldek.patch
aa278a7b 37Patch2: %{name}-meson.patch
bcd7526e 38Patch3: consolekit-fallback.patch
90405068 39URL: https://www.freedesktop.org/software/PackageKit/
ea58ad5c 40%{?with_apt:BuildRequires: AppStream-devel >= 0.12}
a2d83637 41BuildRequires: NetworkManager-devel >= 0.6.5
49ea0764
JB
42# pkgconfig(libalpm) >= 12.0.0
43%{?with_alpm:BuildRequires: alpm-devel >= 5.2}
44%{?with_dnf:BuildRequires: appstream-glib-devel}
ea58ad5c 45%{?with_apt:BuildRequires: apt-devel >= 1.9.2}
e0e35018 46BuildRequires: bash-completion-devel >= 2.0
577193a4 47BuildRequires: connman-devel
49ea0764 48%{?with_slack:BuildRequires: curl-devel}
6808f644 49BuildRequires: dbus-devel >= 1.2.0
f5f5e3ff 50BuildRequires: dbus-glib-devel >= 0.76
bdd8c0ca 51BuildRequires: docbook-dtd412-xml
52BuildRequires: docbook-dtd42-xml
dac2b5e1 53BuildRequires: fontconfig-devel
a0f1aeda 54BuildRequires: gettext-tools
49ea0764 55BuildRequires: glib2-devel >= 1:2.54.0
53810c7c 56%{?with_introspection:BuildRequires: gobject-introspection-devel >= 0.9.9}
7cd3cbcf
MB
57BuildRequires: gstreamer-devel >= 1.0.0
58BuildRequires: gstreamer-plugins-base-devel >= 1.0.0
dac2b5e1 59BuildRequires: gtk+3-devel >= 3.0.0
577193a4 60%{?with_doc:BuildRequires: gtk-doc >= 1.11}
78293e06 61BuildRequires: libarchive-devel
aa278a7b 62%{?with_dnf:BuildRequires: libdnf-devel >= 0.43.1}
49ea0764
JB
63%if %{with apt} || %{with nix}
64BuildRequires: libstdc++-devel >= 6:4.7
65%endif
66%{?with_slack:BuildRequires: libstdc++-devel >= 6:5}
dac2b5e1 67BuildRequires: libxslt-progs
3b18414e 68%{?with_zypp:BuildRequires: libzypp-devel >= 15}
e0e35018 69BuildRequires: meson >= 0.50
aa278a7b 70BuildRequires: ninja >= 1.5
49ea0764
JB
71# nix-expr nix-main nix-store
72%{?with_nix:BuildRequires: nix-devel >= 1.12}
dac2b5e1 73BuildRequires: pango-devel
a2d83637 74BuildRequires: pkgconfig
e0e35018 75# just to detect which reboot modes to use (library not linked)
49ea0764 76#BuildRequires: plymouth-devel >= 0.9.5
7cd3cbcf 77%{?with_poldek:BuildRequires: poldek-devel >= 0.30-1.rc6.4}
49ea0764
JB
78BuildRequires: polkit-devel >= 0.114
79# or 1:3.2
02b3d2d3 80%{?with_python:BuildRequires: python-devel >= 1:2.7}
827cd5e7 81BuildRequires: readline-devel
e0e35018 82BuildRequires: rpm-build >= 4.6
ea58ad5c 83%{?with_dnf:BuildRequires: rpm-devel >= 1:4.6}
a2d83637 84BuildRequires: rpm-pythonprov
aa278a7b
JB
85BuildRequires: rpmbuild(macros) >= 1.736
86BuildRequires: sed >= 4.0
577193a4 87BuildRequires: sqlite3-devel >= 3
49ea0764 88BuildRequires: systemd-devel >= 1:213
e216f3d9 89BuildRequires: tar >= 1:1.22
9ed4ca79 90BuildRequires: udev-glib-devel
8ad97aee 91%{?with_vala:BuildRequires: vala >= 2:0.16}
e216f3d9 92BuildRequires: xz
fcd0bc5c 93Requires(post,postun): shared-mime-info
0d5f415c 94Requires: %{name}-backend
a2d83637 95Requires: %{name}-libs = %{version}-%{release}
8d48627e 96Requires: crondaemon
49ea0764 97Requires: polkit >= 0.114
48178e4e 98Suggests: ConsoleKit-x11
e0e35018
JB
99Obsoletes: PackageKit-backend-pisi < 1.2
100Obsoletes: PackageKit-backend-ports < 1.2
101Obsoletes: PackageKit-backend-smart < 1.0
102Obsoletes: PackageKit-backend-urpmi < 1.2
103Obsoletes: PackageKit-backend-yum < 1.2
7cd3cbcf 104Obsoletes: PackageKit-docs < 0.8.4
e0e35018 105Obsoletes: pm-utils-packagekit < 0.8.15
a2d83637
MB
106BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108%description
109PackageKit is a D-Bus abstraction layer that allows the session user
110to manage packages in a secure way using a cross-distro,
111cross-architecture API.
112
85d27e4f
JB
113%description -l pl.UTF-8
114PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
115sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
116zgodnego z wieloma dystrybucjami i architekturami.
117
a2d83637 118%package libs
d05d9108
MB
119Summary: packagekit-glib library
120Summary(pl.UTF-8): Biblioteka packagekit-glib
a2d83637 121Group: Libraries
49ea0764
JB
122Requires: glib2 >= 1:2.54.0
123Obsoletes: browser-plugin-packagekit < 1.1.0
a2d83637
MB
124
125%description libs
d05d9108 126packagekit-glib library.
a2d83637
MB
127
128%description libs -l pl.UTF-8
d05d9108 129Biblioteka packagekit-glib.
a2d83637
MB
130
131%package devel
d05d9108
MB
132Summary: Header files for packagekit-glib library
133Summary(pl.UTF-8): Pliki nagłówkowe biblioteki packagekit-glib
a2d83637
MB
134Group: Development/Libraries
135Requires: %{name}-libs = %{version}-%{release}
9ed4ca79 136Requires: dbus-devel >= 1.2.0
49ea0764 137Requires: glib2-devel >= 1:2.54.0
9ed4ca79 138Requires: sqlite3-devel
a2d83637
MB
139
140%description devel
d05d9108 141Header files for packagekit-glib library.
a2d83637
MB
142
143%description devel -l pl.UTF-8
d05d9108 144Pliki nagłówkowe biblioteki packagekit-glib.
a2d83637
MB
145
146%package static
d05d9108
MB
147Summary: Static packagekit-glib library
148Summary(pl.UTF-8): Statyczna biblioteka packagekit-glib
a2d83637
MB
149Group: Development/Libraries
150Requires: %{name}-devel = %{version}-%{release}
151
152%description static
d05d9108 153Static packagekit-glib library.
a2d83637
MB
154
155%description static -l pl.UTF-8
d05d9108
MB
156Statyczna biblioteka packagekit-glib.
157
8ad97aee
JB
158%package -n vala-packagekit
159Summary: Vala API for PackageKit library
160Summary(pl.UTF-8): API języka Vala do biblioteki PackageKitu
161Group: Development/Libraries
162Requires: %{name}-devel = %{version}-%{release}
163Requires: vala >= 2:0.16
0e84469f 164BuildArch: noarch
8ad97aee
JB
165
166%description -n vala-packagekit
167Vala API for PackageKit library.
168
169%description -n vala-packagekit -l pl.UTF-8
170API języka Vala do biblioteki PackageKitu.
171
16acf8d5
JB
172%package apidocs
173Summary: PackageKit library API documentation
174Summary(pl.UTF-8): Dokumentacja API biblioteki PackageKit
175Group: Documentation
176Requires: gtk-doc-common
2aa4ef3d 177BuildArch: noarch
16acf8d5
JB
178
179%description apidocs
180PackageKit library API documentation.
181
182%description apidocs -l pl.UTF-8
183Dokumentacja API biblioteki PackageKit.
184
d06070b1
JB
185%package backend-alpm
186Summary: PackageKit ALPM backend
187Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece ALPM
188Group: Libraries
189Requires: %{name} = %{version}-%{release}
190Provides: %{name}-backend = %{version}-%{release}
d06070b1
JB
191
192%description backend-alpm
193A backend for PackageKit to enable Arch Linux packages via ALPM
194library.
195
196%description backend-alpm -l pl.UTF-8
197Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
198bibliotekę ALPM.
199
04e18045
JB
200%package backend-aptcc
201Summary: PackageKit APTcc backend
202Summary(pl.UTF-8): Backend PackageKit APTcc
203Group: Libraries
204Requires: %{name} = %{version}-%{release}
ea58ad5c
JB
205Requires: AppStream >= 0.12
206Requires: apt >= 1.9.2
04e18045
JB
207Provides: %{name}-backend = %{version}-%{release}
208
209%description backend-aptcc
210A backend for PackageKit to enable APT support via C++ API.
211
212%description backend-aptcc -l pl.UTF-8
213Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
214C++.
215
49ea0764
JB
216%package backend-dnf
217Summary: PackageKit dnf backend
218Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece dnfhif
219Group: Libraries
220Requires: %{name} = %{version}-%{release}
ea58ad5c
JB
221Requires: libdnf >= 0.43.1
222Requires: rpm >= 1:4.6
49ea0764 223Provides: %{name}-backend = %{version}-%{release}
e0e35018
JB
224Obsoletes: PackageKit-backend-hawkey < 1.0
225Obsoletes: PackageKit-backend-hif < 1.2
49ea0764
JB
226
227%description backend-dnf
228A backend for PackageKit to enable RPM packages support via dnf
229library (used in Fedora).
230
231%description backend-dnf -l pl.UTF-8
232Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
233dnf (używaną w dystrybucji Fedora).
234
04e18045
JB
235%package backend-entropy
236Summary: PackageKit Entropy backend
237Summary(pl.UTF-8): Backend PackageKit Entropy
238Group: Libraries
239Requires: %{name} = %{version}-%{release}
240Requires: python-packagekit = %{version}-%{release}
241#Requires: python-entropy
242Provides: %{name}-backend = %{version}-%{release}
243
244%description backend-entropy
245A backend for PackageKit to enable Sabayon packages support through
246Entropy package manager.
247
248%description backend-entropy -l pl.UTF-8
249Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
250użyciu zarządcy pakietów Entropy.
251
49ea0764
JB
252%package backend-nix
253Summary: PackageKit Nix backend
254Summary(pl.UTF-8): Backend PackageKit oparty na zarządcy pakietów Nix
04e18045
JB
255Group: Libraries
256Requires: %{name} = %{version}-%{release}
49ea0764 257Requires: nix >= 1.12
04e18045
JB
258Provides: %{name}-backend = %{version}-%{release}
259
49ea0764
JB
260%description backend-nix
261A backend for PackageKit to enable Nix packages support (used in
262NixOS).
04e18045 263
49ea0764
JB
264%description backend-nix -l pl.UTF-8
265Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
04e18045 266
0d5f415c
ER
267%package backend-poldek
268Summary: PackageKit Poldek backend
16acf8d5 269Summary(pl.UTF-8): Backend PackageKit oparty na Poldku
0d5f415c
ER
270Group: Libraries
271Requires: %{name} = %{version}-%{release}
7cd3cbcf 272Requires: poldek >= 0.30-1.rc6.4
16acf8d5 273Provides: %{name}-backend = %{version}-%{release}
0d5f415c
ER
274
275%description backend-poldek
04e18045
JB
276A backend for PackageKit to enable RPM packages support through Poldek
277- native PLD package manager.
0d5f415c 278
16acf8d5 279%description backend-poldek -l pl.UTF-8
04e18045
JB
280Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
281natywnego zarządcę pakietów dystrybucji PLD.
282
283%package backend-portage
284Summary: PackageKit Portage backend
285Summary(pl.UTF-8): Backend PackageKit Portage
286Group: Libraries
287Requires: %{name} = %{version}-%{release}
288Requires: python-packagekit = %{version}-%{release}
289#Requires: python-portage
290Provides: %{name}-backend = %{version}-%{release}
291
292%description backend-portage
293A backend for PackageKit to enable Gentoo Portage support.
294
295%description backend-portage -l pl.UTF-8
296Backend PackageKit dodający obsługę systemu Portage dystrybucji
297Gentoo.
298
49ea0764
JB
299%package backend-slack
300Summary: PackageKit Slack backend
301Summary(pl.UTF-8): Backend PackageKit Slack
302Group: Libraries
303Requires: %{name} = %{version}-%{release}
304Provides: %{name}-backend = %{version}-%{release}
e0e35018 305Obsoletes: PackageKit-backend-katja < 1.2
49ea0764
JB
306
307%description backend-slack
308Slack backend for PackageKit to enable Slackware repositories support.
309
310%description backend-slack -l pl.UTF-8
311Backend PackageKit Slack dodający obsługę repozytoriów Slackware.
312
04e18045
JB
313%package backend-zypp
314Summary: PackageKit Zypp backend
315Summary(pl.UTF-8): Backend PackageKit Zypp
316Group: Libraries
317Requires: %{name} = %{version}-%{release}
3b18414e 318Requires: libzypp >= 15
04e18045
JB
319Provides: %{name}-backend = %{version}-%{release}
320
321%description backend-zypp
322A backend for PackageKit to enable RPM packages support through Zypp
323library (originated in openSUSE/SLE).
324
325%description backend-zypp -l pl.UTF-8
326Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
327Zypp (pochodzącą z dystrybucji openSUSE/SLE).
16acf8d5 328
d05d9108
MB
329%package gstreamer-plugin
330Summary: GStreamer codecs installer
331Summary(pl.UTF-8): Instalator kodeków GStreamera
332Group: Applications
333Requires: %{name} = %{version}-%{release}
aa278a7b 334Requires: %{name}-gtk3-module = %{version}-%{release}
d05d9108
MB
335
336%description gstreamer-plugin
337The PackageKit GStreamer plugin allows any GStreamer application to
338install codecs from configured repositories using PackageKit.
339
340%description gstreamer-plugin -l pl.UTF-8
341Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
342zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
343
dac2b5e1
AF
344%package gtk3-module
345Summary: GTK+ 3.x module to detect and install missing fonts
346Summary(pl.UTF-8): Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
347Group: X11/Libraries
aa278a7b 348Obsoletes: PackageKit-gtk-module < 1.2.0
dac2b5e1
AF
349
350%description gtk3-module
351The PackageKit GTK+ 3.x module allows any pango application to install
352missing fonts from configured repositories using PackageKit.
353
354%description gtk3-module -l pl.UTF-8
355Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
356brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
357
a2d83637 358%package -n bash-completion-packagekit
16acf8d5
JB
359Summary: Bash completion for PackageKit console commands
360Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
a2d83637 361Group: Applications/Shells
577193a4
JB
362Requires: %{name} = %{version}-%{release}
363Requires: bash-completion >= 2
ead2d2f6 364BuildArch: noarch
a2d83637
MB
365
366%description -n bash-completion-packagekit
16acf8d5 367This package provides bash-completion for PackageKit console commands.
a2d83637
MB
368
369%description -n bash-completion-packagekit -l pl.UTF-8
16acf8d5
JB
370Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
371konsolowych PackageKit.
a2d83637 372
a2d83637
MB
373%package -n python-packagekit
374Summary: PackageKit Python bindings
375Summary(pl.UTF-8): Wiązania PackageKit dla Pythona
376Group: Development/Languages/Python
377Requires: python-dbus
378Requires: python-pygobject
379
380%description -n python-packagekit
381PackageKit Python bindings.
382
86086d14 383%description -n python-packagekit -l pl.UTF-8
a2d83637
MB
384Wiązania PackageKit dla Pythona.
385
386%prep
387%setup -q
d113818a 388%patch0 -p1
aa278a7b 389%patch2 -p1
bcd7526e 390%patch3 -p1
a2d83637 391
aa278a7b
JB
392%if %{with static_libs}
393%{__sed} -i -e '/^packagekit_glib2_library =/ s/shared_library/library/' lib/packagekit-glib2/meson.build
d5617342 394%endif
aa278a7b
JB
395
396%build
04e18045 397%{?with_zypp:CPPFLAGS="%{rpmcppflags} -D_RPM_5 -I/usr/include/rpm"}
aa278a7b
JB
398%meson build \
399 -Dbash_command_not_found=false \
aa278a7b
JB
400 %{!?with_introspection:-Dgobject_introspection=false} \
401 %{?with_doc:-Dgtk_doc=true} \
402 -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
403 %{!?with_python:-Dpython_backend=false} \
404 -Dpythonpackagedir=%{py_sitescriptdir} \
405 -Dsystemdsystemunitdir=%{systemdunitdir}
406
407# TODO:
408# -Ddnf_vendor=
409# -Dpackagekit_user=
410
411%ninja_build -C build
a2d83637
MB
412
413%install
414rm -rf $RPM_BUILD_ROOT
aa278a7b 415install -d $RPM_BUILD_ROOT/var/cache/PackageKit/downloads
a2d83637 416
aa278a7b
JB
417%ninja_install -C build
418
419%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
e0e35018 420%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
5059111f 421
d05d9108 422# use pk-gstreamer-install as codec installer
aa278a7b 423ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libexecdir}/gst-install-plugins-helper
d05d9108 424
aa278a7b
JB
425install -d $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants
426ln -sf ../packagekit-offline-update.service \
427 $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
428
429%if %{with python}
430%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
431%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
dac2b5e1 432
a2d83637 433%py_postclean
aa278a7b 434%endif
a2d83637 435
6808f644
MB
436%find_lang %{name}
437
a2d83637
MB
438%clean
439rm -rf $RPM_BUILD_ROOT
440
fcd0bc5c
MB
441%post
442%update_mime_database
443
444%postun
445%update_mime_database
446
85d27e4f 447%post libs -p /sbin/ldconfig
a2d83637
MB
448%postun libs -p /sbin/ldconfig
449
6808f644 450%files -f %{name}.lang
a2d83637 451%defattr(644,root,root,755)
02b3d2d3 452%doc AUTHORS HACKING MAINTAINERS NEWS README
a2d83637
MB
453%attr(755,root,root) %{_bindir}/pkcon
454%attr(755,root,root) %{_bindir}/pkmon
50832223 455%attr(750,root,root) /etc/cron.daily/packagekit-background.cron
02b3d2d3
JB
456%attr(755,root,root) %{_libexecdir}/packagekit-direct
457%attr(755,root,root) %{_libexecdir}/packagekitd
458%attr(755,root,root) %{_libexecdir}/pk-offline-update
a2d83637 459%dir %{_libdir}/packagekit-backend
aa278a7b 460%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dummy.so
a2d83637
MB
461%dir %{_sysconfdir}/PackageKit
462%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
d05d9108 463%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
5baab3aa
ER
464%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
465/etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
d05d9108 466%dir %{_datadir}/PackageKit
6e66a3a4 467%dir %{_datadir}/PackageKit/helpers
d05d9108 468%attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
f058dba9 469%{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
577193a4 470%{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
a2d83637 471%{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
a2d83637 472%{_mandir}/man1/pkcon.1*
78293e06 473%{_mandir}/man1/pkmon.1*
53810c7c 474%{systemdunitdir}/packagekit.service
7cd3cbcf 475%{systemdunitdir}/packagekit-offline-update.service
02b3d2d3 476%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
78293e06
MB
477%dir /var/cache/PackageKit
478%dir /var/cache/PackageKit/downloads
a2d83637 479%dir /var/lib/PackageKit
d05d9108 480%ghost /var/lib/PackageKit/transactions.db
a2d83637
MB
481
482%files libs
483%defattr(644,root,root,755)
74872af2 484%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
02b3d2d3 485%attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
dac2b5e1 486%{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
2ab9cd42
JB
487# NOTE: dbus interface xmls are commonly used:
488# - at runtime by packagekitd
489# - for development of applications using PK dbus interface
490%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
491%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
08c67dac 492
a2d83637
MB
493%files devel
494%defattr(644,root,root,755)
74872af2 495%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
74872af2 496%{_pkgconfigdir}/packagekit-glib2.pc
d05d9108 497%dir %{_includedir}/PackageKit
74872af2 498%{_includedir}/PackageKit/packagekit-glib2
dac2b5e1 499%{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
08c67dac 500
0e57d6d1 501%if %{with static_libs}
a2d83637
MB
502%files static
503%defattr(644,root,root,755)
74872af2 504%{_libdir}/libpackagekit-glib2.a
0e57d6d1 505%endif
d05d9108 506
8ad97aee
JB
507%if %{with vala}
508%files -n vala-packagekit
509%defattr(644,root,root,755)
aa278a7b 510%{_datadir}/vala/vapi/packagekit-glib2.deps
8ad97aee
JB
511%{_datadir}/vala/vapi/packagekit-glib2.vapi
512%endif
513
0e57d6d1 514%if %{with apidocs}
16acf8d5
JB
515%files apidocs
516%defattr(644,root,root,755)
517%{_gtkdocdir}/PackageKit
0e57d6d1 518%endif
16acf8d5 519
d06070b1
JB
520%if %{with alpm}
521%files backend-alpm
0d5f415c 522%defattr(644,root,root,755)
d06070b1
JB
523%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
524%dir %{_sysconfdir}/PackageKit/alpm.d
525%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
526%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
527%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
0d5f415c
ER
528%endif
529
04e18045
JB
530%if %{with apt}
531%files backend-aptcc
532%defattr(644,root,root,755)
533%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
534%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
535%dir %{_datadir}/PackageKit/helpers/aptcc
536%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
537%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
538%{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
539%endif
540
49ea0764
JB
541%if %{with dnf}
542%files backend-dnf
543%defattr(644,root,root,755)
544%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dnf.so
545%endif
546
04e18045
JB
547%if %{with entropy}
548%files backend-entropy
549%defattr(644,root,root,755)
550%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
551%dir %{_datadir}/PackageKit/helpers/entropy
552%attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
553%endif
554
49ea0764
JB
555%if %{with nix}
556%files backend-nix
ee375c30 557%defattr(644,root,root,755)
49ea0764 558%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
04e18045
JB
559%endif
560
d06070b1
JB
561%if %{with poldek}
562%files backend-poldek
563%defattr(644,root,root,755)
564%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
565%endif
566
04e18045
JB
567%if %{with portage}
568%files backend-portage
569%defattr(644,root,root,755)
570%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
571%dir %{_datadir}/PackageKit/helpers/portage
572%attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
573%endif
574
49ea0764
JB
575%if %{with slack}
576%files backend-slack
577%defattr(644,root,root,755)
578%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_slack.so
579%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Slackware.conf
580%dir /var/cache/PackageKit/metadata
581%ghost /var/cache/PackageKit/metadata/metadata.db
582%endif
583
04e18045
JB
584%if %{with zypp}
585%files backend-zypp
586%defattr(644,root,root,755)
587%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
588%endif
589
d05d9108
MB
590%files gstreamer-plugin
591%defattr(644,root,root,755)
592%doc contrib/gstreamer-plugin/README
aa278a7b 593%attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
02b3d2d3 594%attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
d05d9108 595
dac2b5e1
AF
596%files gtk3-module
597%defattr(644,root,root,755)
aa278a7b 598%doc contrib/gtk-module/{GLASS.txt,README}
dac2b5e1 599%attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
7cd3cbcf 600%{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
dac2b5e1 601
a2d83637
MB
602%files -n bash-completion-packagekit
603%defattr(644,root,root,755)
577193a4 604%{bash_compdir}/pkcon
a2d83637 605
02b3d2d3 606%if %{with python}
a2d83637
MB
607%files -n python-packagekit
608%defattr(644,root,root,755)
609%dir %{py_sitescriptdir}/packagekit
610%{py_sitescriptdir}/packagekit/*.py[co]
02b3d2d3 611%endif
This page took 0.203624 seconds and 4 git commands to generate.