]> git.pld-linux.org Git - packages/Glide_VG.git/blame - Glide_VG.spec
- pass AR to remove 'l' option, which changed meaning
[packages/Glide_VG.git] / Glide_VG.spec
CommitLineData
ac1d23c1
JB
1#
2# Conditional build:
3%bcond_with glide2_sdk # build Glide2x_SDK here (normally built from Glide_V3.spec)
4#
4c49c243 5Summary: Glide runtime for 3Dfx Voodoo Graphics boards
61beb790 6Summary(pl.UTF-8): Środowisko Glide dla kart 3Dfx Voodoo Graphics
cf05b513 7Name: Glide_VG
8Version: 2.46
0c0bac19 9Release: 11
4c49c243 10License: 3DFX GLIDE Source Code General Public License
edf0eec0 11Group: Libraries
07dc9c23 12Source0: Glide%{version}.tar.gz
0a60b64a 13# Source0-md5: be7762636b46cb04b238a16f45cfcfa8
07dc9c23 14Patch0: %{name}-asm.patch
63739d9f 15Patch1: %{name}-opt.patch
d98d2b0c 16Patch2: %{name}-morearchs.patch
4dc461ef 17Patch3: %{name}-ioctl.patch
fe94377d 18Patch4: %{name}-soname.patch
26652483 19Patch5: %{name}-C_brainos.patch
0c0bac19
JB
20Patch6: %{name}-format.patch
21Patch7: %{name}-include.patch
ca5929e7 22URL: http://glide.sourceforge.net/
4df864eb 23%ifarch %{ix86}
d5e33c76 24BuildRequires: /usr/bin/gasp
4df864eb 25%endif
ca5929e7
JB
26BuildRequires: xorg-lib-libX11-devel
27BuildRequires: xorg-lib-libXxf86dga-devel
28BuildRequires: xorg-lib-libXxf86vm-devel
e5c076fb 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53af08fa 30
31%description
4c49c243 32This library allows the user to use a 3Dfx Interactive Voodoo Graphics
edf0eec0 33card under Linux.
3d6c707d 34
a216d7c4
JR
35%description -l pl.UTF-8
36Ten pakiet pozwala na używanie kart 3Dfx Interactive Voodoo Graphics
4c49c243
JB
37pod Linuksem.
38
ac1d23c1
JB
39%package devel
40Summary: Development package for Glide 2.x built for Voodoo Graphics
41Summary(pl.UTF-8): Pakiet programistyczny dla Glide 2.x zbudowanego dla Voodoo Graphics
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44Requires: Glide2x_SDK >= %{version}
3b38075b 45Provides: Glide2x-devel = %{version}
ac1d23c1
JB
46
47%description devel
48Development package for Glide 2.x built for 3Dfx Interactive Voodoo
49Graphics adapters.
50
51%description devel -l pl.UTF-8
52Pakiet programistyczny dla Glide 2.x zbudowanego dla kart 3Dfx
53Interactive Voodoo Graphics.
54
53af08fa 55%package -n Glide2x_SDK
ac1d23c1 56Summary: Development files for Glide 2.x
61beb790 57Summary(pl.UTF-8): Część Glide 2.x przeznaczona dla programistów
cf05b513 58Group: Development/Libraries
d20f55c8 59Conflicts: Glide_SDK
53af08fa 60
61%description -n Glide2x_SDK
62This package includes the headers files, documentation, and test files
63necessary for developing applications that use the 3Dfx Interactive
64Voodoo Graphics, Voodoo Rush, or Voodoo2 card.
65
a216d7c4
JR
66%description -n Glide2x_SDK -l pl.UTF-8
67Ten pakiet zawiera pliki nagłówkowe, dokumentację i pliki testowe
68potrzebne do tworzenia aplikacji używających kart 3Dfx Interactive
4c49c243
JB
69Voodoo Graphics, Voodoo Rush lub Voodoo2.
70
53af08fa 71%prep
cf05b513 72%setup -q -c
63739d9f
JB
73%patch0 -p1
74%patch1 -p1
d98d2b0c 75%patch2 -p1
4dc461ef 76%patch3 -p1
fe94377d 77%patch4 -p1
26652483 78%patch5 -p1
0c0bac19
JB
79%patch6 -p1
80%patch7 -p1
53af08fa 81chmod +x swlibs/include/make/ostype
82
83%build
753c8420 84%{__make} -j1 -f makefile.unix \
7441da6e 85 AR="ar rcs" \
c38e5d24 86 CC="%{__cc}" \
7441da6e 87 CNODEBUG="%{rpmcflags} -fPIC -Wno-missing-braces %{!?debug:-fomit-frame-pointer} \
ca5929e7 88 %{!?debug:-funroll-loops -fexpensive-optimizations -ffast-math}" \
d98d2b0c
JB
89%ifnarch %{ix86}
90 FX_GLIDE_CTRISETUP=1
91%endif
53af08fa 92
93%install
94rm -rf $RPM_BUILD_ROOT
46c6bc1f 95install -d $RPM_BUILD_ROOT{%{_libdir},%{_bindir}}
53af08fa 96
97# Install the glibc 2.1 libraries normally
d8c27465
JB
98install sst1/lib/libglide.so.2.46 $RPM_BUILD_ROOT%{_libdir}
99ln -sf libglide.so.2.46 $RPM_BUILD_ROOT%{_libdir}/libglide.so.2
100ln -sf libglide.so.2 $RPM_BUILD_ROOT%{_libdir}/libglide2x.so
403fc473 101ln -sf libglide.so.2 $RPM_BUILD_ROOT%{_libdir}/libglide.so
d8c27465
JB
102install swlibs/lib/libtexus.so.1.1 $RPM_BUILD_ROOT%{_libdir}
103ln -sf libtexus.so.1.1 $RPM_BUILD_ROOT%{_libdir}/libtexus.so.1
104ln -sf libtexus.so.1 $RPM_BUILD_ROOT%{_libdir}/libtexus.so
53af08fa 105
106# Install the executables
07dc9c23
JB
107install swlibs/bin/texus $RPM_BUILD_ROOT%{_bindir}
108install sst1/glide/tests/test00 $RPM_BUILD_ROOT%{_bindir}/test3Dfx
53af08fa 109
ac1d23c1 110%if %{with glide2_sdk}
46c6bc1f
JB
111### SDK
112install -d $RPM_BUILD_ROOT%{_includedir}/glide \
113 $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/{tests,texus/examples}
114
53af08fa 115# Install the headers
cf05b513 116install swlibs/include/3dfx.h $RPM_BUILD_ROOT%{_includedir}/glide
117install sst1/include/glide.h $RPM_BUILD_ROOT%{_includedir}/glide
118install sst1/include/glidesys.h $RPM_BUILD_ROOT%{_includedir}/glide
119install sst1/include/glideutl.h $RPM_BUILD_ROOT%{_includedir}/glide
120install sst1/include/sst1vid.h $RPM_BUILD_ROOT%{_includedir}/glide
121install sst1/include/gump.h $RPM_BUILD_ROOT%{_includedir}/glide
122install swlibs/include/linutil.h $RPM_BUILD_ROOT%{_includedir}/glide
123install swlibs/include/texus.h $RPM_BUILD_ROOT%{_includedir}/glide
53af08fa 124
125# Install the examples and their source
bb15827d
JB
126install sst1/glide/tests/makefile.distrib $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/tests/makefile
127install sst1/glide/tests/*.3df $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/tests
128install sst1/glide/tests/test??.c $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/tests
129install sst1/glide/tests/tldata.inc $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/tests
130install sst1/glide/tests/tlib.[ch] $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/tests
131gzip -9nf $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/tests/*.3df
53af08fa 132
133# Install the texture tools source
bb15827d 134install swlibs/texus/examples/makefile.distrib $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/texus/examples/makefile
bb15827d 135install swlibs/texus/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/glide2x-%{version}/texus/examples
ac1d23c1 136%endif
edf0eec0 137
53af08fa 138%clean
139rm -rf $RPM_BUILD_ROOT
140
4c49c243
JB
141%post -p /sbin/ldconfig
142%postun -p /sbin/ldconfig
53af08fa 143
144%files
cf05b513 145%defattr(644,root,root,755)
ca5929e7 146%doc glide_license.txt readme.txt
cf05b513 147%attr(755,root,root) %{_bindir}/texus
edf0eec0 148%attr(755,root,root) %{_bindir}/test3Dfx
d8c27465
JB
149%attr(755,root,root) %{_libdir}/libglide.so.2.46
150%attr(755,root,root) %ghost %{_libdir}/libglide.so.2
edf0eec0 151%attr(755,root,root) %{_libdir}/libglide2x.so
d8c27465
JB
152%attr(755,root,root) %{_libdir}/libtexus.so.1.1
153%attr(755,root,root) %ghost %{_libdir}/libtexus.so.1
edf0eec0 154%attr(755,root,root) %{_libdir}/libtexus.so
53af08fa 155
ac1d23c1
JB
156%files devel
157%defattr(644,root,root,755)
158%attr(755,root,root) %{_libdir}/libglide.so
159
160%if %{with glide2_sdk}
53af08fa 161%files -n Glide2x_SDK
cf05b513 162%defattr(644,root,root,755)
edf0eec0 163%doc docs/*.pdf
cf05b513 164%{_includedir}/glide
ac1d23c1
JB
165%{_examplesdir}/glide2x-%{version}
166%endif
This page took 0.118104 seconds and 4 git commands to generate.