]> git.pld-linux.org Git - packages/Glide_VG.git/commitdiff
- pass AR to remove 'l' option, which changed meaning master
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 26 Sep 2022 19:32:03 +0000 (21:32 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 26 Sep 2022 19:32:03 +0000 (21:32 +0200)
- added asm fix to morearchs patch
- added -Wno-missing-braces to avoid massive warning messages

Glide_VG-morearchs.patch
Glide_VG.spec

index 3eb438c4c12b65b9da57cfbef65046e6813e5585..1029fcbe75a2d138294528e22827ce8699f0dc31 100644 (file)
  
  
  void double_precision_asm() {
+-  asm("push %eax \n fnclex \n fstcw (%esp) \n movw (%esp), %eax \n "
+-      "and $0x0000fcff, %eax \n or $0x000002ff, %eax \n mov %eax, (%esp) \n "
 +#ifdef __i386__
-   asm("push %eax \n fnclex \n fstcw (%esp) \n movw (%esp), %eax \n "
-       "and $0x0000fcff, %eax \n or $0x000002ff, %eax \n mov %eax, (%esp) \n "
++  asm("push %eax \n fnclex \n fstcw (%esp) \n movl (%esp), %eax \n "
++      "and $0x0000fcff, %eax \n or $0x000002ff, %eax \n movl %eax, (%esp) \n "
        "fldcw (%esp) \n pop %eax");
 +#endif
  }
index 20e7abee7d552c26dc0f5ddaa43616441e0789d7..aad4314553d135e563f22361bf86d3bec9a78178 100644 (file)
@@ -82,8 +82,9 @@ chmod +x swlibs/include/make/ostype
 
 %build
 %{__make} -j1 -f makefile.unix \
+       AR="ar rcs" \
        CC="%{__cc}" \
-       CNODEBUG="%{rpmcflags} -fPIC %{!?debug:-fomit-frame-pointer} \
+       CNODEBUG="%{rpmcflags} -fPIC -Wno-missing-braces %{!?debug:-fomit-frame-pointer} \
        %{!?debug:-funroll-loops -fexpensive-optimizations -ffast-math}" \
 %ifnarch %{ix86}
        FX_GLIDE_CTRISETUP=1
This page took 0.125083 seconds and 4 git commands to generate.